[UNSUPPORTED][TP] Warpz0r v1.4.2 - Multiworld Warp and Home plugin [1317]

Discussion in 'Inactive/Unsupported Plugins' started by Drakia, Feb 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Warpz0r - Yet another warp and home plugin! Now with iConomy support!
    Version: 1.4.2
    CraftBukkit: 1317

    Plugin Dependencies:
    Any SuperPerms handler, as well as Permissions 2.x/3.x (Optional)
    Register (Optional, will allow any Economy plugin to be used)

    Yet another warp and home plugin.
    I didn't think there were quite enough warp and home plugins out there, so I decided to write my own for my server.
    Added basic iConomy support for /home /warp and /sethome

    Download (Direct JAR): http://thedgtl.net/bukkit/Warpz0r.jar
    Source: https://github.com/TheDgtl/Warpz0r

    Copy Warpz0r.jar to the plugins/ folder
    After the initial run it will create a Warpz0r folder with the config file in it. Edit the config file to your liking then run "reload" in the CraftBukkit terminal.

    This plugin supports warping/homing between multiple worlds.
    You only have one "home," so if you are in one world and your home is in another, you will warp to your "home" world if you use /home
    Permissions plugin is used if installed, otherwise goes based on isOp().
    Will import your existing homes and warps if you place homes.txt/warps.txt file into the plugins/Warpz0r/ folder
    Ability to disable inter-world warp
    iConomy 5.x support (DOES NOT SUPPORT ICONOMY 6.x)

    /warp <name> - Warp yourself to specified warp point
    /warpto <player> <name> - Warp target player to specified warp point
    /listwarps - List all available warps
    /setwarp <name> - Create a named warp at your current location
    /setwarp <name> <cost> - Create a named warp at your current location with the specified cost to use it.
    /removewarp <name> - Removes a named warp
    /home - Warp to your set home
    /home <player> - Warp to a specified players home
    /sethome - Sets your home
    /sethome <player> - Set a specified players home
    /clearhome <player> - Clear a players home
    /wz compass - Set your compass to point to your home
    /wz compass <warp> - Set your compass to point to <warp>
    /wz compass reset - Set your compass to point to spawn

    useiconomy - Set to "true" to use iConomy
    sethomecost - The cost to use /sethome
    warpcost - The cost to use /warp
    homecost - The cost to use /home
    setwarpcost - The cost to use /setwarp
    removewarpcost - The cost to use /removewarp
    noPrefix - Set to "true" to disable "[Warpz0r]" prefix for player messages
    bedhome - Set to true to allow players with warpz0r.bedhome permissions to set home on entering a bed

    warpz0r.use: Allow full use of Warpz0r warping commands
        warpz0r.use.warp: Allow use of warping functionality)
            warpz0r.warp: Allow use of /warp <warp> (default: op)
            warpz0r.set: Allow use of /setwarp <warp> (default: op)
            warpz0r.setcost: Allow use of /setwarp <warp> <cost> (default: op)
            warpz0r.remove: Allow use of /removewarp <warp> (default: op)
            warpz0r.list: Allow use of /listwarps (default: op)
            warpz0r.worldwarp: Allow warping between worlds (default: op)
        warpz0r.use.home: Allow use of home commands
            warpz0r.sethome: Allow use of /sethome (default: true)
            warpz0r.home: Allow use of /home (default: true)
            warpz0r.worldhome: Allow teleporting between worlds during /home  (default: true)
            warpz0r.bedhome: Allow use of a bed setting players home (default: true)
        warpz0r.use.compass: Allow use of compass commands
            warpz0r.compasshome: Allow use of /wz compass (default: true)
            warpz0r.compassreset: Allow use of /wz compass reset (default: true)
            warpz0r.compasswarp: Allow use of /wz compass <warp> (default: op)
    warpz0r.admin: Allow use of admin commands
        warpz0r.admin.warpto: Allow use of /warpto <player> <warp> (default: op)
        warpz0r.admin.sethome: Allow use of /sethome <player> (default: op)
        warpz0r.admin.home: Allow use of /home <player> (default: op)
        warpz0r.admin.clearhome: Allow use of /clearhome [player] (default: op)
    warpz0r.free: All warpz0r commands are free
        warpz0r.free.warp: Don't charge for /warp (default: op)
        warpz0r.free.setwarp: Don't charge for /setwarp (default: op)
        warpz0r.free.removewarp: Don't charge for /removewarp (default: op)
        warpz0r.free.sethome: Don't charge for /sethome (default: op)
        warpz0r.free.home: Don't charge for /home (default: op)
        warpz0r.free.bedhome: Don't charge on bed usage setting home (default: op)

    ** Note on Permissions 2.x/3.x: If you are using Perms 2/3, you MUST specify the child nodes individually,
    as Perms 2/3 are not SuperPerms compatible, they do not support the permissions hierarchy defined in plugin.yml
    Q) Why don't beds show animation?
    A) Iunno, ask Notch.

    Q) Can you add private warps?
    A) Iunno, as... Oh wait, this one's on me. This isn't the type of plugin Warpz0r is meant to be, and it's probably never going to support private /hidden warps.

    Q) I'm giving my users warpz0r.use but they can't use /warp, why not?
    A) Permissions 2.x/3.x do not support the hierarchy structure in plugin.yml (They don't support perms in plugin.yml at all) so you must define every node for them.

    [Version 1.4.2]
    - Prefer SuperPerms over PermsBridge
    - Register support instead of iConomy
    [Version 1.4.1]
    - Stupid iConomy.
    [Version 1.4.0]
    - Implemented SuperPerms. This includes a perms overhaul, please re-do your permissions.
    - Fixed teleporting to unloaded chunks
    - Fixed iConomy error when 6.x is installed
    [Version 1.3.1]
    - Fixed location saving on bedhome
    [Version 1.3.0]
    - Added /home <player>
    - Added /sethome <player>
    - Added ability to set home on entering a bed
    - New config options:
    - bedhome
    - New Permissions:
    - warpz0r.bedhome
    - warpz0r.free.bedhome
    - warpz0r.admin.home
    - warpz0r.admin.sethome
    [Version 1.2.4]
    - Updated for iConomy 5.x
    [Version 1.2.3]
    - Added noPrefix config option
    [Version 1.2.2]
    - Added /clearhome [Player]
    - Made /warpto and /clearhome allow partial names
    [Version 1.2.1]
    - Forgot to check to make sure the player supplied a warp name
    [Version 1.2.0]
    - Added Free permissions
    - Added per-warp costs
    [Version 1.1.1]
    - Updated to latest RB
    [Version 1.1.0]
    - Changed version numbering
    - Changed method used to hook plugins
    - Updated iConomy support.
    [Version 1.09]
    - Added "/wz compass" "/wz compass reset" and "/wz compass <warp>"
    [Version 1.08]
    - /listwarps is now alphabetical
    [Version 1.07]
    - More iConomy costs
    - Fixed a reference to Tombstone
    [Version 1.06]
    - Small permissions handling update
    - Updated to iConomy 4.x
    - Warplist now shows proper case
    [Version 1.05]
    - Tweaked permission handling
    - Warp names are no longer case sensitive.
    [Version 1.04]
    - Added iConomy support
    - Added a function to handle messaging the player, now only the "[Warpz0r]" text is colored
    [Version 1.03]
    - Fixed disallowing teleport between worlds, was always returning false.
    [Version 1.02]
    - Remove long constructor
    - Fixed Permission handling, works with /pr now
    - Ability to disable inter-world warping
    [Version 1.01]
    - Changed permission handling to send "Permission Denied" messages
    - Prepended "[Warpz0r]" to all messages sent to player
    [Version 1.00]
    - Initial Release
    Baghtal, _Robert, Brain and 1 other person like this.
  2. Offline


    I got an idea for this plugin:

    It should be possible to config how many warps each player can set.
    Maybe make it into permissions, so a group can fx. make 3 warps per player.
    I dont know if this is hard to make, but i think it would be smart!
  3. Offline


    You make me sad :(
    Brain likes this.
  4. Offline


    why the ... it says permission denied when my friends try to do any of these warpzor commands? cuz they are builders and i've already copied all of those permissions to permission.config and to builder group
  5. Offline


    Copied all the permissions? Do you want all of them? Try this node:
    The wildcard should give them all of the permissions and clear up your file. Also, are you giving it to them, as well as the group? That can mess things up. If my solution doesn't work, post your permissions file and quote me.
  6. Offline


    hey ive got it and thanks for the good plugin ... i just want to know how do you make people with no op use the command cause it says permission denied thanks
  7. Offline


    Confused by the update iv had to swap because i was unsure and could not be 100% trusting of you to keep it working Now to see that you have is a bit of a kick in the face.
  8. Offline


    And what? I owe you something? I haven't actually UPDATED anything, every single one of my plugins has worked fine through the last 3 RBs. My current plan is to keep them working as such, but offer no support beyond the initial post.
    Had you paid me to develop you this plugin and I pulled this, then it would be a kick in the face. As it is, it's just a dev being fed up with self-entitled users such as yourself.
  9. Offline


    No you don't owe me any thing But I expect some common human decency. such as a straight answer. not say 1 thing and do another that's just annoying and frustrating.

    My server needs stable reliable plugins if you can't provide that long term why release it. instead you half ass it get people to rely on you then bail when it all gets to hard. Get over it life is hard.
  10. Offline


    Life is easy, developing plugins is easy, and had you read the actual topic I had posted that I would keep the plugins up to date with the RBs.
    I don't see how my decision to not cater to the needs of every idiot user shows that this is "too hard".
  11. Offline


    Hey Drakia,

    I was hesitant to report this at first but I am pretty sure it is a bug. I think you may have a permissions chain issue.

    The issue is that /home and /sethome didnt work for nonops.

    This is how i set in my config file in chronological order...

    - 'warpz0r.warp.home'
    - 'warpz0r.warp.sethome'

    so that didnt work so i tried to add the following.

    - 'warpz0r.free.sethome'
    - 'warpz0r.free.home'
    - 'warpz0r.worldhome'

    Finally I added

    - 'warpz0r.warp'

    And i was able to do /warp, but still denied access to /sethome and /home.

    So the reason for this is that I am trying to change to a new home as MyHome has a SQL lite library dependency that I do not have for some reason out of the blue..

    I found this, and bonus - it was updated for 803 and now this is where I am at.

    Permissions is latest as well, no iconomy added.

    Hope you can help, Thanks a lot for your brain power.
  12. Offline


    I would highly recommend reading the first post more closely before claiming there's a bug. Your permissions are WAY off.
  13. Offline


    ...Your permissions. They are wrong. Did you even read the first post?
    The permissions are:
    - 'warpz0r.sethome'
    - 'warpz0r.home'
    - 'warpz0r.worldhome'
    I'd suggest removing the apostrophes if they're giving you trouble, I personally allow permissions to add them, and remove them anyways <.<"
  14. Offline


    Hey Drakia!
    Gotta start with saying its a great plugin. Used it for 2 months now, but had a problem now as I updated bukkit to 803 and some plugins to their latest version. Problem is now that i think Essentials listens to warp/home/sethome/setwarp. In Console it says CONSOLE: [PLAYER_COMMAND] *username*: /warp *whatever*
    Not as before when it was Warpz0r: Warped to *whatever*

    Now I checked Essentials override commands and there are nothing that should interfier with Warpz0r when looking at its config. I used Essentials since i started the server so weird it messes now.
    Have any idea what it could be? I use it with iConomy and Permissions, have always worked until now when i updated craftbukkit to 803, and these plugins to their latest release: Falsebook, jobs, Residence, Nocheat, HelpPages, Citizens.
    Info about the plugins I use:
    CBukkit-Build: 803
    Use: McMyAdmin
    ChairCraft 1.2.2
    Citizens 1.0.8
    CraftIRC 2.0 Preview 11
    Essentials 2.2.22
    EssentialsSpawn 2.2.22
    FalseBookBlock 0.85alpha
    FalseBookCart 0.85alpha
    FalseBookCore 0.85alpha
    FalseBookExtra 0.85alpha
    HelpPages 1.0
    HeroChat 4.10.3
    LWC 2.31
    LogBlock 0.15b
    BukkitCompat r12
    MobileAdmin 2.4.2
    NoCheat 1.01a
    Permissions 2.7.4
    RealShop 0.62
    Residence v2.1.3
    Vanish 1.5.2
    Warpz0r 1.2.4
    Whitelist 2.7
    WorldEdit "4.5"
    WorldGuard 5.0-alpha10
    Yeditor 1.2
    bAntiCaps 1.2.0
    iConomy 5.01
    Jobs 1.3.3b
    mcMMO 1.0.07
    mcbans 2.9.1
    Any Idea why warpz0r let go? I can still use other functions of warpz0r like /listwarps that doesnt interfier with Essentials. And at startup/reload everything loads fine seeing all the warpz0r messages going through ok.

    Ok, I solved it by myself. Downloading Brain's forked plugin version made everything work again as normal. If anyone experincing any problems "Brain" did a fork.
    He keeps everything the same as the original plugin, so it uses the same commands and even same config as this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  15. Offline


    @thernztrom I kindly request you remove that link from my topic, or I will ask an admin to remove it for you.

    In regards to why it stopped working with the update to b803, they changed how commands are handled, and since Essentials is loaded first it will take over the commands. To make Warpz0r load first just rename the .jar to something starting with an "a".
  16. Offline


    Actually I think your problems might be caused by a change in load order. The SimplePluginManager used by default doesn't seem to load plugins in any particular order. The "fix" you observed is probably just being my plugin loaded before Essentials, thus I can grab the commands before Essentials gets its "hands" on them. Maybe newer versions load in alphabetical order and since "Warpz0r" comes after "Essentials", essentials gets the input first whereas "BrainWarpz" would be before "Essentials". Don't know. But if it works for you, good for you.
  17. Offline


    Oh, so now everyone with a plugin touching Essentials area have to be renamed to begin with a-d to work...
    Seems like they did it "worse" by adding such a feature eh? Weird.. well anyhow im happy since it finally works. :)
  18. Offline


    holy shit i am retarded.
  19. Offline


    When do you think this will be updated?
    Do you think it might be updated some time today possibly?
  20. Offline


    If someone makes a warp, is that warp available to the rest of the server? Or only the warp's maker?
  21. Offline


    whole server
  22. Offline


    Thanks for making an awesome plugin for us. I like your new Notice. Wish I could help prevent idiots from posting without doing any reading.
  23. Offline


    How do you Use Multi-World?
  24. Offline



    Can you to add a multiworld home (one home per world) ?

    (sorry for my english, I'm french)
  25. I have this server and only ops can set home and make warps im not usewing icon or permissions
  26. Offline


    [Version 1.3.0]
    - Added /home <player>
    - Added /sethome <player>
    - Added ability to set home on entering a bed
    - New config options:
    - bedhome
    - New Permissions:
    - warpz0r.bedhome
    - warpz0r.free.bedhome
    - warpz0r.admin.home
    - warpz0r.admin.sethome

    As a side-note, beds appear to be totally screwy in 1.6, the bedhome option works, but you can only sleep in beds at night, there's no bed animation, etc.

    @rexs123 Without Permissions, only Ops can do things, if you want to control who can do things, install Permissions.
  27. but then no one can build, i dont get permissons
  28. Request:

    A config flag to enable hiding the warp location. Thus upon /warp X, it would say something like [warpzor] Warped. And not: Warped to X.
  29. Offline


    @Joy Not something I'm going to be adding/changing
  30. Offline


    I am having a problem with my permissions, it does not allow me to "allow" regular users to /sethome or /home for that matter. moderators and admins can, and it shouldn't have a problem, I did the permissions correctly according to YAML parser.

            default: true
                prefix: ''
                suffix: ''
                build: true
                - 'appleseed.plant'
                - 'appleseed.plant.apple'
                - 'appleseed.infinite.plant'
                - 'appleseed.infinite.fertilizer'
                - 'appleseed.infinite.cap'
                - 'appleseed.wand'
                - 'appleseed.sign.place'
                - 'commandbook.who'
                - 'commandbook.motd'
                - 'commandbook.rules'
                - 'commandbook.kit.list'
                - 'commandbook.kit.kits.starter'
                - 'commandbook.time.check'
                - 'commandbook.spawn'
                - 'commandbook.say.me'
                - 'commandbook.msg'
                - 'commandbook.whereami'
                - 'commandbook.whereami.compass'
                - 'falsebook.blocks.bridge'
                - 'falsebook.blocks.door'
                - 'falsebook.blocks.gate'
                - 'falsebook.blocks.lift'
                - 'falsebook.blocks.area'
                - 'iConomy.access'
                - 'iConomy.bank.access'
                - 'iConomy.bank.deposit'
                - 'iConomy.bank.join'
                - 'iConomy.bank.join.multiple'
                - 'iConomy.bank.leave'
                - 'iConomy.bank.list'
                - 'iConomy.bank.main'
                - 'iConomy.bank.main.change'
                - 'iConomy.bank.main.set'
                - 'iConomy.bank.main.view'
                - 'iConomy.bank.transfer'
                - 'iConomy.bank.transfer.multiple'
                - 'iConomy.bank.withdraw'
                - 'iConomy.list'
                - 'iConomy.payment'
                - 'iConomy.rank'
                - 'SignShop.Signs.*'
                - 'lockette.user.create.*'
                - 'minecartmania.teleport.create'
                - 'minecartmania.teleport.break'
                - 'minecartmania.teleport.use'
                - 'movecraft.aircraft.*'
                - 'movecraft.boat.sail'
                - 'movecraft.boat.info'
                - 'movecraft.car.*'
                - 'musiccraft.use'
                - 'musiccraft.ignore.repeat'
                - 'musiccraft.ignore.mintempo'
                - 'OwnBlocks.use'
                - 'OwnBlocks.info'
                - 'OwnBlocks.add'
                - 'quickstrasse.use'
                - 'towny.wild.*'
                - 'towny.town.new'
                - 'towny.town.claim'
                - 'towny.nation.new'
                - 'towny.spawntp'
                - 'towny.publicspawntp'
                - 'warpzor.list'
                - 'warpzor.set'
                - 'warpzor.set.cost'
                - 'warpzor.warp'
                - 'warpzor.remove'
                - 'warpzor.warpto'
                - 'warpzor.home'
                - 'warpzor.sethome'
                - 'warpzor.bedhome'
    Did I mess up anywhere? I have iconomy costs disabled on config.
  31. Offline


    Is there a settings that only allows all the commands for an op?

    I am using McMyAdmin, the standard permissions&groups, and I allowed listwarps as a command to everyone. However, it doesn't work. Says permission denied, with [Warpz0r] in the beginning.

    And whenever I try GroupManager, the essentials, it shows that the command doesn't exist. So, help?
Thread Status:
Not open for further replies.

Share This Page