Inactive [SEC] Ore To Client Obfuscation v1.9.1.1 - Anti X-Ray (xray) [1.2.5-R4]

Discussion in 'Inactive/Unsupported Plugins' started by TyrOvC, Jul 12, 2011.

  1. Offline


    solarox5, DaveDee, kahlilnc and 27 others like this.
  2. Offline


    The 1045+ version works with CB 1060

    Haven't tried out the Spout version with 1060 myself yet, but:
  3. Offline


    OtCO Spout version is confirmed working with Spout 1.0.2 build 121 on Craftbukkit 1060
    Just loaded up the xrayer to check to be 100% sure. Nothing but iron :D
  4. Offline


    @TyrOvC Just wondering. Are you going to add a permission node for bypass. I love the mod. But some times my users lose there hidden chests. So I have to find them for them. If not I would like to request this.
  5. Offline


    Seems like a lot of wasted time finding chests they wanted to be hidden...
  6. Offline


    Alright, I have updated to the latest craftbukkit version and have tried this plugin, however it ceases to work. Does it only hide the transparent blocks inside stone? I use my own custom map generator that makes underground netherrack.
  7. Offline


    doesnt work when i install it and join the server none of the chunks load i am using cb1060 any ideas?
  8. Offline


    So just for clarification.. All I need to do is copy the .jar file into my plugins folder if I have spout on the server?
  9. Offline


    Are you gonna do anything about the worledit compass bugg?
  10. Offline


  11. Offline


    Mining with superpick doesn't make the ores appear (probably because it needs to trigger a mining node, and superpick isnt?). Not really a problem but fyi
  12. Offline


    I think this plugin and MCmmo conflict with each other. With MCmmo and this plugin enabled (on mode 4, at least) at the same time, users can place gold or iron ore, mine it, and get double drops, which doesn't happen with just MCmmo (it detects if the ore was natural or placed somehow?).
  13. Offline


    1060 does not work - no chunks load.
  14. Offline


    When I use settings 1-3, I can't even see ores that are on the surface. They just look like stone. I placed 1 diamond ore on the floor and I relogged and it just looked like stone to me, it's even in plain sight. What is the problem here?
  15. Offline


    So it seems there are XRay available now that work to find ore... fuck my life.
    monir likes this.
  16. Offline


    Last edited by a moderator: Nov 27, 2016
  17. Offline


    Probably going to. Will add it as an optional thing soon.

    @d00ba Yes, just copy the plugin jar from the Spout version download

    @monir @Jacek
    I'm going to see if I can fix that.

    If I could get pointed in the direction of something a little more specific then a 142mb dump of a minecraft folder, probably could figure out what they did! (though, when it finishes downloading in another five minutes maybe the xray mod is obvious in said large file, which is alright :p )
  18. Offline



    WTF dude ? I've just download your file and its nothing more than a bunch of old minecraft launchers and some outdated/incomplete mods.

    Please man, think before doing FUD again.
  19. Offline


    Basically, one of my admins is easily able to detect ores... I've tried using the xray mod to do what hes doing but it doesnt work.

    He was able to detect any ore i placed / turned into an area with worldedit. Something is definitely not working correctly and im trying to find out why.

    We've caught 3 XRayers so far since the update to Spout / 1060
  20. Offline


    This plugin makes my world corrupt :(.
    badcompression.png (click on it, bukkit upload system bugged?)
    I get that error when i install the plugin.

    cb #1000 and otc # and spout #
  21. Offline


    When you use worldedit the normal block_place and block_break events are not triggered. So the chunk wont have been updated as far as this plugin can work out, meaning it does nothing.

    The same is true for the super pick axe, if you mine with that you see all the diamond next to you when it would normally move away as you go.

    Awesome ! I would be interested to know the cause too if you work it out. I can't think of a reason this would happen :s
  22. Offline


    mcMMO has this feature to give double drops if you have a high enough skill.
  23. Offline


    mcMMO allows you to get double drops from ore that has been naturally found. If a player collects it, replaces it and mines it again, you won't get double drops or XP. So Chekkaa is saying that when using this ore-to-clien-obfuscation mod, players are able to get double drops by placing the ore they just mined and mining it again.
  24. Offline


    Problem is this plugin doesnt actually modify the ore itself in the map, only what the client at the other end sees. mcMMO wouldnt see it any differently. Therefore it is most likely an issue in mcMMO itself
  25. Offline


    I keep getting this error on startup. I've made sure several times that the correct files are in the correct minecraft_server.jar

    11:21:26 [INFO] [SEVERE] Ore Obfuscation Plugin Cannot Attach To The Engine:
    11:21:26 [INFO] Ore Obufuscate Engine is not installed, please add the required
    class to the server jar
  26. Offline


    I hope you mean in the craftbukkit.jar - this needs bukkit to function.
  27. Offline


    Im having some trouble with the plugin, when someone breaks a block of dirt or a block of stone, an iron/diamont block appears behind :S Just happens sometimes :S I don't really have any idea why.
    When it appears, if you break it, the zone is updated and all seems right
    Im not ussing Instant mining nor WorldEdit

    I just get this on load:

    2011-08-18 18:25:49 [INFO] RawcriticsOreObfuscationPlugin plugin enabled
    2011-08-18 18:25:49 [INFO] RawcriticsOreObfuscationPlugin connected to the Ore Obfuscate Engine and turned it on! Using Engine: 4

    Here you have a WorldGuard report with info about my server (and the plugins, etc)

    If a normal user do it, the iron block stays
    If an OP user do it, the iron block stays
    If I do it (i have -'*' permission node) the iron block goes away

    Seems like it update right for the one who is breaking the block, but no for the other who are looking

    Wierd :S
  28. Offline


    im using cb#1060 and otco plugin,
    and each use of any essentials teleporting e.g /home, /back, /spawn, /jump and so on, let show all ores again :/ so its useless :confused: is this a fault from this plugin or from essentials then?
  29. Offline


    Getting this after i updated to non spout 1060+ version: Ore Obfuscator has a problem! Error: byte array mismatch
  30. Offline


    Have you fixed the problem with 1060 yet? When I start up my server, no chunks load - you glitch in the air and nothing loads.
    I've put the class files in my bukkit.jar and put the plugin in the /plugins folder.

    I did not have this problem in 1000
  31. Offline


    We have caught 2 Xrayers im using Regular Version for CraftBukkit 1045+

Share This Page