Inactive [SEC/MECH/ECON] Residence v2.4.2 - Self serve area protection system! Buy/Sell Land! Economy! [1185]

Discussion in 'Inactive/Unsupported Plugins' started by bekvon, Mar 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline



    v2.4.2 Released - 9/24/2011​
    See the change log for details.​
    Everyone using PermissionsEx, Essentials, or anything else besides the regular permissions plugin or PermissionsBukkit should add or change this in their config under the Global section:
    LegacyPermissions: true
    As of 2.4.0 the bPermissions plugin is supported directly.​
    As of 2.3.7 the PermissionsBukkit plugin is supported directly.​
    This support is not done through the new built in Permissions that bukkit provides, because there is no way to get a players group using the built in methods. However, by supporting this directly, you can now use the new permissions system while still keeping Residence, and not having to use old permissions at all anymore.​

    Latest Recommended Build
    Version: v2.4.2
    Download: Residence

    Latest Development Build
    Latest Snapshot: Residence.jar
    Latest Config: config.yml

    Developer API: Wiki
    GitHub Source: GitHub
    DevBukkit Project Page: DevBukkit


    Daniel Few (Wiki)​
    Linaks (Residence Logo)​
    SirHedgehog (Code)
    GSValore (Code)​
    Samkio (Wiki Video)​
    JustinGuy (Code)​

    Residence Signs (by KarnEdge)​

    NOTE: All Residence usage information has been moved to the wiki!

    Residence is different from most protection plugins in that it aims for the users to be able to protect their own homes without having to bother the admin to do it. Residence has support for a variety of different protection types including preventing movement through areas, all of which can be configured by the land owner, and limited by the admin.​
    Features (open)

    • Allows players to define protected areas for themselves.
    • Individual permissions for each protected area. Land owner can give / deny permissions globally or to other specific players.
    • Different permissions per land include: move, build, use, pvp, fire, teleport, monsters spawn, damage prevention
    • Support for group permissions on protections.
    • Multi-World support.
    • Teleport system to allow users to teleport to residences.
    • Collision detection system to prevent residences from overlapping.
    • Limits to protected size can be set up by the admin.
    • Limits to number of protected areas per player can be set.
    • Two ways to select land including using the select command, or using a item to select 2 points.
    • Messages when you enter / leave a residence. (customizable)
    • Land "leasing" system which requires users to renew the lease on their protection every X number of days or loose the protection. (off by default, see config file)
    • Recursive Sub-zoning. Create zones within zones, and then zones within those zones...
    • TONS of configuration for admins. Customize every single flag that players can or cannot use in the config file, based on their permissions group.
    • (Optional) IConomy support, can set up cost per X number of blocks protected.
    • (Optional) Permissions support.
    • In-game help / commands descriptions

    • Fix bug affecting some people with the new save system
    • Support for iConomy 6
    • Prevent enderman from messing with blocks in residences with the -build flag.
    • Paintings are now protected properly (Thanks JustinGuy!)
    • Fix Rent auto-renew bug.
    • Fix other miscellaneous small bugs.
    ChangeLog (open)

    • Support for bPermissions
    • Add "/res pset <residence> [player] removeall" command to remove all flags for that player
    • Added console only command "/resworld remove [world]" to remove all residences in a world.
    • "/res remove" now requires confirmation using the "/res confirm" command, before removing a residence.
    • Fixed subzone flag.
    • Fixed a few null pointer exceptions related to the "/res message" command, and a few other issues with it as well.
    • Fixed few cosmetic rent message bugs.
    • Fixed few mispellings...
    - Added name filter to Residences to prevent characters that mess up YML from being used. This should fix many of the errored YML files that people have been getting.
    - Fixed arrow damage in no-pvp zones (bug introduced in the Residence 1060 update).
    - Added a "Permissions Group" line of text into /res limits, this will show your Permissions group as reported by Residence.

    - Fixes to better handle the piston flag, and world "flow" flags (thx JustinGuy :) )
    - "Use" flag now covers trap doors.
    - Lease renewal can now be pulled from the Residence's bank.
    - Buying a residence now causes the default flags to be set for the user who is buying it.
    - Minor fixes to new PermissionsBukkit support (fix message about permissions not being detected when it actually was)
    - Added a few miscellaneous forgotten commands to the in-game Residence help.

    • Added direct support for PermissionsBukkit (doesn't go through the bukkit API)
    • Added LegacyPermissions true/false config option.
    • Support for residence.admin and residence.create permission nodes using new permission system.
    • Recommend using SuperPermsBridge or something that ensures backwards compatibility with old permissions.
    • Few permission changes to hopefully make it work better.
    • Fix for firespread flag with CB1000.
    • Added "piston" flag.
    • Fixes for CB1000
    • Fixes for a few minor bugs, and for concurrent modification issue with the Lease Manager.
    • Removed subzone list from /res info, and gave it its own command that supports multiple pages, /res sublist <residence> <page>
    • If the save file errors, it will now be preserved rather then overwritten, it will be renamed res-ERRORED.yml, the plugin will now disable itself upon error as well unless the StopOnSaveFault option in the config is set to false.
    • Fixed non-working per-world flags.
    • Fixed a few message bugs.
    • Add /resadmin removeall <player> admin command to remove all residences owned by a player.
    • Changed MaxUpDown in the default config to 128...
    • Fixed issue with /res vert still selecting more then the MaxUpDown allowed.
    • Fixed a few initial issues with a couple language localization messages.
    • Removed area list from /res info, use /res area list [residence] or /res area listall [residence] now.
    • New language localization system, upon first run v2.3 will create a Languages folder under your Residence config folder with the default English.yml file.
    • New in-game help system. (part of the new language localization system)
    • All commands now run without admin privileges unless you specify /resadmin before.
    • Added config option to allow rented residences to be modifiable. (PreventRentModify option)
    • Fixes to improve compatibility with Permissions 3.X
    • /res listall now has pages
    • Added the "physics" flag to control block movement. (separated from the flow flag more like)
    • New ResidenceTPEvent, and ResidenceRentEvent API events
    • Fixed residences not being properly removed from lease / rent system, upon deletion.
    • Fixed bug related to default group option in the config.
    • Fixed global "container" flag bug.
    • Fixed some NPE's related to explosions.
    • Added /resload command to load the save file after you make changes to it (UNSAFE, as it does not save residences first, and so you may loose new residences that were just created)
    • Added per residence Blacklist/Ignorelists that will allow you to specify certain block types to be ignored from residence protections, or unable to be placed in residences.
    • Added Server owned land, use /resadmin server <residence> to change the owner to "Server Owned"
    • Added global Ignorelists which allow certain block types to become unprotectable for the whole world / for a specific user group.
    • Fixed a couple bugs with the lease system, including being enabled when it shouldn't be and the lease auto-renew option.
    • Added "/res area replace" command, allows you to resize / move a physical area. If the new area is bigger, it will only charge you for the difference in size.
    • Added 'waterflow' and 'lavaflow' flags which override the flow flag if set.
    • Fixed a bug causing money to still be charged when failing to add a area to a residence.
    • Fix case sensitivity bug in rent system.
    • BOSEconomy support.
    • Essentials Economy support.
    • RealShop Economy support.
    • Added the 'place' and 'destroy' flags, which if used overrule the 'build' flag. These allow you to give only block placement permissions in a certain area, or only block destroy permissions.
    • /res check [residence] [flag] <player> command, this command evaluates if <player> is affected by [flag] at [residence]. You can leave off <player> and it will use your name.
    • Added a LeaseAutoRenew config option, that will cause leases to automatically renew so long as the player has the money to do so. Note that, if economy is disabled this doesn't work, as there would be no point to leases. Needs Testing! :)
    • Global FlagPermission config section, that allows you to give permission to use a flag to all groups, useful for the build / move / use flag that you almost definitely want everyone to have access to. Flags under each individual group will overrule these.
    • You can now set a limits on how deep or how high protections can go into the group, using each groups MinHeight and MaxHeight settings.
    • /res select sky, and /res select bedrock commands, these auto adjust to the above mentioned MinHeight and MaxHeight settings, so it won't select into a area you can't protect.
    • Rent system implemented.
    • Many bug fixes, including proper creeper explosion prevention now. Also, fixed some bugs when renaming residences.
    • New healing flag.
    • The monsters flag has been split up into "animals" and "monsters" now.
    • New Developer API, including custom Bukkit events.
    • New Global CreatorDefault / GroupDefault / ResidenceDefault flag sections to help clean up the Groups section, and remove redundant flags.
    • Probably some other minor things I've forgot :)
    - Residence 2.0 now in alpha testing, core code has been mostly rewritten.​
    - Supports multiple areas per residence using '/res area <add/remove>' commands.​
    - Added new selection commands '/res select expand' and '/res select shift'​
    - Added Predefined permission lists that can be applyed to residences.​
    - Enter / Leave messages now support %player, %owner and %area variables.​
    - Config file has been cleaned up and most things are better named.​
    - Should be fixed to work with newer iConomy versions.​
    - Save system now only uses yml as save format.​
    - Save system wont corrupt the whole file if one residences gets corrupted, you just loose that one residence.​
    - When a residence changes owner, flags are set to default for that owner.​
    - Added '/res default' command to manually reset flags to default.​
    - Released source code for v2.0​

    v1.2.8 - BETA
    - Fixed broken flag setting permissions.​

    v1.2.7 - BETA
    - Fixed chests being able to be opened from outside protected area.​
    - Fixed enter/leave message (hopefully)​
    v1.2.6 - BETA
    - Updated for CB 612 / Minecraft 1.4​
    v1.2.5 - BETA
    - Fixed tiny bug in saving messages.​
    - yml is now the default save format because its more reliable.​

    v1.2.4 - BETA
    - Fixed bug related to fire / ignite event.​
    - Added ability to remove enter / leave messages​

    v1.2.3 - BETA
    - Added a optional different save system, you can now save residences in pure YML format (same format as config files). See the config file for how to enable.​

    v1.2.2 - BETA
    - Fixed TP bug.​

    v1.2.1 - BETA
    - Fixed bug in new saving system.​

    v1.2 - BETA
    - New save system, will attempt to auto-convert from old system.
    - Fixed some permission bugs when not using permissions plugin.​
    - OPs are now residence admins when not using permissions.​
    - Fixed collisions detection issues related to having multiple worlds.​
    - Added global pvp setting.​
    - Added a "flow" flag to control water/lava flow in residences.​
    v1.1.9 - BETA
    - Fixed a severe bug when not using permissions.​

    v1.1.8 - BETA
    - Fixed a subzone bug.​
    v1.1.7 - BETA
    - Added ability to buy and sell land using /res market commands.​
    - Added a land leasing system which can be configured to expire protections if they are not renewed after a period of time. See the /res lease command. (this is off by default, turn it on and customize it in the config)​
    - Implemented a Auto-Save interval. Saves residence areas every X minutes.​
    - Fixed minor onBlockIgnite error.​
    - Added a few admins commands using /resadmin.​

    v1.1.6 - BETA
    - Fixed spaces not working in enter / leave messages.​

    v1.1.5 - BETA
    - Added Enter / Leave messages for Residences, as well as a permission option in the config to allow / deny changing of them.​
    - Fixed residence admins not being able to modify the outside world when using deny build rights outside of residences.​
    - Fixed issue related to default group.​
    - Added a config option to specify the default group.​

    v1.1.4 - BETA
    - Fixed bug in group permissions...​
    v1.1.3 - BETA
    - Changed the configuration vastly again, server admins now have control over every flag for every group.​
    - Group permissions implemented, but in need of TESTING! :)
    - World permission implemented (default world permissions for when you are not in a residence zone)​
    - Fixes subzone collision bug.​

    v1.1.2 - BETA
    - Fixed residence admins still requiring IConomy money.​
    - Fixed a bug with TNT explosions.​

    v1.1.1 - BETA
    - Fixed bug breaking subzone permissions.​

    v1.1 - BETA
    - Recusive sub-zoning, make subzones within zones, and then subzones within those subzones :)
    - Different limits based on permissions group​
    - New setting for choosing the selection tool item id.​
    - Anti-lag configuration option.​
    - Moved some permissions into the config file.​
    - All protections are now OFF by default.​

    v1.0.1 - 3/21/2011
    - Added permissions / config option to disable teleports.​

    v1.0 - 3/20/2011
    - Initial Release​

    Bug Reports:
    Please include at minimum the following information with all bug reports:
    • CraftBukkit Version
    • Residence Version
    • What you were doing when the error occurred.
    If available, also include:
    • Any server console error messages
    • Other plugins that may be causing the issue
  2. Offline


    I've been using this plugin for what seems like ages, with MultiVerse (not 2.0). I updated to Bukkit 1060 MultiVerse went to the new "Multiverse 2.0", and Residence was updated to the latest stable build. What took ages to figure out was why Residence was crashing with an error that it couldn't find several of my Multiverse worlds. In the past, this had only happened during a Multiverse issue/crash on boot, but Multiverse 2.0 seemed to be running fine. All functions worked as expected in Multiverse. I used PlugMan plugin to reload Residence plugin after the server was fully up, and it worked 100% fine. Days later I figured out that Multiverse 2.0 was loading after Residence, with this new bukkit build, new Multiverse, and new Residence. Residence looks for the worlds I have homes in, but without Multiverse 2.0 having loaded already, Residence crashes. Seconds later, Multiverse 2.0 opens and works fine, and then Residence could work fine too, but it's already crashed / disabled, and now I have to manually reload it to get things working normally again. This wouldn't be so bad if that didn't make automated restarts impossible.

    Provide a dump of my console? I'd love to, but my server isn't broken anymore as I've had to go back a version of bukkit, Residence, and Multiverse (no longer 2.0) to be sure the problem is solved, and I'm not willing to break it again to get the console dump. The plugins I used are 04:20:36 [INFO] Plugins:

    I'll give the console dump next time I update things, if it slaughters the server again. The error was something like [SEVERE] null
    org.bukkit.somethingorother.Residence[nameofResidence] could not load World NameOfWorld

    I'd post my worlds.yml, config.yml or whatever else, but everything works fine if I wait for the server to fully load and force reload Residence, so I don't think it's a problem with those files. Ask for a file and I'll dig it up in hopes we can find and solve another plugin bug, if one exists.

    Seems like I'm the only one who ever had this problem. I wonder if it's a perfect storm of plugins or something.
  3. Offline


    The one previous to the one just released. I'm using permissions bukkit. I used the node "superpermbridge.residence.*: true"
  4. Offline



    Any Sell/Buy/Rent flags for the future ? :D

  5. Offline


    what sort of permissions do i need to set up for this, defult user's, once they have bought there property to be able to build in it, and no where else, but say there rent' finnished that they cant anymore !! :p if som1 could link me the perssions for that, that would be great xD i use permission 3x -- i only want them to be able to build in that 1 house, and thats it..
  6. Offline


    Back in the old days, we would simply rename multiverse.jar to aMultiverse.jar and Residence to xresidence.jar to solve the loading problem ;)
  7. Offline

    Simon Welker

    Thank you a lot, great quick support here. :)

    Small hint to anyone: When you have installed plugins like CommandHelper- it's great to define /ra as an alias to /resadmin. I truly hate to type "/resadmin area add Nya Cat", /ra feels way more natural!

    Another thing about this.
    1. you forgot to update your version number inside the plugin, it tells me 2.3.8 at /res version :p
    2. could you implement the name regex like... that it won't just replace illegal characters with _, in my case, I just tested this; but deny creating that residence and giving the user some error message like "your residence name contains illegal characters and was not created"? Would be great :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  8. I've tried to create a residence area but it said 'Area size is not within your limits' how do I change my limits?
  9. Offline


    In the config -.-
  10. Offline

    Simon Welker

    Oh, and it might be a config issue, but I can't find it: I'm getting all enter/leave messages twice.
  11. Which bit of it?
  12. Offline


    There is a option in the config:
         MultiWorldPlugin: MultiVerse
    which is supposed to cause Residence to enable your multi-world plugin before Residence itself initializes. Either your config was missing this, or maybe its broken :( I havn't tested it with newer MultiVerse / Crafbukkit so I can't say for sure it works. As an alternative, you can always rename the .jar files, try renaming "Residence.jar" to "zResidence.jar" and "MultiVerse.jar" to "aMultiverse.jar" CraftBukkit is SUPPOSED to load them in alphabetical order, but the actual order seems to depend on what Operating System / Java you are using.

    Remove the "superpermbridge" from before the permissions node, Residence doesn't go through superpermbridge for PermissionsBukkit, it ties directly into it instead, which means you just use "residence.*"

    Heh, whoops on the version number :) Il fix that soon. And yea, perhaps it would be better to just send the user a error message rather then filter them out. I actually found a interesting java file in CraftBukkit itself that I think is used to filter out illegal messages in chat, and I might just be able to use that :)
    Simon Welker likes this.
  13. Offline


    Thanks for the update to the arrow damage. One question though. Has anyone noticed that they are slowly healing over time now that they updated to this? It is not the healing flag doing it because that heals much faster. This is a slow slow 1/2 heart heal over time in or out of any residence. Thanks!
  14. Offline


    Could U please add something, that u can set like 2 owners or more for 1 Plot? like this /resadmin setowner [PLOT] [owner1] [owner2] [owner3] etc...
    and if u enter the plot and there are more then 2 owners. it would show it like this. Welcome fellerets to *plot*, owned by Owner 1, owner 2 and 3 more owners.
    so it would show jus the 2 first owners.
    Me and some other guys run a really big server and some of them play otgether, and would like to build both on that plot. could u pls add that as fast as possible?
  15. Offline


    Does this mod have any compatability with WorldGuard? For instance, what happens when someone tries to define a Residence region that sits within a WorldGuard region?
  16. Offline


    you can already do this. You can change the message for when entering and leaving plots and the owner can give the other two people the same permissions that he/she has.
  17. Offline


    I'm thinking about moving to this instead of worldguard, as worldguard seems to be seriously resource intensive... especially on the event playerMove... Res seems to at least control the obsessive use of onplayermove with timed bailouts, I like that feature alone, seems the authors put in a thought about the server strain.

    So I need to know has anyone moved from Worldguard to Res? If so has there been marked improvements in performance? Ease of use, transition pain. I have like 50 regions to remake, if I do switch.

    Just looking for a healthy, recent opinion :)

  18. Offline


    this is bizarre - we've been using this plugin for weeks and we though it was all set but we're having the weirdest issue now: sheep, pig, chicken all spawn fine. However, there are no cows, nor squid.

    Trying to spawn them using the Essentials plugin doesn't work either, although it says it was spawned.

    However, when we visit an island where monsters is set true (as well as tnt, but that's not related) the cow and squid spawn fine.

    Here is our config:

    Any ideas? We miss the cows.
  19. Offline


    Has anyone mentioned color coding for the enter messages?
    I'm sure they have, but if not, that's a request I'd like to make lol
  20. Offline

    Simon Welker

    So, well, this crashes seem to have some other source than just illegal characters (I think it was good to fix this, though.).
    I did kwalify on my res.yml and removed/altered the errored stuff until it gave me no "real" errors back (Just that the key Economy: is unknown, but I think it's just kwalify complaining pointlessly?). Then I did the following:
    disable Residence.jar, restart, remove all res.yml-like files it saved itself, move my "better" res.yml into the Residence/ folder, enable Residence.jar again, restart.

    Worked fine, at first. Then I did, to test it, /reload 3 times in a row (I always waited until it was finished, I swear :p), and well, the first two times it didn't change anything in the folder, but the third time, it weirdly renamed my res.yml to an ERRORED again. Next time I tried, it happened immediately after the server restart.

    I'm sorry to say this, but if it keeps going like this, I will have to switch to WorldGuard for the server's sake :/

    So well, let's figure that dumb error out. Can you, somehow, give [SEVERE] messages about the line that errored, or at least make a verbose output about what's happening when it's renaming to ERRORED and unloading itself? Because I don't think this is an ordinary issue, it's something that terribly goes wrong inside, and well, it should be found out what this is.
  21. Offline


    Can someone explain what the "PreventRentModify" option does?

    I have a problem where my players cannot place water, I suspect it is this problem. The description on the wiki is not clear to me.
  22. Offline


    I have also updated from whatever 1000 build there was to the latest 2.3.9 and it is now causing an ERRORED res.yml to come up. Can I post my file for some debugging?
  23. Offline

    Simon Welker

    mcanusrules, I'd happy to check it with a yaml syntax checker, even though I'm not the plugin developer. Might help finding the actual error :)

    - so prease post it, or send it to me. :3
  24. Offline


    I tweaked the load system so that it should print out the exception now, grab the latest dev build and see if you can get it to happen and get a error log :) Hopefully this wont be too obscure a bug.

    Please do post it, I think we are getting closer to narrowing down what causes this :)

    All that does is prevent a user who is renting a residence from modifying it at all.

    Whoops, cows and squid were under the monsters flag all along lol :D Try the new latest dev build, I got them under animals now :)

    I think somone has mentioned this before heh, I can see about adding it when I can :) Need to think about how to do it exactly.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  25. Offline

    Simon Welker

    The character restrictions don't work, I think you did something wrong there, I can create a residence named ' although this character isn't included in my regex.
  26. Offline


    Hi, I used this plugin a month or so back, and we wiped the map, plugins, etc. I've been looking to add this again, but when I do, I put it in, set the permissions, edit config, etc, but every time I try and use ANY command, I get the dreaded "an internal error occurred while attempting to perform this command" message. I see that many others have had this issue, and in the console it looks just like it did for everyone else. PLEASE help me out, I'm dying to get this back into my server again, it was one of my favorite plugins. :D
  27. Offline

    Simon Welker

    HAHAHA seriously, I'm so damn stupid.
    Thanks to your verbose output, I just found that it considered the res.yml to be corrupt because it couldn't find the world Badlands on our server. And then I remembered some option about multiworld plugins, lol... Now set it to
    and everything seems to be fine for now.

    Sorry, dude. :D
  28. Offline


    i get an error saying command has caused an internal error when i try to use any command (/res /resadmin)
    Thanks heaps :)
  29. Offline



    I figured out my blacklist problem with PermissionsBukkit - seems that Residence makes all group names lowercase. E.g. I have a player group "Citizen", and when I added them as "Citizen" to the blacklist it didnt work, but when I changed it to "citizen" it worked immediately.

    In any case, love the plugin as ever ;)
  30. Offline


    I can't find the permission notes.. Can someone give me a link?
  31. Offline


    Can anyone assist me with this?
    Im using bukkit 1060
    residence 2.3.9

    From what i can tell, it doesnt seem to error untill i use compass to teleport.. but i could be wrong on this.

    09:28:50 [SEVERE] Could not pass event PLAYER_INTERACT to Residence
    java.lang.NoSuchMethodError: com.nijiko.permissions.PermissionHandler.getPrimary
            at com.bekvon.bukkit.residence.permissions.PermissionManager.getPermissi
            at com.bekvon.bukkit.residence.permissions.PermissionManager.getGroupNam
            at com.bekvon.bukkit.residence.permissions.PermissionManager.getGroupNam
            at com.bekvon.bukkit.residence.listeners.ResidencePlayerListener.onPlaye
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEven
            at net.minecraft.server.ItemInWorldManager.dig(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(
Thread Status:
Not open for further replies.

Share This Page