[SEC/FUN] Factions 2.0.0 - Guilds, War and user-controlled antigrief [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by MassiveCraft, May 29, 2011.

  1. Offline


    Faction Home; no delay?
    Can you add something where there is a delay to TP to the faction home? its really annoying because my players are using it to combat tp! This is really urgent!
  2. Offline



    I see that the plugin is aware of monster spawning, as monster spawns do not happen in Peaceful or safe zones.

    Is it possible to make this a configurable option so we can have it that monsters won't spawn in any claimed territory? We would like our server to have monsters only spawning in the wilderness.

  3. What are the permissions nodes for like /f join (Faction name)
  4. Offline


    Same url on main post and my post two above yours.

    • factions.join – join a faction"
    Sharpsniperzero1 likes this.
  5. Offline


    I've looked online and here a lot for a solution to this issue but can't seem to find one. Sorry if it's been discussed already.

    On our server, when players use /f home it loads literally every chunk around them except the one they're standing on. So they're forced to log out and back in if they want to be able to move. This is the only problem we've had with factions.
    When doing any /warp or /home commands, it warps them there fine. No chunk errors.
    Please help! :(
  6. Offline


    I don't think our admin wants Spout being mandatory.
    I've been on plenty of Faction servers before too, and have never seen this problem.

    It's just weird to me that all other warping methods, /warp /home /tpa /tpahere all work flawlessly.
  7. Offline


    what does "econCostPower" mean? Does this mean you can pay money to buy power (therefore more land)? Or does it mean it costs money to regenerate lost power?
  8. I found that out right after I posted that :p
  9. Offline


    Spout is never mandatory (unless admin sets it to that) but it does add a lot even if people don't use the client.
  10. Offline


    20:10:57 [SEVERE] Could not pass event PLAYER_COMMAND_PREPROCESS to Factions
    java.lang.UnsupportedOperationException: Not supported yet.
            at com.sk89q.worldguard.protection.regions.ProtectedCuboidRegion.getIntersectingRegions(ProtectedCuboidRegi
            at com.massivecraft.factions.integration.Worldguard.checkForRegionsInChunk(Worldguard.java:112)
            at com.massivecraft.factions.FPlayer.canClaimForFactionAtLocation(FPlayer.java:668)
            at com.massivecraft.factions.FPlayer.attemptClaim(FPlayer.java:773)
            at com.massivecraft.factions.cmd.CmdClaim.perform(CmdClaim.java:32)
            at com.massivecraft.factions.zcore.MCommand.execute(MCommand.java:126)
            at com.massivecraft.factions.cmd.FCommand.execute(FCommand.java:59)
            at com.massivecraft.factions.zcore.MCommand.execute(MCommand.java:116)
            at com.massivecraft.factions.cmd.FCommand.execute(FCommand.java:59)
            at com.massivecraft.factions.zcore.MCommand.execute(MCommand.java:131)
            at com.massivecraft.factions.zcore.MPlugin.handleCommand(MPlugin.java:206)
            at com.massivecraft.factions.zcore.MPlugin.handleCommand(MPlugin.java:216)
            at com.massivecraft.factions.zcore.MPluginSecretPlayerListener.onPlayerCommandPreprocess(MPluginSecretPlaye
            at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.java:296)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
            at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:751)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:723)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:716)
            at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:180)
            at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:93)
            at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:550)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:527)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Using the most recent Worldguard (5.2) and Factions (1.6.2) and Bukkit (1.0.1 R1) versions. Help!
  11. Offline


    I am the owner, and I cannot access other players chests or doors, any permission or config that allows me ot do everything?
  12. Offline


    Hi. I have been trying for a while now, and gotten to the point where I removed all my plugins except Factions. I still get the same error every time. If anyone knows why, could you please tell me? Here are my plugins: Citzens, CraftBook, CraftBookCircuits, CraftBookMechanisms, Essentials, EssentialsChat, EssentialsSpawn, Factions, HeroicDeath, iChat, iConomy 6, LWC, NarrowtuxLib, PermissionsBukkit, PermissionsEx, Register, Showcase, SimpleSignEdit, Spout, WorldEdit, and WorldGuard. Maybe one of them is conflicting? Here is the error:
    22:05:48 [INFO] [Factions v1.6.2] === ENABLE START ===
    22:05:48 [INFO] [Factions v1.6.2] Will use this plugin for permissions: PermissionsEx v1.17
    22:05:48 [SEVERE] Error occurred while enabling Factions v1.6.2 (Is it up to date?): com/google/gson/reflect/TypeToken
    java.lang.NoClassDefFoundError: com/google/gson/reflect/TypeToken
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:221)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:32)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at com.massivecraft.factions.P.getGsonBuilder(P.java:144)
        at com.massivecraft.factions.zcore.MPlugin.preEnable(MPlugin.java:69)
        at com.massivecraft.factions.P.onEnable(P.java:78)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:188)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:968)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:186)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:169)
        at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:348)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:335)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:165)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:399)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    Caused by: java.lang.ClassNotFoundException: com.google.gson.reflect.TypeToken
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        ... 28 more
    So it will not start. I've tried many things. I would really like this to work...

    EDIT: I am using the current latest reccomended build (build 1597). I am using the factions 1.6.2 jar file.
  13. Offline


    /f bypass.
  14. Offline


    Going to the first part I use worldguard/factions and have never seen that error. Are you running anything else that tends to break things like essentials?

    Main post, 2 and 4 posts above you asking.

    • /f bypass – Enable admin bypass mode: build/destroy anywhere
    First guess is you are missing the Lib folder for the gson file to go into. I thought it was changed where this was made automatically but if that is wrong go to your minecraft folder and make a new folder named "lib" and in that a file gson.jar

    That is my guess but now looking at my temp server I'm fairly sure it made that by itself but if not try what I said.
  15. Offline


    Alright, so... I have the lib folder from the full download with that gson.jar file you're talking about. I also see a bunch of files in there too-- they are my plugins and some other stuff. Do you want me to go to my .minecraft or /minecraft folder? Or do you mean the server's main folder? Or /plugins?
  16. Offline


    Would be the servers minecraft folder with that and was a guess as that was the main part I saw on your error.

    If this is a new error and you have nothing to lose try re-installing it from scratch.

    Edit: Wait what files are in your Lib folder? I have a server with many plugin but nothing is in there other then gson.jar
  17. Offline


    In /MassiveCraft-Factions-1c918ad (the full folder)/Lib, I have: bukkit-1.0.1-R1.jar, CopyLibs, EssentialsChat.jar, gson.jar, junit, junit_4, nblibraries.properties, Permissions.jar, PermissionsEx.jar, Register.jar, SpoutAPI.jar, WorldEdit.jar, and WorldGuard.jar.

    EDIT: Turns out I already had a folder named "lib" with gson.jar in it. Should i back it up and overwrite it with the one in the full Factions folder i have?
  18. Offline


    Not sure what system you have going on but for me lib only has gson.jar for me and I keep all plugins in the plugin folder >.> So maybe your style is breaking it?
  19. Offline


    My style? As in my MacBook Pro (you said what system I have)? I know my friend who is running Windows 7 has his server that works fine with Factions.

    EDIT: Keep in mind that the "lib" folder I have in my main server directory ONLY has gson.jar. The one in my downloads with all of the extra Factions stuff has a "Lib" folder (with the capital L) and has those files in it.
  20. Offline


    Meant if you have all those in your lib folder as you made it seem.
    To be fair I've only run my server one way and not on a Mac but I have Lib in the root folder for my server then plugins in another file named plugins. If you have two lib folders I would keep the one outside the plugin folder and see how that works for you.

    Edit: My factions folder only has board, conf, factions, players, and tags.
  21. Offline


    Thanks for taking so much time to help me out with this. I have one lib folder (in the server's root folder), I will move the other one out of /plugins, but Factions doesn't do ANYTHING. If I put the .jar in the /plugins folder, and start up the server, all it does is give me an error and generate a "Factions" folder.
  22. Offline


    Odd the jar is meant to make the folder in the same file and it reads from the lib/gson.jar. Are you getting another error now? And will go ahead and say try to use the bukkit factions recommends first to see if you still get the error. If you do then its something on your end if you no longer get it maybe factions breaks with one of the later bukkit updates.

    And np for helping.
  23. Offline


    Holy crap!! I copied all the files that were in there and it worked... Now don't feel like you wasted your time! You gave me the idea to do that by telling me about the lib folder in my root folder. Thank you so much! I've been trying for weeks.
  24. Offline


    Glad to see you got it working and if you have any more questions feel free to ask. Factions is great and can do a lot. If you have towns on your server I use factions to name my towns if you are interested :D
  25. Offline


    How does a faction owner make his land ungriefable to outsiders?
    But still have PVP on?
  26. Offline


    Depends on how you have the config. But just naturally pvp is always on and blocks are protected in factions.
  27. Offline


    First: Thanks for the excellent plugin, not sure where my server would be without it!

    There is only one possible feature I could possibly request and that is to set a warmup timer for the /f home so players can't use it as a means to escape death.
  28. Offline


    They arent though
    The blocks aren't protected, How do i protect them??
  29. Offline


    I own a server which runs with factions, but the problem is, neither me, or my admins can open chests or doors in another factions claimed land, this causes issues as we cant find hackers, or monitor players correctly.
    Is there any way I can change this? I dont know if this helps, but I use permissionsEx
  30. Offline


    All you have to do is type /f bypass on or just /f bypass .. I think its on help page 8 or 9...

Share This Page