[RPG/MECH] mcMMO v1.2.07 - RPG Addiction Redefined! Multi-Lingual! [1337][1549]

Discussion in 'Inactive/Unsupported Plugins' started by nossr50, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    When repairing a diamond pickaxe I get "!AdeptDiamond!" I am on 18 not 19
    Fixed in 19.

    Now on 19 I get

    Could not pass event BLOCK_BREAK to mcMMO
    java.lang.ArrayIndexOutOfBoundsException: -1
    at java.util.ArrayList.remove(Unknown Source)
    at com.gmail.nossr50.config.Config.removeBlockWatch(Config.java:89)
    at com.gmail.nossr50.mcBlockListener.onBlockBreak(mcBlockListener.java:177)
    at org.bukkit.plugin.java.JavaPluginLoader$35.execute(JavaPluginLoader.java:482)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at net.minecraft.server.ItemInWorldManager.c(ItemInWorldManager.java:160)
    at net.minecraft.server.ItemInWorldManager.a(ItemInWorldManager.java:122)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:458)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:223)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  3. Offline


    Version 1.0.20
    • Fixed Array Index Out of Bounds error
    "Whoops" :)
  4. Offline


    Thanks ;D
  5. Offline


    Windows 7 Ult.
    Bukkit 860
    we got around 10 - 20 people online at once
    I am running mcMMO in mySQL mode.
    Got a AMD Phenom II X4 955 Overclocked to 4.2GHz
    8 Gigabytes DDR3 1333
    Onboard graphics ATI 4250 (I skimped on the graphics because i am to poor for a nice card.)

    I get no errors when someone types /myspawn
  6. Offline


    This maybe a dumb question but I can't get any of the admin commands to work, can anyone help me?
  7. Offline


    Do you have the * permission?
  8. Offline


    Except, like I said, it is not listed in the change log, hence why I am reporting it in case if it wasn't. Duh.
    PS: Yes, it is not in the list I've snipped form your post.
  9. Offline


    I am having an odd error. I upgraded from the old version(before the yml file) and had it create the yml file and made my changes to mysql and now it isn't working. Not seeing any change in experience at all. I can see my stats but no change to them no matter how much I do.

    No error msgs in the log so I am confused.

    Using mysql if that helps.

    NVM it seems to work when I threaten it with a post to the forums. Sorry for buggin you

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
  10. Offline


    when do you think we could see new skills!? example: fishing?
  11. Offline


    Hey, the fire rate limiter: false in config.yml doesn't seem to work. It always seems like it's on.
    lipe123 likes this.
  12. Offline


    I'll check it out
  13. Offline


    Do you think we could see any new skills soon? :eek:
  14. Offline


    Is there a way to STOP players from useing tools be for a sertin level?
    and how do i import my old levels?
  15. Offline


    Customizeable level restriction system maybe that WOULD be awesome! As for your questions nope not possible :O
  16. Offline


    ok how about this how do i get my old levels to the MySQL data base?
  17. Offline


    Converting Users from Flat File to MySQL
    Right now this is handled by an in game command, let me know if you'd want this to be a server command. Assign the 'mcmmo.admin' permission to yourself and go in game and type '/mmoupdate'. This will begin the update process. It will inform you when it starts and finishes. Once its done everyones stats should immediately be updated with no need to restart the server or have users rejoin. You can check the server console to see a debug message of how many items were added/updated to the MySQL DB to see if it went well.
    Read the post next time. I take no credit for this. I just copied this from the post!
  18. Offline


    thank you sir! but every one lost 1 level in axes:eek:
    mah go figuere not worrryed:rolleyes:
  19. Offline


    Yup fire rate limiter isnt working, that feature is really evil.

    Also I just killed all my wolves by accident :( IR sad panda.
  20. Offline


    12:01:42 [SEVERE] Error occurred while enabling mcMMO v1.0.20 (Is it up to date?): URLDecoder: Incomplete trailing escape (%) pattern
    java.lang.IllegalArgumentException: URLDecoder: Incomplete trailing escape (%) pattern
    at java.net.URLDecoder.decode(URLDecoder.java:187)
    at com.mysql.jdbc.NonRegisteringDriver.parseURL(NonRegisteringDriver.java:633)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:296)
    at java.sql.DriverManager.getConnection(DriverManager.java:620)
    at java.sql.DriverManager.getConnection(DriverManager.java:222)
    at com.gmail.nossr50.Database.<init>(Database.java:35)
    at com.gmail.nossr50.mcMMO.mcLoadMySQL(mcMMO.java:92)
    at com.gmail.nossr50.mcMM:confused:nEnable(mcMMO.java:78)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    i use mysql then there is the issue.
  21. Offline


  22. Offline


    fix your permissions file
  23. Is that timer change the fix to the thread issue in 17/18 you think?

    Dropbox download is giving an error currently :(
  24. Offline


    Here is an alternative download link
    <Edit by Moderator: Redacted mediafire url>
    Your welcome :D
    Feel free to use this as a mirror :D
    Last edited by a moderator: Dec 15, 2016
  25. Offline


    All of this is on 1.0.20
    -It appears that slimes and ghasts currently give no xp for your combat skills.
    -Special abilities are currently lasting a very long time. Approximately one minute. It doesn't seem to be affected by your skill level, as my tree feller lasts just as long as my super-breaker, whereas my mining skill is drastically higher than my woodcutting skill.
    -When you raise an item to perform a special attack, it is also staying raised for an extended duration.
    -Super-breaker still doesn't work on Redstone or Sandstone.

    Thanks for keeping up the awesome mod. =)
  26. Offline


    I'll test this out to confirm

    Confirmed they don't
  27. Offline


    yes i mean I know that but.. i have to put them manually in difference permission.. Is there such a plugin that when they type a command, they will be changed into a difference permission..?
  28. Offline


    i cannot confirm that, it worked well
  29. Offline


  30. Offline


    I was saying the fire rate limiter works TOO well. It works so well I can't disable it :D
  31. mcMMO still has the same major issue you added somewhere in 17 or 18 :(

    I have a visual now for you:


    That 2nd Java thread is mcMMO's thread, it only appears on version after 16, and it's load reaches 100% after a bit of uptime and 50+ or so people online.

    If other people aren't seeing this, they simply aren't putting any load on this plugin, this major bug is clearly there, and it's not there in 1.0.16

    Sadly rolling back to 1.0.16 again :(
Thread Status:
Not open for further replies.

Share This Page