[INACTIVE] iQuest v3.2.0 - Take NPC questing to the next level! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by sddddgjd, Aug 2, 2011.

  1. Offline


    iQuest is no longer in active development!

    Yeah,that's right,i quit,you can all go home now...:D
    Jokes aside, i am forced to quit working on iQuest,for a number of reasons,including:​

    • The code was old...very old! Updating the entire thing just isn't possible!
    • I am really busy with 2 other,bigger,projects, so i can't spend that much time on this!
    • I am not as familiar with the code as i could be if i created it!
    • Big parts of the code just plain suck...i was a really bad coder when i starter this project! :D
    That being said,don't panic! I am going to recreate iQuest from SCRATCH, using just a small part of the main code! It will act the same,however some of the important changes will be:

    • Superperms support! It's the future,it's time for people to switch over...
    • More quest types!
    • Parties!
    • Speed improvements!
    • MySQL/SQLite database support!
    • Much easier commands,and interface
    • Spout support!
    • MASSIVE support for RPGWorld, one of the 2 big projects i'm working on...that thing will be INSANE!
    • New configuration support! Should be much harder to mess it up...

    You may be wondering,how am i going to pull this off? Well, first of all, i have @Samkio , @tips48, @r3Fuze , and the rest of our coding team to help me! However, we all have to work on separate parts of the plugin, so i will make yet another coding team, which will work exlusively at the questing part! (it will also work as a stand-alone,don't worry :D)

    So,that was it, i will start actually working on it now!
    If you want to take part in development,just PM me! If you have atleast one plugin,i'll probably know you already! :p


    You guys helped me the most during development...interested in joining this?

    For more details on the new plugin, click!

    chudy126p, Samkio, powback and 6 others like this.
  2. Offline


    I'm on windows but the same thing happened. However, putting iQuest.bin in the iQuest folder did not fix the issue.
  3. Offline


    noo,that's a different problem! The iquest.bin file should be in the main plugins folder!
    Anyway,updated the plugin to support linux...
    I'll look into your problem again!
    P.S: PM me your skype if you have one,please!
  4. Offline


    its have a iconomy support?
  5. Offline


    yeah,iconomy and boseconomy!

    where did everyone go? :confused:
    Did i just solve all the problems with the latest update? :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  6. Offline


    Hey there!

    I'm having the following issue: NPC creation with Citizens works just fine. I can also assign a quest by /qn create [NPC-Name] [Quest-No.]. But when i right click on the NPC, nothing happens...
  7. Offline


    Check if you set "use item for questing" in the config files to true!
  8. Offline


    I set it to true, did a reload but it still won't work :(
  9. Offline


    you need to set it to false!
    ok,what did you download! You need the latest .jar,AND the files!
  10. Offline


    I downloaded it a few hours ago. Both the files and the jar. But I downloaded it again, deleted the "old" ones and dropped the new ones. I don't know why, but now it works. Thanks...
  11. Offline


    Ah,you probably had the old bugged version! I fixed that one!
    And no problem,enjoy!
  12. Offline


    Okay, I know whats the problem: As soon as I use the german quests, it won't work :(
  13. Offline


    the german quests are bugged?
    Are you sure?
    I'll test now...
    LE: Nope,it's working fine for me!
    What,exactly,happens when you put the german quests? does it crash on startup?
  14. Offline


    I'm sorry, I can't test it further atm, because my internet connection sucks (exactly when i shut the server down... had to restart it using my android phone :p)

    This is what I experienced about an hour ago: As i mentioned before I replaced all the files again, also the quests file (which was german before). It worked then. But when I replaced the default quests file with the german quests file in your first post, I couldn't get quests from NPCs. I right clicked them, but nothing happened.

    And I get a lot of the following error messages in the server console (it doesn't matter if english or german quests):
  15. Offline


    delete iquest.bin again,will solve all your problems! Trust me,it will work!
  16. Offline


    I have exactly the same error and I can not deal with it
  17. Offline


    Amazing plugin ! It's work correctly but i have 2 questions :
    - Possibility to give to a Npc 2 quest ? ( When a player finish the first he have the possibility to have a other quest ? )
    - When a player go to a npc-quester and he finish the quest , he have the possibility to restart the quest . How to stop this ?
  18. Offline


    Great work on the move quests! Question though in regards to it... when I do /qn <npc1> <npc2> dis the first npc gives but doesn't receive.. which is right... but the 2nd npc will give AND receive. Am I doing something wrong here? I do a /qn create <npc> <quest number> on both before running the above command.
  19. Offline

    Cosmic Break

    i have pvp, so i'd like if a quest type could be to kill a certain player or multiple players
  20. Offline


    will add!

    you need to use the DIZ argument,to dizable one of them!
    or swap,to swap the quests between each other!
    it will look like this:
    /qn change [npc1] [npc2] diz

    Did you just download the plugin for the first time? if not,then delete iquest.bin!!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  21. Offline

    Randy Schouten

    Maybe late reaction, but the reason why it's in the WIP section is exactly what you say :p
    It's undergoing major changes all of the time.

    uQuest, on the other hand, was pretty much done developing.
    So if you take it over it's in exactly the same state and only minor changes have to be made to make it working again.
    Plus the whole system is worked out, making it easier to implement new features in, especially fairly easy ones such as NPC support.
    So you must take this in consideration before branding my plugin as bad.

    PS: I still really appreciate you helping me test.
    I only want to protect my own plugin a little ;)
  22. Offline


    Hey, Randy helped me a lot in adding NPC support, we all owe him one! + right now, iQuest is bugged as hell...
  23. Offline

    Randy Schouten

    Well, it's your job to fix it, haha.
    Just ask me for help too, if you want some.

    Right now, I really gotta remake the whole system to check if a quest is done, it's quite annoying sometimes to have multiple quests at the same time :p
  24. Offline


    Yeah,i don't even want to try to do multiple quests! -.-
  25. Offline


    I deleted and now I have this error

    2011-08-11 18:22:31 [SEVERE] Could not pass event PLAYER_INTERACT_ENTITY to iQuest
    java.lang.NoClassDefFoundError: com/citizens/npcs/NPCManager
        at sddddgjd.NPC.NPCListener2.onPlayerInteractEntity(NPCListener2.java:30)
        at org.bukkit.plugin.java.JavaPluginLoader$11.execute(JavaPluginLoader.java:314)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:845)
        at net.minecraft.server.Packet7UseEntity.a(SourceFile:33)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    I need to have installed a citizens? since I do not use NPC
  26. Offline

    Randy Schouten

    I recognize that error.
    It's the error that Citizens could not be found.

    So it's either:
    • iQuest has to update to have the correct class file in the actual plugin
    • Citizens has to be installed or the feature disabled in the plugin

    Hope that helped you out a bit @sddddgjd , if you didn't know what it means anyways.
  27. Offline


    Just what Randy said,and yes,you need citizens even if you're not gonna use NPCs! (which are awesome!)
    Also,you will have to disable "Use npc based questing" in the properties to be able to use the normal commands!
  28. Offline


    Maybe I'm reading this wrong but this doesn't work. What happens is:

    npc1 will now give the quest, but NOT take it
    npc2 will now give the quest AND take it

    I'm trying to set this up so that:

    npc1 will give the quest but NOT take it
    npc2 will take the quest but NOT give it
  29. Offline


    there's no way npc2 will give another quest than the one he's assigned to! You need to check again...
    P.S: Use /change restore [npcname] to restore them to their original state!

    Also,if you're doing this on a server,give me the ip! (or get hamachi,so i can help you)
  30. Offline


    I'm not trying to make npc2 give a different quest, I'm just trying to make it so he doesn't give anything at all, only takes. But if you wanna see the setup, you're more than welcome, I'll show you around.

    mc.midgardrealm.net I'm assuming sddddgjd is your minecraft ID? I'll whitelist that.
  31. Offline


    I use Essentials eco. Do you think Essential's signs will still work with Bose eco ?

Share This Page