[GEN/TP/ADMN] CommandBook 1.7 - Essential and useful commands (/item, etc.) [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by sk89q, Feb 28, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    General commands as used on my server since '10. Warping, item giving, time changing, weather changing -- the usual.

    Thor command, one of many (video by Rubenbeebl):

    Note: You can remove any of these commands from CommandBook using the download link below.
    • General:
      • item [-d] <item[:data]> [amount]
      • give [-d] <target> <item[:data]> [amount]
      • more [-a] [-i] <target>
      • online [filter]
      • motd
      • intro (play intro music)
      • midi (play a MIDI file for yourself)
      • rules
      • setspawn [destination]
      • time [world] <time>
      • weather <'stormy'|'sunny'> [duration] [world]
      • thunder <'on'|'off'> [duration] [world]
      • spawnmob [-p] [-d] [-i] [-r] <mob> [count] [location]
      • kit <kit> [target]
    • Teleportation:
      • spawn
      • tp [target] <destination>
      • bring <target>
      • put <target>
      • call <target> (request a teleport)
    • Messaging:
      • broadcast <message>
      • say <message>
      • me <message>
      • msg <target> <message...>
      • reply <message...>
      • mute <target>
      • unmute <target>
    • Player:
      • whereami
      • compass
      • clear [-a] [target]
      • slap [-s] [-h|-v] [-d] [target]
      • rocket [-s] [-h] [target]
      • barrage [-s] [target]
      • shock [-s] [target]
      • thor [target] (get Thor's hammer)
      • unthor [target] (revoke Thor's hammer)
      • whois [target]
    • Utilities:
      • ping
      • debug info
      • debug clock (very accurate server lag benchmark)
    • Bans:
      • kick <target> [reason...]
      • ban [-e] <target> [reason...]
      • unban <target> [reason...]
    Complimentary plugins:


    [​IMG] CommandBook 1.7
    Requirements: Java 6+, WorldEdit, Bukkit build 753+

    You need WorldEdit: Install WorldEdit. If you don't want WorldEdit, put WorldEdit.jar in the root folder of your server or in the plugins/CommandBook folder.​

    If you find CommandBook useful, [​IMG]

    How to Use

    Check out my server too!

    [​IMG] (CommandBook is open source!)
    dragon8510, Psychoma, Goodi and 26 others like this.
  2. Offline


    I have the same error as above... using bukkit 1060 vanilla.
  3. Offline


    When i install the .jar there isnt a file created ?? help
  4. Offline


    How to make /players with colored names?
  5. Offline


  6. Offline


    When I use ToManyItems client side plugin to 'give' items to myself, it interfaces with your plugin just like in essentials. However, it doesn't update the client interface. i.e. When I give myself and item, it gives a block of 64 to me, but I have to click on the the empty inventory slot to updated the inventory, which will make it 'appear'. That's not too clear.

    To put it another way. When I click on an item, it reports as given, but nothing shows up in my inventory. If I click on the next available blank slot it shows the item. It doesn't refresh basically.

    Any way to fix this?
  7. Offline


    Still the wrong thread. That's a problem of TooManyItems obviously
  8. Offline


    151 recipes
    16 achievements
    19:19:19 [INFO] Starting minecraft server version Beta 1.7.3
    19:19:19 [INFO] Loading properties
    19:19:19 [INFO] Starting Minecraft server on
    19:19:19 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-
    g4ed23b1-b1060jnks (MC: 1.7.3)
    19:19:20 [SEVERE] Could not load 'plugins\CommandBook.jar' in folder 'plugins':
    java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandExcepti
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:143)
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:110)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:133)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:337)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.C
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            ... 11 more
    19:19:20 [INFO] [Permissions] (Yeti) was initialized.
    19:19:20 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    19:19:20 [INFO] Preparing level "world"
    19:19:20 [INFO] Preparing start region for level 0 (Seed: -3111825382619327742)
    19:19:21 [INFO] Preparing start region for level 1 (Seed: -3111825382619327742)
    19:19:21 [INFO] Preparing spawn area: 0%
    19:19:22 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    19:19:22 [INFO] [HeroChat] Permissions 3.1.6 found.
    19:19:22 [INFO] Server permissions file permissions.yml is empty, ignoring it
    19:19:22 [INFO] Done (0.209s)! For help, type "help" or "?"
    I keep getting this error. Only plugins I have installed are HeroChat and Permissions. Please help.

    Oops that's because I didn't have WE sorry :D

    Yeh I got that error and it's because I didn't have WorldEdit installed.

    Do you have WorldEdit installed?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  9. Offline


    yeah, I did have worldedit installed. but I tried to start server with just commandbook as the only plugin and it still spit out this error.
  10. Offline


    Any news about when Commandbook 1.6 (Or whatever the next version is) will be released?
  11. Offline


    Get the latest dev build. The issue is fixed.
  12. Offline


    Thanks! I'll check it out! [diamond]

    I know that you know this, but it worked like a charm. Thanks again!
  13. Offline


    # Give ops all permissions
    op-permissions: true
    use-display-names: true
    online-on-join: true
    colored-names: true
    grouped-names: true
    show-max-players: true
    verify-name-format: true

    one group look like this:
    default: true
    prefix: '[&eVIP&f]&4'
    suffix: '&f'
    build: true
    - Default

    I dont get colors why is that? when typing /online
    and the groups order is sorted random is there some way to choose order
  14. Offline


    I Know you dont want this to be bloated but can you add a kick all feature because I use MC Server GUI and I want the users to get kick and display a message saying the server get restarted as a example and maybe add a /help feature to give basic commands.
    I dont want to use essentials anymore.
  15. Offline


    You can use /kick * to kick all users. This works in any command that takes a target (/slap, etc.).
  16. Offline


    Cool i just did not understand all those sub commands thanks i swithg to commands book yes.
  17. Offline


    CommandBook doesn't use prefix or suffix for name colors. It uses the display name (or nick name). If the display name has colors included in it (I don't know if & works or not in the display name, but what does work is §), it will show up colored.
  18. Offline


    Can you show an example i would appreciate that
  19. Offline


    Bug: Using the command "/item air" or "/item 0" boots you off the server. Also no built-in aliases (though they can be added manually in the config) for shears, chestplates/vests, lapis ore/block (correction: alias exists if you add "lazuli"), glowstone dust, or pistons. I also would've expected "/item redstone" to produce redstone dust rather than wire, and the default clay/brick bindings aren't my favorite. Otherwise, I'm pleased to see just how many synonyms there already are in the plugin.
  20. Offline


    Well, I have a complicated way of doing it. It involves the essential's nick command and some CommandHelper code to put in the color. I believe there are some plugins that change the color of names to the display name directly. I think the plugin ColorMe does this or applies the prefix color to the displayname; I'm not sure though.
  21. Offline


    Hi, sk89q!
    It would be cool if you could add the ability to create and edit your own commands like /motd and /rules in config.yml and give them the name of your choice. For example, /team - administration list appears on screen and so on.
    MineMaster likes this.
  22. Offline


    CommandHelper and McDocs provide similar functionality for what you want.
  23. Offline


    just wanna ask if commandbook is bug-free now? For example the /return command didn't worked a while ago.
  24. Offline


    What do you use for a /help command guys? The one he links to is inactive.
  25. Offline


  26. Offline


  27. Offline


    Thank you!
  28. Offline


    Which permission system does this work with? Phoenix Permissions or Superperms?
  29. Offline



    could you add a time to bans so we can ban people for a temporary amount of time?
  30. Offline


    Quick Question: Does this plugin work with -

    WorldEdit 4.6

    Anyone have this plugin configured and working the above ^^? My main issue is... the plugin is loading but not pulling the PermissionsBukkit :(


    Okay.....figured it out.........

    You must download both the CommandBook and WorldEdit dev builds and ensure you rename them in your /plugins folder to 'CommandBook' and 'WorldEdit' respectively. It is pulling from PermissionsBukkit now.... 90% of commands tested...... however the /tell command's format is... strange :(
  31. Offline


    Im i the only one who's /warp doesn't work?
Thread Status:
Not open for further replies.

Share This Page