[GEN] General 3.6.2 (Webern) -- A plugin for general commands, now on BukkitDev! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Celtic Minstrel, Mar 6, 2011.

  1. Offline

    Celtic Minstrel

    General 3.6.2 [Webern]
    NOTE: If you are updating from 3.4.1 or earlier, you must copy the aliases section from the sample config file into your own config file. If you don't do this, many commands will not work.
    Download from the BukkitDev page (Older versions | Source)

    General provides a small set of basic commands for your server. See more details on the BukkitDev page.

    General is a fork of Nijikokun's plugin. It adds a few commands to the original set provided by General.

    Without Nijikokun's original General plugin, this plugin would never have been possible. Or at least, I would not have made it. General Essentials (the source of the /kit command) was created by wjykk and has had some input from cjc343. The SpawnMob plugin, from which I adapted the code for the /mobspawn command, was created by xmlns and is now maintained by jordanneil23.

    I recommend using sk89q's CommandHelper in conjunction with this plugin. Starting from 3.4.5, there is a command-helper.txt file included with the download which you can copy to CommandHelper's config.txt for some handy aliases, such as /spawn and /home.

    Differences from cjc343's now-inactive fork
    • Does not detect that another plugin has registered the same command.
    • /playerlist and /who are two separate commands
    • Different items.db format
    • Does not support setting or viewing the raw time.
  2. Offline

    Celtic Minstrel

    First, you're supposed to put the name of the player at the end (/give 1 1 DJ411) though it will sometimes work when it's at the beginning. Second, /give stone should work without issue since that's the Bukkit built-in name for it. However, if some names don't work, you may be missing an items.yml file.

    Tested, and seems to work without issue. I didn't test everything though.
  3. Offline


    Are you planning on adding /kick /ban commands?
  4. Offline

    Celtic Minstrel

    There are no plans for that, no.
  5. Offline


    Ok i guess there are two Generals... i have now switched over to This General and /give stone worked.

    but in console i keep getting this
    18:15:07 [SEVERE] Nag author: 'Celtic Minstrel' of 'General' about the following: onPlayerJoin has been replaced with a new signature, (PlayerJoinEvent)
  6. Offline

    Celtic Minstrel

    Are you using 3.3.1? That should have been fixed in 3.3.1.
  7. Offline


    Main "Download" link at the top of the thread still points to 3.3 and not 3.3.1
  8. Offline

    Celtic Minstrel

    Whoa, I completely missed that. Thanks for noticing.
  9. Offline


    I apparently have to report this error! I was doing a /heal. I have * permissions. :D

    Running CB#670. This happens whether General is the only plugin enabled, or if I have all of them enabled. It doesn't matter whether I pass arguments or leave it at the basic '/heal'.

    19:11:36 [SEVERE] [General-3.3.1] There was a big problem executing command [misc.heal]! Please report this error!
    19:11:36 [SEVERE] [General-3.3.1] Full command string: [heal]
    19:11:36 [SEVERE] java.lang.ClassNotFoundException: net.craftstars.general.command.misc.healCommand
    19:11:36 [SEVERE]       at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    19:11:36 [SEVERE]       at java.security.AccessController.doPrivileged(Native Method)
    19:11:36 [SEVERE]       at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    19:11:36 [SEVERE]       at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    19:11:36 [SEVERE]       at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    19:11:36 [SEVERE]       at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    19:11:36 [SEVERE]       at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    19:11:36 [SEVERE]       at net.craftstars.general.General.onCommand(General.java:235)
    19:11:36 [SEVERE]       at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    19:11:36 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    19:11:36 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:254)
    19:11:36 [SEVERE]       at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:596)
    19:11:36 [SEVERE]       at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:559)
    19:11:36 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
    19:11:36 [SEVERE]       at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    19:11:36 [SEVERE]       at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    19:11:36 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    19:11:36 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    19:11:36 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    19:11:36 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    19:11:36 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    On a totally different topic to my above post, is there a way to set a different iConomy price per kit in the config.yml, or is it a blanket "1 price doesn't matter what the kit is"?

    If there's a way to set per-kit pricing, then I'm able to have one less plugin loading up :)


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  10. Offline

    Celtic Minstrel

    Ah, that iConomy section is not used yet; iConomy support is not yet implemented beyond the ability to display the user's balance in the MOTD. When I get around to adding it, you'll be able to specify individual prices for each item and each kit. I think the current target is to have it in 3.5.

    For some reason, the heal command didn't get moved properly. As a quick fix you can edit your plugin.yml and change "misc.heal" to just "heal". I'll upload a version with the fix at some point.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  11. Offline


    Looking forward to v3.5 then! Thanks for letting us know.

    Done. Fixed. Works without a problem. Awesome stuff. Appreciate that it's that easy to put in a temporary fix :D I'm kinda OCD about not having any errors pop up on the console. Even if the commands work :)
  12. Offline


    Hi Cletic Minstrel,

    great Plugin. Thanks for the work, you put in it.
    But I have a question about the broken heal issue.
    The only things with heal in my plugin.yml are

        permission: general.heal
        description: Restores your health. (Can also reduce it if you give a negative amount.)
        usage: /heal [player] [amount]
    There isn't a "misc.heal" to change.
    Sry for being such a newby ;)
  13. Offline

    Celtic Minstrel

    @Civer - Do other commands have "misc." in front of them? If yes, and if they work and heal doesn't, you can add "misc." in front of "heal". I think most likely you're just using an older version, though.
  14. Offline


    I'm using 3.3.1.
    In the file is not one "misc". Neither there is one in the "default configs" plugin.yml .
    I think i'll use the golden apples and wait for the official bug fix;
    Don't want to bother you. Thx :)

    (ah.. and sry for my bad eng xD)
  15. Offline

    Celtic Minstrel

    What happens when you use /heal?
  16. Offline


    Ingame message says:
    /heal [player] [amount]
    In the Server.log you can find:

    2011-04-13 14:06:17 [SEVERE] [General-3.3.1] There was a big problem executing command [misc.heal]! Please report this error!
    2011-04-13 14:06:17 [SEVERE] [General-3.3.1] Full command string: [heal]
    2011-04-13 14:06:17 [SEVERE] java.lang.ClassNotFoundException: net.craftstars.general.command.misc.healCommand
    2011-04-13 14:06:17 [SEVERE]     at java.net.URLClassLoader$1.run(Unknown Source)
    2011-04-13 14:06:17 [SEVERE]     at java.security.AccessController.doPrivileged(Native Method)
    2011-04-13 14:06:17 [SEVERE]     at java.net.URLClassLoader.findClass(Unknown Source)
    2011-04-13 14:06:17 [SEVERE]     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    2011-04-13 14:06:17 [SEVERE]     at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    2011-04-13 14:06:17 [SEVERE]     at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-04-13 14:06:17 [SEVERE]     at java.lang.ClassLoader.loadClass(Unknown Source)
    2011-04-13 14:06:17 [SEVERE]     at net.craftstars.general.General.onCommand(General.java:235)
    2011-04-13 14:06:17 [SEVERE]     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    2011-04-13 14:06:17 [SEVERE]     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80)
    2011-04-13 14:06:17 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:254)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:596)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:559)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:553)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetworkManager.a(NetworkManager.java:198)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:72)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:368)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    2011-04-13 14:06:17 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
    The Server seems to know the command "misc.heal"... but in the config.yml isn't a single misc...
    weird :eek:
  17. Offline

    Celtic Minstrel

    Ah, so you do in fact have the same problem as Slimey_G. You need to actually open the jar file in a ZIP viewer and edit the plugin.yml in there (or unzip it, edit, and rezip). It sounds like you have another plugin.yml floating around somewhere; that doesn't do anything, and you can delete it if this is the case.
  18. Offline


    Ah Thx, now it's working ;)
    You're a god xD
  19. Offline

    Celtic Minstrel

    Sorry, but this is simply not true. :p
  20. Offline


    I've been running General for ages until suddenly tonight after a /reload the server came up with this

    2011-04-15 18:16:40 [SEVERE] Could not load 'plugins\General.jar' in folder 'plugins': Permissions
    org.bukkit.plugin.UnknownDependencyException: Permissions
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:123)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:158)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:106)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:84)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  21. Offline


    You appear to be running the other version of General.

    If you meant to use this one, which works without Permissions, then you should re-download it from the top post.

    If you meant to use the other, Permissions is required.
  22. Offline


    I've tried both still the same

    EDIT: Re-installed this one and it works Essentials still doesn't though
  23. Offline


    Suddenly getting this message, was working fine before and I haven't really changed anything

    21:44:30 [WARNING] [General-3.3] The names section of items.yml is missing or invalid.
    21:44:30 [WARNING] [General-3.3] No aliases were defined in items.yml.
    21:44:30 [SEVERE] null loading General v3.3 (Is it up to date?)
            at net.craftstars.general.items.Items.loadHooks(Items.java:137)
            at net.craftstars.general.items.Items.setup(Items.java:132)
            at net.craftstars.general.General.onEnable(General.java:116)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:127)
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:578)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:216)
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:115)
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:93)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:215)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:202)
            at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:142)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:257)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:375)
  24. Offline

    Celtic Minstrel

    Well, that's strange. You still have an items.yml? What's in it? It sounds like it's probably empty for some reason. If nothing else, you could always copy the default items.yml over from the jar file.
  25. Offline


    Same happens to me, it deletes the original .yml file, and replaces it with an empty...
    Dunno why...
  26. Offline

    Celtic Minstrel

    @Satros & @Johniver - First question... are you on 3.3 or 3.3.1? Normally I wouldn't need to ask this, but initially 3.3.1 was incorrectly reporting its version.

    Released version 3.3.2
    • Finally supports spawning wolves! I also added cookies and locked chests to the items.yml, though that could have been done manually by anyone who cared enough.
    • Using the /heal command on someone else now displays the correct amount (thanks to jtojnar)
    • You need the general.hurt permission to use the /hurt command on someone other than yourself (thanks to jtojnar) - this applies to /heal with a negative value too.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  27. Offline

    Adam McFarland

    Download still shows 3.3.1,
  28. Offline

    Celtic Minstrel

    Oh right, duh. If you had clicked on "older versions", or "source" and then "downloads", it would be there, but you're right, I forgot to update the main download link. Fixed now.
  29. Offline


    I made items.yml "read only", and works as a temp solution.
  30. Offline

    Celtic Minstrel

    That's not a solution. Can you at least tell me if there are any errors or warnings about items.yml either on startup or shutdown? (With the items.yml not set to read-only; I'm asking you to make a copy and test it this) It's probably an error in loading or saving that's causing the trouble.

    Actually, you could test loading by using /give. For example, type "/give 52/2" in-game and see what it responds with. If it says "mob spawner", there's something wrong with loading; if it says "cow spawner", there isn't.
  31. Offline


    I'm having the same issue, it deletes it and replaces it with a file containing {} only. The plugin won't load at all.

Share This Page