[FUN] Citizens v2.0.11 - Human NPCs for Bukkit [1.7.2]

Discussion in 'Archived: Plugin Releases' started by Citizens, Mar 5, 2011.

  1. Offline


    Citizens - Human NPCs for Bukkit
    Version: 2.0.11
    Authors: @fullwall and @aPunch
    Source: Citizens on GitHub

    Citizens is now on BukkitDev

    This thread will no longer be updated. We encourage you to use our page on BukkitDev. You can find information, links to our wiki and website, and the download page there.

    Showing Your Support

    We work hard to maintain Citizens. We've been working on Citizens2 around the clock on new and exciting features. A little motivation never hurts, so feel free to donate to us - fullwall and aPunch.

    If you can't donate, we appreciate a "hello" every now and then. Stop by the IRC channel #citizens on irc.esper.net to discuss Citizens and give thanks!
  2. Offline


    Please, where can I have the test version of Citizens ?
  3. Offline


    Top of page 122.
  4. Offline



    Running 818 and the test version 108 linked before.

    Every time a user tries to repair, he gets a denied command. The trader doesnt open his trade window.

    Each of those nodes have been tried on GroupManager (last version):

    default: true
    - citizens.use.*
    - citizens.trader.stock
    - citizens.use.blacksmiths
    - citizens.use.npctype
    - citizens.use.trader

    Any idea or do I hae to wait for stable update ?
  5. Offline


    yeah my 1 is like that with the trader no window
  6. Offline


    Permissions has an issue in that test build. This has since been fixed. If you want to apply the fix, open the JAR and edit the plugin.yml to include this line -
    softdepend: [Permissions]
  7. Sweet, thanks. What about the shift-click dupe thing?
  8. Offline


    I get this, running 818

    Last login: Fri Jun  3 18:17:04 on ttys000
    The-Hax0r:~ Sandro$ /Users/Sandro/Desktop/Stuff/1.6.6\ Server/Run.command ; exit;
    148 recipes
    16 achievements
    18:18:27 [INFO] Starting minecraft server version Beta 1.6.6
    18:18:27 [INFO] Loading properties
    18:18:27 [INFO] Starting Minecraft server on *:25565
    18:18:27 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    18:18:27 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    18:18:27 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
    18:18:27 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-g3fc0460-b818jnks (MC: 1.6.6)
    18:18:27 [INFO] Preparing level "world"
    18:18:27 [INFO] Preparing start region for level 0
    18:18:28 [INFO] Preparing spawn area: 40%
    18:18:29 [INFO] Preparing start region for level 1
    18:18:29 [INFO] Preparing spawn area: 20%
    18:18:31 [INFO] [Permissions] (Phoenix) was Initialized.
    18:18:31 [INFO] While loading Reagent (plugins/reagent.jar) found old-data folder: plugins/reagent next to the new one: plugins/Reagent
    18:18:31 [INFO] ControllerBlock: 1.18 by Hell_Fire
    18:18:31 [INFO] ControllerBlock: Using IRON_BLOCK (42) as ControllerBlock, loaded 0 disallowed types from config
    18:18:31 [INFO] [AimCannon] version 0.4 is enabled!
    18:18:31 [INFO] [ArrowWall]: Permissions enabled.
    18:18:31 [INFO] [ArrowWall]: version 0.4 enabled.
    18:18:31 [INFO] BlastControl version 1.0.4 is enabled!
    18:18:31 [INFO] BlocksOnGlass version 0.22 is enabled!
    18:18:31 [INFO] Bukkit Flow Control version 0.0.4 loaded.
    18:18:31 [INFO] [Cabinet] Permissions found hooking in.
    18:18:31 [INFO] [Cabinet] version 0.8 is enabled!
    18:18:31 [INFO] [Citizens]: Permissions enabled.
    18:18:32 [INFO] [Citizens]: version [1.0.8d] (Helpers) loaded
    18:18:32 [INFO] ControllerBlock: Enabling full redstone check
    18:18:32 [INFO] ControllerBlock: Events registered
    18:18:32 [INFO] [CookieMonster] Attached to iConomy.
    18:18:32 [INFO] [CookieMonster]  v1.3.4 loaded successfully.
    18:18:32 [INFO] [CookieMonster]  Developed by: [jascotty2, Coelho]
    18:18:32 [INFO] Disposal Chest STARTED
    18:18:32 [INFO] Elevators version 1.4.2 is enabled and linked to Permissions! 8 elevators in worlds "world", "world_nether" loaded.
    18:18:32 [INFO] Loaded Essentials build 2.2.7 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    18:18:32 [INFO] Loaded EssentialsChat build 2.2.7 by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    18:18:32 [INFO] Loaded EssentialsSpawn build 2.2.7 maintained by Zenexer, ementalo, Aelux, Brettflan, KimKandor, snowleo and ceulemans.
    18:18:32 [INFO] WallClimber version 0.0.1 is enabled!
    18:18:32 [INFO] [FireControl] Using permissions.
    18:18:32 [INFO] FireControl 1.1 enabled!
    18:18:32 [INFO] FLT Detector detected Permissions.
    18:18:32 [INFO] FLTDetector version 1.2.1 by <Soxra> has been enabled!
    18:18:32 [INFO] [Gills] - Gills version 2.3 is enabled!
    18:18:32 [INFO] [HeroChat] HeroChat version 4.10.3 enabled.
    18:18:32 [WARNING] [HeroChat] Conflicting plugin detected: EssentialsChat. If you experience issues, please try disabling this plugin.
    18:18:33 [INFO] [HeroicDeath] enabled.
    18:18:33 [INFO] [Humiliation] Permissions enabled.
    18:18:33 [INFO] [Humiliation] version 0.7 is enabled!
    18:18:33 [INFO] [iConomy] Logging is currently disabled.
    18:18:33 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    18:18:33 [INFO] [iConomy] Developed by: [Nijikokun]
    18:18:33 [INFO] [Citizens]: Payment method found (iConomy version: 5)
    18:18:33 [INFO] [?aInventorySort?f] Using [Permissions v2.6] for Permissions.
    18:18:33 [INFO] [?aInventorySort?f] version 1.9 is enabled!
    18:18:34 [INFO] [IOBookcase] version 1.32 by lonelydime is enabled!
    18:18:34 [INFO] ItemDetector version 0.0.1 is enabled!
    18:18:34 [INFO] [Jail] Loaded 0 jail zones.
    18:18:34 [INFO] [Jail] Loaded 0 prisoners.
    18:18:34 [INFO] Lampstone version 0.6 is enabled.
    18:18:34 [INFO] [Lampstone] 338 lampstones loaded.
    18:18:34 [INFO] [LC] Level Combat Loaded
    18:18:34 [INFO] [LC] Level Dexterity Loaded.
    18:18:34 [INFO] [LC] Level Excavation Loaded
    18:18:34 [INFO] [LC] Level Explosives 0.1 Loaded
    18:18:34 [INFO] [LC] Level Farming 0.1.7_01 Loaded
    18:18:34 [INFO] [LC] Level Forager 0.1 Loaded
    18:18:34 [INFO] [LC] Level Forgery 0.1.2 Loaded
    18:18:34 [INFO] [LC] Level Mining Loaded
    18:18:34 [INFO] [LC] Level Range Loaded.
    18:18:34 [INFO] [LC] Level Swimming Loaded
    18:18:34 [INFO] [LC] Level WoodCutting Loaded
    18:18:34 [INFO] [LC] Using Permissions.
    18:18:34 [INFO] [LC] Using FlatFile To Store Data.
    18:18:34 [INFO] [LC] LevelCraftCore 0.1.4 Loaded
    18:18:34 [INFO] [LC] Loaded levels:[Dexterity, Combat, Forgery, Farming, Range, Forager, Excavation, WoodCutting, Explosives, Swimming, Mining]
    18:18:34 [INFO] [LightningControl] v1.1 now enabled!
    18:18:34 [INFO] [LightningControl] Loaded configuration file.
    18:18:34 [INFO] [LightSwitch] version 2.0 loaded.
    18:18:34 [INFO] Lockette version 1.3.7 is being enabled!  Yay!  (Core version 1.0)
    18:18:34 [INFO] Lockette: Detected craftbukkit build [818] ok.
    18:18:34 [INFO] [Permissions] version [2.6] (Phoenix)  loaded
    18:18:34 [INFO] [HeroChat] Permissions 2.6 found.
    18:18:34 [INFO] [iConomy] hooked into Permissions.
    18:18:34 [INFO] Lockette: Linked to Permissions plugin version 2.6
    18:18:34 [INFO] Lockette: Using ops file for admin permissions.
    18:18:34 [INFO] Lockette: Ready to protect your containers.
    18:18:34 [INFO] [Minecart Mania] Debug mode switched to NORMAL
    18:18:34 [INFO] [Minecart Mania] MinecartManiaCore version 1.1.9_special_release_1 is enabled!
    18:18:34 [INFO] [Minecart Mania] MinecartManiaSignCommands version 1.1.3 is enabled!
    18:18:34 [INFO] [Minecart Mania] MinecartManiaStation version 1.1.0 is enabled!
    18:18:34 [INFO] [MinecartManiaTeleport] Permissions support enabled! Remember to set the appropriate permissions!
    18:18:34 [INFO] [MinecartManiaTeleport] Successfully loaded 2 teleporter signs
    18:18:34 [INFO] [MinecartManiaTeleport] version 1.2.2 enabled!
    18:18:35 [INFO] MobRider enabled
    18:18:35 [INFO] MobRider - Permissions Plugin Detected
    18:18:35 [INFO] [MonsterTamer]: version [1.33] (Commander) loaded
    18:18:35 [INFO] [mSafe] Version 2.7 is using Permissions!
    18:18:35 [INFO] [mSafe] Version 2.7 has been enabled!
    18:18:35 [INFO] [NoDrop] 0.2.3 is enabled!
    18:18:35 [INFO] Pitfall version 0.4a is enabled!
    18:18:35 [INFO] [PreciousStones] version [3.4] loaded
    18:18:35 [INFO] [PreciousStones] loaded 0 unbreakable blocks
    18:18:35 [INFO] [PreciousStones] loaded 36 forcefield blocks
    18:18:35 [INFO] Reagent v0.1 - Enabled.
    18:18:36 [INFO] [RealShop] load dependency : iConomy 5.x ok
    18:18:36 [INFO] [RealShop] Uses iConomy plugin (/money commands) as economy system
    18:18:36 [INFO] [RealShop] version [0.63] (tickleman) loaded
    18:18:36 [INFO] [SimpleSpleef] SimpleSpleef version 0.6 is enabled!
    18:18:36 [INFO] [SimpleSpleef] Using Permissions.
    18:18:36 [INFO] [SimpleSpleef] Successfully linked with iConomy 5.0+.
    18:18:36 [INFO] [Sprint] v0.9 is enabled!
    18:18:36 [INFO] Stargate v.0.4.8 is enabled.
    18:18:36 [INFO] [Stargate] Loaded 4 gate layouts
    18:18:36 [INFO] [Stargate] Unregistering gate Nyan Town
    18:18:36 [INFO] [Stargate] Destroying stargate at Portal [id=net.TheDgtl.Stargate.SignPost@2b8153bd, network=Towns name=Nyan Town, type=big.gate]
    18:18:36 [INFO] [Stargate] {world} Loaded 33 stargates with 0 set as always-on
    18:18:36 [INFO] [Stargate] {world_nether} No stargates for world
    18:18:36 [INFO] [Stargate] Found Permissions (v2.6)
    18:18:36 [INFO] TimeAnnounce - Copyright 2011 - Shannon Wynter (http://fremnet.net) - Source released under GPL3
    18:18:36 [INFO] TimeAnnounce version 1.1 is enabled :)
    18:18:36 [INFO] Turnstile 1.7.3 is enabled!
    18:18:36 [INFO] Turnstile Successfully linked with Permissions!
    18:18:36 [INFO] Turnstile Successfully linked with iConomy!
    18:18:36 [INFO] WorldEdit 4.4 enabled.
    18:18:36 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    18:18:36 [INFO] [iCoLand] Successfully linked with iConomy
    18:18:36 [INFO] [iCoLand] Successfully linked with Permissions
    18:18:36 [INFO] [iCoLand] Initializing land manager...
    18:18:36 [INFO] [iCoLand] Found iConomy Tax/Bank account: iCoLand
    18:18:36 [INFO] [iCoLand] Version [v2.45] (fattire) enabled. 18 lands found.
    18:18:36 [INFO] [Minecart Mania] Permissions detected. Using permissions.
    18:18:37 [INFO] [Minecart Mania] MinecartManiaAdminControls version 1.1.4 is enabled!
    18:18:37 [INFO] [Minecart Mania] MinecartManiaAutocart version 1.1.3 is enabled!
    18:18:37 [INFO] [Minecart Mania] MinecartManiaAutomations version 1.1.2 is enabled!
    18:18:37 [INFO] [Minecart Mania] MinecartManiaChestControl version 1.1.3 is enabled!
    18:18:37 [INFO] Done (0.995s)! For help, type "help" or "?"
    18:18:37 [WARNING] Task of 'Citizens' generated an exception
    java.lang.NoSuchMethodError: net.minecraft.server.ItemInWorldManager.<init>(Lnet/minecraft/server/World;)V
        at com.fullwall.resources.redecouverte.NPClib.NPCSpawner.SpawnBasicHumanNpc(NPCSpawner.java:66)
        at com.fullwall.Citizens.NPCs.NPCManager.register(NPCManager.java:62)
        at com.fullwall.Citizens.Citizens.setupNPCs(Citizens.java:129)
        at com.fullwall.Citizens.Citizens.access$0(Citizens.java:120)
        at com.fullwall.Citizens.Citizens$1.run(Citizens.java:83)
        at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:138)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:388)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    18:18:37 [INFO] ControllerBlock: Loaded v4 data - 1 ControllerBlocks loaded
    18:18:42 [INFO] [Minecart Mania] Loading Sensor Data.
  9. Offline


    Calling all Citizens fanatics:

    A new [NPC] category is currently being discussed. Go support this here:


    Vote "Yes" if you feel Citizens and the other NPC plugins deserve their own [NPC] tag.

    @Hitman4Hire Citizens 1.0.8d does not work with 818. There is a dev build on page 122 with a 1.6-compatible build.
  10. Hey, come back to our server, I was away for a moment :)
  11. I've added this to plugin.yml and people still get permission denied when trying to even select the vendor. They all have citizens.use.trader
  12. Offline


    The new permissions nodes are not working properly for some people. I have tested on my personal server and did not have any problems, so it's hard to tell what is causing this, unfortunately. I would wait until an official 1.0.8e release.

    Also, I just hopped by the server to advertise this:


    Shameless plug, but hey, I'm in it for the glory!
  13. I support you.
    I'm on 2.7.4 permissions btw. Any troubleshooting tips, maybe? Players are frowning that vendors are down more than they're up so I really want to make it work :(
  14. Offline


    Well, I tested the nodes on Permissions 3.0.x, so that may be the issue. I don't want to force anyone to use 3.0, however, as it seems to be a bug-magnet at the moment. I'll do some more testing with 2.7.x and see if I can replicate your issues.
  15. Offline


    Hi aPunch, i'm random annoying guy n° 1521.
    Do you have any clue when the last release will show up instead of the test version ?

    Many thanks for your support.
  16. Yeah, with 3x I'm just afraid that it will take qute some time for all plugins to support it.
  17. Offline


    Using the test build on 818, when I try to use a Wizard I seem to always be teleported to the wizard himself. I had tried using another wizard npc name as destination, a /warp as the destination, and a coordinate set as destination. Is this just a usage issue? The wiki mentions "/wizard addloc" but not the specifics of how a location should be defined. Thanks!
  18. Offline


    Ok. Downloaded the test version. I'm on bukkit 819. I just can usw traders when I'm op. I've installed the newest permission and set it up but it doesn't work. I've added to all groups - 'citizens.use.trader'.
  19. Offline


    Well nevermind! I have downloaded the test build :D
  20. Offline


    So I downloaded the test build too. I set up all commands for a Trader but there's no way to buy or sell things. ( I have all permissions ('*') and also I changed the owner, so that's bugged )
    Also when I write /Basic help 2 then it shows the "/citizens help 2 (basic help 2)" list
    Keep up your work!
  21. Offline


    Nope, tested this with both Permissions 2.7.4 and 3.1.1 with the same results as I mentioned previously.

    EDIT: Just tried the softdepend: [permissions] fix, doesn't work unfortunately, same result as before.


  22. Offline


    Hi guys.
    I have a problem with this plugin. My permissions are ok, but I can't spawn any NPC. It gives me an error.


    Please help me, because this plug-in is the best so far.
    I also add the softdepend: [permissions] string in plugin.yml.
    Thank you.
  23. Offline


    My members cannot view the inventory of the traders, the windows won't show up :(

    Love the mod, will wait for the update :eek:

    Keep up the good work!
  24. Offline

    Jonathan Thorpe

    God himself just facepalmed.
  25. Offline

    Jonathan Thorpe

    That error has nothing to do with Permissions, or any other plugin. It does, however, have a LOT to do with your inability to read.
  26. Offline


    what has he missed? because i have the same problem and i get this by everything i do with them (in this case using toggle) and i can't select them using rightclick (great for wizards!)
    15:27:46 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'toggle' in plugin Citizens v1.0.8
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:128)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:281)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:718)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:684)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:677)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
        at net.minecraft.server.NetworkManager.b(NetworkManager.java:217)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:401)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:311)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NullPointerException
        at com.fullwall.Citizens.Properties.Properties.WizardProperties.saveMode(WizardProperties.java:36)
        at com.fullwall.Citizens.Properties.Properties.WizardProperties.saveState(WizardProperties.java:57)
        at com.fullwall.Citizens.NPCTypes.Wizards.WizardNPC.saveState(WizardNPC.java:60)
        at com.fullwall.Citizens.Commands.CommandExecutors.TogglerExecutor.toggleState(TogglerExecutor.java:164)
        at com.fullwall.Citizens.Commands.CommandExecutors.TogglerExecutor.buyState(TogglerExecutor.java:190)
        at com.fullwall.Citizens.Commands.CommandExecutors.TogglerExecutor.onCommand(TogglerExecutor.java:106)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
  27. Offline

    Jonathan Thorpe

    He's not using CraftBukkit 803 or less. Read the last couple of pages of this thread for more information.
  28. Offline


    This is awesome plugin, but when I create more, than 2 npc, server starts laggy SO MUCH, whatever I have good connection! :mad:
    How can I fix that? :(
  29. Offline


    any word on 818? i get the same error as everybody else and would like to know a release date.
    Drei Gyuu and Pim1234 like this.
  30. Offline


    1.08e isn't compatible with 1.6?
    i am confused right now... really confused
  31. Offline


    Lets wait until their plug is actually compatible with 818 before filling their forum.... Think a bit guys :)

Share This Page