[FUN][ADMN] OpenInv 2.2.4 - Open anyone's inventory as a chest Real-Time! [1.4.5-1.7.10]

Discussion in 'Archived: Plugin Releases' started by lishid, Apr 30, 2011.

  1. Offline


    OpenInv - Open anyone's inventory as a chest! in real time! Works with offline players! Open EnderChests of any player via command!

    Source Code hosted on GitHub

    Link to BukkitDev: http://dev.bukkit.org/server-mods/openinv/

    Open a player's inventory as a chest and interact with it in real time.
    Access to the inventory and armor slots.
    Open any chest that has blocks on top (blocked chests) with AnyChest.
    Open a chest silently (without chest animation nor sound) with SilentChest.
    Open any player's EnderChest from a command.
    Drop item as another player (by putting it in the 5 unused slots in openinv)!

    How to use:
    Install: Copy to your plugins folder, and restart/reload your server.

    Use command "/openinv <player>" to open a player's inventory
    Use command "/toggleopeninv" to toggle Item openinv:
    Hit a player with an item of your choice (STICK by default), and you will open the player's inventory (no damage)
    Right click the air with the item opens the last opened inventory (toggle must be ON)
    Use command "/anychest" to toggle anychest (blocked chest bypass)
    Use command "/silentchest" to toggle silent chest
    Use command "/openender <Player>" to open a player's enderchest
    Use command "/searchinv <Item> [MinimalAmount]" list all players having a certain item in their inventory.

    To use a sign for quick access (this uses the normal Openinv.openinv permissions, override and exempt applies), You need:
    "[openinv]" (without quotes) on the 1st line
    and the player's name on the other lines.

    Permissions nodes (CaSe SeNsItIvE):
    "OpenInv.openinv" gives permission to use OpenInv
    "OpenInv.openself" Allows opening the inventory of the command user
    "OpenInv.editinv" - Allows editing of inventory

    "OpenInv.openender" - Allows opening of EnderChests
    "OpenInv.openenderall" - Allows opening of EnderChests of everybody. Without this permission, someone can only open his own enderchest.
    "OpenInv.editender" - Allows editing of enderchest

    "OpenInv.search" gives permission to use searchinv
    "OpenInv.crossworld" allows cross-world openinv.
    "OpenInv.exempt" makes the player's inventory protected (unable to be opened)
    "OpenInv.override" gives permission to open anyone's inventory, even protected ones
    "OpenInv.anychest" gives permission to open chests that are blocked by a block on top.
    "OpenInv.silent" gives permission to open chests in total silence, without animation.
    (without quotes)

    • Read-only permissions for OpenInv and OpenEnder! Just don't give the editinv and editender permissions nodes!
    • Administrators can modify any user's inventory contents as they wish, in real time.
    • Access it anywhere! No distance or obstacle limitations.
    • Permissions support.
    • Use the command without argument opens the last accessed person's inventory.
    • Use sticks or any (configurable) item and toggles for quick access.
    • Search all online players for a certain item in their inventory.
    • Protect players from openinv with exempt permission, and bypass protection with override permission.
    • Use a sign to perform openinv for convenience.
    • Cross-world openinv protection.
    • Offline player openinv supported.
    • Open chests that are blocked because they have a solid block on top. (AnyChest)
    • Silent opening of chest, no sound and opening animation.
    • EnderChests can be opened, even for offline players!
    • NEW: Drop item as another player (by putting it in the 5 unused slots in openinv)
    • Self-opening protection.

    Video tutorial:

    Thanks to WMisiedjan for the source of iSee, located here: http://forums.bukkit.org/threads/6676/
    Thanks to Dark_Balor from AdminCmd for helping with the bugs in Offline Openinv.
    Thanks to the many supporters who've tested this plugin.


    Download OpenInv (2.2.4) CB1.4.5 up to CB1.7.10

    Legacy versions:
    See http://dev.bukkit.org/server-mods/openinv/

    Source Code

    • None ATM
    • None ATM
    Openinv will connect to http://mcstats.org/ to collect anonymous data (only version information).


    Version 2.2.4[CB 1.7.10]
    • Fixed getting inventory from other plugin's custom inventory crashing

    Version 2.2.2[CB 1.7.10]
    Finally fixed offline players
    Version 2.1.8[CB 1.7.10]
    Updated to MC1.7.10
    Removed metrics as the service is no longer available
    Version 2.1.7[CB 1.7.8]
    Fixed Offline player NoSuchMethodError
    Version 2.1.6[CB 1.7.8]
    Fixed ClassNotFoundError.
    Version 2.1.5[CB 1.7.8]
    Updated to CB1.7.8
    Version 2.1.4[CB 1.7.5]
    Updated to CB1.7.5
    Version 2.1.3[CB 1.7.4]
    Fixed silent chest not working with sneak+build.
    Removed /enderchest as alias for compatibility with Essentials. Use /openender or /oe instead.
    Version 2.1.2[CB 1.7.2]
    Changed updater to be compliant with new Bukkit rules.
    Version 2.1.1[CB 1.7.2]
    Changed updater to be compliant with new Bukkit rules.
    Version 2.1.0[CB 1.7.2]
    Update to CB1.7.2.
    Version 2.0.9[CB 1.6.4]
    Update to CB1.6.4.
    Version 2.0.8[CB 1.6.2]
    Added * nodes for permissions.
    Version 2.0.7[CB 1.6.2]
    Added OpenInv.openenderall permission node.
    Version 2.0.6[CB 1.6.2]
    Updated to CB1.6.2.
    Version 2.0.5[CB 1.6.1]
    Fixed editinv not locking shift-click and click-drag.
    Version 2.0.4[CB 1.6.1]
    Added config options for notifications for SilentChest and AnyChest.
    Version 2.0.3[CB 1.6.1]
    Updated to CB1.6.1.
    Version 2.0.2[CB 1.5.2]
    Updated to CB1.5.2.
    Version 2.0.1[CB 1.5.1]
    Fixed player loading crash caused by CraftBukkit internal change.
    Version 2.0.0[CB 1.5.1]
    Fixed trapped chest problem.
    Version 1.9.9 [CB 1.5.1]
    Updated to 1.5.1.
    Version 1.9.8 [CB 1.5]
    Updated to 1.5.
    Version 1.9.7 [CB 1.4.7]
    Fixed offline inventory not saved when server restarts.
    Version 1.9.6 [CB 1.4.7]
    Updated to 1.4.7.
    Version 1.9.5 [CB 1.4.6]
    Added new feature: Put item in any of the 5 unused slots and the item will be dropped by the targeted player.
    Version 1.9.4 [CB 1.4.6]
    Updated for MC1.4.6.
    Version 1.9.3 [CB 1.4.5]
    Fixed an issue about copying code from my other plugin without proper renaming.
    Version 1.9.2 [CB 1.4.5]
    Massive rewrite to support new CB naming system.
    Added auto-updater.
    Version 1.8.8 [CB 1.3.2/CB 1.4.2]
    Added permissions "OpenInv.openself".
    Version 1.8.7 [CB 1.3.1-R1]
    Added /openender <player>
    permissions, added "OpenInv.editinv", "OpenInv.openender", "OpenInv.editender".
    Version 1.8.6 [CB 1.3.1]
    Updated to 1.3.1. Not only works with 1.3.1.
    Version 1.8.5 [CB 1.2.5-R4]
    Fixed all problems related to Offline OpenInv (including inventory not updating AND/OR inventory being emptied on some occasions).
    Updated Metrics module to R5.
    Version 1.8.4 [CB 1.2.4-R0.1]
    Updated to MC 1.2.4.
    Version 1.8.3 [1.1-R6/CB 1.2.3-R0.1]
    Fixed perms not working.
    Version 1.8.2 [1.1-R6/CB 1.2.3-R0.1]
    New permissions system (removed support for old perms).
    Version 1.8.1 [1.1-R6/CB 1.2.3-R0.1]
    Updated to 1.1-R6.
    Version 1.7.5 [1.1-R3]
    Fixed Metrics add-on error on startup.
    Version 1.7.4 [1.1-R3]
    Fixed offline openinv being case sensitive.
    Version 1.7.3 [1.1-R3]
    New CB events.
    Version 1.7.2 [1.0.0-R1/1.1-R1]
    CraftBukkit refactoring. Fix the Exception caused by that.
    Version 1.7.1 [1.0.0-R1/1.1-R1]
    Official CB1.1-R1 support.
    Still backward compatible (with 1.0.1-R1).
    Version 1.6.6 [1.0.1-R1]
    Help menu (/openinv ?).
    Code re-organizing.
    AnyChest now toggle-able.
    Version 1.6.5 [1.0.1-R1]
    Fix for silentchest + spout error.
    Version 1.6.4 [1.0.1-R1]
    Silent chest opening, no animation, no sound, use /silentchest to toggle on/off.
    Version 1.6.3 [1.0.1-R1]
    Switched toolbar from top to bottom.
    Added armor slots.
    Version 1.6.2 [1.0.1-R1]
    Added a fix for Offline Openinv.
    Version 1.6.1 [1550]
    Fixed inventory update bug that everyone was having!
    Updated for Minecraft 1.0.
    Version 1.5.2 [1185]
    Offline openinv bugfix.
    Version 1.5.1 [1185]
    Version 1.4.6 [1118-1160]
    Fix conflict of anychest with other plugin.
    Version 1.4.5 [1118-1160]
    Fix for previous update not closing chests.
    Version 1.4.4 [1118-1160]
    Now allows opening of chests that are blocked by solid blocks on top!
    Use "OpenInv.anychest" for permission node.
    Version 1.4.3 [1118-1160]
    Toggle should now be saved between server restarts.
    Added configuration file.
    Configure the item to use instead of a stick be default.
    Version 1.4.2 [1118-1160]
    Fixed a character limit problem.
    Version 1.4.1 [1118-1160]
    Updated for 1.8.
    Version 1.3.3 [953+]
    Cross world openinv disabled! Use permissions node 'OpenInv.crossworld' to allow cross-world openinv.
    Version 1.3.2-test [818+]
    Try fixing compatibility problem.
    Version 1.3.1 [818+]
    Fixed for 818.
    Only works for 1.6+ (CraftBukkit RB 818).
    Version 1.2.3 [803-]
    Sign quick access: use second line for "[openinv]" (without quotes) and third line for target name.
    Use this for 1.5 versions.
    Version 1.2.2
    PERMISSIONS NODES CHANGE: please read permissions section.
    new "OpenInv.exempt" and "OpenInv.override" feature.
    Version 1.2.1
    MAJOR BUGFIX: inventory not updated correctly, especially after a death/respawn.
    Version 1.1.1
    New feature: /searchive Item Amount.
    Version 1.1.0
    New feature: sticks + toggle openinv (explainations on top).
    Version 1.0.3
    Fixed history not saved correctly.
    Fixed inventory access to respawned players.
    Version 1.0.2
    use the command without argument opens the last accessed person's inventory .
    Version 1.0.1
    Initial Release.
    Support the developer: [​IMG]
  2. Offline


    Could be using the new dupe trick (try searching for it on youtube, it uses pistons)
  3. Offline


    It was before 1.7 :p
  4. Offline


    No it was caused on 1.7.2
    1.7.3 fixed it but bukkit is still on 1.7.2

    EDIT: Hello? was there pistons before 1.7? :D
  5. Offline


    No, Pistons did not exist in versions before 1.7:p. And the guy got the items before 1.7 were released, so he used 3rd party stuff
  6. Offline


    oh lol
  7. Offline


    Idk, think he used some sort of In-Game-Invedit thing. Atleast i cought him! ;)
  8. This is perfect! Now I can see if some1 is gonna lie about lossing or not getting an item!
  9. Offline


    Exactly my point of making this plugin.
  10. Offline


    Can you make openinv work with offline players also? This plugin provides the required api.
  11. Offline


    The problem now is that I can open offline data, but I cant know exactly when to save it. Even with that one, it will not tell me WHEN to save the data (i.e. when you close the inventory menu)
  12. Offline


    Hmmm... there's no event triggered when the chest is closed?
  13. Offline


    Not yet, but i expect it to come soon though...
  14. Offline


    hey, all my permissions are correct, (i have had a dozen people check them) but for whatever reason, it says i do not have permission to open other players inventories. I am the admin/owner, and have all permissions enabled.

    default: true
    prefix: '&e'
    suffix: ''
    build: true
    inheritance: []
    - 'SpawnX.spawn'
    - 'iConomyChestShop.shop.create'
    - 'iConomyChestShop.shop.buy'
    - 'iConomyChestShop.shop.sell'
    default: false
    prefix: '&4'
    suffix: ''
    build: true
    - Officer
    - '*'
    - -essentials.protect.damage.*
    default: false
    prefix: '&9'
    suffix: ''
    build: true
    - Default
    - 'jail.command.jail'
    - 'jail.command.unjail'
    default: false
    prefix: '&d'
    suffix: ''
    build: true
    - Cop
    - 'lwc.mod'
    - 'jail.command.jailcreate'
    - 'jail.command.jaildelete'
    - 'jail.command.jail'
    - 'jail.command.unjail'
    - 'jail.command.jailtransfer'
    - 'jail.command.jailtransferall'
    - 'jail.command.jailcheck'
    - 'jail.usercmd.jailstatus'
    - 'OpenInv.openinv'
    default: false
    prefix: '&5'
    suffix: ''
    build: true
    - Officer
    - '*'
    - 'OpenInv.openinv'
    - 'OpenInv.override'
    - Default
    - Cop
    - Officer
    - Admin
    - GOD

    my jail players also doesnt work (but thats irrelevant it think)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  15. Offline



    is this permissions 3.x ? If so, check that you are not just using the global group assignment. As far as I know it is bugged ATM.
    Also i don't think it is required to do a
    - Officer
    as "God" (Admin) as you are assigning all permissions with * from the other groups
  16. Offline


    ok i will try this now, thanks

    heres the start up

    >11:58:58 [INFO] WorldGuard: (world) TNT ignition is PERMITTED.
    >11:58:58 [INFO] WorldGuard: (world) Lighters are PERMITTED.
    >11:58:58 [INFO] WorldGuard: (world) Lava fire is blocked.
    >11:58:58 [INFO] WorldGuard: (world) All fire spread is disabled.
    >11:58:58 [INFO] WorldGuard: Loaded configuration for world 'world"
    >11:58:58 [INFO] WorldGuard: (world_nether) Single session is enforced.
    >11:58:58 [INFO] WorldGuard: (world_nether) TNT ignition is PERMITTED.
    >11:58:58 [INFO] WorldGuard: (world_nether) Lighters are PERMITTED.
    >11:58:58 [INFO] WorldGuard: (world_nether) Lava fire is blocked.
    >11:58:58 [INFO] WorldGuard: (world_nether) Fire spread is UNRESTRICTED.
    >11:58:58 [INFO] WorldGuard: Loaded configuration for world 'world_nether"
    >11:58:58 [INFO] WorldGuard: 33 regions loaded for 'world'
    >11:58:58 [INFO] WorldGuard 5.0-alpha10 enabled.
    >11:58:58 [INFO] [BoundaryKill:1.31z] enabled!
    >11:58:58 [INFO] [BBROTHER] ------------------------------------
    >11:58:58 [INFO] [BBROTHER] Hello, and thank you for using the TESTING version of BigBrother!
    >11:58:58 [INFO] [BBROTHER] Please note that, since this is far from complete, there will be many bugs.
    >11:58:58 [INFO] [BBROTHER] IF YOU FIND ANY BUGS, PLEASE REPORT THEM ON http://bugs.nexisonline.net/bb
    >11:58:58 [INFO] [BBROTHER] Please stay tuned in irc.esper.net #bigbrother for updates and build notifications.
    >11:58:58 [INFO] [BBROTHER] ------------------------------------
    >11:59:00 [INFO] [BBROTHER] Building `bbdata` table...
    >11:59:00 [INFO] [BBROTHER] BBData H2 Driver r1 loaded!
    >11:59:00 [INFO] [BBROTHER] Building `bbworlds` table...
    >11:59:00 [INFO] [BBROTHER] Building `bbusers` table...
    >11:59:00 [INFO] [BBROTHER] Permissions enabled using: Permissions v3.1.6
    >11:59:00 [WARNING] [BBROTHER] 'Help' isn't detected. No /help support
    >11:59:00 [INFO] [BBROTHER] BigBrother 1.9.1-SNAPSHOT (build #581) enabled!
    >11:59:00 [INFO] [OpenInv] version 1.3.3 enabled!
    >11:59:00 [INFO] [HeroChat] HeroChat version 4.11.0 enabled.
    >11:59:00 [INFO] [HeroChat] Permissions 3.1.6 found.
    >11:59:00 [INFO] [HeroicDeath] enabled.
    >11:59:00 [INFO] CommandBook 1.5.2 enabled.
    >11:59:00 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some features have been disabled to be compatible with poorly written server wrappers.
    >11:59:00 [INFO] CommandBook: 1 banned name(s) loaded.
    >11:59:00 [INFO] CommandBook: 1 kit(s) loaded.
    >11:59:00 [INFO] CommandBook: Permissions plugin detected! Using Permissions plugin for permissions.
    >11:59:00 [INFO] [iConomyChestShop] version 2.75 initialized!
    >11:59:00 [INFO] [iConomyChestShop] iConomy version 5 loaded.
    >11:59:00 [INFO] [iConomyChestShop] Permissions version 3.1.6 loaded.
    >11:59:00 [INFO] [iConomyChestShop] LWC version 3.21 loaded.
    >11:59:00 [SEVERE] Error occurred while enabling AntiXRay v0.6.10 (Is it up to date?): com/asdaarg/bukkit/NSCommand/NSCommand
    java.lang.NoClassDefFoundError: com/asdaarg/bukkit/NSCommand/NSCommand
    at com.asdaarg.bukkit.antixray.AntiXRay.onEnable(AntiXRay.java:68)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:864)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:264)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:151)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:136)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.ClassNotFoundException: com.asdaarg.bukkit.NSCommand.NSCommand
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 11 more
    >11:59:00 [INFO] LWC: Loaded 133 locale strings (0 overrides)
    >11:59:00 [INFO] Using Permissions API
    >11:59:00 [INFO] LWC: Loading SQLite
    >11:59:00 [INFO] LWC: Using: Native
    >11:59:00 [INFO] LWC: Precached 0 protections.
    >11:59:00 [INFO] LWC: At version: 3.21-git-LWC-2936c58564bf9d84e97a9a024af1644c8f67f269-b54jnks
    >11:59:00 [INFO] [Prefixer] v2.4 has been enabled.
    >11:59:00 [INFO] Done (0.418s)! For help, type "help" or "?"
    >11:59:00 [INFO] / lost connection
    >11:59:02 [INFO] hamm3rbird [/] logged in with entity id 85 at ([world] 81.84505566466534, 73.0, 11.725553231690016)
    >11:59:03 [INFO] jackdavo [/] logged in with entity id 86 at ([world] 101.35607567316066, 72.0, -7.433112851650313)
    >11:59:03 [INFO] [BBROTHER] Removed 0 old records because of age in 0h00m00s.
    >11:59:03 [INFO] [BBROTHER] Building `ownership` table...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  17. Offline


    Looks more like an issue with antixray.
  18. Offline


    hey guys, whats the permission node to only allow someone the /toggleopeninv command?
  19. Offline


    It uses OpenInv.openinv
    but everything else also uses that
    there's no way of only give that permission, since it calls "openinv <player>" command
  20. Offline


    wow this is a really awesome plugin cant wait to it get updatet ! :D
  21. Offline


    Don't know if it's just me or not, but when I try using the /openinv command on another player, the inventory doesn't open for me and the server disconnects me roughly 1 minute later. I have all permissions on the server. Any idea what may be causing this? My moderators for my live server really want this to check for stolen items, etc, but something's preventing it from working properly.

    I have more plugins on the server than I should list in a single post, but none of them have anything to do with modifying inventory data, so I'm a bit confused as to what could be causing the issue.
  22. Offline


    Didn't test with 1000 but I suppose it still works?
    Well it should unless something has changed in inventories with 1.7.3 (1k) update
  23. Offline


    (Don't know if you were posting in reply to me or not...)
    I've been having my particular issue since before CB1000.
    ... In fact, I'm still using 953.
  24. Offline


    What version of openinv?
    (btw, is it consuming a lot of CPU on idle?)
  25. Offline


  26. Offline


    no complaints about b1000 except one who says high CPU... I guess it should be good.
  27. Offline


    Latest version. Also, I don't have any way of knowing since I run from a command prompt, I don't use a GUI.

    You can just ignore me though, the issue seems to be a hashmap error as this is happening with other plugins that call up 'chests', such as VirtualChest (I tested both individually from eachother, they spit out the same error). I've likely got something on my server that's causing this, so no fault to you.

    I'll post again if/when I get around to figuring out what's causing the error, it may be good for people to know which plugins break eachother.

    Sorry for the hassle.
  28. Offline


    Hey do this work with Build [1000]
  29. Offline


    Very likely, I haven't checked but everyone else who was using this didn't complain, so no problems I think.
    Can you confirm?
  30. Offline


    Yes i have try it now and it's works fine ! :D gunna test out the permssions to soon i write to you if i experience something wrong
  31. Offline


    It still uses permissions plugin, not the built in permissions though...

Share This Page