Inactive [DEV] SpoutPlugin - Unleash the flow of endless possibilities [1.0-1.3.2]

Discussion in 'Inactive/Unsupported Plugins' started by SpoutDev, Aug 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    In order to centralize support of our legacy projects, we will no longer be providing support on Bukkit. Please use for support with our projects going forward.
  2. Offline


    19:02:46 [INFO] Spout has been initialized
    19:02:46 [INFO] [mcMMO] Using Bukkit Permissions.
    19:02:46 [INFO] Loading Config File...
    19:02:47 [INFO] mcMMO version 1.1.03 is enabled!
    19:02:47 [INFO] Server permissions file permissions.yml is empty, ignoring it
    19:02:47 [INFO] Done (0.360s)! For help, type "help" or "?"
    19:02:52 [INFO] chrsquinn1 [/] logged in with entity id 108 at
    ([world] 14.966535608593748, 66.0, 109.38117443858984)
    19:02:53 [INFO] [Spout] Successfully authenticated chrsquinn1's Spoutcraft clien
    t. Running client version: 102
    19:02:53 [SEVERE] Exception in thread "Thread-14"
    19:02:53 [SEVERE] java.lang.NoSuchFieldError: rawData
    19:02:53 [SEVERE]       at org.getspout.spout.MapChunkThread.handleMapChunk(MapC
    19:02:53 [SEVERE]       at org.getspout.spout.MapChunkThread.handle(MapChunkThre
    19:02:53 [SEVERE]       at
    19:02:53 [SEVERE]       at Source)
    19:02:55 [INFO] The automatic update-Check only work every 6 hours, the last che
    ck was 15 minutes ago.
    while i was in the server the world was not rendering properly. it would render only the zone the spawn was in then i would walk to the non rendered zone. it would then render only the portion beneath my feet and then crash.
  3. Offline


    @js105287 @chrsquinn1
    19:02:53 [SEVERE] java.lang.NoSuchFieldError: rawData

    Update your CB, this thread clearly has 1060 in it's title
  4. Offline


    any news on the memory leak fix? so far its locked my laptop up twice, even the server seems to be using more then it should
  5. Offline


    could spout do something with the building limit (to 200 instead of 128 for example)
  6. Offline


    I'm amazed at how many server owners don't run a local test server and just throw plugins at their production server.:confused:
  7. Offline


    Can someone please tell me how i can control fog (client side) if i don't hit fog 4 times every 10 seconds or so i get 4 fps, and if i do i get 25 fps.
  8. Offline


    since the 1060 bukkit rb.....when i use the spoutcraft launcher i see double and triple buildings, or buildings cut in half and folded out wards ect
    Any Idea whats causing this...everything worked fine before
  9. Offline


    yeah, i'm getting weird chunk loading errors as well. I get the same thing that the guy above is getting and it's kinda annoying... Any ideas? I'm using the dev build of Spoutcraft and the server I'm on also has the dev build of Spout.
  10. Offline


    disabling "ChunkDataCache" in the spout config fixes that error
    that's not possible yet, maybe with minecraft 1.8
  11. Offline


    DAMN YOU SPOUT... keeps on crashing my minecraft and using a shit ton load of cpu... why did they have to go in and add optifog... it messes every thing up :(
  12. Offline


  13. Offline




    I just now got SpoutCraft and can definitely confirm this. Not even the pig knows what's going on. Otherwise, absolutely sweet server-side and client-side plugin, I love the client for sure. Keep up the good work, and hope that this gets fixed soon :)
  14. Offline


    It was totally broken (was a problem with hand-over between threads). However, it should work now with the latest builds.

    The latest build has a CRC on the chunk, so the client can detect if there are problems. (Many chunk duplication errors was actually underground so you wouldn't see them). With the updated code, there are no more mismatches detected.
  15. Offline


    why post that here?
    lets see all my players had there clients updated with out asking them
    all my players where then unable to access my server (including me)
    so i think to myself, the bukkitcontrib guys, wonderful bunch ofpeople loved the way they showed itemcraft(modloader enabler) to be a pile of bug ridden server killing stuff.... they would of tested this fully, they would of never forced an update on thier users with out testing it. So a combination of trust and the fact i was forced to...i updated, i backed up the server first ofcourse but even though i can go back...wheres the point i cant access it with out using an old spoutcraft client

    you know what amazes me? people like you who think that all server admins dont think about thier players and just throw things in willy nilly.

    seems bukkitcontrib/spout devs have done a notch on us and though they are quick to tell us to use the correct bug reporting method, appear to be burying thier heads in regards to the memory leak
    Stephen304 likes this.
  16. Offline


    The vanilla teleport process is

    - unload chunks where the player is standing
    - player is floating
    - move player to the new location
    - still floating
    - load chunks around the player

    Teleport smoothing changes it to

    - unload chunks but not the ones right beside the player
    - load the chunks near the player's target location
    - move the player to the the target
    - no floating
    - unload the chunks at the origin
    - load the remaining chunks near the player

    It eliminates the floating. You should try to teleport with and without Spout, it makes a big difference.
  17. Offline


    Alright, been having issues using the latest dev build. It seems that the fog is broken, as I can not get it to show up on any level. Tried toggling with key, and through settings. Anyone else having this problem, or know a fix?
  18. Offline


    The memory leak should be fixed in the latest dev builds.
  19. Offline


    can confirm that going false on chunkdatacache solves the problem of feeling like im in inception
    kibbles4everyone likes this.
  20. Offline


    latest dev build i cant even join my server you should try things before running ur fingers
  21. Offline


    Is that dev build of both client and server?
  22. Offline


    how can i remove this plugin??? always when i delete the .jar and the spout folden, and then start the server, the plugin will download again
  23. Offline


    Some other plugin is downloading it.
  24. Offline


    Spout Build 121 causes an NPE in Spoutcraft on joining the server.

            at org.getspout.spout.packet.PacketUtil.getNumBytes(
            at org.getspout.spout.gui.GenericTexture.getNumBytes(
            at org.getspout.spout.packet.PacketWidget.getNumBytes(
            at org.getspout.spout.packet.CustomPacket.a(
            at ki.a(
            at pf.e(
            at pf.c(
  25. Offline


    I still can't find the plugin that keeps downloading bukkitcontrib automatically.
  26. Offline


    Those are not compatible builds, use dev client with dev server.

    Try removing half, if it persists halve again, if not switch to the other half. Repeat until you find it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 13, 2016
  27. Offline


    I have done all that, its irritating lol.
  28. Offline


    I've also noticed with spout 1.0.2 and things like magiccarpet, when going up or down fast you sometimes drop as there is a delay before the floor is placed back. This didnt happen with 1.0.1.

    Unfortunately no errors to paste in this case. I've just seen the noticable difference between the two builds.

    How to reproduce:
    1) Install spout 1.0.2 and magiccarpet on a cb1060 server.
    2) join the server
    3) type /mc
    4) start jumping and after a few jumps (seems to be 5 or 6) the lag will make you fall.
    5) Eventually the glass floor will stop moving at all for a second or so

    Without spout installed, this does not happen on cb1060 (and cb100). This did not happen on spout 1.0.1 - It doesnt actually seem to lag the server though but for some reason the block updates are being delayed
  29. Offline


    I guarantee you're running mcMMO. I was dealing with Client NPE with Spout #120 and tracked it down.

    Dev version of client fixes memory leak... breaks everything else! No mcMMO exp bar or health bars with SpoutCraft Dev version.
  30. Offline


    I think it was because I had mcmmo 1.1.0 and not the later one ( iirc) - dont seem to get it now with build spout 121
  31. Offline


Thread Status:
Not open for further replies.

Share This Page