Inactive [ADMN/FUN/GEN/TP/WGEN] CommandBin v2.29 - MOVED TO BUKKIT DEV! [1.2.5-R3)

Discussion in 'Inactive/Unsupported Plugins' started by CainFoool, Nov 1, 2011.

  1. Offline


    The Vanish Command Does Not Work.?
    PLEASE FIXX ~!~!~!
  2. Offline


    CommandBin v2.08 released.
    Adds /god, /realname, /blind and /drunk
  3. Offline


    Hey when ever i start my server i get this error and i tried reinstalling multiple times

    174 recipes
    27 achievements
    03:57:15 [INFO] Starting minecraft server version 1.1
    03:57:15 [INFO] Loading properties
    03:57:15 [INFO] Starting Minecraft server on *:25565
    03:57:15 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R4-b19
    38jnks (MC: 1.1) (Implementing API version 1.1-R4)
    03:57:15 [SEVERE] Could not load 'plugins\CommandBin.jar' in folder 'plugins':
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.<init>(
    at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.NullPointerException
    at org.cain.cmdbin.CommandBin.<init>(
    ... 13 more
    03:57:15 [INFO] MLog clients using java 1.4+ standard logging.
    03:57:15 [INFO] [Vault] Loading Vault v1.2.9-b111.
    03:57:15 [INFO] [Vault][Economy] Essentials Economy found: Waiting
    03:57:15 [INFO] [Vault][Permission] SuperPermissions loaded as backup permission
    03:57:15 [INFO] [Vault] Enabled Version 1.2.9-b111
    03:57:15 [INFO] Preparing level "World One"
    03:57:15 [INFO] Default game type: 0
    03:57:15 [INFO] Preparing start region for level 0 (Seed: -1393647989664018251)
    03:57:16 [INFO] Preparing start region for level 1 (Seed: -1393647989664018251)
    03:57:16 [INFO] Preparing spawn area: 85%
    03:57:16 [INFO] Preparing start region for level 2 (Seed: -1393647989664018251)
    03:57:17 [INFO] [Essentials] Loading Essentials v2.8.2.
    03:57:17 [INFO] Bukkit version format changed. Version not checked.
    03:57:17 [INFO] git-Bukkit-1.1-R4-b1938jnks (MC: 1.1)
    03:57:17 [INFO] 1.1-R4
    03:57:17 [INFO] File not found: plugins\Essentials\jail.yml
    03:57:17 [INFO] [Vault][Economy] Essentials Economy hooked.
    03:57:17 [INFO] Essentials: Using config based permissions. Enable superperms in
    03:57:17 [INFO] [EssentialsChat] Loading EssentialsChat v2.8.2.
    03:57:17 [INFO] [EssentialsProtect] Loading EssentialsProtect v2.8.2.
    03:57:17 [INFO] Initializing c3p0- [built 21-May-2007 15:04:56; debug? tr
    ue; trace: 10]
    03:57:18 [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.8.2.
    03:57:18 [INFO] File not found: plugins\Essentials\spawn.yml
    03:57:18 [INFO] Server permissions file permissions.yml is empty, ignoring it
    03:57:18 [INFO] Done (2.526s)! For help, type "help" or "?"
  4. Offline


    He's right the same thing happens to me.
  5. Offline


    I'm using an older version and it works just fine, except sometimes the spawn (that I made with /setspawn) just randomly moves to somewhere odd!

    Also, I tried installing the latest version and it just doesn't work. I put the jar into my plugins folder and nothing happens. No config, no loading, no nothing :(
  6. Offline


    How can I remove one command that i want another plugin to handle, such as /sethome and /home?
    also, what happened to /warp?

    just updated also... and it stopped working...
    none of the commands work...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  7. Offline


    I dont see any permissions from the link that i click and it says 'Commands and permssions link'
  8. Offline


    I installed this it worked, now when I start the server it won't work. The folder that is suppose to appear when you install a plugin isn't appearing. Can anyone help with this?
  9. Offline


    I registered just to say I love your profile photo...
  10. Offline


    Haha thank you :)
    As for that CommandBin bug, I will look into it now.
  11. same issue here, just downloaded commandbin.jar, put it into plugins folder, nothing, cant use any commands in game and no new plugin folder created.i am running 1.1 r4.
  12. Offline


    I use the 1.1 r3
  13. Offline


    Well I came here to talk about the not loading error, but it seems everyone is having the same problem already. I've noticed though that with the previous 2.07 commandbin the permissions didn't seem to work.

    I am using PermissionsEX, of which has a bridge for the original Permissions 2.0+ and the commandbin links to that when loading, but otherwise it won't recognize that the users have permission for basic commands like /spawn

    Yes I am using nodes such as CommandBin.spawn
    could this be a error between permissions compatibility? I know the bridge works with other plugins so its not that PEX doesn't link to it properly.

    I do love this Command plugin, it brings me so many features with simple shortcuts making my life easier, but because of these little snippet problems I have to turn to others to get the job done.
  14. Offline


    i'm using BukkitPermissions and I can't get the plugin to load either. It tries to load the plugin but fails. Hopefully it'll be fixed soon.
  15. Offline


    V2.08 is likely broken in some way, and Cain didn't catch the error. Just downgrade back to 2.07 if you can, otherwise, it sucks to be you.
  16. Offline


    Any chance we can get a download link for the 2.07 version since 2.08 is broken? I was stupid and upgraded without keeping my old version.
  17. Offline


    [quote uid=42675 name="CainFoool" post=780840]<font color="#ff0000">[​IMG]</font>
    <Edit by Moderator: Redacted bit url>


    CommandBin is an attempt to bring essential commands that a server needs into the life of Bukkit. CommandBin was started on the 1st of November 2011 and has ever since been maintained by CainFoool.

    Sure, BrandonHopkins made a completely voluntary video for CommandBin!

    CommandBin supports every permissions system.

    You can view the Commands and Permissions at this link
    Working again!

    CommandBin can be used as an Administration Tool, a fun tool, an all-around general tool and a teleportation suite. I have tested every command and they're all working fine. v1.42 was never properly tested by me.

    Due to this post getting too long and I am trying to simplify the post as much as possible, the change log has been greatly shortened.

    Show Spoiler
    Version 2.08
    - Added /god
    - Added /realname
    - Added /drunk
    - Added /blind

    Version 2.07
    - Added /potion <player> <potion> <time>

    Version 2.06
    - Added /vanish
    - Minor bug fixes
    - Console Message Logging

    Version 2.05
    - Fixed up minor bugs

    - Added /thor
    - Added /sudo
    - Added /msg
    - Added /ram

    Version 2.02
    - Minor Fixes
    - Added /home and /sethome

    Version 2.01
    - Removed Maven Support
    - Added a /nick command
    - Added a /gm command
    - Added a /fsay command
    - Added full permission support
    - Added a /broadcast command

    Version 2.00
    - Full CommandBin Rewrite
    - Bukkit Permissions Support


    I just updated the plugin. Now bukkit doesn't recongize the plugin!!!
    plz help. Nice plugin though!

    can you post a link to mediafire with commandbin 2.07?
    plz i run a big server and this is a very good plugin.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Feb 20, 2017
  18. Offline


    Update destroyed it for me too, doesn't work
  19. Offline


    Having this bug too... please fix it :)
  20. Offline


    I apologise for the inactivity, working on it now.

    Fixed. Re-download and it *should* work.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  21. Offline


    Thanks for the fix, works great!

    One problem though, players on my server can use /setspawn for some reason!
    I didn't give them anything (except CommandBin.spawn, and home/sethome, etc.) but they still could. I tried giving them -CommandBin.setspawn and they still could.

    What's up with this? (and where can I find the permissions nodes, some of them aren't working, eg. CommandBin.vanish, etc.)
  22. Offline


    You saved my server!
  23. Offline


    Wow really? I thought I fixed that already, one second. Ill post a *very* quick update.

    Uploaded the fix, I must not have saved changes last time :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 14, 2016
  24. Offline



    In a Crafbukkit 1.1-R4(1938) server, I've this error when loading Commandbin 2.08 :

    2012-02-28 22:58:44 [INFO] [CommandBin] Loading CommandBin v2.08.
    2012-02-28 22:58:44 [SEVERE] Error occurred while enabling CommandBin v2.08 (Is it up to date?): null
    at org.cain.cmdbin.CommandBin.rc(
    at org.cain.cmdbin.CommandBin.registerCommands(
    at org.cain.cmdbin.CommandBin.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.t(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(

    Thank you in advance for your help.
  25. Offline


    You cannot remove commands from the config.yml.
  26. Offline


    This plugin works great the only problem i have is that only ops can use the commands normal players can't even do /sethome i am not using permissions i just got it and ran it and no one but ops could use it. Please help me out!
  27. Offline


    That's the point ...
    Only Ops can use the commands if no Permission System is installed.
    Also: 1,337th post on this thread :D
  28. Offline


    Love the new update, but i still cant /feed other people or /heal
  29. Offline



    I don't understand the answer... :confused:

    The config file was not created because of the error...
  30. Offline


    You modified your CommandBin.jar/plugin.yml to attempt to remove some commands.

    This will -not- work.

Share This Page