WorldGuard Flag Entry Deny doesn't work for me.

Discussion in 'Bukkit Help' started by AncientTom, Jul 2, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I have Googled this problem for hours and only found issues with the entry flag not allowing entry when set to allow. I have a small region (Living Quarters) inside a larger parent region, the Hotel. The concept is to allow only the room occupant to enter the room but lock all others out. I've tried everything I can think of without success but I can't keep unauthorized players out of this region.

    Why won't "Entry: deny" work for me.

    Using: WorldGuard 5.7.5 with custom flags option
    SimpleRegionMarket 3.5

    Thanks for any help I can get.
  2. Offline


    First deny entry > /rg flag <region_ID> entry deny
    Then choose who is denied > /rg flag <region_ID> entry -g nonowner

    So only owner can get in.
  3. Offline


    If you are testing this as an OP, or with an OP, then they may have permissions to bypass the entry.
  4. Offline


    I am using a 2nd player account that has only default permissions to test out my work.

    I am using SimpleRegionMarket to handle the rental signs to the rooms. When someone rents a room, SRM adds that player to the room's region as a member, not owner. I have tried those commands over & over again with no success albeit I use the -g nonmember in stead since there is no owner of the room regions. One thing that I don't understand is that when I do "/region flag roomID entry -g nonowner", I get the message "region group flag for 'entry' reset to default". Could there be a plugin that is monitoring regions and reseting this flag to a default value when it is set by me?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
Thread Status:
Not open for further replies.

Share This Page