[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Install.sh seems to have some problems (Debian squeeze, apache2 everything updated, ...):
    -e Checking dependencies...
    -e unzip...-e                  OK
    -e webserver...-e                      Apache2
    -e sql...-e                            MySQL
    -e php...-e                            OK
    -e php-curl...-e                        OK
    Dependencies are OK!
    -e Downloading SpaceCP now...-e        OK
    -e Unzipping...chmod: cannot access `app/tmp': No such file or directory
    chmod: cannot access `app/webroot': No such file or directory
    chmod: cannot access `app/Config/database*': No such file or directory
    chmod: cannot access `app/configuration*': No such file or directory
    unzip:  cannot find or open web.zip, web.zip.zip or web.zip.ZIP.
    --2012-02-05 14:28:54--  http://dl.xereo.net/rec/web.zip
    Resolving dl.xereo.net... /usr/lib/libcurl-gnutls.so.3    /usr/lib64/libcurl-gnutls.so.3
    /usr/lib/libcurl-gnutls.so.4      /usr/lib64/libcurl-gnutls.so.4
    /usr/lib/libcurl-gnutls.so.4.2.0  /usr/lib64/libcurl-gnutls.so.4.2.0
    /usr/lib/libcurl.a                /usr/lib64/libcurl.a
    /usr/lib/libcurl.la              /usr/lib64/libcurl.la
    /usr/lib/libcurl.so              /usr/lib64/libcurl.so
    /usr/lib/libcurl.so.3            /usr/lib64/libcurl.so.3
    /usr/lib/libcurl.so.4            /usr/lib64/libcurl.so.4
    /usr/lib/libcurl.so.4.2.0        /usr/lib64/libcurl.so.4.2.0
    chmod: cannot access `app/webroot/3d_skin': No such file or directory
    rm: cannot remove `web.zip': No such file or directory
    -e                      OK
    Everything has been unzipped, modded and owned correctly! You now have a perfect copy of the awesome SpaceCP Panel! \o/ *!party!* \o/
    Connecting to dl.xereo.net||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5396711 (5.1M) [application/zip]
    Saving to: `web.zip'
    100%[======================================>] 5,396,711  8.65M/s  in 0.6s
    2012-02-05 14:28:55 (8.65 MB/s) - `web.zip' saved [5396711/5396711]
    Manual install however works fine
  2. Offline

    Nathan C

    I think you should do this. Maybe sell panel hosting services, because it seems the large majority of the people have no clue how to run a simple webserver.
  3. Offline


    Read the wiki page, it says bash install.sh, not sh install.sh...

    Nathan C indeed, or people who don't want to go through all the hasstle...
    What would be a good price though?
  4. Offline


    You'd need to benchmark how many instances you could comfortably run, then divide that by the cost of the server, add a little for the hassle ;)

    I don't think anyone would be willing to pay more than their actual hosting, so I think a max of 3 euros is fair, something like 2 euros setup cost and 1.5 euros a month?
    Jamy likes this.
  5. Offline


    D'oh ok, my bad :(
    However I can't get past step 4 (adding the server), the page just reloads and nothing happens when I click on next.
  6. Offline


    Hey SpaceBukkit, I seem to have a problem :(

    The server was not reached. Please check your data.
    I have all of the details correct, jars in the right place etc... What do I do?
    (I have RTK installed too).
  7. Offline


    Please, Disable Auto Ajax Refresh on Online Players Tab.

    My server has more than 80 online, and when I going to page 3, they reload and gonna to page 1 again.

    This make almost impossible to see the last page of player list.
  8. Offline


    Now I get the same error, although the server is definitly running, rtk has been loaded and enabled (heartbeats too)
  9. Offline


  10. Offline


    To everybody having this issue:
    The server was not reached. Please check your data.
    Please go on our forums, register and PM me your hostname, ports and salt. We'll see together if it's happening because your ports aren't opened or if it is because of anything else.

    Edit: Well, do a research on the forums before and see if it might solve your issue.
  11. Offline


    Ok, Im trying to go through the installation but I'm stuck on step 4 of 5. what does it mean "Now let's add a SpaceBukkit-ready server to this panel! (must be running)"

    and i'm not sure what to enter in the fields. is Address my local IP address? Is title anythign? What is salt?
  12. Offline


    Still looking for help on getting these issues.

  13. Offline


    You must have a Mc server running SpaceBukkit and SpaceRTK to add it the panel.
    Address = Hostname, usually localhost if the panel and server are on the same host.

    Hey Anni, I would like to apologize for the whole team: Antariano is still sick so it can't really work on SpaceBukkit, Jamy has been really busy this week-end and me, as a Java developer, I can't fix the panel related issues. I hope you'll forgive us and wait until Antariano or Jamy came back and fix all those bad issues.
  14. Offline


    It's all good, I mean obviously I would love to get this working sooner than later, but I also understand that people get sick/busy. Thank you for your response though.

  15. Offline


    I got it now! I just needed the SALT from the config. I thought salt was something random I had to make up.

    I have a couple more questions. When viewing world overview. I do have multiverse installed and all of my worlds are imported. What is the steps to make this work?
    I also cannot edit plugin configs.
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  16. Offline


    I have gotten it working. I basically had to rage at my host and say "OPEN THE MFin PORTS!"

    It's an amazing system, sir. Works great as it is, can't wait for updates.
  17. Offline


    Very, do it, do it now! :D
  18. Offline


    I'm confused on the requirements. Is it possible to install this on a web server completely separate from our game server?
  19. Yes you can, you will have to open the ports 2011 and 2012 on your mc-server.

    1$/month will be easily possible, heck, maybe even 50c/month
    Servers aren't so expensive anymore :D
    B3NW likes this.
  20. Offline


    Try to update MultiVerse. Jamy any idea?

    SpaceBukkit hasn't been able to find this plugin configuration file. What is the plugin's name?
  21. Offline


    I don't get what the problem is, that message is just a notice. Can you actually press config buttons?
  22. Offline


    I could start a SpaceBukkit hosting company. It would be (oviusly) free for a server and account. Would I still have to pay?
  23. Offline


    Yes I could press the config button, then that message appears next to a "X" to close the message. I cannot edit configs for any of the plugins, they all have the same error including the spacebukkit plugins.

    As far as my multiworld issue, my multiverse plugin is up to date.
  24. Offline


    hello my host is having issues. and they will not use Spacebukkit.
    but as required i must have root access to start a SH file. am i right.
    because idont have it. but i do have a external webserver wich i can use for the panel.

    how can i install the toolkit and such without root rights?(and ssh) wich i dont have?
  25. Offline


    I get a http 500 error when I try to enter the SpaceBukkit Cp
    Error output
  26. Enable the rewrite module.
    If you are running apache:
    a2enmod rewrite
    service apache2 restart
    You can't, you will need root.
    honam1021 likes this.
  27. Offline


    I. LOVE. YOU. Thank you so much!

    One issue, I just unzipped all the files to a wampserver running on my machine, I go localhost:81 (my wampserver port) and get this:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
    Antariano likes this.
  28. Offline


    Make you sure you've followed our tutorial, and then if it's still not working, post in our forums.
  29. Offline

    nick fryman

    Love it.

    MineOS+ 5 is on its way with full Spacebukkit support from the moment you load up our ISO
    cheese5505 likes this.
  30. Offline


    Great news, thanks!
Thread Status:
Not open for further replies.

Share This Page