[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    The website isn't working. I like this plugin really :)
  2. Offline


    Can anybody post the install tutorial plz. I love this plugin but I can't install it because I don't know how to.
  3. Offline


    SpaceCP Jamy
    I'm sure you are aware that your site is down.
  4. Offline


    Our host is having some massive issues, we're doing the best we can but it doesn't depend on us. Sorry about the inconvenience
    tyzoid likes this.
  5. Offline


    Makes sense.

    How much traffic do you get a day? If it isn't too much, I can host a mirror on my vps.
  6. Offline


  7. Offline


    please help when i run rtoolkit it jays ' java' is not nrecognized as an internal or external command! please help!!
  8. Offline


    Has any progress been made on this?
    I see the forums still says its moving to a different host, the XereoNet homepage is having problems and the Git Repos havent been updated in a while.
  9. Offline


    hello i have some problems.
    1. i cant activate my account on the forums of spacebukkit the activation email never comes.
    2. the contact on the main domain is also not working
    3. the console of my spacebukkit panel keeps getting nothing at all (blank console)
    4. the updater gives an error every time :
    | Checking for updates... [||||||||||||||||||||||] 100 % |
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at me.neatmonster.spacemodule.api.ActionsManager.invoke(ActionsManager.j
            at me.neatmonster.spacemodule.api.ActionsManager.execute(ActionsManager.
            at me.neatmonster.spacertk.PanelListener.interpret(PanelListener.java:59
            at me.neatmonster.spacertk.PanelListener.run(PanelListener.java:198)
    Caused by: java.lang.OutOfMemoryError: Java heap space
            at java.util.Arrays.copyOf(Unknown Source)
            at java.lang.AbstractStringBuilder.expandCapacity(Unknown Source)
            at java.lang.AbstractStringBuilder.ensureCapacityInternal(Unknown Source
            at java.lang.AbstractStringBuilder.append(Unknown Source)
            at java.lang.StringBuilder.append(Unknown Source)
            at org.apache.commons.io.output.StringBuilderWriter.write(StringBuilderW
            at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1486)
            at org.apache.commons.io.IOUtils.copy(IOUtils.java:1461)
            at org.apache.commons.io.IOUtils.copy(IOUtils.java:1436)
            at org.apache.commons.io.IOUtils.toString(IOUtils.java:585)
            at org.apache.commons.io.FileUtils.readFileToString(FileUtils.java:1458)
            at me.neatmonster.spacertk.actions.FileActions.getFileContent(FileAction
            ... 8 more
    5. i get also this error :

    ERROR: There was an issue binding the UDP server to port 25561: java.net.BindExc
    eption: Address already in use: Cannot bind
    Attempting to refresh UDP server in 5 seconds...
    Starting UDP listen server on port 25561
    ps. i have allocated 4 GB ram it uses avg 30% sometimes it spikes to 70%
    and i use spacebukkit 1.2 and module 81

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  10. Offline


    Maybe add rcon support to connect to minecraft server, without having to use remotetoolkit??
  11. Offline


    Pretty sure SpaceBukkit is dead -- which is a shame. I really wanted to get away from McMyAdmin, and I hate MultiCraft.
    MikeA likes this.
  12. Offline


    Why is that? We're always open to feedback on things you'd like to see :) You can even post suggestions directly on our support page.
  13. Offline


    As someone that has evaluated your product for commercially viable hosting, let me post a few things.

    1) Your UI was not up to par with some other competitors when I evaluated it. The design is getting better, but your buttons look horrible.
    2) Really, Mono? Build a native linux version or port your code to Java.
    3) Your documentation is lacking, and you didn't even bother to set your background to fill the screen.

    I can't complain about your licensing fees, those are better compared to Multicraft.
    You have some room for improvement.
  14. Offline


    You're a long way behind the times. McMyAdmin hasn't needed Mono since McMyAdmin 2.0 (released over a year ago) and has a native 64-bit Linux binary. I also think you've not seen MCMA2's UI which uses flat looking buttons in its default theme ( http://i.imgur.com/PPJwo.png ) and you can customize however you please.
  15. Offline


    Wish i could get the admin panel working with nginx XD Sucks the devs haven't been active to try and fix it.
  16. Offline


    Nuu! Come back Spacebukkit! We need you!
    Ivan and Omgitsbob12 like this.
  17. Offline


    Oh, I thought that the linux binary included mono. Oops.
    I glanced at some of your more recent screenshots and I saw bad looking buttons (assumed this was global and current), haven't tested a recent version yet.

    It appears that
    1) The forums are broken.
    2) It's always been like that, notified them multiple times.
    4) There's not enough memory, for some reason. It's crapping out with no memory.

    5) You're already running SpaceBukkit, try running ps aux | grep java. Kill the PID that appears to be Java by typing kill -9 (pid) . Note that this will forcefully kill Java.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  18. Offline


    Can't register on the site to report any issues on the forums but I have been getting errors with the CPU and RAM calculation.
    Also the console was working perfectly yesterday now it does not show up at all.

    The playercount under the server name has no numbers at all. CPU, RAM and Java are all stuck at "Calculating...", this worked on my previous installing but does not work anymore. The Activity and Admins online also does not work.
  19. Offline


    go to your server settings and empty the line for dynmap. that shout fix the calculating and such
    Omgitsbob12 likes this.
  20. Offline


    Wow that totally fixed it, thank you so much!!! The console still doesn't show up though :(
    Edit: Fix for console not showing up, run rtoolkit.sh from a root user.
  21. Offline


    well i am a root user on windows. i use the batfile as administrator. and still its gone everytime
  22. Offline


    Help me im such a noob >.<

    root@TerraElysio:/home/jeff# cd /var/
    root@TerraElysio:/var# clear
    root@TerraElysio:/var# cd www
    root@TerraElysio:/var/www# sudo sh install.sh
    Checking dependencies...
    unzip...                        OK
    webserver...                    Apache2
    sql...                          MySQL
    php...                          OK
    php-curl...ls: cannot access /usr/lib*/*curl*: No such file or directory
    You don't have Curl installed. Spacebukkit will need it. Do you want to install Curl now? [Y]/n y
    Installing Curl...              OK
    Dependencies are OK!
    Are you SURE the current directory you are in (/var/www) is the directoy the script is in and also the directory where you want to install Spacebukkit? [y/N]
    Downloading Spacebukkit now...  OK
    Unzipping...chmod: cannot access ‘SpaceDev-SpaceBukkitPanel-*/app/tmp’: No such file or directory
    chmod: cannot access ‘SpaceDev-SpaceBukkitPanel-*/app/webroot’: No such file or directory
    chmod: cannot access ‘SpaceDev-SpaceBukkitPanel-*/app/Config/database*’: No such file or directory
    chown: cannot access ‘SpaceDev-SpaceBukkitPanel-*/*’: No such file or directory
    cp: cannot stat ‘SpaceDev-SpaceBukkitPanel-*/*’: No such file or directory
    cp: cannot stat ‘SpaceDev-SpaceBukkitPanel-*/.htaccess’: No such file or directory
    rm: cannot remove ‘SpaceDev-SpaceBukkitPanel-*’: No such file or directory
    Everything has been unzipped, modded and owned correctly!
    You now have a perfect copy of the awesome Spacebukkit Panel! \o/ *!party!* \o/
  23. Offline


    Ermm... MSD is doing this... ( minecraftserverdeals.com )
    breezeyboy likes this.
  24. Offline


    is spacebukkit gonna be updated to support bukkit 1.7.2?
  25. Offline


    There's really nothing to update except for the log location. (now (server root)/logs/latest.log) I might even be able to get it running...
  26. Offline


    there is a lot to update.
    for example a server console that doesnt always load. same counts for chat.
    the servers log location. i changed. and such
  27. Offline


    Anyone know how to fix the console not showing up because of the server log changing folders?
  28. Offline


    I'm really loving the looks of this, but I've got a few unfortunate bugs, probably on 1.2 (I can't tell what version I'm on, but it's mangled... ;~; ):
    * Changing a player's theme removes all their permissions and changes their password
    * Console and Chat don't connect, sending works, receiving doesn't.
    * Neither do the Statistics / Activity tabs. These just calculate forever.
    * Themes don't actually change when changed.

    Yes, I am sure that it's theme changing that had that effect; I'm loading this on a home server, and I've given the IP to one person who doesn't know my password, and who had no permissions on his own account.
    If not the theme changer, then what else? :eek:
  29. Offline


    i doubt they will fix the bug since they are focusing on spaceCP which is a replacement to this.
  30. Offline


    You can use a symlink to fix
Thread Status:
Not open for further replies.

Share This Page