[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Yeah, I managed to install it on the server, didn't realise I was putting the wrong jar in there! Though, the web panel doesn't want to work at all, it just hangs on the mySQL page regardless of which option you choose (1.2RC)
  2. Offline


    today I´ve got at the startup of my server the folowing error:
    Loading SpaceModule...Done.
    ----------------[SpaceModule v1.2-SNAPSHOT]---------------
    Error enabling Toolkit module SpaceModule:      ]  0 % |
            at java.io.StringReader.<init>(Unknown Source)
            at com.thoughtworks.xstream.XStream.fromXML(XStream.java:903)
            at me.neatmonster.spacemodule.management.ArtifactManager.setup(ArtifactManager.java
            at me.neatmonster.spacemodule.SpaceModule.onEnable(SpaceModule.java:382)
            at com.drdanick.McRKit.module.Module.startModule(Module.java:45)
            at com.drdanick.McRKit.module.ModuleManager.handleToolkitStateEvent(ModuleManager.j
            at com.drdanick.McRKit.McRKitLauncher.<init>(McRKitLauncher.java:144)
            at com.drdanick.McRKit.McRKitLauncher.main(McRKitLauncher.java:103)
    I tested it also on my testserver on my pc but I get the same error. I have nothing changed since two days and everything works fine till now. My server starts up but SpaceBukkit can't reach the server. You can see the full log of the start up here. My testserver is an 1:1 copy of the original server.
    The following plugins are installed: dynmap, MCRTKit, multiworld, spacebukkit
  3. Offline


    Make sure you hav pdo_mysql and PDO_sqlite on there

    Should be fixed now

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  4. Offline


    I've got another problem with the RC panel. The schedule task "stop" don't work. If I try to start the task manual nothing happen. It says that the task starts but the server is still running. With the UDP Client it works fine. Every other task works fine.

    And another problem: Every task disappear after restarting the apache server.
  5. Offline


    Warning: _cake_core_ cache was unable to write 'cake_dev_es-es' to File cache in /var/www/html/panel/lib/Cake/Cache/Cache.php on line 306
    Warning: _cake_core_ cache was unable to write 'cake_dev_es-es' to File cache in /var/www/html/panel/lib/Cake/Cache/Cache.php on line 306
    Warning: /var/www/html/panel/app/tmp/cache/persistent/ is not writable in /var/www/html/panel/lib/Cake/Cache/Engine/FileEngine.php on line 320
    Warning: /var/www/html/panel/app/tmp/cache/models/ is not writable in /var/www/html/panel/lib/Cake/Cache/Engine/FileEngine.php on line 320
    Warning: /var/www/html/panel/app/tmp/cache/ is not writable in /var/www/html/panel/lib/Cake/Cache/Engine/FileEngine.php on line 320 true
  6. Offline


    can anyone help me with this error?
    i cant connect or ping the ports 2011 and 2012
    and i cant reinstall, the spacemodule servers are offline
    Minecraft Remote Toolkit R10 Alpha 13
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Loading SpaceModule...Done.
    ----------------[SpaceModule v1.2-SNAPSHOT]---------------
    java.lang.ClassNotFoundException: me.neatmonster.spacertk.SpaceRTK
            at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
            at me.neatmonster.spacemodule.SpaceModule.load(SpaceModule.java:268)
            at me.neatmonster.spacemodule.SpaceModule.onEnable(SpaceModule.java:405)
            at com.drdanick.McRKit.module.Module.startModule(Module.java:45)
            at com.drdanick.McRKit.module.ModuleManager.handleToolkitStateEvent(ModuleManager.java:66)
            at com.drdanick.McRKit.McRKitLauncher.<init>(McRKitLauncher.java:144)
            at com.drdanick.McRKit.McRKitLauncher.main(McRKitLauncher.java:103)
    | Starting SpaceBukkit... [||||||||||||||||||||||] 100 % |
    Wrapper is running on: Linux 2.6.32-5-amd64 amd64
    Starting wrapper...
    Starting UDP listen server on port 25561
    Jan 14, 2013 6:03:27 PM net.wimpi.telnetd.net.PortListener run
    Information: Listening to Port 25.561 with a connectivity queue size of 5.
    208 recipes27 achievements18:03:31 [INFORMATION] Starting minecraft server version 1.4.5
    18:03:31 [INFORMATION] Loading properties
    18:03:31 [INFORMATION] Default game type: SURVIVAL
    18:03:31 [INFORMATION] Generating keypair
    18:03:33 [INFORMATION] Starting Minecraft server on *:25565
    18:03:33 [WARNUNG] The server will make no attempt to authenticate usernames. Beware.
    18:03:33 [WARNUNG] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    18:03:33 [WARNUNG] To change this, set "online-mode" to "true" in the server.properties file.
    18:03:34 [INFORMATION] This server is running CraftBukkit version git-Bukkit-1.4.5-R1.0-b2543jnks (MC: 1.4.5) (Implementing API version 1.4.5-R1.0)
    18:03:35 [INFORMATION] [RemoteToolkitPlugin] Loading RemoteToolkitPlugin v0.61
    18:03:35 [INFORMATION] Preparing level "world"
    18:03:36 [INFORMATION] Preparing start region for level 0 (Seed: -782781235510741093)
    18:03:37 [INFORMATION] Preparing spawn area: 0%
    18:03:38 [INFORMATION] Preparing spawn area: 28%
    18:03:39 [INFORMATION] Preparing spawn area: 69%
    18:03:40 [INFORMATION] Preparing start region for level 1 (Seed: -782781235510741093)
    18:03:40 [INFORMATION] Preparing spawn area: 4%
    18:03:41 [INFORMATION] Preparing spawn area: 32%
    18:03:43 [INFORMATION] Preparing spawn area: 69%
    18:03:44 [INFORMATION] Preparing start region for level 2 (Seed: -782781235510741093)
    18:03:44 [INFORMATION] Preparing spawn area: 36%
    18:03:44 [INFORMATION] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin v0.61
    18:03:44 [INFORMATION] Memory max: 1029046272 bytes
    18:03:44 [INFORMATION] Memory total: 1029046272 bytes
    18:03:44 [INFORMATION] Remote Toolkit Plugin V0.61 enabled!
    18:03:44 [INFORMATION] Server permissions file permissions.yml is empty, ignoring it
    18:03:45 [INFORMATION] Done (9,420s)! For help, type "help" or "?"
    First attempt at checking for presence of Bukkit RTK plugin...
    Bukkit RTK plugin found! Enabling heartbeats...
  7. Offline


    May be wrong bukkit version?
  8. Offline


    How is it fixed or where to get the fix...

    cus I have the same problem ...

    Loading SpaceModule...Done.
    ----------------[SpaceModule v1.2-SNAPSHOT]---------------
    Error enabling Toolkit module SpaceModule: ] 0 % |
  9. Offline


  10. Offline


    Can I just make the suggestion to change the web install script so that sudo/root is NOT a requirement? Just give us the files to upload, and make the installer check all that stuff (which it does).

    Also, why do I need to chmod ALL of my files in webroot (not just the folders, even pictures and css) just to run spacebukkit?

    Other than these two things, the panel seems really nice! A good alternative to those of us who already have a web server running and don't want it built in (mcmyadmin).
  11. Offline



    The server cant be added into the panel, I tried Ip with port, without port, localhost.
    anyone know the solution ?

    Thank you.
  12. Offline


    SpaceBukkit has been confusing the hell out of me lately, in fact, every control panel has been. You see, in-game I'll type /lag to find that I have around 6GB of free RAM. But on spacebukkit, that would be the Java meter, not the RAM. All control panels I use recognize my server as using 90%-100% RAM allocated to it, but ingame, they've always said I have between 4-6GB of free RAM. I have absolutely no clue what is happening xD.

    For example: Right now, my "Java" reading is at 20%, but my "RAM" reading is at 97%, however, when I type /lag in-game, it matches the amount of used "Java" I'm not sure how the two differ from each other, all I know is that Bukkit's autorestart is really starting to piss me and my players off :confused:
  13. Offline


    jakichan77 If I remember correctly, in SpaceBukkit, the value listed under RAM is the amount of memory allocated to the server process. If you are hosting your server with a hosting company, you should expect it to be around 100%.

    The value listed under Java is the RAM actually being used. Whatever plugin you use to get the amount of RAM used reports this value as well.
  14. Offline


    1 year! [flintnsteel]
  15. Offline


    I have been trying to get the panel installed for 6 hours now. It's all been on step 4.

    Yes - server is running
    Yes - i opened 2011 and 2012 on both windows firewall and on my motorola SBG6580 cable modem

    After a few hours found a post here about a different jar file to use.

    Now I still cannot get past step 4 due to 2 warnings.

  16. Offline


    When i use this in a hour the server is consuming all my host virtual memory. About 11gb, plus all remaining RAM. And crash.
  17. I had the same problem when i used localhost, tried with the FQDN and that worked for me. IP might also have woked.

    Hope it works!
  18. Offline


    Hi there. Awesome work on making this wrapper. I have one question for you.

    If I were to run multiple servers on the same machine with the same IP addresses, separated by port, how do I add them all into the web panel so that I can manage them all from the same page?
  19. Offline


    I logged onto my space bukkit this morning and had the same problem that I have been having all week. Spacebukkit likes to either forget to add the port to dynmap or it adds a space between the ip and the port. Every once in a while it works correctly. I need help! I just want to be able to view dynmap in spacebukkit! Also I would like to be an alpha tester.
  20. Offline


    I've got CraftBukkit running on a Debian VPS as a daemon. I. e. there's an /etc/init.d/minecraft script that lets me start/stop the server in background. The server also starts automatically on server startup.

    I want to install SpaceBukkit. SpaceBukkit requires RemoteToolkit, and RemoteToolkit supposes running a server by launching the wrapper startup script manually. I failed to find any information on how to set up RemoteToolkit wrapper running as a Debian/Ubuntu daemon.

    Could you please help me out with this?
  21. Offline


    Have you guys considered packaging it for major OS's: Arch, Debian, CentOS, ect?
  22. Offline


    I know im stealing this guys thread and should be posting on yours I want to get your attention and I cant figure out how to post on your forums... :) LOL but random users keep spawning in my user config area and there all just blank and I cant delete any of them its really irritating.....
  23. Offline


    Any release why it runs so slow on the webpanel ?
  24. Offline


    I am getting a HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request. on ports 2011 and 2012 - I have the webserver installed fine on my webserver, however when trying to connect it to my dedicated server it appears the ports aren't loading. For some reason the dedicated server that is running SpaceBukkit it throwing a 500 server error on both ports 2011 and 2012.
    What can I do? I do receive a pong back on both ports, and I have disabled selinux on the minecraft server
  25. Offline


    Any further help should be pointed over at there forums.
  26. Offline


    spacemodule don't work can you update?
  27. Offline


    spacebukkit keeps giving me this annoying error that it keeps failing to ping (btw, port is open, 2011 and 2012). It's not doing anything, but still annoying and spams my server log. Can you fix this bug?
  28. Offline


    Cant get it to work, port forwarding is correct..."Server was not reached. Is the address correct, are the ports open?" Im sure the address is correct (not localhost, remote IP) and the ports I scanned using a port checker...
  29. Offline


    2013-05-01 21:22:42 [INFO] [SpaceBukkit] Enabling SpaceBukkit v1.2
    2013-05-01 21:22:42 [SEVERE] Error occurred while enabling SpaceBukkit v1.2 (Is it up to date?)
    com.drdanick.rtoolkit.ToolkitRuntimeException: java.lang.NullPointerException
    >       at com.drdanick.rtoolkit.system.EventDispatcher.<init>(EventDispatcher.java:58)
    >       at me.neatmonster.spacebukkit.SpaceBukkit.onEnable(SpaceBukkit.java:142)
    >       at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    >       at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    >       at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
    >       at org.bukkit.craftbukkit.v1_5_R2.CraftServer.loadPlugin(CraftServer.java:282)
    >       at org.bukkit.craftbukkit.v1_5_R2.CraftServer.enablePlugins(CraftServer.java:264)
    >       at net.minecraft.server.v1_5_R2.MinecraftServer.j(MinecraftServer.java:303)
    >       at net.minecraft.server.v1_5_R2.MinecraftServer.e(MinecraftServer.java:282)
    >       at net.minecraft.server.v1_5_R2.MinecraftServer.a(MinecraftServer.java:242)
    >       at net.minecraft.server.v1_5_R2.DedicatedServer.init(DedicatedServer.java:150)
    >       at net.minecraft.server.v1_5_R2.MinecraftServer.run(MinecraftServer.java:381)
    >       at net.minecraft.server.v1_5_R2.ThreadServerApplication.run(SourceFile:573)
    Caused by: java.lang.NullPointerException
    >       at com.drdanick.rtoolkit.system.EventDispatcher.<init>(EventDispatcher.java:45)
    >       ... 12 more
    Can anyone help?
    I tried change craftbukkit, replace spacebukkit.jar etc.. nothing.. :( so i can't complete instalation :X
  30. Offline


    I think the problem is Web Port from SpaceBukkit.
    Space Bukkit's download pages can't download anything.
    Are the Bukkit Space Plugin & Web maintaining ??
    (Sorry for my poor English)
Thread Status:
Not open for further replies.

Share This Page