[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    You are AWESOME!
    I love Spacebukkit!

    But I have some problems creating a sheduled Backup ;(
    The error:
    Unexpected exception loading backup metadata for "Freebuild": /home/minecraft/Backups/Freebuild (Is a directory)
    Unexpected exception loading backup metadata for "StarCraft_nether": /home/minecraft/Backups/StarCraft_nether (Is a directory)
    Unexpected exception loading backup metadata for "StarCraft_the_end": /home/minecraft/Backups/StarCraft_the_end (Is a directory)
    Unexpected exception loading backup metadata for "temp": /home/minecraft/Backups/temp (Is a directory)
    Unexpected exception loading backup metadata for "plugins": /home/minecraft/Backups/plugins (Is a directory)
    Unexpected exception loading backup metadata for "StarCraft": /home/minecraft/Backups/StarCraft (Is a directory)
    Thank you guys for your help,
  2. Offline


    We are fixing backups, they are a bit broken right now. Sorry bout that!
  3. Offline


    Antariano Ok!
    How long will you need for that?
    Because all Backup plugins crash my server ;(

    I'm having a big problem.
    I love your webinterface, but after some time I'm getting this error:
    2012-10-06 20:34:44 [SEVERE] Could not pass event AsyncPlayerChatEvent to SpaceBukkit
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:341)
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
        at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:477)
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:459)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:831)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:808)
        at net.minecraft.server.Packet3Chat.handle(Packet3Chat.java:44)
        at net.minecraft.server.NetworkManager.i(NetworkManager.java:211)
        at net.minecraft.server.NetworkManager.c(NetworkManager.java:332)
        at net.minecraft.server.NetworkReaderThread.run(SourceFile:93)
    Caused by: java.lang.ThreadDeath
        at java.lang.Thread.stop(Unknown Source)
        at net.minecraft.server.NetworkMasterThread.run(SourceFile:291)
    Nobody can write or execute any command.
    I need a fix, quick!
    Or I have to remove this awesome webinterface ;(

    Thank you,

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 29, 2015
  4. Offline


  5. Offline


    I'm trying to install this on an nginx server. When I get to the installation script, it gives you a link to your wiki (this link) that tells me how to set up rewrite rules, but it doesn't load.

    I can't find a page about nginx rewrite rules in your documentation either... how do I set them up? Also, why is the Wiki down?
  6. Offline


    can we get a android app?
  7. Offline


    This looks so much nicer than multicraft
  8. Offline


    We've updated the thread for our 1.2 release. Note that 1.2 is a release candidate and may have bugs here or there, but we're already working on a fix. Have fun!
  9. Offline


    Hi @Antariano, i can't backup my world, is the problem resolved or.. ?
  10. Offline


    We're on it. I have an important exam tomorrow, but after that I'll get right on it.
    dark_hunter likes this.
  11. Offline


    Any problem using this and Spout ?
  12. Offline


    There should not be any problems, except for the updating feature (only craftbukkit supported right now) and the inventory (only vanilla blocks will display)
  13. Offline


    Ok, thanks. I'll give it a try right now then :)
  14. Offline


    Hm, I got a little problem while installing. Everything is fine with the autoinstall, the panel is launching and I'm setting up the link between panel and server. The problem is ; the spacebukkit.jar is nowhere to be found. I need to put it in the /plugins forlder, but where can I download it ?

    Hm and Spacemodule/configuration.yml seems to be empty

    Edit : The problem may be that ./rtoolkit.sh is apparently doing nothing

    Edit 2 : Because rtoolkit.sh seems to be empty >.>

    Edit 3 : I ran the install script 3 times, with root or non root permissions and i still got the same result. I don't have any error while installing

    Edit 4 : I ran the MinecraftRTK.jar manually, seems to work.

    Edit 5 : Still not working. Get a Java Error + Panel can not connect to the server

    Minecraft Remote Toolkit R10 Alpha 13.1
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Loading SpaceModule...Done.
    ----------------[SpaceModule v1.2-SNAPSHOT]---------------
    | Checking for updates... [||||||||||||||||||||||] 100 % |
    | Starting SpaceBukkit... [||||||||||||||||||||||] 100 % |
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:616)
            at me.neatmonster.spacemodule.SpaceModule.load(SpaceModule.java:270)
            at me.neatmonster.spacemodule.SpaceModule.onEnable(SpaceModule.java:391)
            at com.drdanick.McRKit.module.Module.startModule(Module.java:45)
            at com.drdanick.McRKit.module.ModuleManager.handleToolkitStateEvent(ModuleManager.java:66)
            at com.drdanick.McRKit.McRKitLauncher.<init>(McRKitLauncher.java:144)
            at com.drdanick.McRKit.McRKitLauncher.main(McRKitLauncher.java:103)
    Caused by: java.lang.NoSuchFieldError: bindAddress
            at me.neatmonster.spacertk.SpaceRTK.onEnable(SpaceRTK.java:111)
            ... 10 more
    Edit 6: After getting the last Spacemodule.jar from the website all is working fine. I still got a java error while stopping the server :

    20:15:26 [GRAVE] Error occurred while disabling SpaceBukkit v1.2 (Is it up to date?)
    java.lang.NumberFormatException: For input string: "Serv)"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
            at java.lang.Integer.parseInt(Integer.java:481)
            at java.lang.Integer.parseInt(Integer.java:514)
            at com.jezhumble.javasysmon.LinuxProcessInfoParser.parse(LinuxProcessInfoParser.java:33)
            at com.jezhumble.javasysmon.LinuxMonitor.processTable(LinuxMonitor.java:123)
            at com.jezhumble.javasysmon.JavaSysMon.processTree(JavaSysMon.java:230)
            at com.jezhumble.javasysmon.JavaSysMon.visitProcessTree(JavaSysMon.java:253)
            at com.jezhumble.javasysmon.JavaSysMon.killProcessTree(JavaSysMon.java:271)
            at com.jezhumble.javasysmon.JavaSysMon.infanticide(JavaSysMon.java:282)
            at me.neatmonster.spacebukkit.system.PerformanceMonitor.infanticide(PerformanceMonitor.java:144)
            at me.neatmonster.spacebukkit.SpaceBukkit.onDisable(SpaceBukkit.java:76)
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:219)
            at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:400)
            at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:400)
            at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:393)
            at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:265)
            at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:328)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:437)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
  15. Offline


    Hep, coming back to talk about a bug.

    I wanted to delete my worlds, as I want to us TerrainControl to generate new ones. Deleting through the web interface did not seem to work (checked on the server) so I stopped Spacebukkit and deleted the world manually. New worlds have been generated by bukkit+TC, but Spacebukkit does not list them within the web UI.

    Edit ; after several restart, the worlds are now normaly showing in the web UI.
  16. Offline


    Does this support Tekkit?
  17. Offline


    Very excellent !! I love !
    But one question:

    Have you make an auto-install for a daemon script to launch minecraft in a dedicated server (linux-ubuntu) ?
    Or you have a good script with help for spacebukkit?

    Thanks you in advance !
  18. Offline



    Loving this thing but a few problems:

    1. Manually entering a craftbukkit build to install does nothing. It says it's installing it for a while, then it closes and nothing happens.

    2. All buttons (restart/stop/start/reload etc) don't do anything. Again, they say they are doing something but then nothing happens when they "finish".

    3. Executing commands through console doesn't work. It says the command was executed successfully, but again nothing happens.

    I don't believe I installed wrong, and it's not a problem sending data to the server because I can send messages through the online Chat interface just fine.

    Hope to get this resolved quickly.
  19. Offline


    Thanks for pointing that out, we will look into it
  20. Offline


    ( ! ) Fatal error: Maximum execution time of 30 seconds exceeded in C:\www\blink\spacebukkit\app\SpaceBukkitAPI.php on line 58Call Stack#TimeMemoryFunctionLocation10.0005168352{main}( )..\index.php:020.01641167680Dispatcher->dispatch( )..\index.php:9630.02821828312Dispatcher->_invoke( )..\Dispatcher.php:8540.06983514088Controller->invokeAction( )..\Dispatcher.php:10350.06983514536ReflectionMethod->invokeArgs( )..\Controller.php:48860.06983514552GlobalController->serverConnectionInfo( )..\Controller.php:488721.10814259520SpaceBukkitAPI->call( )..\GlobalController.php:680821.10814259880SpaceBukkitAPI->curl( )..\SpaceBukkitAPI.php:27

    Just started happening
  21. Offline


    Make sure you're server is running fine. If it's acting up (the updater not working) refer to http://forums.xereo.net/threads/jenkins-down-please-read.1378/
    We're having issues with out main update server due to unpredictable circumstances and will work on a stable experience as much as we can.
  22. Offline


    Where can I download an alternative copy of RTK? The link appears broken.
  23. Offline


    Well we ended up fixing it, well i didn't but one of my friends did, and ya we just re-installed it, and its a good thing it did this, turns out there was an update we missed :p
  24. Offline


    I've just intalled it on a Ubuntu server 12.10 and it works perfectly.
    This is exactly what I was looking for administrating my server.
    Thank you very much for this awesome work!

    Just one question: Is your ram usage indicator right? Because another monitor on my server (webmin) doesn't indicate the same amount of used and free ram.
    Jamy likes this.
  25. Offline


    It's currently broken on linux ^^ We're working on it!
  26. Offline


    After a server reboot, ram monitor was working (same value than webmin).
    Would you add an settings panel for dynmap ? Because I don't use dynmap website but my own so I had to tweak Tworldcontrolle something to make it work in your interface :p
  27. Offline


    Normally if you go to your server settings in the panel (Panel->Settings->Servers->Edit) you can add a dynmap address, if you put in the address of your dynmap site (including http://) it should work ;)
  28. Offline


    Can you guys add support for spigot? I have a server running the latest version of spigot and it says that i am running an outdated server.
  29. Offline


    I'm trying to get this working, but all I get is the following when I load my server:

    2012-12-27 20:43:02 [SEVERE] Could not load 'plugins/spacemodule-1.2-SNAPSHOT.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:247)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:132)
    at org.bukkit.craftbukkit.v1_4_5.CraftServer.loadPlugins(CraftServer.java:229)
    at org.bukkit.craftbukkit.v1_4_5.CraftServer.<init>(CraftServer.java:207)
    at net.minecraft.server.v1_4_5.ServerConfigurationManagerAbstract.<init>(ServerConfigurationManagerAbstract.java:52)
    at net.minecraft.server.v1_4_5.ServerConfigurationManager.<init>(SourceFile:11)
    at net.minecraft.server.v1_4_5.DedicatedServer.init(DedicatedServer.java:111)
    at net.minecraft.server.v1_4_5.MinecraftServer.run(MinecraftServer.java:398)
    at net.minecraft.server.v1_4_5.ThreadServerApplication.run(SourceFile:856)
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
    ... 9 more
  30. Offline


Thread Status:
Not open for further replies.

Share This Page