[WEB/ADMIN] SpaceBukkit Beta 1.2 - Web Administration the awesome way!

Discussion in 'Bukkit Tools' started by SpaceCP, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I've never tried the ping thing. I tried that syntax on cmd prompt and other stuff, but no matter where I tried, it didn't work. Where am I supposed to try that? (I feel stupid now) :eek:
  2. In a browser.
    alebcay and Jamy like this.
  3. Offline


    Oh. OK. ^.^

    2011 returns a pong, 2012 doesn't.

    It also appears that no matter what I change 2012 to, Google Chrome still can't ping it...(I've tried 80, and just about any free port on my VPS)
  4. Offline


    Are you sure the port is set to 2012? Are you sure that port is open? There's a break in the chain somewhere.
  5. Offline


    I'll try switching the 2011 and 2012 ports and see if that works. That way, I'll see whether its a ports issue or a SpaceBukkitRTK issue...
  6. Use build #6 of our module then, you have a dev build. Also change Developpment to false and Recommended to true in SpaceModules Configuration.
  7. Offline


    I've already tried switching to #6, I've downloaded #6 twice already. And this is my config file:

        Artifact: <automatic>
        Type: Bukkit
        Development: false
        Recommended: true
        Salt: JIEFIUEOUIR0893297837890FFDJFJL
        WorldContainer: .
        Port: 2011
        Port: 2012
    EDIT: OK, so after I posted this, I switched the port numbers above (made 2012 for SpaceBukkit and 2011 for SpaceRTK) and found that I could then ping 2012 and not 2011, so the problem lies in the SpaceRTK, not port 2012.
  8. Protip: NEVER paste your salt anywhere, it's the key into your SB and thus into your MC-Server, so don't do that ;)

    Are you sure you copied the module to <mc>/toolkit/modules/ and not <mc>/plugins/ ? Happened to quite some people :p

    Did you restart the whole wrapper?
  9. Offline


    I know. I just reinstalled EVERYTHING...Module, and FOLDER (and changed my Salt ;) ), with the build #6 above...I guess its just a matter of letting it regenerate the SpaceModule folder. I just tried and now both ports are replying. I'm now trying the Web Panel Installation one more time...

    Still reports server could not be reached...:eek:
  10. But it is still Ponging?
    Then you might not have cURL installed.

    making a wild guess you probably have ubuntu as distro, you can install cURL with this command:
    apt-get install curl php5-curl
  11. Offline


    Wait...somehow the page didn't update and its working now?!?


    You have a fully operational SpaceBukkit installed.

    Here are some links to get you started if you need help:

    SpaceBukkit Home
    SpaceBukkit Forums
    SpaceBukkit Wiki
    SpaceBukkit Home

    Please note that Your login credentials are:


    Once logged in immediatly change these credentials on the "Settings" page!

    Allright! Are you ready for awesomeness? Click next to begin your biggest adventure!
  12. So it's working now? That's good then, isn't it? :p
  13. Offline


    Yay! Its working now! One problem...when I try to log in, I end up on a blank page, with nothing on it. The tab title just says "localhost/spacebukkit/dash", and I don't see anything...I'm looking at the F.E.P section on the SB wiki, but I'm running Apache on Windows, with no console window, so I don't know what to do...
  14. Offline


  15. Offline


  16. Offline


  17. I'm still searching for a solution, sorry :(

    Did you maybe also try what the error tells you to do?
  18. Offline


    No -.- /sarcasm

    Yes, Yes i did.
  19. Well that's great that you knew that, but how do you expect us to help you w/o any information at all? :p

    Did you set AllowOverride to All for your webroot?
  20. Offline


    Yes ;(
  21. Did you restart apache after enabling the rewrite module with a2enmod mod_rewrite?
  22. Offline


    From prior experiences, note that if this is on a public webhost that you don't have root access to, you probably can't fix the issue. (I HATE 000WEBHOST FOR THAT DX)
  23. Offline


    Any feedback on the thing I talked about in the post above yours, which I quoted?
    Tom Swift likes this.
  24. Offline


    I talked with our java department (sounds snazzy, eh?). They say it's normal for how Java works - it builds up memory until the garbage collector deletes most of it again.
    Nathan C and M1sT3rM4n like this.
  25. Offline


    Cool. I thought it was either I or the server going insane.
    Tom Swift likes this.
  26. Offline


    Yes ;[
  27. Then it must work :/ Did you clear your cache and then try to reload the page? Maybe you get a cached version of it all the time...
  28. Offline


    What's the latest news on spacebukkit?
    do we get any incremental upgrades? stuff that starts working for example, backups?
  29. Offline


    You should check out our forums or IRC for news :)
  30. Offline


Thread Status:
Not open for further replies.

Share This Page