[UNSUPPORTED][TP] Warpz0r v1.4.2 - Multiworld Warp and Home plugin [1317]

Discussion in 'Inactive/Unsupported Plugins' started by Drakia, Feb 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Warpz0r - Yet another warp and home plugin! Now with iConomy support!
    Version: 1.4.2
    CraftBukkit: 1317

    Plugin Dependencies:
    Any SuperPerms handler, as well as Permissions 2.x/3.x (Optional)
    Register (Optional, will allow any Economy plugin to be used)

    Yet another warp and home plugin.
    I didn't think there were quite enough warp and home plugins out there, so I decided to write my own for my server.
    Added basic iConomy support for /home /warp and /sethome

    Download (Direct JAR): http://thedgtl.net/bukkit/Warpz0r.jar
    Source: https://github.com/TheDgtl/Warpz0r

    Copy Warpz0r.jar to the plugins/ folder
    After the initial run it will create a Warpz0r folder with the config file in it. Edit the config file to your liking then run "reload" in the CraftBukkit terminal.

    This plugin supports warping/homing between multiple worlds.
    You only have one "home," so if you are in one world and your home is in another, you will warp to your "home" world if you use /home
    Permissions plugin is used if installed, otherwise goes based on isOp().
    Will import your existing homes and warps if you place homes.txt/warps.txt file into the plugins/Warpz0r/ folder
    Ability to disable inter-world warp
    iConomy 5.x support (DOES NOT SUPPORT ICONOMY 6.x)

    /warp <name> - Warp yourself to specified warp point
    /warpto <player> <name> - Warp target player to specified warp point
    /listwarps - List all available warps
    /setwarp <name> - Create a named warp at your current location
    /setwarp <name> <cost> - Create a named warp at your current location with the specified cost to use it.
    /removewarp <name> - Removes a named warp
    /home - Warp to your set home
    /home <player> - Warp to a specified players home
    /sethome - Sets your home
    /sethome <player> - Set a specified players home
    /clearhome <player> - Clear a players home
    /wz compass - Set your compass to point to your home
    /wz compass <warp> - Set your compass to point to <warp>
    /wz compass reset - Set your compass to point to spawn

    useiconomy - Set to "true" to use iConomy
    sethomecost - The cost to use /sethome
    warpcost - The cost to use /warp
    homecost - The cost to use /home
    setwarpcost - The cost to use /setwarp
    removewarpcost - The cost to use /removewarp
    noPrefix - Set to "true" to disable "[Warpz0r]" prefix for player messages
    bedhome - Set to true to allow players with warpz0r.bedhome permissions to set home on entering a bed

    warpz0r.use: Allow full use of Warpz0r warping commands
        warpz0r.use.warp: Allow use of warping functionality)
            warpz0r.warp: Allow use of /warp <warp> (default: op)
            warpz0r.set: Allow use of /setwarp <warp> (default: op)
            warpz0r.setcost: Allow use of /setwarp <warp> <cost> (default: op)
            warpz0r.remove: Allow use of /removewarp <warp> (default: op)
            warpz0r.list: Allow use of /listwarps (default: op)
            warpz0r.worldwarp: Allow warping between worlds (default: op)
        warpz0r.use.home: Allow use of home commands
            warpz0r.sethome: Allow use of /sethome (default: true)
            warpz0r.home: Allow use of /home (default: true)
            warpz0r.worldhome: Allow teleporting between worlds during /home  (default: true)
            warpz0r.bedhome: Allow use of a bed setting players home (default: true)
        warpz0r.use.compass: Allow use of compass commands
            warpz0r.compasshome: Allow use of /wz compass (default: true)
            warpz0r.compassreset: Allow use of /wz compass reset (default: true)
            warpz0r.compasswarp: Allow use of /wz compass <warp> (default: op)
    warpz0r.admin: Allow use of admin commands
        warpz0r.admin.warpto: Allow use of /warpto <player> <warp> (default: op)
        warpz0r.admin.sethome: Allow use of /sethome <player> (default: op)
        warpz0r.admin.home: Allow use of /home <player> (default: op)
        warpz0r.admin.clearhome: Allow use of /clearhome [player] (default: op)
    warpz0r.free: All warpz0r commands are free
        warpz0r.free.warp: Don't charge for /warp (default: op)
        warpz0r.free.setwarp: Don't charge for /setwarp (default: op)
        warpz0r.free.removewarp: Don't charge for /removewarp (default: op)
        warpz0r.free.sethome: Don't charge for /sethome (default: op)
        warpz0r.free.home: Don't charge for /home (default: op)
        warpz0r.free.bedhome: Don't charge on bed usage setting home (default: op)

    ** Note on Permissions 2.x/3.x: If you are using Perms 2/3, you MUST specify the child nodes individually,
    as Perms 2/3 are not SuperPerms compatible, they do not support the permissions hierarchy defined in plugin.yml
    Q) Why don't beds show animation?
    A) Iunno, ask Notch.

    Q) Can you add private warps?
    A) Iunno, as... Oh wait, this one's on me. This isn't the type of plugin Warpz0r is meant to be, and it's probably never going to support private /hidden warps.

    Q) I'm giving my users warpz0r.use but they can't use /warp, why not?
    A) Permissions 2.x/3.x do not support the hierarchy structure in plugin.yml (They don't support perms in plugin.yml at all) so you must define every node for them.

    [Version 1.4.2]
    - Prefer SuperPerms over PermsBridge
    - Register support instead of iConomy
    [Version 1.4.1]
    - Stupid iConomy.
    [Version 1.4.0]
    - Implemented SuperPerms. This includes a perms overhaul, please re-do your permissions.
    - Fixed teleporting to unloaded chunks
    - Fixed iConomy error when 6.x is installed
    [Version 1.3.1]
    - Fixed location saving on bedhome
    [Version 1.3.0]
    - Added /home <player>
    - Added /sethome <player>
    - Added ability to set home on entering a bed
    - New config options:
    - bedhome
    - New Permissions:
    - warpz0r.bedhome
    - warpz0r.free.bedhome
    - warpz0r.admin.home
    - warpz0r.admin.sethome
    [Version 1.2.4]
    - Updated for iConomy 5.x
    [Version 1.2.3]
    - Added noPrefix config option
    [Version 1.2.2]
    - Added /clearhome [Player]
    - Made /warpto and /clearhome allow partial names
    [Version 1.2.1]
    - Forgot to check to make sure the player supplied a warp name
    [Version 1.2.0]
    - Added Free permissions
    - Added per-warp costs
    [Version 1.1.1]
    - Updated to latest RB
    [Version 1.1.0]
    - Changed version numbering
    - Changed method used to hook plugins
    - Updated iConomy support.
    [Version 1.09]
    - Added "/wz compass" "/wz compass reset" and "/wz compass <warp>"
    [Version 1.08]
    - /listwarps is now alphabetical
    [Version 1.07]
    - More iConomy costs
    - Fixed a reference to Tombstone
    [Version 1.06]
    - Small permissions handling update
    - Updated to iConomy 4.x
    - Warplist now shows proper case
    [Version 1.05]
    - Tweaked permission handling
    - Warp names are no longer case sensitive.
    [Version 1.04]
    - Added iConomy support
    - Added a function to handle messaging the player, now only the "[Warpz0r]" text is colored
    [Version 1.03]
    - Fixed disallowing teleport between worlds, was always returning false.
    [Version 1.02]
    - Remove long constructor
    - Fixed Permission handling, works with /pr now
    - Ability to disable inter-world warping
    [Version 1.01]
    - Changed permission handling to send "Permission Denied" messages
    - Prepended "[Warpz0r]" to all messages sent to player
    [Version 1.00]
    - Initial Release
    Baghtal, _Robert, Brain and 1 other person like this.
  2. Offline


    This would be something to ask the author of Overviewer.
  3. I suppose so but since Overviewer is used by so many, for so many plugins, I thought that since those that use this plugin probably reads this and perhaps one of you also uses Overviewer and already had a solution ^^

    But I'm asking the author and users of overviewer to. The more people you aske, the bigger chance of finding the solution :)

    So far I've only seen a solution to show regions by Worldguard. And I find that addon to advanced. I love this addon thought. Works like a charm and easy to get the hang of. :)
  4. Offline


    is their a way to give a group a warp that the group below cant warp to?
  5. Offline


    Not sure if this is a bug or if I'm just really (un)lucky... Hopefully someone can help?

    I recently learned that Essentials doesn't play nicely with other plugins on my SMP Server so I'm out trying to find new ones to use. I've spent over an hour converting all of the warps and homes from essentials format to warpz0r. I feel committed to this plugin after that time spent!

    Anyway onto my issue. I've got around 20 warps and all but three or four work just fine. Those that don't work aren't working because the chunk that houses the warp isn't loading. All the chunks around the warp do though :( I've tried changing the warp location... if i move it 2 or 3 chunks away you can warp there fine. If I walk close so that the chunk is rendered already and warp the warp will work fine as well.

    I've tried several different clients. On Ubuntu with a single warp I "fall", but on the others warps and other clients I do the jittery-bounce thingie. Where I can't really move and I just get stuck in place

    Resolution Attempts:
    1. Walking to the warp area and making a new /setwarp -- Didn't help.
    2. Changing all of my video settings to allow the chunks to load as quickly as possible... still the surrounding chunks but not the chunk i'm warping to.
    3. Changing clients (as noted above) -- didn't help
    4. Running the server on another (MUCH more powerful) machine -- No help
    5. Update Java -- already up to date on clients and servers attempted (Java 6, x64 on the first server, Java7, x64 on the second)
    6. review the config.yml for every plug, and server.properties for any signs of anything that might be useful? -- Nothing found
    7. Searched this thread and google for anyone else who has fixed this already -- nothing found :(

    Work Around:
    As a work around i've just moved the warps and put up signs pointing how to get where the warp originally was... but a couple of them are places that are difficult to get too (hidden away private places, deliberately difficult to walk too)

    If anyone has any ideas please let me know :)
  6. Offline


    @Baghtal I've never encountered this and haven't had any users post with this problem before. Could you attempt using this version, and see if it resolves the issue?
    The only change is it calls loadChunk before teleporting the player.
  7. Offline


    For the noPrefix option, does this mean that if its set to false, it will display what world the player is in if he types a message into minecraft?
  8. Offline


    I tried with the .jar you posted, and now the /warp command isn't working at all.

    151 recipes
    16 achievements
    18:32:08 [INFO] Starting minecraft server version Beta 1.7.3
    18:32:08 [INFO] Loading properties
    18:32:08 [INFO] Starting Minecraft server on *:25565
    18:32:08 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    18:32:08 [INFO] Preparing level "world"
    18:32:09 [INFO] Preparing start region for level 0 (Seed: 6610004184920976226)
    18:32:09 [INFO] Preparing start region for level 1 (Seed: 6610004184920976226)
    18:32:10 [INFO] Preparing spawn area: 73%
    18:32:10 [INFO] Warpz0r version 1.3.1-dev is enabled
    18:32:10 [INFO] Server permissions file permissions.yml is empty, ignoring it
    18:32:10 [INFO] Done (0.122s)! For help, type "help" or "?"
    18:32:17 [INFO] baghtal [/] logged in with entity id 209 at ([wor
    ld] 69.6875, 69.0, 141.75)

    [[Here I tried to /warp elle]]

    18:32:20 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp
    ' in plugin Warpz0r v1.3.1-dev
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:12
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:3
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)

    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoSuchMethodError: org.bukkit.Chunk.load()Z
    at net.TheDgtl.Warpz0r.Warpz0r.onCommand(Warpz0r.java:202)
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    ... 12 more

    Oh, and i forgot to mention, that I did remove all other plugins and such. Wanted to make sure it wasn't another Plugin interfering :)

    Thanks for the help looking into this!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  9. Offline


    That version I uploaded is only compatible with b1060, why are you running an extremely (Almost 2 month now) old RB?
  10. Offline


    I was actually just noticing the same thing. I had tried installing an older version of the server seeing if something might change. When i noticed that and restored to the 1060 your .jar file from above worked like a charm!
  11. Offline


    Good to hear :) Post back if you run into any more chunk loading issues.
  12. Offline


    Day later, everything is still working great. I'm thinking that fixed it!

  13. Offline


    good plugin good
  14. Offline


    I am using this plugin and i love it! <3
  15. Offline


    You still need this function? I released a plugin called WarpMarkers (Github) that shows Essentials warps on Minecraft Overviewer maps. I have extending it to support Warpz0r on my todolist. Let me know if you need this and I'll bump it up to the top of the list ;)
  16. Yes! :)
    That would be awesome.
  17. Offline


    Can you update pls for 1.8? Thx :D
  18. Offline


    How can i select world with permissions??? [diamondore]
  19. Offline


    iConomy 6 support incoming?
  20. Offline


    Download the permission and fix the user.yml and groups.yml, need help with that?
  21. Offline


    Plugin confirmed working in RB 1185
  22. Offline


    And what's with iConomy 6 support?
  23. Offline


    no matter if i add the nodes to bpermissions file or not. It keeps telling me i don't have the permission to use the commands :/

    is it simply not compatible ?
  24. Offline


    I do not use iConomy, and have many other things I'm working on at the moment (Including working full time). iConomy update is on the bottom of the list at the moment due to this.
  25. Offline


    Aha, cool.
    Thx for answering :D
  26. Offline



    I'm using iConomy6 and have iConomy Support in Warpz0r disabled. But on startup it crashes:
    2011-09-24 14:02:30 [SEVERE] Error occurred while enabling Warpz0r v1.3.1 (Is it up to date?): com/iConomy/iConomy
    java.lang.NoClassDefFoundError: com/iConomy/iConomy
        at net.TheDgtl.Warpz0r.Warpz0r.onEnable(Warpz0r.java:92)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:920)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    Caused by: java.lang.ClassNotFoundException: com.iConomy.iConomy
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 11 more
  27. Offline


    @raupy Known bug, working on a fix for this weekend.
  28. Offline


    i wait updated for iConomy 6.x :)
  29. Offline


    I might be blind, but does this work with BukkitPermissions? Would love to let my donators make warps :)

  30. Offline


    [Version 1.4.0]
    - Implemented SuperPerms. This includes a perms overhaul, please re-do your permissions.
    - Fixed teleporting to unloaded chunks
    - Fixed iConomy error when 6.x is installed
    brzavr, raupy and Rytis like this.
  31. Offline


    Requesting one addition:
    /wz reload
    Reloads the permissions file without having to reload all plugins or restart server :)
Thread Status:
Not open for further replies.

Share This Page