Unable to convert a 1.1.0 world?

Discussion in 'Bukkit Help' started by barrbossa, Apr 5, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello there,
    I originally started to build a new server under 1.1.0, the setup was stable and nothing was wrong with the map (such as lands being sliced in half and such). However on trying to update it to work with the new Dev. Build of craftbukkit-1.2.5-R1.0 I'm running into errors I have not seen before.

    At first these were chunk errors I think it said, when trying to convert the worlds I had (three of them) to the new 1.2.5 version. On a little search I came across this tool called 'Chunkster' of which I used to repair my worlds and try again. This seemed to work as the server now began to run normally, loading and starting up, only snagging on the occasional error because a plugin was out of date and it failed to load.

    Until it got to this bit:
    2012-04-05 13:01:01 [INFO] Preparing level "MainWorld"
    2012-04-05 13:01:01 [INFO] Converting map!
    2012-04-05 13:01:01 [INFO] Scanning folders...
    2012-04-05 13:01:01 [INFO] Total conversion count is 43
    2012-04-05 13:01:02 [INFO] Converting... 41%
    2012-04-05 13:01:04 [INFO] Converting... 41%
    2012-04-05 13:01:04 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 0
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.OldChunkLoader.a(SourceFile:59)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.WorldLoaderServer.a(SourceFile:204)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.WorldLoaderServer.a(SourceFile:169)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.WorldLoaderServer.convert(SourceFile:128)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:220)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
    2012-04-05 13:01:04 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    2012-04-05 13:01:04 [SEVERE] Unexpected exception
    java.lang.ArrayIndexOutOfBoundsException: 0
        at net.minecraft.server.OldChunkLoader.a(SourceFile:59)
        at net.minecraft.server.WorldLoaderServer.a(SourceFile:204)
        at net.minecraft.server.WorldLoaderServer.a(SourceFile:169)
        at net.minecraft.server.WorldLoaderServer.convert(SourceFile:128)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:220)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:187)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    To be honest I do not know what this is exactly, but what I can read from it is that it's having problems with my 'MainWorld' and conversion. It is the biggest world I have at the moment with large areas of the map having been explored too. As soon as it hits this part though the whole thing just gives up and dies, refusing to do anything else.

    Has anyone else run into this type of trouble before?
    I found it odd when I had to use Chunkster in the first place, considering I can just usually pop in the .jar file and have it all convert/change on it's own without much from me. It seems like 1.2.0+ is determined to give me trouble compared to all the past versions.

    Many Thanks.
  2. Offline


  3. Offline


    See when I converted my world to 1.2.5 on my server I mean it was pretty easy for me. I did get different issues but I just restarted the counsel Maybe try that?
  4. Offline


    I have MC edit and know of it's uses, but that the problem with that is I have an extremely large world. If I were to copy/paste the whole thing (or even sections of it) the transfer would take an extremely large amount of time and would probably crash mid-process. Though it is a backup plan if all else fails, thank you.
    I did restart the console, but alas it ends up to the same point, stopping there and refusing to do anything else.

    There was a spark in my head where I thought about using the actual game, by placing in the world files under my saves and then having it convert them, though 1/3 converted successfully. Again both 'MainWorld' along with the second one 'VIPWorld' made the client crash.

    I've harked on about their size and I do think it is that preventing it, but I am not sure.
  5. Offline


    Try going from 1.1 to 1.2.3 or 1.2.4 and then 1.2.5.

    If that does not work, then there must be something about your world it cannot convert.

    Another option would be to use the same seed to generate a new 1.2.5 world that is exactly like how your original world was...then copy/paste pieces over.

    I have a 150 MB world and it converted without a problem going from CB 1.1-R4 to 1.2.3-R0.2 and then 1.2.4-R1.0

  6. Offline


  7. Offline


    A splendid idea! Although yet again I've run into the same problem.

    Taking the newest 1.1.0 bukkit, which was R6 since my server is under R4, I was first going to update it from that and then move it to the next version up and so on. O

    In the list of server builds though the next one along was 1.2.2 with no earlier version. The R6 worked fine but as soon as I even attempted 1.2.2 it gave way to the same error as above. I have no idea what it can't convert but it usually gets stuck to around "46%" completion before crashing.

    I am looking now in a separate tab as I type this, seeing if anyone has had the same thing happen or if certain problems have been found linking back to it.

    Edit: Here is an interesting note I've uncovered. It has been said that the crash you get acts the same as an "out of memory" error. So thinking back to it my smaller worlds converted fine, as a result the problem may be a lack of memory due to having quite a bit to do.
    Nope. Not the case.
  8. Offline


    Well then, the next step I would try since the upgrade paths did not work would be to assume something is wrong with the world. Look for some "chunk" cleaners out there. I recall seeing a couple different ones.

    I would run it through the chunk utilities one at a time, then see if 1.1-R4 can still work with it (connect and verify the world looks ok). Then see if the upgrade paths work. But only do this with one utility at a time since none of these are "official" utilities...and who knows if they will cause more damage than they fix.

    Good luck friend.
Thread Status:
Not open for further replies.

Share This Page