Inactive [TP] xWarp v3.1.7 - MyWarp fork (w/ prices, economy, visibility) [1.2.5-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by xZise, Jan 17, 2011.

  1. Offline


    Hello everyone,
    I forked the MyWarp project and added some functionality. In basic it is the same as the MyWarp.

    Now on BukkitDev
    This plugin is already on BukkitDev. I will transfer this post to BukkitDev.

    3.1.7 + marker (Tested: 1.2.5-R1.0)
    3.1.7 (Tested: 1.2.5-R1.0)
    2.12.0 (Tested: cb819, Should run ≥ cb691)
    All downloads

    The versions for other builds are normally only compatibly updates. So they don't provide other features. This means version “a-cb684” is the same (in basic) as “a-cb556” or simply “a”.
    Notice: With version 2.3.0, 2.6.0, 2.8.0, 2.9.0, 3.0.0 (or later) I changed the database layout. Previous versions of xWarp couldn't read this database. So backup it for sure.


    Changelog moved to BukkitDev. The full changelog is still on github.

    Since 2.8.0 it is possible to use prices for warp and creation. It uses the Permissions nodes to change define basic prices. Also it is possible to define a price for each warp. At the moment iConomy version 4 and 5, Essentials Economy (at least Dev build 2.2.104) and BOSEconomy supported.
    Global/Public/Private warps
    With the Version 2.0.0 beta 13 I introduce the new state of global warps. Every user can create warps for its own (public/private) like before and hasn't be aware of already existing one's from others. So Player “A” could create a warp named “foo” and another Player “B” could also create a warp called “foo”. Now to access these warps you have to specify which warp do you want to use.
    Therefore I added a parameter to specify the owner of the warp. To warp to the “foo” warp of Player “A” you simply type:
    /warp foo A
    You could exchange the second parameter (= A) with a B to warp to B's warp “foo”.
    Now to shorten the warps you could globalize a warp with
    /warp global <name> <owner>
    Now you don't have to add the owner of the warp. For example if somebody globalized the warp “foo” of player “A” you now can simply type:
    /warp foo
    There is one rule: “If you don't define the owner it searches the global warps.”
    But a global warp also has a owner (in our case Player “A”) so you also define the owner.
    So there is one major change: If your warp contains a space you have to escape it, otherwise it will guess the second part as a owner (to escape see the section above).
    For further information visit the wiki.
    Sign Warps
    Creating a sign warp is really easy. You have 3 layouts: MyWarp, Single Line and xWarp.
    In MyWarp your sign has two lines. In the first place only “MyWarp” and in the second the name of the warp. This works only if the warp is in the global map.
    The “Single Line” layout only needs a line with “Warp: <name>”. If there are more than one lines with this layout on one sign it won't work. The colon is optional, the W could be lowercase and the spaces between “Warp:” and the name have to be at least one.
    With xWarp layout you could place “xWarp” in the first line (case-insensitive) or “Warp”/“warp” and optional a colon.
    In the second line is the name of the warp and in the third the owner (optional)
    Upcoming changes
    Backups? (unknown)
    If possible I maybe make it possible to backup the warps with others backup plugins. It is only an idea at a moment, but maybe sometimes xWarp supports this.
    tkelly's suggestion system (Suspended)
    tkelly created a system, that can get a warp similar named if you didn't spell it right.

    Fabian aka xZise
    RazorFlint, Taranis01 and uitology like this.
  2. Offline


    Is there a way to add an update to make it possible to give different groups and or members different amount of warps cause currently theres only the one option to set for all.
  3. Offline


    Not sure what I'm doing wrong, but every time I try typing a command, it gives me the message: "/warp help - Displays the help for all warp commands," even when I type "/warp help". Not sure what I'm doing wrong here.
  4. Offline


    I don't understand what you are asking for. There are already limits available.

    I guess you didn't followed the installation procedure so you missed to install Bukkit Plugin Utilities.

  5. Offline


    Why are you calling tkelly a girl, isn't tkelly a male? (profile)
  6. Offline


    1 Of My Most Favourite Plugin I've Been Waiting For This :D [diamond][diamond][diamond]
  7. Offline


    Gave your post a bit of a trim; I'm glad you enjoy the plugin but please do not spam.
  8. Offline


    :confused: I'm not sure, but several months ago I thought that somewhere tkelly was a woman. But as I'm not sure I edited the post and make it impossible to be wrong ;) Hopefully.

  9. Offline

    Lord Chaos

    I have really enjoyed using xWarp, especially because it allows for sign warps. But I am also using PermissionsEX now and have set up all other plugins with no problems. But this plugin lacks a guide on how to set it up with PEX and I can't figure out what exactly to write to make it work. I somehow need xWarp to limit certain user groups to only 1 or 2 personal warps and no global warps. Much transportation will happen through sign warps, which everyone will have access to, but only admins can set up.
  10. Offline


    Ehr? This is about xWarp and not PEX. If you want to know how to configure please look in the documentation of PEX. I couldn't test and support all available permissions systems. But maybe this post help you.

  11. Offline

    Lord Chaos

    PEX doesn't provide information on how to configure xWarp permissions. No permission plugin does. :(
  12. Offline


    No they couldn't do it like me?! I mean how should they tell you how to configure “xWarp permissions” (whatever this is). In fact you should do it on your own: I provide the information which permissions my plugin use and the permissions plugin (PEX in your case) provide the information how to configure permissions in general. You combine both by applying the rules from the permissions plugin with the content of the permissions which xWarp is using.

  13. Offline

    Lord Chaos

    Well, apparently none of that is working, so I am looking to see if anyone else has got it to work and what to put in exactly. This thread and the documentation is confusing to say the least.
  14. Offline


    Im having trouble's with mine when i try to create a warp it says:
    say /xwarp help for help (something like that)
    And when i say that it replys with the same answer :eek:
    But it works on the update before (not 1.0.0)
  15. Offline


    What did you tried?

    Did you followed the installation instructions? I would bet you didn't installed Bukkit Plugin Utilities.

  16. Offline


    How come I can't get my users to list global/public warps that I create?

    I have given them the following permissions:
    - xwarp.warp.command.list
    - xwarp.warp.edit.list.change
  17. Offline


    Okay this is strange. Could you test if they could see your warps, when they have the permission “xwarp.warp.admin.list.view”?

    It is possible to remove warps from the list and this permissions overrides it.

  18. Offline


    Yes they could see it with that permission. However, they can also see private warps so that isn't really a good thing.
  19. Offline


    Just finally got around to upgraded from MyWarp. No significant problems. It was a bit tedious to move to the new permissions, but so far I think we're ok. A couple of feedback items for you:
    1. Can no longer use "short" names that autocomplete out to match. For example, if I have a warp called 'tutorial', I can no longer use "/warp tut". Not a big deal, but users miss this.
    2. The debug output is going to [INFO] and it's kind of verbose. Does CraftBukkit not provide a [DEBUG] stream for this level of detail debugging?
    3. See if you can find an expert user that can make you a usage video on youtube.
    4. I saw references to 1.5.a, but it identifies itself as 1.5. Need to be diligent to change the version string for each posted build.
    Thanks for picking this up and carrying it forward.
  20. Offline


    Bukkit only provides Warning, Severe, Info, Config and I'm not sure about the other "Fine","Finer", "Finest","Off"...
  21. Offline


    Please delete the dozens hundreds of "Checked permission 'foo'... debug messages. They are cluttering the server.log.
  22. Offline


    Thanks :p This is my feedbackback:
    1. Autocompletion will come in a future version.
    2. Except the three lines from the warp list command, there shouldn't be any debug message. Can you make examples? And the three lines in the warp list command shouldn't be released but I forgot them … not only once :oops:
    3. Maybe ;) You can go forward if you want :)
    4. What references to 1.5.a?
    This was only for testing purposes. Because it is possible that the warps are unlisted – for some reason. It seems that there is a bug left which makes your warp unlisted. Can you maybe explain which data storage you use (sqlite, hmod, yml) and when a warp get's unlisted. You also could test if a invisible warp gets visible when you “list” them (I guess the command was /warp listed <name> [owner] true).

    I maybe release a 3.1.6 where I remove the three debug lines and it will show you if the warp isn't listed in the warp info command. By this it is easier to determine if a warp is listed and thus you may could find the reason faster why a unlisted warp is … unlisted. [update]Hmpf, I already added this functionality in 3.1.5.[/update]

    Ah found a new post:

    Aha! I guess you downloaded the Bukkit Plugin Utilities WITH the debug output.

  23. Offline


    Oh. Not sure how I did that. OK, I just got 3.1.5 jar from git. I guess that's the one I really want.
  24. Offline


    Does anyone know how to make xWarp see bPermissions? currently when i type /xwarp status it tells me that permissions isnt linked (yet) Any help?

    Here is my config BTW
    case-sensitive: false
    use-force-to: false
        enabled: false
        - public
        - global
        png: marker.png
        notify: true
            movement: false
            damage: true
    show-free-price-message: false
        plugin: bPermissions
        base-account: ''
        plugin: ''
        connection: sqlite
        - owner
        - world
        - location
    update-if-exists: false
        notify: true
        defaultmsg: Welcome to '{NAME}'!
  25. Offline


    I mean the Bukkit Plugin Utilities not xWarp, as the debug output you posted is from BPU not xWarp.

    Even if it tell you that it isn't linked, it uses the SuperPerms of Bukkit. So the permissions should work.

  26. Offline


    OK, I downloaded bukkitutil-1.2.1.jar (without debug) and put it in the lib folder (I removed the BukkitPluginUtilities.jar that was in there from before). With xWarp-3.1.5.jar I get this at startup:
    08:33:48 [SEVERE] Error occurred while enabling xWarp v3.1.5 (Is it up to date?): de/xzise/XLogger
    java.lang.NoClassDefFoundError: de/xzise/XLogger
        at de.xzise.xwarp.XWarp.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: de.xzise.XLogger
        at Method)
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 11 more
  27. Offline


    Hmmm, rename it to “BukkitPluginUtilities.jar” to finish it.

  28. Offline


    Same error with bukkit #1529
  29. Offline


  30. Offline


    My xWarps were working very well with permissionsBukkit until I updated CB 1510 plus with register.jar. Then everything on xWarps went to heck. I've tried the permissionsbridge plugin, no change.
    Nice to know I'm not the only one having issues.
  31. Offline


    Hopefully you will see this shortly but we got Xwarps working on 1337 server 1.8 but the only problem currently is that it is not allowing players to teleport to their warps even though they have the permission to do so. The current permission set up is and I hope this is all the info you require currently. If there is something im missing let me know
            default: false
            prefix: '&d[&dTierV] '
            - essentials.back
            - essentials.back.ondeath
            - myhome.home.*
            - lwc.protect
            - iConomy.payment
            - mcdocs.*
            - xwarp.warp.edit.invite.add
            - xwarp.warp.edit.invite.delete
            - xwarp.warp.edit.message
            - warp.limit.private
            - xwarp.warp.create.private
            - xwarp.warp.edit.delete
            - xwarp.warp.15.warmup.private
            - xwarp.warp.15.cooldown.private
            - xwarp.warp.command.list

Share This Page