[TP] VoxelPort v2.033 - Travel In Style and On Schedule [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 28, 2011.

  1. Offline

    Voxel Box

    HawkIHeo, svict4, Mahagon and 5 others like this.
  2. Offline


    "Hehe, looks like I got live one, Jeb!"

    I'll enthusiastically respond to your RFIs so long as we retain hope of this sucker running despite my configuration (which isn't too rare for us MineOS enthusiasts at minecraft.codeemo.com).

    Thank you for stepping forward to help.

    I do think I got the directory and file names right...VP prolly wouldn't have saved the portal settings to the directory unless it was. VP just doesn't seem to be able to pull the info back out of its directory on server restart.

    Directory listings are below.

    Listing of directory containing craftbukkit jar:
    /usr/games/minecraft/ram-worlds/one/ [This has the world I'm setting up portals within]
    /usr/games/minecraft/ram-worlds/plugins/ [This one is empty]

    Listing of directory containing the VoxelPort directory:
    /usr/games/minecraft/ram-worlds/one/Moria/ [target world]
    /usr/games/minecraft/ram-worlds/one/VoxelPorts/ [directory apparently used by VoxelPort.jar to save settings]
    /usr/games/minecraft/ram-worlds/one/plugins/ [VoxelPort plugins and others here]
    /usr/games/minecraft/ram-worlds/one/world/ [main world]

    Listing of directory listing of VoxelPort directory:
    /usr/games/minecraft/ram-worlds/one/VoxelPorts/IM [the name I gave the portal]

    Listing of plugins directory:
  3. Offline


    Yeah ofc, once you are in that second world simply create a VoxelPort and link it to any portal on the outside.
  4. Offline


    Great plugin. Works perfectly. Are you going to/Can you add iConomy support so we can charge for using a VP, or even better a price for each VP. Thanks.
  5. Offline


    I've done what I needed using the Multiverse plugin, though I do miss the "regularly scheduled" departure feature offered by VoxelPort.
  6. Offline


    really? i was having trouble doing that.. it worked at first, then we crashed and and then it only redirected to the world spawn and wasnt working after i tried again... hmm i guess ill have another look at it later
  7. Offline


    Nah its not your fault, there is actually a bug, which will Crash VoxelPort when after a server restart ( after creating a portal between worlds ) you travel thru a mutli-world port.
  8. Offline

    Voxel Box

    i've just returned from a brief vacation. evilseph and peter have done some really nice work on the plugins while i was out of town. i will be doing some final testing, attending to new documentation and getting the plugins released in the next day or so, so stay tuned.
    --- merged: Mar 2, 2011 3:41 AM ---
    VP 1.7 is out, get it while it's hot. =)
  9. Offline


    got it while it was hot, and it works so much better now, i kept getting short errors every 25 seconds if somone had a ticket and it wouldnt teleport them. was really getting discouraged with trying to get it to work, but now it does and im really glad :D
    thanks for the awesome plugin!

    EDIT: so does this mean (related to my question above a few posts) that itl be easier and smoother to connect actual ports in sepearte worlds, rather then them linking to the spawn? if so, that would be fantastic, because i dont like sometimes landing on one side of a mountain spire, and sometimes on the other lol
  10. Offline


    Awesome looking plugin you've got here!

    1.7 was the first version I've downloaded, so I didn't actually have the other versions installed, so no need to run the fix.
    I created the admns.txt file and put just my name in there on one line. My name is set as lowercase so it is lowercase in the file. I also created the VoxelPorts folder

    Problem is when the server is starting up I get an error that says that it cannot load the admns.txt file

    Here is my plugins folder:

    and here is the admns.txt file:

    The server is running Windows server 2008 x64 web, Intel Q6600, 8gb Ram
    Running bukkit 484
  11. Offline


    Hello Voxelteam,

    I wanted to use your Voxelport with my Bukkit because I already have VoxelSniper and VoxelMore and these tools are awesome.
    So i built two ships and I wanted to connect them. I did everything like it was written and I also watched the video for /vpoint but it isn't working. It prints out the coords, but when I create the two zones and link them and make that /gendisp it is not working. I am standing on my ship entering "/depart" but it says "You are not in a VoxelPort".
    I redid everything 2 times but I get the same error all the time. Also I recogniced that I can't destroy some blocks inside the defined zones, but only with VoxelSniper. I can't teleport to these blocks with ARCT also.

    I'm using the latest VoxelPort and Craftbukkit 440 (recommended version)

    Hope you can help me, Peacemaker
  12. Offline


    I also have the problem that the file admns.txt can't be loaded.

    I tried "Dominator" and "dominator", with no newline and Unix and DOS format newline but no combination worked.

    I'm running CraftBukkit 493 on Arch Linux x86_64.
  13. Offline


    Sweet multiworld support, maybe I can finally get rid of the piece of s*** plugin MultiVerse
    diegokilla likes this.
  14. Offline


    just one weird error which didnt effect anything:
    2011-03-07 21:28:11 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'gendisp' in plugin VoxelPort v1.7
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:21)
    	at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:77)
    	at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:176)
    	at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:638)
    	at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:601)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:595)
    	at net.minecraft.server.Packet3Chat.a(SourceFile:24)
    	at net.minecraft.server.NetworkManager.a(SourceFile:230)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:70)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:338)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:253)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
    	at com.thevoxelbox.bukkit.port.VoxelPort.onCommand(VoxelPort.java:268)
    	at org.bukkit.command.PluginCommand.execute(PluginCommand.java:19)
    	... 12 more
    Actualy works fine. For me!
    Everyoneelse can get a ticket and everything. but they wont get ported for some reason.

  15. Offline


    Same here
  16. Offline


    Slight issue here, I had no problem making two ports. I even connected them and set dispatch times just fine. But when I get on to test it with /depart, I get a "Your are not inside a VoxelPort" message no matter how many times I recreate the port. The port in the other direction functions just fine so I doubt my method is the error.

    Running craftbukkit 493
    VoxelPort 1.7
  17. Offline


    Running craftbukkit 493
    VoxelPort 1.7

    i set up both ports fine. connect them. set depart times. go in type /depart for my ticket
    i get the message but i never get ported
  18. Me also, same versions :/

    I also would like to request an optional feature to actually teleport the structures :}
  19. Offline


    Every command just reports back and example.
  20. Offline


    same here with CB 531
  21. Offline


    Each time i try to use a command it will tell me Exemple... same thing also happen for VoxelSniper but VoxelDoop work fine.

    Help please
  22. Offline


    So I got everything set up and it all works great until I go to actually teleport. I type /depart and it says that I have a ticket and to wait there but nothing ever happens after that. What could I be doing wrong?
    Nevermind. I restarted the server and now it works.
  23. Offline


    Anyone figure out what is causing the "example" thing?
  24. Offline


    When that happened to me it was because I didn't have my name in the admns.txt file correctly. It is case sensitive, so make sure if your username is capitalized that it is also capitalized in the file (that fixed it for me).
  25. Offline


    That seems to be it. Thanks.
  26. That doesn't solve the fact that we can't depart :/ I did that right from the first time but the plugin doesn't wanna teleport !
  27. Offline


    Have you tried restarting your server?
  28. Offline


    I am trying to make a voxelport, and I enter all of the thingys, I set the dispatch time and stuff, but it won't give me a ticket, it just says: "You are not in a voxelport", but I'm in a voxelport!
    Peacemaker957 likes this.
  29. Offline


    Nevermind it works now.[​IMG]
  30. Offline


  31. Offline


    I was really excited about this plugin until I read "Note: VoxelPort only moves player entities around the map, not the blocktypes inside the VoxelPort." I'm posting this quick note to encourage you to work towards also moving the blocks. I would love it if I could setup an actually ferry boat model to run twice daily between ports; moving players with it. I imagine I would have to somehow define a path for the model to follow. Perhaps a wand that allows me to set a series of waypoints and have the path travel between them on a bspline for realistic turns. (would need to be able to visualize the full path and add/remove waypoints to/from as well). It sounds like a big project but it would be worth it.

Share This Page