[TP] VoxelPort v2.033 - Travel In Style and On Schedule [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 28, 2011.

  1. Offline

    Voxel Box

    HawkIHeo, svict4, Mahagon and 5 others like this.
  2. Offline


    How far is the next update?
    I just cant wait until VoxelPort support muiltiple worlds =)
  3. Offline


    Oh, it hasn't been updated yet? derp :/

    Gimme 20 min
  4. Offline


    Multiword = Online server?
  5. Offline

    David Lewis

    Does VoxelPort work on the latest version of Craftbukkit? I cannot seem to set coordinates even though I added my name to the admns text file in my plugins folder.
  6. Offline


    Would love to see this updated soonish :):):)
  7. Offline


    Argh! Teasing! I know this is already running fine on thevoxelbox. I want it too! :)
  8. Offline

    Voxel Box

    "running fine" and "ready to release" are different. when the new features are smoothed out, it will be released. you may have noticed we have not created any new public voxel ports on the new version.
  9. Offline


    I certainly appreciate your dedication to a stable release, and even more so your contribution of the plugin at all. But you have to admit it's a bit funny to see the words "ready for release" next to "minecraft" and "bukkit"

    David Lewis likes this.
  10. Offline

    Voxel Box

    indeed, "ready" is relative! we got the multi-world support working great last night, and it is pretty amazing. you can, using voxelport, now create a new worldfile and a way to get there directly from in the game. the new voxelports can be set to generate a non-existant named world (regular OR nether) and then will load it up for you upon activation, placing you at 0,0. use it to create distant lands or easy peasy pocket dimentions!

    prz is just adding a new feature to make setting up a voxelport as easy as pointing to two blocks with the cursor and typing a single command -- no more six-coordinate declarations. very cool. once that's working, we are ready to roll for a release.
    --- merged: Feb 15, 2011 12:18 AM ---
    VoxelPort v1.1 is out!

    A video tutorial for the new pointer definition system is in the OP, and a multi-world tutorial is forthcoming. Meanwhile, the commands are documented in the OP for those of you who want to get cracking on your worlds!
  11. Offline


    ok i seem to have a problem i set it up just as you do it and i type /depart i get the Ticket and then nothing i dont move no count down this is from the log Nothing else happens after it .

    2011-02-15 00:16:44 [INFO] [VoxelPort] Portal "rp2" saved.
    2011-02-15 00:17:01 [INFO] [VoxelPort] Portal "rp" saved.
    2011-02-15 00:17:26 [INFO] [VoxelPort] Portal "rp2" saved.
    2011-02-15 00:18:09 [INFO] [VoxelPort] Portal "rp" saved.
    2011-02-15 00:18:09 [INFO] Darkwizard98 issued server command: gendisp rp 0 2000
    2011-02-15 00:18:09 [INFO] Unknown console command. Type "help" for help.
    2011-02-15 00:18:33 [INFO] [VoxelPort] Portal "rp2" saved.
    2011-02-15 00:18:33 [INFO] Darkwizard98 issued server command: gendisp rp2 1000 2000
    2011-02-15 00:18:33 [INFO] Unknown console command. Type "help" for help.

    i did everything i followed the video right to the end and nothing. plz help. also attached log since i may have missed something.

    Attached Files:

    • log.zip
      File size:
      79.5 KB
  12. Offline

    Voxel Box

    are you sure you have your account name listed in your admns.txt? re-read the installation guide and check.
  13. Offline


  14. Offline

    Voxel Box

    ah -- i've updated the multi-world fix for existing voxelport 1.0 users to the installation guide in the OP. check the documentation if you had the old voxelports working and need to get them re-running. sorry about that, i forgot about this utility for upgrading users!
  15. Offline


    This is phenomenal! Can't wait to get it set up.
  16. Offline


    Maybe im a nub or something, but I set up the /vpoints to my area and it gives me all the info and say its ready to create a portal. but when i do /addport temple, nothin happens. The Server console says unknown command. My folder is in the root of my server and the admns.txt with my name is set up. im using build 320. Did i miss a step?
  17. Offline


    doublecheck your admns.txt file. Try using some other commands as well and reply if you are able or not.
  18. Offline


    This looks pretty sweet! It'll certainly do in a pinch seeing as moving block-based entities isn't an option at the moment.
  19. Offline


    yea all good, is there any plugin that interfere? worldguard/world edit, towny anything like that?
  20. Offline

    Voxel Box

    I'm not familiar with Towny, so you could try disabiling it. We run WorldEdit and WorldGuard on our server, so those should not be causing a problem for you.
  21. Offline


    Would it be possible to add a check for gendisp that cancels the command if you set the interval to zero? The darn thing looped because I mixed up my interval and starttime values. Then it froze the server. Recurrence is a terrible thing.
  22. Offline


    Hmm that wasnt it either. I been trying to take out/disable all the plugins but still have the same error lol

    My list of plugins... god i use alot
    Worldguard, worldedit, woolcolor, warpgate, war, towny, teleplus, repairshop, permissions, netstats, mywarp, myhome, movecraft, mcdocs, lwc, jail, imonster, iconomy, ichat, herobounty, herochat, heroicdeath, elevators, dynmap, craftirc, bigbrother
  23. Offline


    Sometimes, I tend to forget my favorite quote:

    But worry not, it is fixed and plusnine will update the download link in the near future.
  24. Offline

    Voxel Box

    consider it done, prz! =)
  25. Offline


    Hey Sparky,

    You missed another bounds check. If you type /portlist with no defined ports it crashes the client with an out of bounds exception.
  26. Offline


    Who do you think you are?
    Do you wan't to know why I tend to forget that quote? It's because as time passes by and I am making these plugins for MY server, I see that people in fact aren't idiots. They have common sense, and basic understanding that certain things are made for other certain things, and don't work unless certain circumstances are met. In this case, it would be a portal being present for it to be printed.

    This behavior is sorta like riding a roller-coaster, I will start trusting that people are capable of performing basic actions, that's the up of the roller-coaster, than people like you show up and the roller-coaster rolls down hill like a giant wooden barrel full of broken hopes and dreams.

    I hope you are happy sir. You crashed the roller-coaster.
  27. Offline


    My apologies. You appeared to be calling someone an idiot for pointing out a bug for you. Perhaps I misinterpreted.
    --- merged: Feb 17, 2011 4:13 AM ---
    Did this get resolved? I'm seeing the same issue here. VoxelPort 1.6. Craftbukkit 322. All commands appear to work, with the exception of /gendisp. I can create ports, and add targets. I see portal_names and the various portal files in VoxelPorts/ being created on disk. When I execute the /gendisp command, the client console replys with "Generated dispatch times..." but the server log shows:

    2011-02-16 22:55:29 [INFO] [VoxelPort] Portal "dst-green" saved.
    2011-02-16 22:55:29 [INFO] eggplant issued server command: gendisp dst-green 0 3000
    2011-02-16 22:55:29 [INFO] Unknown console command. Type "help" for help.
    if I deop myself, I get:

    2011-02-16 23:10:11 [INFO] eggplant tried command: gendisp dst-green 0 3000
    I can buy a ticket with /depart, but I see no count down and no departure.
    --- merged: Feb 17, 2011 4:20 PM ---
    It looks like 1.6a fixed this. Thanks!
  28. Offline


    Haha i figured it out... i was tired when i set it up, i named the file admns.txt which turned out to be admns.txt.txt lmao
  29. Offline


  30. Offline


    I upgraded to 1.6a. It seems to be fixed in that version.
  31. Offline


    None of my commands work. I get the same error below, even with no other plugins installed.

    admns.txt (not.txt.txt)

    The "VoxelPorts" folder also exists in the root server folder.

    Not sure what else I should post.

Share This Page