[TP] VoxelPort v2.033 - Travel In Style and On Schedule [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Voxel Box, Jan 28, 2011.

  1. Offline

    Voxel Box

    HawkIHeo, svict4, Mahagon and 5 others like this.
  2. Offline


    Hey, just wanted to start off by saying excellent addition to the Voxel Plugins Prz.

    I am however having a issue and I'm not sure what to do. I got Admn file working and I was able to make a successful portal from one part of the map to another, but the thing is- it only works for 2 or 3 times immediately after a server restart and then ceases to work. They're configured properly with Instaport to true and Requireticket set to false, but I just can't seem to get it to work for more than the short duration.

    Any insight you guys have on what might be causing this issue would be really helpful.

  3. Offline


    Any errors?
    Have you tried walking into the Port with the golden ingot in hand? (Admin teleport-override item)
  4. Offline


    I'm not receiving any errors ingame, and I just walked into the portal with a Gold Ingot and it didn't teleport me either. :/
    What would cause a portal to stop functioning?
  5. Offline


    What I'm looking for is errors in the console, specifically stuff about the PortTick thread being interrupted.
    The only way the admin teleport item would stop working would be if your name was on the list of Registered tickets on the PortTick thread and the thread itself wasn't running.

    But yea, without any output from the console I can't help ya.
  6. Offline


    When ever I try to do ANYTHING with this plugin all it says is
    Can you please help me get this to work!
  7. Offline


    I have installed this perfectly, but when i try to type anything with /vp i get this.
    Example: /vp - need to write help
    What can i do? I need to get this plugin to work when the sky dimension gets added.
  8. Offline


    Does this work with build 1000?
  9. Offline


    Can't anybody help me?
  10. Offline


    As much as I love this plug-in, I sadly bring a bug.
    17:02:02 [INFO] [VoxelPort] ContainerSize set to 100
    17:02:02 [INFO] [VoxelPort] Config loaded
    17:02:02 [WARNING] [VoxelPort] Error while loading VoxelPorts
    17:02:02 [SEVERE] java.lang.IllegalArgumentException: No enum const class org.bukkit.World$Environment.
    17:02:02 [SEVERE]     at java.lang.Enum.valueOf(Enum.java:196)
    17:02:02 [SEVERE]     at org.bukkit.World$Environment.valueOf(World.java:673)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.Zone.<init>(Zone.java:24)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.newPort.readData(newPort.java:439)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.newPort.<init>(newPort.java:64)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.PortManager.loadPortals(PortManager.java:149)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.PortManager.<init>(PortManager.java:45)
    17:02:02 [SEVERE]     at com.thevoxelbox.bukkit.port.VoxelPort.onEnable(VoxelPort.java:44)
    17:02:02 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    17:02:02 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    17:02:02 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    17:02:02 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    17:02:02 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    17:02:02 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    17:02:02 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    17:02:02 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    17:02:02 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    17:02:02 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    17:02:02 [INFO] VoxelPort version 2.028 is enabled!
    17:02:02 [INFO] Server permissions file permissions.yml is empty, ignoring it
    17:02:02 [INFO] Done (0.102s)! For help, type "help" or "?"
    This happened suddenly when I came home and attempted to put the server up. Also, NONE of my VPs work, and the Plugins folder where everytihng is looks perfectly fine.

    [EDIT] - Same as some of the other people, I too get this error:
    >vp instaport Mine1 true
    17:15:09 [INFO] /vp
    17:15:09 [INFO] Example: /vp - need to write the help.

    Everytime I try to type "/vp......" Anything, it always shows that. And really, I don't want to reinstall voxelports...such a pain to repoint and create all those vp's.
  11. Offline


    There shouldn't be anything wrong with the files, but basically what this says is that Bukkit's Environment class does not contain an enumeration of the value that was attempted to retrieve. I would try re-downloading CraftBukkit.
  12. Offline



    Hm, I noticed something I havent yet before: VoxelPort seems to stops our server from shutting down properly. It does the routine until it gets to "VoxelPort Thread Tick ended" and stall - java stacktraces that moment, and I need to kill -9 the javaprocess to stop the server and be able to restart it.

    Now, I removed other plugins that do things to the server timer, and it still happened. The only thing that *might* be conflicting could be BukkitContrib (as the only newish thing we have). Do you think that there is some connection? Am slightly stumped and cannot stop & restart our server all the time ;)
  13. Offline


    Weird, we've never had this issue.
    I'll see whether I can reproduce it.
  14. Offline


    From now on - I hate anyone on the VoxelBox server. I got banned for being the age of 11. I got on said hi and all that, looked around , said I was 11 and I got banned... I hadnt broken any rules. So you people suck ; tell the owner / admins to consider unbanning me please? Minecraft name : popdog15
  15. Offline


    Wow, how long ago did you quote that from? Also, yes, yes you did break rules.

    First line in the TOS.
  16. Offline


    WHERE R THE TOS? ( I Know thats Terms of Service... I spent some time on the Wiki and didnt see it.)
  17. Offline


    Stop spamming my plugin Thread. Gtfo.
  18. Offline


    I've created two working teleporters and linked them up successfully... problem is when I use one it teleports me there but then the chunk directly below me does not load and I'm stuck in a bouncing state. Is this a VoxelPort issue or is something else going on?

    Edit: Seems like the first player to go through experiences the issue and if you follow through right after it's fine for the second.

    Also my server is not displaying welcome messages on teleports at all. '/vp welcome fh_mc test' is what I've tried. I get the happiness message saying it set the welcome message for fh_mc to 'test' but it does not display upon porting. Again is this a VP issue or something else?
  19. Offline


    I have a similar issue as TGC79. Several arrival points do not load the chunk and I get stuck. I have to exit out of the game and come back in. Several of the ports work fine, several have this issue every time. Any ideas or suggestions. I am running Craftbukkit 1000.

    I experimented with relocating the arrive point, but it would not redirect to the new location. I finally was able to fix the issue by redirecting the portal to a new portal location, changing the arrival point of the bad portal to a new spot, and then redirecting the target back to the original portal. I did this to each affected portal and this fixed the issue on all the portals having the missing chunk issue.

    I hope this helps.
  20. Offline


    Can't anybody help me? I have the admns.txt file in the plugins directory, and my name is in it, but i always get this:
    Example: /vp - need to write the help.
    When commenting on The VoxelBox profile they say that i must have my name in that file, but i have, but it still doesn't work.
  21. Offline


    Lately Voxelport hasn't been working for me.
    When I start the server I get this error:
    18:18:53 [WARNING] [VoxelPort] Error while loading VoxelPorts
    18:18:53 [SEVERE] java.lang.IllegalArgumentException: No enum const class org.bukkit.World$Environment.
    18:18:53 [SEVERE]     at java.lang.Enum.valueOf(Enum.java:196)
    18:18:53 [SEVERE]     at org.bukkit.World$Environment.valueOf(World.java:673)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.Zone.<init>(Zone.java:24)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.newPort.readData(newPort.java:439)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.newPort.<init>(newPort.java:64)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.PortManager.loadPortals(PortManager.java:149)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.PortManager.<init>(PortManager.java:45)
    18:18:53 [SEVERE]     at com.thevoxelbox.bukkit.port.VoxelPort.onEnable(VoxelPort.java:44)
    18:18:53 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    18:18:53 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    18:18:53 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:272)
    18:18:53 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    18:18:53 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    18:18:53 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    18:18:53 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    18:18:53 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    18:18:53 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    18:18:53 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    and whenever I try to use a voxelport it gives me this severe error:
    18:21:01 [SEVERE] java.lang.ArithmeticException: / by zero
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.newPort.nextDepartureTotal(newPort.java:280)
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.PortTick.registerTicket(PortTick.java:25)
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.PortContainer.check(PortContainer.java:72)
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.PortManager.inBound(PortManager.java:58)
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.PortListener.actOnMove(PortListener.java:21)
    18:21:01 [SEVERE]     at com.thevoxelbox.bukkit.port.PortListener.onPlayerMove(PortListener.java:14)
    18:21:01 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader$7.execute(JavaPluginLoader.java:286)
    18:21:01 [SEVERE]     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    18:21:01 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:332)
    18:21:01 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:164)
    18:21:01 [SEVERE]     at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:491)
    18:21:01 [SEVERE]     at net.minecraft.server.Packet10Flying.a(SourceFile:126)
    18:21:01 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    18:21:01 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    18:21:01 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    18:21:01 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    18:21:01 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    18:21:01 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    How can I fix this? I rely heavily on voxelport for transportation around my server.
  22. Offline


    same error ;/
  23. Offline


    no errors but i often experience 1 or 2 worldholes on destination teleport, and it dosent seem to load the worldholes
    at all, you manually have to /reload, while the terrain around the hole is fine and loaded players get stuck in arrivel :(

    otherwise.. AMAZING :D
  24. Offline


    same problem pls help.
    i made the admns.txt file and im in it alone and still i cant make it work
    i cant even write /vp point
    plz help meee
  25. Offline


    Anybody know if this plugin is going to be updated to 1000?
  26. Offline

    Voxel Box

    Re: Chunk errors. This is a Notch bug, but can be remedied by running VoxelSniper on your server (no need to add anyone to the snipers.txt) and telling your users to do /vupdate when they are in a chunk error.
    Re: No welcome messages. Make sure you're linking ports to ports, not ports to a random destination location.
    Are you sure you are doing one name per line, proper caps?
    This is a Notch bug, but can be remedied by running VoxelSniper on your server (no need to add anyone to the snipers.txt) and telling your users to do /vupdate when they are in a chunk error.
    Are you sure you are doing one name per line, proper caps?
    This plugin is compatible with build 1000.
  27. Offline


    Sweet Thank you, solution works ;)
    i was running voxelsniper = most amazing tool :D
    but didnt know about the /vupdate command
  28. Offline


    Yes, im sure.
  29. Offline

    Voxel Box

    Glad to hear you're enjoying our plugins (thanks to przerwap)! Have fun!
    The admns.txt file is spelled correctly and located in you're /plugins folder too? Maybe try re-installing VoxelPort on your server?
  30. Offline


    i finaly made it work(the admns.txt file was in the wrong folder XD)
    super awsome plugin but when pepole teleport sometime they fall into the void xD
    anyway awsome plugin!
    if u could make an option to make every teleport is own ticket so one will be lets say diamond block and one iron block or what ever :D
  31. Offline

    Voxel Box

    The "falling into the void" glitch is purely Notch/Bukkit (you could put VoxelSniper on your server and use /vupdate as any user on the server to update the chunk below you). In regards to making one port cost more than others, you could maybe require multiple ports to get to a destination (costing 1 iron bar each). More ports = more expensive. Do be aware, however, that when a port accepts a VoxelTicket, it accepts an entire stack of them. Having 1-64 tickets in your hand will have the port take however many are in the stack (not just one of the tickets out of the stack).

Share This Page