Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Hmm /pwp is alright but its just strange that the other PW will be /pw {gogto} {name} It would be nice if it was just /pw {name} and drop the goto all together
    the fustrating part about pw is the GOTO command. I keep forgetting to type it.

    Since with Mywarp plugin its just /warp list and /warp {name} , Maybe you could do an overhaul and make it like this

    /pwh - For private home warp lists and catagories ect
    /pwp - The public warp stuff

    This way you can DROP the /PW as your essentialy splitting the two into sections you also will no longer need /pw goto

    If your planning on seeing a list or choosing cata you can just do /pwh {cataname} or /pwh list the list command would show u what /pw does now but for the warp type ur trying to do in this case Your own private stash.

    The above method would also then keep the whole system uniform as it would be the same commands for both but depending if your using /pwh or /pwp decided what warp system your using, Understand ?

    IMO its also really clean way to use commands as well.
  3. Offline


    Wrecker: I'm an idiot.. and shouldn't have been messing with the server that late.. we run multiple servers on one machine and of course.. I was modifying the file for one servers directory structure.. and expecting it to work in another.. My apologies if you went through a bunch of effort looking for a problem that didn't exist.. it's workign beautifully!

    Thanks again for this great plugin!
  4. Offline



    I know what you mean about the commands and I feel your pain. I have it too sometimes, but with the 'set' sub - command since I use that more often while testing.

    How about aliases. Basically achieves the same. It creates a new command without the goto. But if you need it you can also make an alias for for example 'del' and 'set' if you want. If it's not possible yet, I'm sure it's something that'll be made/integrated into bukkit or I could make it myself.

    The internal structure of pw s command-handling is very optimized and reuses code within the 3 commands (/pw /pwv /pwa) which is cool(at least I think it is). You're basically running the same code with /pw as you are with /pwa (/pwv actually uses another object type, but same code again).

    Anyway I need to go back to my eclipse :)


    Explains a lot. Thanks for the message. You probably saved a headache or two with your response ;)

    I added support for the groupmanager plugin. GroupManager has a nice API too, I was pleasantly surprised. Can you check it out if it works?

    Permissions support is also still in there except groupManager gets picked first if you have both plugins.
  5. Offline



    Thanks a bunch It should now load now "xfingers"

    Oh we changed out addresss to login to server as well if u want to come the NEW status with address is in my sig!.

    What esle oh yea when doing your converter for Mywarp make sure u include the same checkes to see what WORLD it was created on so that it does not TP u to the default world if, In my case Mywarps broke couple Updates ago due the fact multiworld had no support in it.

    meaning I got ppl hounding my ass now coz they cant warp at all.

    I will give u some basic low down on whats going on with it right now it may have been fixed i have checked today.

    Riftzero - New Default world
    world - world that the warps were orginally made on

    Warping to warp using Mywarp if player is on Default world tp to coords on the Default world and not takes to loctaion on its ment to go to {aka on world map} if u do the same thin on world map it takes u to Rifzero {default map}

    As u can see Neither method gets me to the Actual Location I should be going to.
    They need to fix this or you need to allow an option for when converting to specify the world the warps come from so that you plugin can handle tp the player to the other world if need be, Just like how it converts PW on first run to add the world name to the warp so it takes u to right world map and not the default world if the PW warp is not created for that world.

    Hope you get what I mean but anyway thats what needs needs to be done. Also Bukkit does support alias essentials uses alias and other plugins have alias support, Essentials does it via its plugin.ymal or config.ymal file
    it lists each command in its configs and under it has alias section that users can add desired alieas so you could easily call the command what ever u want for instance I could alias /pw goto as /pwh If I wanted to

    Example of this is how Essentials has a /essentials command used to reload its config, I Alias it as /er

    for short "Essentials Reload" I can type eaither in game it will work but I can also just give out the alias to groups and they call just its alias.
  6. Offline


    I only have the two txt files. I've installed PluginControl, though.
    Also, when I try to use a command, it says that PW isn't enabled/initialized.
    what am I doing wrong? I edited the .txt files.
  7. Offline


    Not sure what you are doing wrong. Can you post some logging or anything? Are you using some permissions plug.

    Ledhead, i think I get it. MyWarp has its default world backwards or something. It always teleports you to the wrong world somehow. Next up is the actual plugin. I'll start working on that tonight. I think I might have a working version on Saturday, but if it's any sooner I'll let you know.
  8. Offline


    So from what I've read this doesn't support multiworld, right?
  9. Offline


    No, PrivateWarp does support multiworld, some MyWarp version appearantly does not (but I am sure that will be fixed, if it's not fixed already).

    I support multiworld since v 1.3.2.(see changelog)
  10. Offline


    Mywarp v1.10.3 is the one that is playing up it worked ok before MC 1.3 tho the v1.10.3 is the latest version for V1.3 It should not be hard to fix just have your converter append the right world to the default and add the world name if its not default, like your currently doing.

    Also your latest version works fine :) even over mulitworld it takes u to correct world!
  11. Offline


    great news,

    I tested it locally, but it's always the question if it (keeps) works on an other config.
  12. Offline


    You'll have to excuse me, but why do we need the default_world= entry in group config files? And also, is there any reason PrivateWarp isn't generating any default configurations for default? It's just an empty file. I know I can just add the entries but it's a tad confusing when the information on how to set it up is a bit scattered throughout the OP.
    --- merged: Mar 4, 2011 8:25 AM ---
    I'm also unsure why the cache settings seem to have to be set per-group as well.. your plugin is really in desperate need of clearer documentation to go with it.
  13. Offline


    default_world is need because of backwards compatablility. If you have older data files from PrivateWarp (without multiworld support) they will be converted. The default world is the world where thos old ones were created.

    Cache settings is not per group, only the default one, but if it exists in other group files that is not problem (not used though). PrivateWarp will create default settings if hey are not set, but are accessed. When you initially did not set any settings they will be filled in with defaults when you use the plugin.
  14. Offline


    I don't get it ?, I'ts all very much self explained the only part that stumped most was the adding the default world as he had it worded really bad and had us all looking in the wrong spot.

    My default was never emptey!
    You don't even have to touch individual groups if u don't think your able to work them out. Cache per group is a good thing it allows an admin to set cache keep in memory times for say a guest group with less time it remembers the users homes and your highest rank group set with more time.

    Its a really nice touch actually its mainly there to help control ram usage why have users who log in and out if they are not planning to stick around have there homes kept in the ram as long as the rest.
    --- merged: Mar 4, 2011 12:11 PM ---
    @ wrecker

    you replied before me darn. but yea I would love to see individual cache time work I thought it already was :(.
  15. Offline


    ?? I'm using the plugin and it just gives me an empty file with no settings in it. Are you sure?
  16. Offline


    It's ok to ingore my post eh[​IMG], To answere you question no it wont make a difference group control is optional and if you don't set anything it will read from the config file and use its settings.
  17. Offline


    try it out. It'll have default settings(won't error out).
  18. Offline


    Okay, I just redownloaded PrivateWarp (16,152 bytes) and PluginControl (13,276 bytes). I upload them to my server, which has no pre-existing settings for it. No PluginControl directory or anything. I start the server. It creates the PluginControl directory. Inside of it is the PrivateWarp directory. And inside of that there is a single file labeled default. It is 0 bytes, it is empty.

    What am I missing?
  19. Offline


    you are missing 1 property. The default_world property. Just enter that into the empty file. Logging should have told you that though.
  20. Offline


    Common wrecker does anyone ever pay attention to logging information around here :p
  21. Offline



    yeah well maybe not. :p

    Anyway, the world property is going to be removed in a future version. I'm guessing 1.4 won't have that anymore since most will have converted their files.
  22. Offline


    @ Wrecker

    I got Mobriding and Mobtraining on our server new im testing it out as I type this!, You can find info out about them on our forum Information section under Plugins and mods.

    I think its going to be cool to ride animals and mobs and keep them as pets and all that coolness I give cred to those plugins, there prob one of the more unique around.
  23. Offline


    lol mobtraining sounds fun.

    QQCumber: any luck yet?
  24. Offline


    You should store the warps in the world folder (makes backups easier, just 1 folder to tar)
  25. Offline


    Easier to backup yes, except a warp can be in any world...

    When seperated and you delete a world you don't have to purge the warps as an added uhm extra benefit. I'll take it into consideration. The whole thing changes though and I don't know which worlds are there since something needs to call them before bukkit knows.
  26. Offline


  27. Offline


    hey guys,

    just anote about ANOTHER PLUGIN

    I'm not sure if I am able to finish a working version of the PublicWarp plugin today unfortunately. I had to take care of some unforeseen events/trouble' today. Wasn't much fun.
    Some guys thought it would be funny to throw our garden-lights out on the street. They were probably drunk too. They did some other stuff as well in our neighborhood.

    - made the base command /wp (WarpPool)
    - got the setting bit done
  28. Offline


    That sucks man, I'ts a pain in the arse when ppl cant control themselves drinking, we get the occasional letterbox knocked off and bins dragged into street, You could always get some of that Eeletric fence tape and wire it up to your lights in the garden lol, get a nice big 200v + strength converter that could nock a horse back.

    he wont be seeing them in your yard again after they get hit by that thing.
  29. Offline


    I am getting the following error when ever I try and load plugincontrol...

    07:27:09 [INFO] Loading PluginControl Version 0.47
    07:27:09 [INFO] Using Group Manager plugin
    07:27:09 [SEVERE] org.anjocaido.groupmanager.GroupManager.getWorldsHolder()Lorg/anjocaido/groupmanager/dataholder/worlds/WorldsHolder; loading PluginControl v0.47 (Is it up to date?)
    java.lang.NoSuchMethodError: org.anjocaido.groupmanager.GroupManager.getWorldsHolder()Lorg/anjocaido/groupmanager/dataholder/worlds/WorldsHolder;
            at<init>(Unknown Source)
            at wrecker.control.PluginControlPlugin.onEnable(Unknown Source)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    I have tried with the latest version of groupmanager and .0.99d
  30. Offline


    Couldn't figure it out, gave up.
  31. Offline


    @Nam it won't work with 0.99d, needs to be GroupManager 1.0 Alpha

Share This Page