Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Edit: I fixed the issue!
  3. Offline


    It says I don' thave permission even though I added it and I'm an op. I use PEX, could that be the issue?
  4. Offline


    It is saying for me "PW: No permission to use: pw" and I use Essentials Group Manager for it. It is version 1.9 which came with Essentials 2.9 (the latest version available). I am Op and the Owner rank, and I set up the permission nodes like this:
    Show Spoiler
    default: false
    - '*'
    - PrivateWarp.pwa
    - PrivateWarp.pwv
    - PrivateWarp.pwr
    - admin
    prefix: '&c'
    build: true
    suffix: ''

    List of other plugins I have installed:

    Show Spoiler

    I am also using version 1.7.1 of Private Warp (latest) and version 1.2.6 of PluginControl (latest), yet I am getting this error. I was using version 1.6.4 of PrivateWarp before, and then when I got that message I updated it and there was no change. Lastly I am using CraftBukkit Version 1.2.5 R2.0. It didn't work for R1.3 either, I just recently updated it.
  5. Offline


    try to rename plugincontrol.jar to z_controlplugin.jar.
    It's spécific problem with groupmanager.
  6. Offline


    Sorry I didn't reply any sooner. I was occupied flying again.

    Anyway. I'll probably release new update tomorrow to address some of the issues. The plugin expects that vault is installed at the moment. If it isn't you'll get an error.

    I want to get rid of the error...
  7. Offline


    Psst. I quietly uploaded a new version.
  8. Offline


    still doesn't work with pex :/
  9. Offline


    Well it shouldn't give the error. Just no permission I'm guessing?
  10. Offline


    yeah, it says no permission
  11. Offline


    I think you need to check your log. I just did a test with pex and PrivateWarp/PluginControl. See the result below:

    C:\Games\bkkit test>java -jar craftbukkit-1.2.5-R2.0.jar
    182 recipes
    27 achievements
    01:39:53 [INFO] Starting minecraft server version 1.2.5
    01:39:53 [INFO] Loading properties
    01:39:53 [INFO] Starting Minecraft server on *:25565
    01:39:53 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.3
    -13-g7ab0391-b2190jnks (MC: 1.2.5) (Implementing API version 1.2.5-R2.0)
    01:39:53 [INFO] [PermissionsEx] sql backend registered!
    01:39:53 [INFO] [PermissionsEx] file backend registered!
    01:39:53 [INFO] [PermissionsEx] PermissionEx plugin initialized.
    01:39:53 [INFO] [PermissionsEx] Loading PermissionsEx v1.19.2
    01:39:53 [INFO] [PermissionsEx] Initializing file backend
    01:39:53 [INFO] [PluginControl] Loading PluginControl v1.2.7
    01:39:53 [INFO] [PrivateWarp] Loading PrivateWarp v1.7.2
    01:39:53 [INFO] Preparing level "world"
    01:39:53 [INFO] Default game type: 0
    01:39:53 [INFO] Preparing start region for level 0 (Seed: -2433614295609203344)
    01:39:53 [INFO] Preparing start region for level 1 (Seed: -2433614295609203344)
    01:39:54 [INFO] Preparing start region for level 2 (Seed: -2433614295609203344)
    01:39:54 [INFO] [PermissionsEx] Enabling PermissionsEx v1.19.2
    01:39:54 [INFO] [PermissionsEx] Superperms support enabled.
    01:39:54 [INFO] [PermissionsEx] v1.19.2 enabled
    01:39:54 [INFO] [PluginControl] Enabling PluginControl v1.2.7
    01:39:54 [INFO] PC: Loading PluginControl Version 1.2.7
    01:39:54 [INFO] PC: Vault not detected
    01:39:54 [INFO] PC: Using PEX Permission plugin
    01:39:54 [INFO] [PrivateWarp] Enabling PrivateWarp v1.7.2
    01:39:54 [INFO] PW: Starting initialization of PrivateWarp 1.7.2
    01:39:54 [INFO] PW: Copyright: Wrecker Technologies
    01:39:54 [INFO] PW: PrivateWarp 1.7.2 initialized
    01:39:54 [INFO] PW: Just got enabled
    01:39:54 [INFO] Server permissions file permissions.yml is empty, ignoring it
    01:39:54 [INFO] Done (1,087s)! For help, type "help" or "?"
    01:40:17 [INFO] The_Wrecker [/] logged in with entity id 574 at (
    [world] 4.369943472921402, 96.0, -31.358518219149126)

     Directory of C:\Games\bkkit test\plugins
    24-05-2012 01:38 <DIR> .
    24-05-2012 01:38 <DIR> ..
    24-05-2012 01:38 <DIR> PermissionsEx
    23-05-2012 17:48 136.970 PermissionsEx.jar
    24-05-2012 01:38 <DIR> PluginControl
    24-05-2012 01:35 20.288 PluginControl.jar
    24-05-2012 01:38 <DIR> PrivateWarp
    24-05-2012 01:34 21.016 PrivateWarp.jar
    3 File(s) 178.274 bytes
      5 Dir(s) 97.969.938.432 bytes free

    my hunch is you have a groups.txt in the pluginfolder of PluginControl.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  12. Offline


    you know what? I'll resinstall >.>
  13. Offline


    I get the same command line as you do Wrecker, but it tells me in-game I don't have the permission to use PW. I've gotten rid of the groups.txt and I'm using PEX.
  14. Offline


    I did test it out ingame. The command worked after adding as a node. (only added it in the default group).

    The groups.txt should not reappear btw! Not when it detects PEX. Would like to see logging though. Maybe I can see what goes wrong.

    Btw. Vault should work as a work-around.
  15. Offline


    Thanks. I'll try adding the node to default or just getting Vault.
  16. Offline


    does not load for me properly, never mind i have a different plugin now :p
  17. Offline


    Just to clarify for myself, do I need PluginControl to use PW?
  18. Offline


    Yes you do. It contains core code (data structures) as well as some Permission handling. PrivateWarp is exploiting that code and presenting it to you through its interface. Though the logic for privateWarp is ofcourse in PrivateWarp itself.
    crash965 likes this.
  19. Offline


    Thanks. You're good at responding to things.
  20. Offline


    Hey if you can please add Sharing warps with other players (/pws) soon.

    I forgot to ask, when is the /pws going to be available, I really need it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  21. Offline


    I don't have an ETA for the features that are currently on the list. Been a while since I released an update which had newly added features. Mostly because of permissions. I'd rather add features than do permissions related issues though.

    Both the Canary and the Bukkit version are in need of an update soon (Minecraft version 1.3.0). Maybe I'll be able to squeeze something in for that release.
  22. Offline


    Just released a new build for Canary (PrivateWarp for ).
    - added support for multiworld and some minor improvements.
    - version v1.3.0 (not minecraft 1.3)
    Which means I can focus some more on the Bukkit version again.
  23. Offline


    Server is/was temporarily down. Fixing it up.
  24. Offline


    I get PW: no permission to use: pw
    What am I doing wrong? It worked for like 3 weeks then suddenly kicked the bucket? Help! I don't want to have to use a different warp pluggin!
  25. Offline



    what did you do before it stopped working?
    - server restart
    - bukkit update
    - anything else

    Most importantly. Look at the log and maybe post it here. You possibly do not need the entire log just the part where you start the server and execute your first (pw) command.
  26. Offline


    Been some time since I posted something. I've been playing the snapshots for 1.3.

    Makes debugging/testing a lot harder and I didn't want to downgrade every time. Looking forward for the official release of 1.3 though.
  27. Offline


    I'll be installing the 1.3.1 release of Bukkit tonight. I'll see if a rebuild is needed.

    I only managed to see that Bukkit starts when my plugin is installed. Haven't gotten around testing it (yet).

    Did a test, seems to be running fine on latest RB for 1.3.1

    I did not end up where I expected when using certain older warps (multiworld warps)... I think it generated a new world. Can't say whether that is the case or something else though.

    Ah, some of my old world are still in the old world format. Not plugin related. Just need to convert my world.
  28. Offline


    Does this plugin work on 1.3.2 the latest bukkit rb. Whenever I attempt to do a private warp even with op and the permissions node that is supposed to be allowed it does not work. Before updating to 1.3.2 private warp worked fine.
  29. Offline


    Works fine for me, I am using the latest 1.3.2 recommended build of bukkit, and the latest build for the plugin and plugincontrol.
  30. Offline


    I think it should work.

    Only problem that you could be having based on your post is permissions related. Plugin Control has the option to use multiple permission systems. So what are you using and what does the console say?

    It does not matter to the plugin whether you are OP or not btw. This is to be sure that you know the permissions work. I could program it in fairly easy though, just not sure if I should.

    I played single player the last few weeks, because of the snapshots and Tekkit. This made me think.
    Maybe I can make my plugin compatible with Tekkit (since it is Bukkit based I heard).
    Anyone interested in that?
  31. Offline


    This plugin is/seems compatible with tekkit server 1.3.2
    - Current version

Share This Page