Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    Hmm for pex it should not be neccesary so I'll look into that either way. But yeah you can use Vault to get to pex too so I'm glad it works for you now.
  3. Offline


    Okay, i have tried getting the permissions to work with this but i just can't get it to work. All i want to do is give donator3 and every group past that permissions to create and use private warps.

    Here is what i tried to do with the inbuilt permissions
    SUPER DONATOR=pw;pwa;pwv;pwr

    it's probably the wrong thing to do, but i can't find where the right format is as you have only just put the admin one. I have also tried putting the permission nodes you gave me into their respective groups in the permissions.yml file, i use permissionsEX. But that didn't work. Could someone just give me a little bump in the right direction?
  4. Offline


    I am also in the same boat. Basically, I want to setup privatewarps so that specific groups on my server can have x amount of warps. An example file of the groups and/or the flatfile to set this up would be very useful. I am using:
    - bpermissions
    - always latest version of bukkit
    - Logging? Its a rented server, ssh/ftp access and given a free copy of McMyAdmin.
    Other info: used this plugin months ago, had the same exact setup. All i remember is having separated files in the PluginControl directory that had the names of my groups. Inside those files specified a specific number of warps. I just dont remember the specifics. Ive read through most of the pages, you are very active with the comments. I apologize if this is a redundant question. Thanks
  5. Offline


    quick note:

    for the built-in permissions:

    SUPER DONATOR=pw;pwa;pwv;pwr
    That should suffice to give permissions. Now the configuration for privatewarp will be under PluginControl/PrivateWarp with the name of the group. When the files aren't there: The commands need to be executed, than it'll create files with default values.

    edit -> restart

    You should than be good.

    If using bPermissions,

    Install Vault plugin (look it up, download and install/config). Make sure Groups.txt is not on the file system(otherwise it'll use the built-in permissions). Start it up and carefully follow logging (if you can). Group files are in the same place...

    With Logging I mean the console output of Bukkit. Don't know if you are able to access that through a rented server. But with ssh/ftp acces you might be able to.

    Oh yeah,

    you probably don't need

    Since those do not have permissions at all. They'll fall into the defaultgroup category.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  6. Offline


    Hey Wrecker,
    did find anything out because of the PEX problem? Vault has a Problem with the intern Metrics, so i feel better without it ;)

    Ps.: Ok, like everytime, I pressed enter for reloading the server and now there are no problems anymore :D
  7. Offline


    Instead of The_wrecker and jungalist81 do i put the names of the players with permissions to use the warps and their groups?
  8. Offline


    Hey Wrecker, I spent at least 7 hours and had some issues:
    - even though I had bpermission and vault installed, I was still getting errors
    - deleting the groups.txt and reloading the server caused privatewarp getting a SEVERE error.
    After dozens of tries, this is what I did:

    Jung's solution to getting specific groups/names to have X amount of warps.
    1. Stop your server.
    2. Install PrivateWarp and PluginControl jars into your plugins folder.
    3. Start your server
    4. After starting server, there should be 2 folders made inside your plugins folder named: PrivateWarp and PluginControl. Make sure they exist. We will never touch the PrivateWarp folder.
    5.After seeing the folder, open the groups.txt inside the PluginControl folder and type this:
    Change the words (group) to the names of the all the groups you want to have PrivateWarp access. You will notice that I doubled spaced. I dunno why but this is how it worked for me.

    3. Next goto your Users.txt file inside your PluginControl folder and type this:

    Change the word (name) to all the players you want to have. Change the word (group) to which group those players belong to. Be careful, it is CASE SENSITIVE! Notice how I doubled space them in this txt file too. If you have 100 members that you want them to use PrivateWarp then be patient and type ALL those names!
    4. We are almost done yay! Now listen carefully and stare at this picture for a moment:
    I want you to goto that directory and remember where it is. This is inside the PluginControl folder. Like I said before, we will not touch the PrivateWarp folder. Now, our objective is to create Files so that it will look like this:

    The new files you see are each of the groups. In this picture example there are groups named: hhelper, isponsor, jmerchant, ktycoon and others. In order for PrivateWarp to work, you need these files.
    Jung I have a question, how do you create these beautiful files??
    Sure I can tell you how to do that. To better explain, let me create an example situation -
    I have a server and I have different groups. I want each of these groups to have X amount of warps to use. This is the name of my groups: guest, builder, mod, admin. After installing
    plugincontrol, and privateWarp. I goto the Groups.txt and I configure this:
    Next I open up my User.txt file and type this:
    In this server, we only have four members. I am the owner of this pretend server but I delibrately set myself as a guest. Next I logon to the server and type /pw
    This will popup on your chat.
    (Dont worry if the numbers are different). After seeing this ingame chat, I have sucessfully created a file! Check it out!
    I need 3 more files. To get those files, I have to change the group I am in the User.txt to another group. Then I have to type: /pw to create that group.
    *cries* Jung I still dont get it.
    Don't worry citizen! I will help you!
    Lets take a look at the user.txt again:
    Notice how my name, Jungalist81 is set as guest? I will change the word guest to builder. This is my new user.txt file now:
    Now I will go back and logon to the server and type /pw. This should appear once again in the ingame chat:
    Afterwards, another File should appear in the folder like this:
    After changing into the different groups and typing /pw ingame. I now have all the files in the directory:
    That is how you create those beautiful files.
    5. We are almost done! The last thing you need to do is open each of those files in notepad or notepad++ and change the number of warps. When you open one of the files, It should look like this:
    In the picture above, I changed max_warp from 10 to 3. You can change the max_warp to any number in each of those files. In the picture above, I changed max_categories and max_warp categorie to 0 because I do not use it.
    6. Finally, restart your server. When you log back on, you can type /pw and the numbers will be what you changed it.

    PrivateWarp Commands
    /pw add (name) - This is for creating a privatewarp on where you are standing. the (name) can be any word, letters or numbers.

    /pw goto (name) - This will make you instantly warp you to your privatewarp. You cant use this unless you create a warp first!

    /pw del (name) - This will remove a specific warp you made.

    Coming soon: Tutorial on setting up basic recommended plugins in the page.
  9. Offline


    Yep you are right


    nice tutorial. Basically you are using the built-in permissions. I would like to know the bPermissions error though. Can you share the stacktrace?

    And I think adding a warp was done with set (not add). But I could make an alias for that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  10. Offline


    when i update the pw jar and pluginmetrics jar the private warps disappear
    and it says it doesnt exist no more
  11. Offline


    Seems that you threw away your warp files when installing...

    [Edit: ]
    Check if you can find the files somewhere
  12. Offline


    nope I never do. All thats still there cause I was able to downgrade and everything works. The new jar file once added and restart server then go in game and use /pw it doesnt recognize it at all
  13. Offline


    When Private Warp is not recognized than that's something to do with permission/rights of windows while placing the java jar (s). I have no idea why this is , but sometimes bukkit just won't pick up/read the jar(s).

    Redownloading/ trying the zipped version might resolve the problem.
  14. Offline


    Hey Wrecker, sorry its been awhile. Thanks, I appreciate it. That tutorial is for those that want to have warps for different groups right away. Its quite confusing to setup and a tutorial was necessary. The tutorial I made is directed towards smaller server because you will have to type all the names of each player in your server.

    Anyway, sorry Wrecker but I do not have records of the old error and I haven't bothered tampering my system. Even though I had to list 100 names, I managed to get it working properly.
  15. Offline


    Ya I still have not got it working in the newest version. Im just still stuck on the older version
  16. Offline


    I should have some time this weekend. I'll see if I can create a fix. Need to find the problem first though.


    I don't think your problem is related to the bukkit permissions system though! Probably has something to do with your windows (the way I read it).
  17. Offline


    uhhhhh 1.2.5 don't work for me
  18. Offline


    I dont see how its my windows? I placed the new plugin jar into the file. restarted server, it no longer recognized the plugin, changed back and restarted, everything was fine....<_<
  19. Offline


    Because otherwise you would see a stacktrace and I think you don't see any errors or loading at all. Sometimes windows does not trust a newly downloaded jar it seems.

    It's not something that is wrong with your install. I myself had the same thing a few months back (never had the problem since though). I guess you are running windows 7 or something?

    If I really need to guess is that windows creates a virtual file that is not actually there(somewhere else) and thus Bukkit does not see it, but I can't confirm.

    I don't want to be rude, but this does not help me find the problem.
    Can you tell me what does not work (errors etc? stacktrace maybe? What was your set up?).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  20. Offline


    The server is not run from my computer. I pay for a host.
  21. Offline


    Yeh, I downloaded this and it doesn't work, are there other certain plugins you need inorder to make this one work?
  22. Offline


    What does the plugin say in the console? Make sure you have PluginControl installed (you have a Dependency Exception?) .

    General comment:
    I appreciate that you report that my plugin has errors and that it does not run/work, but you should understand that I can't help unless you provide me with some sort of error or appropiate description of what went wrong. I'm doing a lot of guesswork lately.

    Something like this would be nice:
    • Environment: (linux/windows/don't know)
    • Java version: (jdk 1.5/1.6/1.7)
    • CraftBukkit version: <version number/build>
    • Permission system: (Vault/PEX/Built-in)
    • Console log: <some logging, stacktrace>
    • Problem description: <What went wrong>
    • Reproduceable: <how to reproduce>
    When you can provide a dump of the log and or screenshots, that would be terrific.

    That's a bit different. Please provide me a dump of your log. This should be getting interesting. I really think there is some sort of error going on.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  23. Offline


    Sorry Wrecker but after uploading our server on Nitrado we can use PW with the built in permissions System only. Any Ideas ??? Just for your Informations:

    Craftbukkit version: Build #2175/ 1.2.5 R-1.3 (beta)
    Permission system: PEX <-- but we can't use it for PW. After deleteing the files in the PluginControl Folder and restarting the server, the files are recreated. There isn't any Error in the log dump or anything else. Also Vault can't solve the problem any longer (same problem).
  24. Offline


    Did you try deleting groups.txt (and doesn't the log point this out)?
  25. Offline


    you need include some of the commands from xWarp, and Essentials like /go, /warp, and /goto Thanks!
    that would make this plugin THE BEST!!!!!
  26. Offline


    Yes, I deleted groups.txt three times. At the moment I'm not at home and online with my mobile phone. In the evening I'll post a log-dump before and after deleting groups.txt. I think the log pointed it out, but it doesn't solved the problem. Groups.txt was still new created
  27. Offline


    That means that pex was not seen by PluginControl.
    Does PEX load after PluginControl? Or before?
    (it should obviously be before, otherwise it can't be seen)

    I'll be able to see that in the log. Or well maybe not nowadays, but it'll be helpful anyway.
  28. Offline


    Hey Wrecker,
    when i looked at the log, i recognized, that we had an old version of PC installed. So i installed the new one ( 1.2.4 --> 1.2.6) After that we had an error. Then I remebered the error before uploading the server and installed VAULT. Now all things work and we have no problems at the time. If you want to konw, why PC doesn't see Pex on it's own, i quoted the log-dump for you, how the server starts. Maybe you can solve this problem, because i don't like Vault. I don't know why but I have the feeling, that Vault is a reason for Problems on our server ;)

  29. Offline



    Thanks. I think PC had a bug in that version.

    You could try the new PC without vault now. There is code to pick up PEX without vault. I'm interested if that part works for you.

    It is always best you upgrade both PC and PW at the same time. Especially had some bugfixes in PC lately.
  30. Offline


    Hey wrecker,
    I'm very sorry, but there are still the same problems. Is the version I can download the new one? Because it's still PC 1.2.6.
    I downloaded both again, PC and PW. But after deleting them and Vault on the server, and inserting the new ones, this error appeared:

    After the reload, Groups.txt appeared again in the PC Folder.
    With Vault all things are right.
  31. Offline


    No apologies findus1994 .
    I think I know what is the problem. While checking if vault exists I'm trying to get to the class, but it isn't there. Thus the exception or error you posted above. The logging you posted made things very clear about what is going on.

    I thank you for the good and clear report. This is now easy to fix.

    A side note to everyone else:

    I'm currently doing some cleanup on my server(s). I'm getting rid of some old installations/machines. It is possible that there are some moments where stuff does not work quite as fast. Also there is a possibility that I would have to reboot some machines.

    I you are unable to download the jar (because of some downtime) , you'll probably be able to a few minutes later.

Share This Page