Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    it says that private warp could not be loaded! WHY????
  3. Offline


    All quite logical, you are forcing my plugin to use its built-in system (by using Groups.txt). you are not using pex at all. You've set up one default group and gave the command pw to that group. All unknown players are in the default group of Groups.txt

    Starting to wonder if it is something special with the vault plugin. Could you do a test without it? I don't support vault yet with the latest 1.7 version. And yeah I don't support per world permissions yet.

    I don't know. Any logging you could share?

    Thanks man!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  4. Offline


    Yea, I had the same problem. Here is the error message from the log:

    18:42:10 [SEVERE] Could not load 'plugins\PrivateWarp.jar' in folder 'plugins'​
    18:42:10 org.bukkit.plugin.​
    UnknownDependencyException: PluginControl​
    18:42:10 at org.bukkit.plugin.SimplePluginManager.loadPlugins(​
    18:42:10 at org.bukkit.craftbukkit.CraftServer.loadPlugins(​
    18:42:10 at org.bukkit.craftbukkit.CraftServer.<init>(​
    18:42:10 at net.minecraft.server.ServerConfigurationManager.<init>(​
    18:42:10 at net.minecraft.server.MinecraftServer.init(​
    18:42:10 at​
    18:42:10 at​

    Hope you can work this out, I love this plugin!
    Edit: I had a similar problem with Essentials, and it was resolved since I had 1.2.5, and Essentials was for 1.2.4. In the end I used the pre-realease. That might help...
  5. Offline


    It says that it misses the plugin PluginControl. It's a sort of vault like plugin (with some other stuff). Do you have PluginControl installed? if yes than it is still an old Bukkit bug.

    Good thing is that it is resolvable by editing the PrivateWarp.jar . Some people reported succes changing the plugin.yml.
  6. Offline


    I ave bug with 1.6.4
    Regulary people use pw spawn at good coordinate but not god Z, people can spawn under bedrock !!
    It's randomly people can use 10x the pw and spawn corectly or die !!
  7. Offline


    Thanks for the report.

    How many Z is the spawn above bedrock? Is it right on top of it? Does pw say there is something in the way?
    Did the chunk get unloaded (not much I can do about that)?

    I suspect the unloading of chunks to be responsible. The game can't handle the coordinates then (I think).
  8. Offline



    I get the no perms bug if i dont use your built in system. Tested with and without vault.
  9. Offline


    Could you post your configuration file?
  10. Offline


    I' don't ave the information about Z , but my map is very big (40 giga), i think the unloading chunk responsability is possible, Can you check if chuck is loading before tp player ? (Load chunk first and tp player after)
  11. Offline


    Maybe I could. Might not be a bad idea.
  12. Offline


    This weekend I'm releasing a new stable version with hopefully working vault support.

    Majority should than be working (I hope).

    I already have updated my current cod to work with it. But you guys are my best beta testers out there.

    I'm toying with the idea of sublevel categories...
    Did some code cleanup as well.
    In case of warmup, you'll get a warping message first....

    Chunk loaded check, proves to be a little more difficult...

    Can the server keep up? RAM requirements ok?
  13. Offline


    PrivateWarp 1.7.1 is out, but I am unable to update the first post because of an error.

    When you click the link you'll download the 1.7.1.
  14. Offline


    All my users get "You don't have permission to use pw", even though they do have the nodes. Not sure why... PEX 1.9.1 and Vault.
  15. Offline


    I need a configuration file of pex/vault. I am not able to reproduce this (tried that already).
    You are sure that PluginControl detects Pex or Vault right? Any way you can send it?
  16. Offline


    16:36:06 [INFO] PC: Loading PluginControl Version 1.2.5
    16:36:06 [SEVERE] Error occurred while enabling PluginControl v1.2.5 (Is it up t
    o date?)
            at wrecker.control.PluginControlPlugin.onEnable(Unknown Source)
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.t(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    Seems sorta like a PC problem to me...

      backend: file
          file: permissions.yml
      superperms: {}
    That's the PEX config file. Vault doesn't have one.

    When I load PW and PC for the first time after updating, it tells me to delete Groups.txt in the PC subdirectory. I go do that and then start the server back up. That's when I get the error I posted in my last post (#862).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  17. Offline


    Thanks, this will help a lot.

    Does PC detect PEX now or Vault? I guess you can't see that yet. Quits before that.
  18. Offline


    Weird thing is, I reverted to an older version (1.6.5?) and it still wouldn't work. But that version was a pain to get working anyways..
  19. Offline


    Thanks for all the work on this plugin. I love it and look forward to using it again - it used to work fine with PermissionsBukkit ( but it doesn't seem to work with that anymore, which I have all my users and groups defined through it for all my mods, do you plan on supporting that in the future at all?
  20. Offline


    Maybe Vault already supports it. Since I have added support to Vault, you could try that (haven't tested it).
    Btw. 1.6.4 should still work though on 1.2.5 for the time being.

    As you noticed above, I still have something to check out related to permissions.

    Permissions keeps on being a pain.... :(:mad:

    All those different systems, plugins and configs....
  21. Offline


    Hi there this seems like a great plugin but when I try to use it on my server it just says "PW: No Permission To Use: PW" please can you help me I have opped myself and every thing but it still wont work =[ any ideas?
  22. Offline


    The plugin does not check whether you are OP.

    What Permission system are you using (or want to use)?
    What version of Bukkit?
    Which jars did you install?

    (My crystal ball broke today, so I'm unable to see all that)

    Server just had a complete restart/reboot.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  23. Offline


    I can image it's a bit of work. Thank you for your response and I'll take a look at Vault and see what it does, or check out version 1.6.4 - I think I was getting an error with it - but that was using a beta craftbukkit, not the stable release for 1.2.5 - I'll give your suggestions a try.
  24. Offline


    The permissions seem to be broke, nobody on my server can use it since I updated it.
  25. Offline


    Any updates Wrecker?
  26. Offline


    Hey wrecker,
    it seems like I have the same problem Jombie has. First of all the Plugin told me to delete the Groups.txt for using the Permissionplugin and after reloading the Server, i had the following Error and the Groups.txt was reconstructed.

    I'm using PermissionsEx and save my informations in a mysql database. Maybe this is important ?

    The configuration file:


    And in the PluginControl folder i just deletet Groups.txt. Users.txt and the private Warp folder are still there.

    Maybe you have any Idea why this happens all the time. ;)

    OH, i forgot to say thanks for your work ;) great Plugin ^^
  27. Offline


    My PrivateWarp file does'nt come up!
    I have restarted my server 3 times but it still not work!
  28. Offline


    I uploaded a new version.

    Redownload to get it. Found a stupid error causing a nullpointer.

    Download PluginControl (v1.2.6) <- this is new
  29. Offline


    Sorry for wasting your time Wrecker, but i can't help myself. After downloading the new PluginControl.jar there is the same problem just with an other error. On first load Groups.txt was createt and after deleting and reloading the new error appeared:

    again Groups.txt was reconstructed...
  30. Offline


    It has an error loading /accessing vault.

    Is Vault loaded when PluginControl is started?

    • Maybe open the PluginControl jar and add the Vault jar to the manifest.
    • Possibly the class it is trying to get does not exist anymore in Vault...

    I think I'll need to load it this evening to see what it does.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  31. Offline


    Thanks for your work ;) Hope you can solve the problem ... I'm not good in develop plugins. ^^

    I tried to add Valut jar in plugincontrol jar... nothing changed.

    Hey wrecker, I'm sorry, I think i found the problem... I didn't know what Vault stands for and thought it is a part from PEX. But after scanning the Log-dump, i recogniced, that Vault is necessary for using your plugins. Am I right ? Hope so, because after downloading and adding it to the pluginfolder all things work perfect.
    Sorry for the chaos... and thanks for your help
    Ps.: It's still a perfect plugin ^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016

Share This Page