Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    It always reverts to the first file listed in the directory and none of the other files seem to work for the other groups.
  3. Offline


    I've solved my problem, I uploaded the file Permissions.jar of PermissionEX 1.18 because it is a bridge for some plugins:
  4. Offline



    So I gotta get pex also on the list (Since permissions.jar is no longer supported by pex).

    I guess Superperms is the way to go on this one.

    current list to add/redo support:

    -Permission system:
    -Best way to access permissions:
    Essentials Group Manager
    -Reason why I chose the above system:
    There are ingame commands that lets you add permissions, remove permissions from different groups and specified players.


    possibly bPermission...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  5. Offline


    Please add support for bPermissions!
  6. Offline


    Not sure if this is there (i cant seem to find it). Is it possible to add some kind of message for when you have a warm up timer on /pw to say it to the player when they use /pw goto name? I have all pw set with a 15 second delay before porting the player to their warp but they get no message and think the warp isnt working till 15 seconds has past and they teleport.
  7. Offline


    I'd like to convert my PrivateWarps to Essentials multiple homes. Even getting the PrivateWarp data in plain text would be great. Is this possible?

    Thank you.
  8. Offline


    Check this out:

    Not yet possible, but nice addition.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  9. Offline


    Any ETA on next release for support of PEX 1.19 and other permissions plugins?
  10. Offline


    I've got some things already set up to start the rewrite. An actual hard ETA is difficult because I'm on a skiing vacation atm.
    Still to give you a possible ETA. I'll be doing some programming on the 25th. Possible release on the 26th.
  11. Offline


    Server is in maintenance will be back up later....
  12. Offline


    Any updates?
  13. Offline


    Not yet. Probably not able to release a new update tonight. Maybe tuesday evening.
  14. Offline


  15. Offline


    I know you guys are waiting for an update.
    I'm just very busy this week with stuff for my own company... and yesterday my eclipse just didn't want to pick up my java install (so I didn't get anything done).

    Anyway, I'm doing my best to get the new stuff in, just hold tight.
  16. Offline


    Thank you very much for the time you put into the mod while having a real life too. :) It's greatly appreciated.
    The_Wrecker likes this.
  17. Offline


    Was wondering if we are close to a fix release? I use PEX, and this is the last plugin we are waiting on for our server to be fully updated. Whenever we try to use it, it says "you do not have permission to use pw" We have never had issues with your plugin and pex before, and are using the same setup we've used for ages.
  18. Offline


    First of all thanks for the messages and support.

    Currently adding essentials and PEX support. Thrown out the old detection...

    Gonna build/upload a new release tommorrow!
    DrMadFellow likes this.
  19. Offline


    Woohoo! My players can't wait :)
  20. Offline


    Uploaded a new build here:
    Let me know what it does...
    I don't have a PEX install... Kinda a shot in the dark for me.

    Sorry It don't yet work right....

    OK should be good.

    Note: only Essentials and PEX in this one!

    The rest follows... (if you are waiting for it leave a message and it'll be going up on the list)

    If you are using bPermission(or some other type) I recommend keeping the old version. This version is not compatible with those.

    built against the 1.2.4 Recommended build of Bukkit.


    Just a few pointers:
    1. look in the logging if it actually says that PluginControl uses the expected system.
    2. If not, try deleting groups.txt (see logging, it'll say something like this)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  21. Offline


    So oddly enough it spams my console with player reference errors, but seems to work perfectly...?
  22. Offline


    It doesn't even enable for me. Plugin Control does, but it never creates a directory.
  23. Offline


    Does it have any errors or logging? Updated all of the jars?

    You are saying that pluginControl does start. That's where the changes are. Does it detect PEX/Essentials GroupManager?

    - edit
    Tried it out on my server, but seems to start/load ok.
    Granted; I don't use PEX or Essentials (just the built-in permission system)

    What kind of referencing errors? I haven't seen them.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  24. Offline


    any eta on a possible bpermission support ?
  25. Offline


    It'll probably in a few days from now.

    Would like to know that PEX and Essentials are working correctly now. I hope they do.
  26. Offline


    Nothing indicating PrivateWarps is found. I see "PC: Using PEX permissions plugin", but nothing about PW's. What about hooking into Vault? Wouldn't that be much easier to handle permissions?
  27. Offline


    So, PluginControl is correctly detecting PEX.
    But, PrivateWarp is just not seen.

    Try downloading PrivateWarp in the zip. And place the privateWarp jar again. Something with rights I think.

    Hooking into vault. Hmm I dunno, but that's why I asked the best way to access the permission system. It wouldn't be faster though.
  28. Offline


    You're probably right about the speed. However, it seems like Vault is what most plugins are hooking to get the perms. If vault can detect PEX correctly and it can also handle positive/negative permission nodes, why not let it?

    Okay, weird thing. I went to download PW and accidentally chose the last stable zip (before I saw the "Unstable Releases" link at the bottom). THAT worked fine... But when I installed the latest unstable I started getting the "You do not have permissions to use pw" again even though I DO have the right nodes.
  29. Offline


    Actually I could add support for vault. But it is not guaranteed that someone has it installed. It would not interfere with the current implementation. Vault is just (again!) another layer.

    The other thing you mentioned is weird indeed.
    Yet, PluginControl does detect PEX.

    Gonna test out tonight what is going on.

    For now I think you have luck with the 'stable release' then.

    Must ask. Do you have any errors in the console when you get the "no permission to use /pw"?
    If yes can you post them?


    got around to do a simple test. First without modification of permissions.yml the /pw command does not work. Which makes sense to me.

    Than I added PrivateWarp.* to the file.
    I than had access

    Than I changed it to
    I only had access to /pw

    In all , my test seemed to go perfect.

    (Tested the latest unstable, only difference is that it is started from my IDE)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  30. Offline



    Using the 1.7 zip, testing on RB 1.2.4, and 1.2.5, using PEX 19.1, latest vault.

    To get /pw to work without the no perm error i had to add a line to the groups txt in the plugincontrol folder. I added x10=pw. Only line i put in the file. I restart and not only do people in x10 have the ability to use /pw now, so does everyone else regardless of what group there in.

    Also, using your system for permissions it is impossible to restrict commands per world.
  31. Offline


    epiic plugiin, dude, keep up the great work

Share This Page