Inactive [TP] PrivateWarp 1.7.4 - Private Warping suite [1.4.4-R0.1]+

Discussion in 'Inactive/Unsupported Plugins' started by The_Wrecker, Jan 14, 2011.

  1. Offline


    PrivateWarp - The Private Warping plugin

    Warping since Dec 2010 ! Proven to last.
    Current Version: v1.7.4
    Download PrivateWarp
    Download PluginControl (v1.2.8)
    Compatible with:
    Tekkit (1.3.2) (Bukkit for minecraft 1.2.5)
    Bukkit 1.3.2-r1.0
    Bukkit 1.4.4-r0.1
    Other stuff:
    Download Waypoint Converter (to convert and maintain warp files)
    Download Full zip (Including PublicWarp 0.65!)
    Current, all downloads page (Includes instruction videos)

    I made one of the apps I have compatible with the format.
    It's a gui which lets you peak inside of the private warp files. Some parts are not yet finished, might not finish it completely, but you'll have a way to get the contents.
    Download here: GUI Editor

    The converter can read your waypoints.txt (former hmod plugin) and create PrivateWarp database files. Those database files can be copied/moved to the privatewarp player directory to once again have your old warps back.
    You can use my plugin to create private warps. Every player can have his or her own set of warps. You can also set categories so you can divide your warps in a logical list. For example: you can list builds other people have built in a separate category (ie "Other_Builds).
    The PrivateWarp plugin has a dependency with PluginControl. PluginControl is a plugin which handles not only permissions, but also plugin configuration (flatfile) based on groups. PrivateWarp now has per group based limitations (maxwarp and so on). This is not another Permissions system since it can use multiple Permission systems.

    This plugin has also been ported from the hmod mod. You can find the old thread here: hmod forum. The old plugin can still be used as a Canary plugin, you can find the link in the Canary forums. The plugin is also mentioned on my website here: Wrecker Technologies.

    Supported Permissions:
    -Vault (support for bPermissions and several others indirectly)
    -Built-in permission system (Groups.txt, built in PluginControl)

    • Ability to create personal private warps
    • Divide your warps into categories
    • Admin can access other warps through the /pwa command
    • A vault system with the /pwv command
    • Some other stuff not yet mentioned
    • Limit the amount of warps a user in a group can have
    • Group manager compatible
    • Permissions compatible
    • Built in fall back permission system
    Commandlist (in chat):
    • /pw
      Display your currently set private warps and categories. Only displays warps in the current category selected.
    • /pw set <name>
      Set/add/overwrite a private warp in your selected category
    • /pw del <name>
      Delete a private warp in your selected category
    • /pw goto <name>
      Use the warp , goto the location where you have set it (warp has to exist)
    • /pw catselect <name>
      Select the category (has to exist). Leave empty to return to default
    • /pw catcreate <name>
      Create categorie with given name
    • /pw catdelete <name>
      Delete the categorie (including the underlying private warps)
    • /pw help
      Displays usage and commands
    • /pwa
      All the commands of /pw except you can pretend to be another player. For example /pwa <name> set home. Sets the warp home to the player <name>. Should be an admin/mod command on most servers.
    • /pwv
      An admin can create a template(or set) of warp categories and names. These cannot be used(del, set) by the players. An admin can set a warp in the template to a player which the player can use. Should be an admin/mod command on most servers.
    • /pwv put "player" "warp"
      Set the templated warp to the player
    • /pwv rem "player" "warp"
      Removes the warp from the player
    The rest of the commands for /pwv are the same as /pw except they don't store any coordinates and it functions as a template for the vault system.

    • /pwr <nr>
      Recall previous used warps. Start at 0 (0 is the most recent)

    Configuration of the plugin(s) is done in the PluginControl data directory.
    For example:
    • bukkit/plugins/PluginControl/PrivateWarp/<groupname> (properties for that group)
    Following 2 files are only there when the built-in permission fallback is used:

    • Users.txt contains the users
      A user is defined like so: The_Wrecker=admingroup
    • Groups.txt contains the groups (first line is the default group)
      A group is defined like so: admingroup=pw;pwa;pwv <- changed due to onCommand()
      A new line is for another group or user.
    Permissions nodes :
    • PrivateWarp.pwa
    • PrivateWarp.pwv
    • PrivateWarp.pwr
    Configuration file:

    Private warp configuration file (under the PluginControl data directory)
    • max_warp=10 Maximum of total warps
    • max_categories=3 Maximum categories a player can create
    • max_warp_categorie=3 Maximum warps in a category (excluded the main/default category)
    • max_cache_minute_timeout=30 Amount of time data is considered useless (0 not ecommended)
    • cleanup_cache_minute_timeout=5 Amount of time between cleanup runs (0 not recommended)
    • Warp_timeout // configurable timeout before warping
    Todo (featurelist)
    • DynamicMap warplocations
    • Sharing warps with other players (/pws)
    • TimeStamping warps (create/modified)
    • Add comments/descriptions to warps
    • Data dir cleanup (--fixed useles creation of files, just needs a cleanup run)
    • Initial starting warp list (a list you get when you first enter the server)
    • Calculate distance to a warp from current position (possibly including height)
    • Changing on the fly config with a new plugin
    • Zones where warps cannot be set (PluginControl feature actually)
    • Cool down function for commands (suggestion from ethood1999)
    • Warp maintenance tool
    • Fix up warp count versus vault warps (partly coded)
    • Add fully qualified warp names (category/warp) Suggested by Ture
    • Warpname Template
    • Redo configuration (add warmup message)
    Having problems?
    try this:
    Loading error 1
    Loading error 2
    Try to pay attention to what the log says when starting Bukkit. Might contain some important hints.


    Version 1.7.4 RC
    • Built against 1.4.4 R0.1
    • Fix when using /pwa (out of bounds error in thread)
    Version 1.7.1 RC
    Missing some versions because those were officially released as unstable. Below changes sums up some of the changes.
    • Built against 1.2.5 R0.1
    • Upgraded permission detection (direct support, PEX and Essentials)
    • Vault Support
    • Message that you'll warp when using a warmup - timeout
    • Some internal structure changes
    Changelog (open)

    Version 1.6.4 RC
    • Built against Bukkit 1370
    • Use of new Event system
    • Beware of Permission systems (I expect a few problems due to changes/breaking of the other plugins)
    Version 1.6.3
    Does not exist (skipped)

    Version 1.6.2
    • Fix to get material type from block
    • A way to force the built-in permission system regardless of other systems installed (checks for existance of groups.txt under the PluginControl directory)
    Version 1.6.1
    • Built against #1578 for 1.0.1 support
    • JDK7 support update
    • Fix for the race condition when warping/teleporting
    Version 1.6.0
    • Fixed crash due to multi byte character reading
    • Added multithreading for every command passed through PluginControl (Meaning the whole set of commands currently available for PrivateWarp)
    • Fixed the error message when you have no rights to use the command
    • Java JRE 7 supported
    • Updated building path to create new Jar
    • Better code to read configuration property readings
    • Support for Permissions updated (bPermission, PermissionEx, SuperPerms)
    • New detection system to detect Permissions (1.5.1 fix)
    • Splitted code for handling commands
    • Player cache managing code reorganized
    • Better file handling (should disable the creation of empty PrivateWarp files)
    • Removed seperate quick and dirty warmup code
    • Refactored AbstractPlugin OO layer
    Version 1.4.9 > 1.5.0
    • Fixed default warping timeout
    • Fixed bug where warpname was passed to permissions
    • Added softdepend loading to yml
    Version 1.4.8 > 1.4.9
    • Added warping delay (default 5 seconds, adjustable in config)
    • Added rename command (/pw ren <old> <new>)
    • Added move command (move warp to another category /pw mv <warp> <cat>)
    • Added shorter aliases for known commands (see help)
    • Refactored the code base a bit for future changes
    • Built against CraftBukkit 953 (minecraft 1.7.2)
    Version 1.4.7 > 1.4.8
    • Added configbit to config files
    • Built against CraftBukkit 818 (minecraft 1.6.6)
    Version 1.4.6 > 1.4.7
    • Fix on help sub command
    • Check for blocks before warping
    • Check alternative warp location
    • Warn and notices when your warp is not quite right (warping yourself half into a step stone for ex.)
    Version 1.4.5 > 1.4.6
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions (AGAIN!)
    • Smarter cache system
    • Update for Public Warp
    Version 1.4.4 > 1.4.5
    • Updates towards the latest Bukkit releases
    • Fix for built-in permissions
    • Added Essentials Group Manager plugin
    Version 1.4.2a > 1.4.4
    • Updates towards the latest Bukkit releases
    • Still has a known issue with built-in permission system (PluginControl)
    • Seems Bukkit changed the way namespacing works... This threw errors around (IllegalAccess Exceptions)
    Version 1.4.1 > 1.4.2a
    • Built with PluginControl(0.52a)
    • /pwr change
    • Recommended build #602 update and fixes
    • Previous release is revoked(1.4.2), hence the added 'a' in this release.
    Version 1.4.0 > 1.4.1
    • Built with PluginControl(0.51)
    • Fixed /pwv put command
    Version 1.3.9 > 1.4.0
    • Built with PluginControl(0.5)
    • Changed the way how the plugin(s) output text
    • PublicWarp might be independent now
    • Removed the default_world check
    • Removed Warp converting from old PrivateWarp version
    • Did an auto updating page (see link previous versions)
    Version 1.3.8 > 1.3.9
    • Built with PluginControl(0.49)
    • Compatability update for build 522
    Version 1.3.7 > 1.3.8
    • Built with PluginControl(0.48)
    • Nothing special added or fixed for PW
    • Support for PublicWarp (test-released plugin)
    Version 1.3.6 > 1.3.7
    • Built with PluginControl(0.47)
    • Fixed null when no default group in fallback
    • Added GroupManager support
    Version 1.3.5 > 1.3.6
    • Built with PluginControl(0.46)
    • Lazy warpname matching in goto subcommand
    • Code cleanup (mainly init stuff)
    Version 1.3.4 > 1.3.5
    • Built with PluginControl(0.45)
    • Update to use Phoenix permissions 2.4
    • Constructor fix
    • Shifted to onCommand
    Version 1.3.3 > 1.3.4
    • Built with PluginControl(0.44)
    • Less IO
    • Fix to /pwv put command
    • HACKY FIX considering the constructor stuff, but works for now.
    Version 1.3.2 > 1.3.3
    • Built with PluginControl(0.43)
    • Added /pwr to help
    • Redid some logging
    • Only show conversion log when it's 'interesting'
    • Teleport hook code for pwr (probably not yet functional)
    • Some more minor fixes
    Version 1.3.1 > 1.3.2
    • Built with PluginControl(0.42)
    • MAJOR Fixes to the plugin loading thing (I hope I got it nailed this time, I haven't seen errors while testing).
    • MultiWorld!!! (For conversion to new format add: "default_world=<world_name>" in config. The Plugin will ask you to do this.)
    Version 1.3.0 > 1.3.1
    • Built with PluginControl(0.41)
    • Added /pwr command
    Version 1.2.9 > 1.3.0
    • Built with PluginControl(0.4)
    • Made calls to Nijikokun's permission static
    Version 1.2.8 > 1.2.9
    • Built with PluginControl(0.3)
    • Code for Nijikokun Permissions through PluginControl
    • Fallback to basic mode when plugin can't be loaded somehow (which was the case for me)
    Version 1.2.7 > 1.2.8
    • Built with PluginControl(0.2)
    • Removed a potential memory leak
    • Better handling when dependency is not found
    Version 1.2.6 > 1.2.7
    • Added permissions with PluginControl(0.1)
    • Per group based limitations
    • /pwv, /pwa available again
    Version *.*.* > 1.2.6
    • Removed the /pwa and /pwv command (temporarily)
    findus1994 and DoomLord like this.
  2. Offline


    The zipped version keeps giving me 1.6.2... for 1.1 servers
  3. Offline


    Having the same issue: zip file contains 1.6.2
  4. Offline


    Yeah you are right. I have the same issue for some reason...

    Gonna kick apache in the butt for this...

    Kicked my webserver (reboot). And it now serves out the right file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  5. Offline


    I'm running craftbukkit-1.2.3-R0.2-20120304.091010-2 the newest development snapshot and it still doesn't read the updated privatewarp.jar file, so if you have one that works with these new snapshots try reposting it in a reply please
  6. Offline


    I also have the 'PW: No permission to use: pw' error :/

    I deleted users.txt and groups.txt and it just keeps generating the file

    Console: 'PC: Forcing built-in system'

    After I delete the groups.txt, and reload/restart, it still says 'PC: Using builtin group system' when starting the plugin.
  7. Offline


    What other permissions system are you using? And is that permissions system loaded before plugincontrol ?

    I expected some troubles here, is the permission system you are using up to date?

    I think it could not find one of the supported permission systems.
  8. Offline


    I use bPermissions 2.9.0, the latest.

    As I can see, it first loads PrivateWarp, then bPermissions and after that PluginControl.
  9. Offline


    When permissions loads after plugincontrol, that is a problem.

    Maybe this could help:

    But instead, try looking at PluginControl. Maybe you should/could add a softdepend to the list in the yml of plugincontrol.

    Hope it helps :(
  10. Offline


    [SEVERE] Error occurred while enabling PrivateWarp v1.6.2 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/event/player/PlayerListener
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at Source)
    at Source)
    at$000(Unknown Source)
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at Source)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.t(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    Caused by: java.lang.ClassNotFoundException: org.bukkit.event.player.PlayerListener
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 26 more

    Plugins I use are Essentials, Factions, LogBlock, MobDisguise, NoLagg, TameGrass, WorldEdit, WorldGuard, EssentialsGroupManager

    I had all of these plugins before the 1.2 update and PrivateWarp worked fine. Also, I use CB 1.2.3-R0.1
    And I got the exact same error when I tried it before with a 1.2-R0.1 CB. Please help because I lost some of my builds that are scattered around the map.

    EDIT: I noticed there was a version 1.6.4 instead of 1.6.2, so I re-downloaded this and it still shows up as 1.6.2 and I get the same error.
  11. Offline


    1.6.4 is the updated version...

    Which should not have that error you posted....

    Maybe empty your browser cache or something? When I download it I get the 1.6.4... I did have an issue a few days back where you would get the 1.6.2 instead of 1.6.4 chaching issue.
  12. Offline


    A solution for permission probleme
    First : remove /plugin/plugincontrol/group.txt
    Second: Rename plugincontrol.jar to z_plugincontrol.jar
    Enjoy :)
  13. Offline


    Thanks for the suggestion!

    Explanation why this might work:

    Removing Groups.txt
    Removing this prevents the plugincontrol into going forced built-in mode (that's good)
    So yes you should remove this if you are using something else!

    If the Groups.txt file exists it will not look for another system.

    The renaming probably does something about the loading order (Should load after the permission plugin you are using). Plugin.yml should handle this, but it hasn't been reliable.

    And , if PluginControl cannot find a suitable/compatible permission system it'll go into the fallback mode again(the built-in system, thus Groups.txt).
  14. Offline


    I am using the latest version of PluginControl and PrivateWarp. PluginControl runs fine but never wants to hook into bpermissions. PrivateWarp on the other hand does not even load. I've tried removing all my plugins except for bpermissions, PluginControl and PrivateWarp and running my server. Still PrivateWarp does not want to load.. Any help?
  15. Offline


    Hey guys, discovered a potential fix for the "PW: No permission to use PW" error for anyone using the latest versions of PermissionsEx, PrivateWarp and PluginControl (could potentially work for other permissions plugins but I haven't tried so can't confirm). Like many of the other users in this thread, I was having issues getting PluginControl to use my permissions system instead of its own even though all plugins were loading in the correct order and I was deleting Groups.txt each time.

    This was when I noticed that PermissionsEx now only has 1 jar file (PermissionsEx.jar) whereas before it used to also include a Permissions.jar. Luckily I had a backup of my 1.1 plugins so I copied across the Permissions.jar file from my 1.1 server to the plugins folder of my 1.2 server, deleted Groups.txt again and SUCCESS! PluginControl recognised my permissions set up and no longer used its own system, allowing me to use the nodes once again.

    I'm afraid I have no clue as to exactly why this fix works but if it helps the plugin dev the info message in my console states: "PC: Using Nijikokun's Permission plugin (new detection system)". Also just in case anyone requires it <Edit by Moderator: Redacted mediafire url>

    Hope this helps!
    Last edited by a moderator: Dec 15, 2016
  16. Offline


    Would like to help you out.

    Do you see any error messages from private warp? Any message at all?
    If no,
    try downloading it again.
    - first the jar
    - than the zip file if the jar did not work

    I would not touch PluginControl at this moment, since that one is loading(yet it has to be the latest version though).

    If you do get a message, post it here

    What permission systems are you guys using?

    I'm still using the older permissions API from Nijikokun, maybe it is time to say that part goodbye and surf another wave?

    Could you tell me what permission system you are using and what the best way of accessing it is?

    Something in this format would be great:
    - Permission System:
    PermissionsEX Version 1.0
    - Best way to access permissions
    Through Bukkit Permission API/ PermissionsEx itself
    - Reason why you choose the above system
    Because I 'm able to change permissions from in-game

    Above is just an example ofcourse!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jan 8, 2016
  17. Offline


    I'm having the same problem, saying I do not have permission to do pw commands.

    I have tried all of the suggestions in order to fix it, none of them have worked. I am using Essentials + Essentials Group Manager.

    -Permission system:
    -Best way to access permissions:
    Essentials Group Manager
    -Reason why I chose the above system:
    There are ingame commands that lets you add permissions, remove permissions from different groups and specified players.

    The_Wrecker please make it so that this plugin works with Essentials.
  18. Offline


    Thanks for your input! I'll test it out!

    Could you add a link to the permissions so I'm sure I have the correct version.
  19. Offline


    "Essentials Core Download"


    "Group Manager Download"
  20. Offline



    I see an EssentialsGroupBridge.jar in my plugins folder. Maybe you are missing that jar? With it my plugin might work again.

    Still I'm working to get rid of that... (but might fix your problem for now)

    Could upload the version I have, but it's old...

    (Ah i see it is in the groupsmanager .zip download!)
  21. Offline


    Works now, thank you so much!
  22. Offline


    I use the version 1.6.4 RC with permissionex 1.19.1 and CB v1.2.3-R0.1
    I added the permission to all users but anyone can use the command /pw; I already tried deleting groups and users in PluginControl's folder but it doesn't resolved nothing.
    What can I do?
  23. Offline


    UHm, probably it is me but,
    I get the feeling I don't understand what you want. You've added pw to all users and all users can use pw? Sounds good to me?
  24. Offline


  25. Offline


    What does the logging say? What kind of system is it trying to use?
  26. Offline


    in the logs don't appear nothing, no errors, no reply to the command.
    What do you mean for "system to use"? The permissions plugin?
  27. Offline


    Yeah, ops can't even use the command on my server...
  28. Offline


    I regret to inform you, this plugin doesn't work :/
  29. Offline


    Wow, what a conclusion that this plugin does not work.

    It'll always work with the built-in permission system. To use the other it has to know it is there...

    I suspect that PluginControl does not see the PermissionEx because of a missing jar.
    I so I think it'll say something like:
    Using built-in system (or forcing built-in system).

    If you see that, than you'll probably need a bridging jar of some sort like a few post above. (Maybe something called superperms or superpermsbridge?)


    There is no exception to ops in the plugin.
  30. Offline


    Well I got the plugin to work for me. How can I customize how many warps each group is allowed to have because right now they all have ten. I would like to give more warps to sponsors and staff as extra perks.

  31. Offline


    From within the plugincontrol directory. You'll have a PrivateWarp directory with files per usergroup. You can adjust the amount in those files.

Share This Page