Inactive [TP] MyHome v2.3 [BukkitDev, 1.3.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Spathizilla, Apr 17, 2011.

  1. Offline


    MyHome v2.2
    Release Date: 1st March 2012
    Yes, MyHome 2.2 works on 1.2.3, Try it.

    Recommended Craftbukkit Build: 1.1-R4+

    Permissions Support:
    MyHome can use Permissions 2, Permissions 3, PermissionsEx, GroupManager, bPermissions, bPermissions2 plugins or the built-in SuperPerms to manage permissions and in some cases, user/group settings also.

    Economy Support:
    Supports iConony 4, iConomy 5, iConomy 6, BOSEconomy 6, BOSEconomy 7, EssentialsEco and MultiCurrency to allow charging for using MyHome commands. This is provided via Register

    Getting Help & Feature Requests:
    Please use the MyHome DevBukkit ticket system to report bugs and submit feature requests. There is also a forum where you can ask questions which are not ticket suitable.

    ChangeLog v2.2:

    Important: You will need to re-generate your config file as it has completely changed.
    • Fix: SuperPerms now correctly allows ops to run commands (when enabled)
    • Fix: Decreased the sensitivity of movement detection
    • R5: Updated to new event listeners
    • Localization: German Translations: Thanks to Maxs
    • Localization: Updated Russian Translations, Thanks to MisterFix
    • New feature: Only allow /home to be used within x blocks of their home point
    • Per user/group distance node: myhome.distance.home
    • New feature: Table name in the database can be changed
    • bPermssions 2 support
    • More cleanup and optimization
    • New config layout - remake your config! [New config.yml]
    New per user/group node:
    * myhome.distance.home - Maximum blocks away from their /home point that /home will work.

    Older changes (open)

    2.1b only: Fixed non PEx plugins failing because I am an idiot
    2.1a only: Fixed an NPE when using SuperPerms

    Important: Be sure to update the permissions if you allow players to bypass the economy costs.
    • A massive permissions overhaul to make things more reliable
      • bPermissions support added
      • SuperPerms support added
    • Feature Localizations (english, spanish and danish so far)
    • Feature: Some commands (like deleting homes) works via console
    • Bug Fix: Zero second timers no longer block in laggy servers
    • Bug Fix: Beds cannot /sethome if the user doesnt have that permission
    • Lots of cleanup (you wont see this bit).
    • Permission Change: Economy "free" permissions no longer included under myhome.home.*
    Permissions changes:
    (*) - Allow /sethome and /home usage for free
    ( - Allow /sethome usage for free
    ( - Allow /home usage for free

    Added /sethome which can be enabled in the config (Config: allowSetHome = false)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown for setting the home position (Config: coolDownSetHome = 0)

    v1.9.4c - Unreleased (fixed with a symlink on the webserver):
    Fixed the update url going to lib/lib.

    Updated SQLite download urls.

    Added Manifests to JAR to fix lib issues

    Forked plugin from 1.9.3
    Fix for onPlayerJoin changes in Bukkit
    Sergey95, Hopium, Phaedrus and 3 others like this.
  2. Offline


    Good lad /thumbs up

    Just one question before I spend the next 20 mins updating to b733...does the /home point command work for the compass again?

  3. Offline


    You mean like disable certain commands? Right now if you have no permissions plugin installed it will default to allowing you to use all commands and admin commands require Op status.

    Unfortunately no, it doesnt change the compass to point to home with /home point. I just had a look into this and the existing code still matches the requirements of Bukkit (setCompassTarget is called correctly with the location) . I remembered a tkelly post saying this was broken because of Bukkit - I guess they still havent fixed it.

    This is also why the original post never mentioned /home point even though it is actually still in the plugin.
  4. Offline


    Will it ever log home usage to the console log again? TK's one stopped it at one point :(
  5. Offline



    Users are reporting /home doesn't work with cool down. Cool down set to 150, people are saying they get the same cool down message even after 20 minutes has gone by.

    1.9.4b CB 740
  6. Offline


    Is it possible to have this plugin store homes on a MySQL database instead?

    Its nice to have everything in one place...
  7. Offline


    Pretty much everyone on my server is now reporting the cool down to not be working now that were on 1.5.
  8. Offline


    Do you get a lot of lag/cant keep up messages? The timers use the Bukkit scheduler.

    That is on my list for v2.0 - I want mysql support for my own server too.
  9. Offline



    No my server purrs like a kitten :) So what can i do to resolve the issue besides setting cooldown to 0.
  10. Offline


    Problem is I don't know what is broken because this is the first time I've heard of it. Try changing the cooldown timer to something slightly lower (but not 0) and see if that changed anything.
  11. Offline


    Have you removed the compass and spawn function?
  12. Offline


    I would like to make a simple request. Can you make it where admins being able to warp to anyone's house toggle-able? As an admin I don't want to make my players feel uncomfortable by being able to go to their house whenever I please.
  13. Offline


    Feature request
    I would love to see a cool-down for /sethome

    This would be a lot more useful than a cooldown for /home. For example I would set it to 24hours, as there is no real need to have to change your /home more often. This would prevent players from setting home in "strategic" places like other towns of PvP arenas to abuse some of the server rules like no spawn killing.

    Thank you.
  14. Offline


  15. Offline



    Tried cooldown 40, 60, 100, 150, and users all rpeort not being able to /home and getting the cooldown message each time for hours. Some say a restart fixed the issue for them and some say the have no issues with the cooldown.

    Been using myhome for a very long time and never had this issue. The issue occurs at all times, when theres only 10 players on or when theres 50 on, doesnt seem to make a difference.

    The only thing i can do is disable the cooldown.

    The /sethome cooldown would allow me to dump /home cooldown all together, so im all for it :)
  16. Offline


    Err, MyHome doesnt use /sethome - That is usually Essentials. MyHome uses /home set to set their home positions. Was that a typo or do you actually use /sethome?

    Running some tests with MyHome-dev-1.9.5:
    Cooldown: 40 --- Test Passed
    Cooldown: 60 --- Test Passed
    Cooldown: 100 -- Test Passed
    Cooldown: 120 -- Test Passed

    With testing dev-1.9.5 it allowed me to /home to the second of the cooldown timer. I even had the stopwatch running on my phone to check them.
  17. Offline


    I appologies i meant /home set, typically home plugins use /sethome. I am using myhome for homes.

    Well i dont know what to tell you, on my server its different. Im willing to provide whatever info you may need.
  18. Offline



    I need a way to delete or move someone else's home.
  19. Offline


    MyHome v1.9.5
    Download MyHome v1.9.5
    Download MyHome (Static Jar)
    Release Date: 2nd May 2011

    v1.9.5 Changes:
    Added /sethome which can be enabled in the config (Config: allowSetHome = true)
    The new /sethome uses the same permission as /home set so no extra permissions needed.
    Added a cooldown timer for the number of seconds between uses of /home set (and /sethome) (Config: coolDownSetHome = 0)

    I thought about this but if its toggleable, isnt that just the same as being able to go whenever you like? Just means you have to toggle it on and then /home playername. Or, did I misunderstand and you meant you want the admin ability to go to other homes as a config option?

    Merry Christmas, see v1.9.5 :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
    khamseen_air likes this.
  20. Offline


    THANK YOU, i know what i,ll be naming my first born :p
  21. Offline


    Thank you for adding the cooldonw for /home set :)

    Does anyone know though why my cooldown times are not counting down in the game? Or is it just how it is?

    I could of sworn though that before it would count down and tell you how time is left.

    Thank you!
  22. Offline


    The code I forked from tkelly (1.9.3) doesn't ever count down. It has a function but a huge //TODO in it. It is on my list to fix though.
  23. Offline


    Oh ok, not a problem :)

    For some reason I thought it did before, no idea why. I did just wake up lol
  24. Offline


    we have over 700 homes but only 100 players is a way to delete old homes
  25. Offline


    Nice, Works fine for me.

    I like that it say welcome to xxxxxx's home. Very Nice touch
  26. Offline


    Any issues with 1.9.5 so far?

    Hows the cooldown problem you were having with 1.9.4? Any improvement with 1.9.5?
  27. Offline


    Very nice and simple. Thank you!
  28. Offline



    I disabled it and am using a 10 minute /home set cooldown now. Users haven't reported any problems. Thx for the update :)
  29. Offline


    Little Feature Requests:
    Multiple homes with Permissions for them. (It should be /home set, /home set 2 and /home set 3 ... and so on) Than with /home 2 you can get to your home 2 or /home Spathizilla 2 that i get to your home when i am invited to it. This could be great for homes in other Worlds... Maybe a function to name the homes like /home set DurtyLol, and /home DurtyLol to get there.
  30. Offline


  31. Offline


    Having a problem since the switch over... MyHome ran great before, since i uped to 1.9.x home commands do not work... server has permissions 2.5.5 -- tried to add the myhome.home.* and still nothing... all members are admins via permissions myhome.* is set on admins... on server load it sees all 3 homes but when you type /t home nothing happens. no errors; nothing... i have no error messages to help with this unfortunately, but nothing is working either....

Share This Page