Inactive [TP/HOME/WARP] Waypoint v1.6.4(beta)- Teleportation points, home, spawn, and warp management. [1609]

Discussion in 'Inactive/Unsupported Plugins' started by miyoko, Jul 12, 2011.

  1. Offline




    Waypoint - simple teleportation point and home/spawn/warp management plugin:
    Version: v1.6.4 beta


    *New in 1.6: modular command hookins, reworked command system, SuperPerms, ????*

    Waypoint is an easy teleportation point management and home location
    management plugin. You can create teleportation points to go back to later
    as well as share privately with other users. You can also create public warps that only certain groups of users can access.

    Waypoint's Features:
    • Add/delete waypoints for later access
    • List all of your waypoints simply
    • Share your points privately with other users
    • Points are private, and only accessable by you, unless shared
    • Multiworld support
    • Permissions/SuperPerms/OP support with strict nodes.
    • Home location management
    • Home location is automatically set to the bed you last exited (only if enabled in config.)
    • Create and manage public warps
    • Control which groups of users can access these warps
    • Save/Load the spawn points for all of your worlds
    • Selective showing of warps (you only see what you can access.)
    • Teleport easily between worlds
    • Create and import other worlds
    • Create and teleportation signs to travel to warps or world spawnpoints
    Download: JAR | SRC
    Development build (bleeding edge): JAR
    Integrity (CI): Waypoint project

    If you like my work, please consider sending a dollar or two my way so my little development company can pay for a server to do work and testing on :)

    For those of you that want to contribute, or even just watch progress get made on this, check this out:

    Phabricator: Source Code/Collaboration

    • /wp add <name> -- add a waypoint to your list
    • /wp del <name> -- remove a waypoint form your list
    • /wp tp <point> -- teleport to your point
    • /wp invite <player> <point> -- send an online player an invite to your point
    • /wp accept <point> -- accept an invite to a point
    • /wp decline <point> -- decline an invite to a point
    • /wp list -- list of all of your points
    • /home -- teleport to your home
    • /home set -- set your current location to your home
    • /spawn [world] -- teleport to the world's spawn point
    • /spawnadmin <save|load> [world] -- save or load the spawn point of the specified world
    • /spawnadmin set -- set the spawn point of your current world
    • /warp [warpname] -- teleport to the specified warp, if you have access
    • /warp add <warpname> -- create a public warp with the default permissions
    • /warp del <warpname> -- delete a warp you own
    • /warp set <warpname> <owner|permission|or a custom value> <newvalue> -- set property values in the warp's metadata
    • /warp list -- list all warps that *YOU* have access to
    • /warpadmin <set|del> <warp> [key] [value]
    • /tp <player> [target] -- teleport to another player, or teleport one player to another.
    • /tphere <player> -- ejects the target from a vehicle (if applicable) and teleports that player to you.
    • /tploc <x,y,z> -- teleport to a set of coordinates.
    • /world [worldname|create|import|list] -- displays what world you are in and your current position, or if given a worldname, teleports you to that worlds spawn.
    Installation and Configuration:
    Download the jar file and drop it into your minecraft server's plugins/
    folder and reload/restart the server. The configuration will be
    automatically created for you.

    Teleportation Signs:
    To create a teleportation sign, you must format it like this:
    Line 1: [WP:WARP] or [WP:WORLD]
    Line 2: world name or warp name
    Line 3: (optional) description # maybe economy cost at some point soon
    Line 4: (optional) description
    It is case insensitive btw.

    Configuration options:
    'set_home_at_bed': set this to true if you want your home to be reset
    whatever bed you get out of.
    'autoupdate': check for updates and download upgraded jars automatically
    'warp.groups': permission groups for warps
    'warp.string': message sent to user after teleporting to a warp, %w is warpname, %p is playername
    'limits': self-explanatory.

    Permissions Nodes: (should each be self-explanatory)
    • waypoint.basic.add
    • waypoint.basic.delete
    • waypoint.basic.teleport
    • waypoint.basic.invite
    • waypoint.basic.invite.accept
    • waypoint.basic.invite.decline
    • waypoint.basic.list
    • waypoint.debug.config_node_test << debugging *ONLY*
    • waypoint.home -- you *must* add this if you want to be able to use home commands
    • waypoint.home.set
    • waypoint.home.set_on_bed_leave
    • waypoint.admin.spawn
    • waypoint.admin.spawn.set
    • waypoint.admin.spawn.load
    • waypoint.admin.warp
    • waypoint.teleport.teleport -- for general teleportation actions
    • waypoint.teleport.location -- for coordinate-based teleportation
    • -- for teleporting players to you
    • waypoint.spawn -- you *must* add this if you want to be able to use spawn commands
    • waypoint.warp -- you *must* add this if you want to be able to use warps
    • -- you *must* add this if you want to be able to use /world
    •<worldname> -- more info on this below
    • waypoint.warp.access.<permission category>
    • waypoint.warp.create
    • waypoint.warp.delete
    • waypoint.warp.list
    • waypoint.sign.warp
    • waypoint.cost_exempt.teleport -- teleports do not cost a single dime.
    Known Bugs:
    • Set home at bed is not disabling, ever. Currently looking into it. T3
    If you find a problem, report it at Github.

    Permissions Setup:
    Here is a sample Permissions 2.7.4 configfile with Waypoint's nodes already set up, and a user set up to give an example. Change it to your liking.

    << Thanks Pr0Failure :D

    World Access
    As of about 1.6.1, I added a few new things that implement a whole "world access" type schema of features. Players will NEVER be able to access a world unless they have the "<worldname>" or "*" permissions. I will add a configuration option to disable this, but for now, it's always on. If you want to effectively disable it without a config option and your permissions system supports inheritance, simply place the "*" node at the lowest level and it should filter up through everything that inherits that or its children. I only added this because I felt it would be handy in the case of servers wanting to prevent griefing in creative worlds, but leaving whitelisting off, and just spawning all new users in the spawn world, but not letting them traverse your minecraft universe of worlds. There will be a config option to turn this off soon. By the way, if you didn't catch the gist of what I was really saying, this prevents ALL teleporting between worlds (only if you don't have the permissions for that world) no matter what you use to teleport. This catches events at a low level and checks each user's permissions as they change worlds. But enough about this.

    Bugs and Errors
    If you get a "An internal error has occurred" message when you use a command, * PROVIDE A TRACEBACK PLEASE. * (hint: a traceback is the error code in the server console that shows the error and its callers)
    And for those of you that didn't read this text, maybe this image will catch your attention:


    • Fix PermissionsEx not being detected correctly.
    • Rewrite command structure again with sk89q's command framework.
    • Add configuration options to disable various things.
    • Clean up core support code (me.pirogoeth.Waypoint.Core.*)
    • OpenAuth integration in the future?
    Version 1.6:
    • Completely rewrote the command parser from the ground up.
    • Added SuperPerms support
    • Split commands apart into categories (much cleaner for anyone who works through the code)
    • (Supposedly) Fixed NPE from LoadWorlds during plugin load.
    Version 1.5:
    • Rewrote the configuration loader and put it in its own class
    • Restructured config storage
    • Added new warp limitations
    • Added an autoupdater
    Version 1.4.5
    • Fixed warp permission loading and detection
    Version 1.4.4
    • Fixed the internal errors spewed on /warp set
    Version 1.4.1
    • Removed some unneeded imports
    • Removed some unused variables
    • Now using String.format in checkperms
    Version 1.4
    • Added warp management
    • Restructured most of the config file formatting.
    • Homes-per-world (you can have one home per world now.)
    • Added spawn management
    • Added backup/restore of world spawn points
    Version 1.3
    • Added home support
    • Fixed configuration node bugs
    Version 1.1
    • Added invite support
    Version 1.0
    • Wrote all base code
    And some thanks.
    Definitely got some big thanks here, especially to Pr0Failure, who been testing the crap out of this, even during its magical beta stages. And some more thanks to all of you that put up with me not being around for weeks on end due to school. And thanks to others who at one point sent in a pull request to fix something I had missed. I love you all, you're a very supportive community :) Also, some big thanks to Ctark who's been following this like crazy and even digging through my messy code to find nodes to help others while I'm not around :) Again, THANK YOU ALL <3
  2. Offline


    If you downloaded the there should be a jar that's just called Permissions, which is the compatibility layer that Waypoint connects to.
  3. Offline


    I have a build of Waypoint with native PEX support, so the compat layer is no longer necessary.
  4. Offline


    Oh yes, your right, i got it to work now, thanks guys.
  5. Offline


    Hi there, do you have to have permissions or can you have GroupManager?
  6. Offline


    I have this problem that resets your home position I set my home in my house using /home set, but when I restart my server it resets so I have to set my home again, also it does the same for warps so I have to reset them as well, I'm not sure what to do. Do you have any ideas?
  7. Offline


    Do you use some sort of external server configurator/manager?
  8. Offline


    I really love this plugin! Great job! I am looking forward to set warp prices because nobody uses streets anymore on my server XD
  9. Offline


    Hey miyoko, I'm getting a 502 bad gateway when trying to get to your experimental builds that you've posted here. Trying to do some fiddling on my server for testing, and I'd like to try a couple of experimental builds.
  10. Offline


    At our server Waypoints don't work with the latest recommended Build of Bukkit 1938 1.1-R4. It says in Game "internal Error occured...." and the Server log says:
    org.bukkit.command.CommandException: Unhandled exception executing command 'warp' in plugin Waypoint v1.6.5
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.handle(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.String
    at me.pirogoeth.Waypoint.Core.Warps.PlayerToWarp(
    at me.pirogoeth.Waypoint.Waypoint.onCommand(
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more

    What should i do????????
  11. Offline


    Hello miyoko! Congrats to such a great plugin, been searching ages to get a hold of something like that for my server :)

    I have 2 questions though - first one, is this the same plugin that is listed at BukkitDev under this:
    ... if so, it has been marked as abandoned and has 2 different owners, so I'm a bit confused here :-P

    Second question - I'm using Multiverse for multiple worlds management and Waypoint seems to be forcing SURVIVAL gamemode on teleport on its own, even though Multiverse has a different gamemode set for my creative world. It also seem to override Multiverse's "/mv tp" command by its own "/tp" command, since calling "/mv tp" twice in a row with timeout set in Waypoint's config gives me a cooldown message.

    Is there any permission or config option that would help me retain gamemode set for my administrators (they're all in creative mode all the time)? The don't have the option to change it back on their own you see... :-D

    Thank you!
  12. Offline


    ok so im new to the plugins thing, and I placed this into my server, but nobody exept for me is allowed to do anything. I cant tp them to me, they cant /home, or /spawn. It says they don't have permission. How do I cange that?
  13. Offline


    I still need to finish the rest of the economy stuff, only teleport prices are done right now :p

    I didn't realise that Integrity was down. It should be back up and working now.

    Try using this jar:

    The project page on bukkitdev is the same as this, I'm the author of both, I just go by different usernames :p
    Waypoint's cooldown crap works for all teleport events that are called, so to disable that, just disable cooldowns in the config.

    You need to set up your permissions correctły. See the top post.
  14. Offline


    It's working now. Thank you.
  15. Offline


    Good. No problem.
  16. Offline


    ... ah, I see. Thank you for the clarification! Any ideas what to do with that game mode changing? :oops:
  17. Offline


    I was getting the same error on 1.6.4 and at one point, one of the dev builds fixed the error and everything was fine (naturally i didn't back that one up). Since you added PEX support, I can't get permissions working. I'm running PEX 1.18 and the above version of Waypoint and 1.1-R4 of Bukkit. Here's the relevant information from the log (I think):

    2012-02-22 20:58:49 [INFO] [Waypoint] Loading Waypoint v1.6.5.
    2012-02-22 20:58:49 [INFO] [Waypoint] Reading configurations.
    2012-02-22 20:58:50 [INFO] [Waypoint] Finalising 1.6.5 configuration.
    2012-02-22 20:58:50 [INFO] [Waypoint] Failed moving old configuration data.
    2012-02-22 20:58:50 [INFO] [Waypoint] Configuration successfully loaded.
    2012-02-22 20:58:50 [INFO] [Waypoint] Searching for a suitable permissions plugin..
    2012-02-22 20:58:50 [INFO] [Waypoint] No Permissions plugin detected. Using OP
    2012-02-22 20:58:50 [INFO] [Waypoint] Enabled version 1.6.5
    2012-02-22 20:58:50 [INFO] [Waypoint] Saved all configurations.
    2012-02-22 20:58:50 [INFO] [Waypoint] Economy support disabled.
    2012-02-22 20:58:50 [INFO] [Waypoint] Checking for updates..
    2012-02-22 20:58:50 [INFO] [Waypoint] Error while checking for updates. (It could be a dev build.)
    2012-02-22 20:58:50 [INFO] [Waypoint] Limits are disabled.
    2012-02-22 20:58:50 [INFO] [Waypoint] WarpLimits are disabled.
    2012-02-22 20:58:50 [INFO] [Waypoint] Warps: loaded permission groups: Default, Mod, Admin
    2012-02-22 20:58:50 [INFO] [Waypoint] No worlds to be loaded.
    2012-02-22 20:58:50 [INFO] [PermissionsEx] Loading PermissionsEx v1.18.
    2012-02-22 20:58:50 [INFO] [PermissionsEx] Superperms support enabled.
    2012-02-22 20:58:50 [INFO] [PermissionsEx] v1.18 enabled
    2012-02-22 20:58:50 [INFO] [MCEat] Loading MCEat v1.1.
    2012-02-22 20:58:50 [INFO] MCEat V1.1: Enabled!
    2012-02-22 20:58:50 [INFO] [FoodTrees] Loading FoodTrees v0.8.
    2012-02-22 20:58:50 [INFO] FoodTrees version 0.8 is Enabled!Made and Maintained by lookatmego!Celeixen deserves a cookie:D
    2012-02-22 20:58:50 [INFO] [Permissions] Loading Permissions v2.7.7.
    2012-02-22 20:58:50 [INFO] [PermissionsCompat] Compatibility layer enabled.
    I don't know anything about Minecraft modding so I'm not sure if order is important here since Waypoint is loading before PEX. Reinstalling 1.6.4 allows the mod to work but obviously the error comes back.
  18. Offline


    how to disable cooldown in the config? ive removed the entry, i've set to enabled: false and i've changed the cd timer to 0 but I still get the Waypoin cooldown message on teleport. this is bad because i use /spectate to spectate first person wta plugin, and the plugin is teleporting you so you see what the player sees. every time it gives me the cooldown message, and it spams chat :(

    Also, I installed bpermissions and set up the groups and users file and put it in the world folder, etc, other plugins detect bpermissions but the console says that waypoing detects no permissions and defaults to the OPs, what am I doing wrong? Does waypoint not support bpermissions?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  19. Offline


    bPermissions provides SuperPerms support basically, right?

    I need to tweak some things in the cooldown then :p

    I need to tweak game mode changing too :p I'll try to get to work on a bunch of this stuff over the weekend.

    If you're having problems with permissions or cooldowns, try this build:

    I lost my main server, and am busy setting up a backup.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  20. Offline


    Define: Lost

    Didn't you do this once or twice already? :D
  21. Offline


    The person that is hosting it cannot host it any longer. I'm moving all my junk and looking for an alternative.

    Good news. Integrity is running once again on the new server, everything should be functional (phabricator, ci, downloads, etc).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  22. Offline

    Mr. Drachian

    so i downlaoded the jar file, placed it into my plugins folder and then started it. it then said"
    [SEVER] coild not load 'plugins\waypoints.jar' in folder 'plugins'
    it then goes on to list that it is an "invalid plug exception at" and then lists a bunch of urls. i tried to re download file and it displayed the same error. can someone help me? ive included a more detailed picture in a file. example of bucket.JPG

    ok i checked again with other plugins and its all of them that behave this way.
    so im thinking that it is something to do with my bukkit server.
    can anyone help me fix this?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  23. Offline


    Shortly after server version 1943 most of my plugins stopped working with similar errors, including this one. I am stuck at version 1943 until I can find a solution. I'm sure it has to do with their "We're cleaning up the code" banner message at the top of this page (and every other page on this site for that matter).

    Go here and try an earlier bukkit server version (1493 or older). :

    I'm sure Miyoko will chime in on this if he hasn't already.

  24. Offline

    Mr. Drachian

    ah ok cool. that made it so it works now, thanks so much for your help
  25. Offline


    I'm doing my best to keep everything up to date. I'll try and keep up with Bukkit. It might be a tad bit difficult though.
    Ctark likes this.
  26. Offline


    odd thing. I update my waypoint and started getting the blue message that I didn't have the permission to warp. The permission was already set as " - waypoint.*" (PEX). I reverted to the previous jar and all was well again. Did something change in the recent version in regards to permissions?
  27. Offline


    Any chance to allow commands (espicially the world load / unload commands) to be run from console?

    I'm thinking about having a timer (like cron) run a script that unloads a world (the end), copies over a backup of the world (with towers regened ect...) and then reloading the world back in.
    Only problem is you can't use waypoint from console at all.... shouldn't be too hard really.....
  28. Offline


    Those guys are machines! I'm not sure they ever stop typing, let alone leave their computers.
  29. Offline


    You'll be able to use commands from the console soon, once I rewrite a ton of stuff to use sk89q's command framework.

    Yeah, I added direct support for PermissionsEx in the handler, and sometimes Waypoint gets loaded before PEX, so Waypoint doesn't know that PEX is loaded yet. I'm working on a solution, but a temporary fix is doing "/wp reloadperms" (you need to be an op to use that).
  30. Offline


    Hey mate.
    First of all: Great PlugIn! I love it and so do the player on my server!
    We upgraded to the R6 bukkit. Can you tell me when WP will be ready for that?
    Big shoutout, love your work.
    (Dont work under pressure though :) )
  31. Offline


    Here's the scoop. I'm going to be VERY busy this week, I've got tons of testing and crud at school. But I'm going to try my hardest to repair Waypoint for 1.1R6. I've already tried to compile with the R6 API JARs and I've what the majority of problems are. The thing is though, my old code is kinda a mess. I've got two options here.

    Trudge through my old code and fix everything, or I can completely rewrite Waypoint from the ground up, which means rewriting waypoints, warps, worlds, a lot of stuff (mostly the command based stuff, newer code I can leave alone).

    It just depends. If I do decide to rewrite it..I don't know how long it will take, or when I'll be able to sit down and get a good start on it. If I rewrite...are there any semi-experienced Java devs in here that would like to help me out with this, only because it's gonna be hard for me to put in the time for a while...but please, PM me or email me or /something/ if you're willing to help me out on this.

    I just thought I'd give everyone a heads up. Thanks for following my work, guys, I hope you continue to follow me and use my plugin, it makes me feel good knowing a bunch of people like my work.
    Ctark likes this.

Share This Page