[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline


    Permissions v3.16 is outdated. I highly recommend PermissionsEx. There's an incredible getting started tutorial for it (Click Here) also.

    Maybe use water for horizontal portals and the normal nether portal block (without the irritating noise?) for vertical portals?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    This plugin it's buggy, sometimes the portals stops working and it breaks world generators like SkyLandPlus (they start to generate normal world). It should be flagged as innactive.
  4. Offline


    No, it shouldn't be flagged as Inactive. It's working perfectly fine with RB 1.0.1-r1 / 1597 and the dev (@Olof Larsson) was last active on Dec. 20th, you know, just before Christmas. "8 days ago" during a major holiday season is not "inactive".

    As is the case in 99.9% of computer related problems: PEBCAK. Post your configs, permissions, plugin list, and someone can probably help you. There's no need to flame this veritably functional plugin.
  5. CreativeGates doesn't work entirely with MC 1.0.1. It teleports people and does pretty much all it's supposed to, but when it shuts down...
    [SEVERE] Error occurred while disabling CreativeGates v1.3.2 (Is it up to date?): null
    at com.massivecraft.creativegates.Gate.empty(Gate.java:344)
    at com.massivecraft.creativegates.Gates.emptyAll(Gates.java:110)
    at com.massivecraft.creativegates.CreativeGates.onDisable(CreativeGates.java:59)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:190)
    at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:989)
    at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:181)
    at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:376)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:455)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:457) 
    Nothing seems to fail, and the server is just closing, so I guess it's academic. But all bugs must be stomped, not just the ones that break the game. This could have unseen consequences.
    But, as Stormbow rather acidy puts, this plugin works otherwise veritably, and any people who can't read the instructions and use it should probably just submit a ID-10t Error and await assistance. ;)
  6. Offline


    There are no errors when I stop my server.

    04:00:22 [INFO] CONSOLE: Stopping the server..
    04:00:22 [INFO] Stopping server
    04:00:22 [INFO] Appleseed version 0.6.5 is disabled.
    04:00:22 [INFO] [DwarfForge] Saved 0 active Forges.
    04:00:22 [INFO] [DwarfForge] v2.2 disabled
    04:00:23 [INFO] [FoundBoxx v1.6.0.2] Disabled.
    04:00:23 [INFO] [Lumberjack] disabled
    04:00:23 [INFO] [NoCheat] version [2.21a] is disabled.
    04:00:23 [INFO] [PermissionsEx] v1.17 disabled successfully.
    04:00:23 [INFO] Essentials: Using Permissions 2 based permissions.
    04:00:23 [INFO] WEPIF: Using the Bukkit Permissions API.
    04:00:23 [INFO] TieDyeSheep is now disabled.
    04:00:23 [INFO] TreeAssist 3.0 Disabled
    04:00:23 [INFO] WorldGuard 5.4 disabled.
    04:00:23 [INFO] [ChatManager] ChatManager disabled!
    04:00:23 [INFO] [Modifyworld] Modifyworld disabled!
    04:00:23 [INFO] Essentials: Using superperms based permissions.
    04:00:23 [INFO] WEPIF: Using the Bukkit Permissions API.
    04:00:23 [INFO] [ScubaKit][3.0.0.D IN 3D!] Disabled Completed
    04:00:23 [INFO] [Fruitful v0.7.4] Plugin has been disabled.
    04:00:23 [INFO] [Citizens] version [devBuild-] disabled.
    04:00:23 [INFO] WorldGuard: (Greystone) Single session is enforced.
    04:00:23 [INFO] WorldGuard: (Greystone) TNT ignition is PERMITTED.
    04:00:23 [INFO] WorldGuard: (Greystone) Lighters are PERMITTED.
    04:00:23 [INFO] WorldGuard: (Greystone) Lava fire is blocked.
    04:00:23 [INFO] WorldGuard: (Greystone) Fire spread is UNRESTRICTED.
    04:00:23 [INFO] WorldGuard: Loaded configuration for world 'Greystone"
    04:00:23 [INFO] [CreativeGates v1.3.2] Disabled
    04:00:23 [INFO] [DeathControl] is disabled!
    04:00:23 [INFO] [DeathTpPlus] Successfully saved TombStone list
    04:00:23 [INFO] [DeathTpPlus] Successfully saved TombStone list
    04:00:23 [INFO] [DeathTpPlus] Successfully saved TombStone list
    04:00:23 [INFO] [DeathTpPlus] [SAVE] Tombs saved !
    04:00:23 [INFO] [DeathTpPlus] v3.3.1597 disabled
    04:00:23 [INFO] LWC: Flushing final updates (0)
    04:00:23 [INFO] LWC: Freeing SQLite
    04:00:23 [INFO] [DeathTpPlus] LWC plugin lost.
    04:00:23 [INFO] mcMMO was disabled.
    04:00:23 [INFO] Saving chunks
    04:00:23 [INFO] Stopping server
    >Press any key to continue . . .
    Justin The Cynical likes this.
  7. No? Huh. Guess it is just me, then.
    From what I gather of the Java puke, it's related to CreativeGates 1.3.2 disabling. That's not a lot of room for misinterpretation. I'm guessing you don't use MultiVerse, which is the only thing I think might be responsible - I'm having to use a dev build because they haven't bought out a solid one yet...
  8. Offline


    do i only need to install Multiverse 2 Core and Creative Gates ?

  9. Offline


    Yes it should, the plugin it's innactive, not him. Im not flaming anything, just going real: the last update of the git source was October 12, 2011, 3 months ago, he's not making replys in this thread anymore, and the plugin it's not submited into dev.bukkit.org. It should be flagged as innactive.

    It's not config issue or other plugin, im not a noob, and i'm not talking without knowlege. I was user of this plugin for 4 months, since the 1.7.3. This plugin always give me problems, gates not saving when the server stops, gates sometimes not working, and the bug of the version 1.8.1 (Frame invalid) that other user gently solved cause the developer didn't care about it. You can see it by yourself in this same thread.

    Also, the bug i'm reporting allready happen to me once in the 1.8.1 version with the flat world generator, and was solved when the developer updated the plugin, but i'm afraid that's not gonna happen this time.

    I don't need help, i allready fixed this, i changed for RealTeleporter and now the conflict has gone :). But FYI,
    the server it's running in Debian 6.03 it's dedicated and working in my home and here are the list of plugins:

    As you can see there are a few plugins, almost very supported and well-developed. I changed creative gates for RealTeleporter, in the meanwhile Multiverse fix they portal plugin.

    For you own good, try to use supported plugins, old unsupported and not continued plugins are a time bomb.


    This plugin have issues with Multiverse, not because multiverse it's bad coded, just because CreativeGates it's not longer supported by the dev :). Try using RealTeleporter.
    Nox13last likes this.
  10. I'm running creative gates 1.3.2 with multiverse core 2.2-b412 (API v9) and I don't see these shutdown errors either.
  11. I would be using Multiverse Core Version 2.2-b419 (API v9). (This one was recommended to me. Tried 424, and people always go back to main spawn when they login or are killed, regardless of what world they're in.)
    It's all diamond-in-the-rough stuff right now. There's no point fretting over stuff that isn't done yet.

    Yeah, I may need to look into that. I didn't like it when this plugin stopped being AncientGates.
    Have a Like.
  12. Offline


    Please Update this Plugin !
  13. OP hasn't been seen since Dec 21. Telling him to update (when so many people have already done so) achieves nothing.
    Besides, I'm sure he has better things to do on Christmas and New Years' than to pander to people he doesn't know to fix a plugin people don't publicly appreciate.
    I know I'd like to spend time with my loved ones than sit alone in front of a computer, being shouted at by people I don't know to fix something that still works adequately.
    Justin The Cynical likes this.
  14. Sorry to get off topic, but said "bug" was with spout + Bukkit. MV just used a feature that was being messed with by spout. The bug to my knowlege is still present, but MV now auto disables said feature (when spout is found) so the "issue" should be gone :)

  15. Oh, ok. Thanks. But I can't trust dev builds. The one I got was a leap of faith because the last Awesome Build vomitted all over Minecraft 1.0. I'm not going to trust any later version unless it is officially endorsed by either yourself or the MV team as one entity.


    Back on topic, though. It kinda sucks that the OP still hasn't shown up. But he did say (rather rudely, back in October) to the effect of "learn java, fix your own damn problems". And if the case here is an author who would prefer to let others fix his own mess, then I will go elsewhere. To say nothing of the logistical nightmare of learning a whole new language that Mr. Larsson so blasély says. I can't even use Lua.
  16. Offline

    Olof Larsson

    Hi :)
    Just a heads up. I am working on a new version and I think it will be out within a week or two.
  17. Offline


    I don't know if anyone answered this yet, but I did not need Multiverse for Creative Gates to work on my server. (I don't use any other teleporting plugins, but don't use multiple worlds aside from the nether.)

    I can actually sort of confirm this. When I installed VanishNoPacket, for the invisibility power, I was 'required' to install the spout plugin (not the client). I got all sorts of errors for reloading the server and when shutting it down. I think that spout plugin was outdated though. VanishNoPacket did work properly though.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  18. Offline

    Olof Larsson

    The Ancient Gates part is done now. There's much more features than the original plugin had though :)
    Special Effects and custom triggers for example.
    Check out the sample gate near the fountain at spawn on my server: http://MassiveCraft.com

    Left is to finish redstone support and make the CreativeGates part of the plugin.
  19. Offline


    Does that mean this has been updated to 1.0.1-R1 / 1597?

    I ran around MassiveCraft. Didn't see a CreativeGate, no one answered me when I asked about it on the server. (Didn't acknowledge me joining the server or anything. They were all too busy killing everyone.)
  20. Offline

    Olof Larsson

    There is a strange hole in the ground just outside the spawn building.
    Two signs next to it:
    "Magic experiment" - "Bathe at own risk"

    Jump in! \ :D /
  21. Offline


    Ahhhh! Very cool. That's what we were missing, horizontal gates. How do you make those?
  22. Offline


    PermissionsEx support now working?
  23. It's been working for a while now.
  24. Offline


    Figured that out :)
    it was a problem with MultiVerse.
    sorry :(
  25. Offline


    Please fix towny support! :/

    13.01 18:55:02 [Server] SEVERE Could not pass event BLOCK_PHYSICS to Towny
    13.01 18:55:02 [Server] INFO at net.minecraft.server.ThreadServerApplication.run(SourceFile:457)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:455)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.MinecraftServer.stop(MinecraftServer.java:376)
    13.01 18:55:02 [Server] INFO at org.bukkit.craftbukkit.CraftServer.disablePlugins(CraftServer.java:181)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:289)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:296)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:989)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:190)
    13.01 18:55:02 [Server] INFO at com.massivecraft.creativegates.CreativeGates.onDisable(CreativeGates.java:59)
    13.01 18:55:02 [Server] INFO at com.massivecraft.creativegates.Gates.emptyAll(Gates.java:110)
    13.01 18:55:02 [Server] INFO at com.massivecraft.creativegates.Gate.empty(Gate.java:344)
    13.01 18:55:02 [Server] INFO at org.bukkit.craftbukkit.block.CraftBlock.setType(CraftBlock.java:73)
    13.01 18:55:02 [Server] INFO at org.bukkit.craftbukkit.block.CraftBlock.setTypeId(CraftBlock.java:77)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.World.setTypeId(World.java:435)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.World.update(World.java:463)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.World.applyPhysics(World.java:501)
    13.01 18:55:02 [Server] INFO at net.minecraft.server.World.k(World.java:514)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    13.01 18:55:02 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$30.execute(JavaPluginLoader.java:469)
    13.01 18:55:02 [Server] INFO at com.palmergames.bukkit.towny.event.TownyBlockListener.onBlockPhysics(TownyBlockListener.java:66)
    13.01 18:55:02 [Server] INFO java.lang.NullPointerException
  26. Offline


    Im having a problem with one gate that will never stay open. is this due to the random chunk error within the plugin? Should i try moving the gate?
  27. Offline


    I am having a problem and I can't understand why I am having it. I have a gate that is entirely diamond blocks. When I right click with a watch I am told that there are two gates made of this material, which is correct. I can go through one get to the other, but not the other way around. What might be causing this? I need to fix this ASAP

    I found out that if I removed my floor panels to open the doors the problem is fixed. Why does redstone near a gate make the gate not work?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  28. Offline


    How's the update coming along?
  29. There's an Edit button for a reason, pal. But glad to see your problem has been circumvented.
    Redstone as a one-way lock system might not be a bad idea if used intentionally.
  30. Offline


    Sorry if this has been discussed/addressed already...

    Apparently, Creative Gates is no longer skipping over blocked/unusable ports...

    Let's say you have 4 portals. and Port #1 is blocked. You can walk into port #2, will take you to #3, walk into #3 and will take you to #4, but when you walk into #4, which would normally take you back to #1, it just says it doesn't lead anywhere, instead of skipping over #1 and taking you to port #2...
  31. Offline


    I hope this is continued..

Share This Page