[TP] Creative Gates [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by Olof Larsson, Jun 23, 2011.

  1. Offline

    Olof Larsson

  2. Offline


    hi, it is possible to make one way gates?
    I mean
    gate A -> gate B but not B -> A ?
  3. Offline


    This is the best portal mod I have seen, but unfortunately it doesn't work with a Creative server.
    How can we make it so right-clicking with the clock activates the portal?
    Simply put, hitting the diamond block with a clock on a Creative server causes it to instantly break. Woops..
  4. Offline


    Thank you! I see what you mean, I will try that!
    And yes, it would be nice, because it's a damn good plugin, very simple and I like the part, that there is no commands :)
  5. Offline


    I've been trying to get this plugin to work for a week now.

    I'm using WorldManager for my multiworld plugin, and the native permissions system for permissions (I've also tried it without setting any permissions at all).

    I'm not receiving any errors, but at the same time I'm not getting anything happening when I try making/initiating gates.

    My permissions file is as follows:
            - admin
                creativegates.create: true
                creativegates.destroy: true
                creativegates.use: true
                description: create gates
                default: true
                description: destroy gates
                default: true
                description: use gates
                default: true
        build: "&cYou do not have permission to build here."
    (Loosely based on the example found on the bukkit wiki and the defaults shown in the original post)
  6. This is a quirk I posted about as well. Workarounds:
    1. Change your permissions so that you can create, but not destroy, a gate.
    2. Change your gamemode to survival when making the gate, then go back to creative.
    I did the gamemode option myself and it does work.
  7. Offline


    I am occasionally getting hangups on the server, so tracking down all errors on the console to see if it helps.

    CreativeGate 1.3.1 on CB1240, I am getting this error, but the portals are all working fine in game.
    06:41:08 [SEVERE] Could not pass event SERVER_COMMAND to CreativeGates
    java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.RangeCheck(Unknown Source)
    at java.util.ArrayList.remove(Unknown Source)
    at com.massivecraft.creativegates.zcore.MPluginSecretServerListener.onServerCommand(MPluginSecretServerListener.java:25)
    at org.bukkit.plugin.java.JavaPluginLoader$49.execute(JavaPluginLoader.java:583)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:339)
    at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:501)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:485)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  8. Offline


    Question: Does CreativeGates treat wool of different colors as the same item, or is it able to differentiate networks based on the wool color?
  9. Offline


    I noticed that, if a block of the frame is removed by the player the portal disables, but if it is removed by a piston it stays active until a player trys to go through
    I made a circuit which changes parts of the frame, stargate like, but since it wont disable when a piston changes the frame it is a pain in the arse :-D I hope you can fix that as well as add the function to activate it via redstone instead of a hit with the clock :-D
  10. Offline


    How are you constructing your portals by completely enclosing your gate? Also, 'children' is an example group. What permissions pluggin are you using? (Doesn't make sense when you say "i tried it without permissions" yet you have the permissions written here) If you ARE using permissions, children: is not a node so get rid of it.

    This permissions format is not one that I use, so you're going to have to be specific with what permissions pluggin you use.
  11. Offline


    Dont work with CB1240... Gettin this Error

    [CreativeGates v1.3.0] === ENABLE START ===
    2011-10-09 21:57:29 [INFO] [CreativeGates v1.3.0] Will use this plugin for permissions: PermissionsEx v1.14
    2011-10-09 21:57:29 [INFO] [CreativeGates v1.3.0] Downloading library gson.jar
    2011-10-09 21:57:31 [SEVERE] Error occurred while enabling CreativeGates v1.3.0 (Is it up to date?): null
        at com.massivecraft.creativegates.Gate.open(Gate.java:59)
        at com.massivecraft.creativegates.Gates.openAllOrDetach(Gates.java:120)
        at com.massivecraft.creativegates.CreativeGates.onEnable(CreativeGates.java:40)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:941)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:174)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:157)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)[/CODE
    kay its working now!
  12. Offline


    I can confirm this is working just fine for me on CB 1240, I absolutely LOVE this plug in, its so convenient and easy to use. I couldn't live without it now, keep up the great work!
  13. Offline


    hey you Kossen, people can get the premise of this pluginsen so people can go into themnot just admin
  14. So, I realize this is a forum for server mods, but is there a way to install this and run it in Single Player? I don't run a server, but I am working an a huge project to create a 1:1 replica of Koholint Island from Legend of Zelda: Link's Awakening, and there are portals on the island that I would love to emulate, and they run circularly just like these do. Also, I don't know much (read: anything) about java, so, is a .class just a .txt with the suffix changed? Like, could I change Config.class to Config.txt, change DIAMOND_BLOCK to GLOWSTONE, resave it as a .txt and then change the suffix back to .class? Same question for .zip and .jar? (Sorry to be dev noob on a dev forum; I am quite experienced at *playing* minecraft, but I have zero programming experience.)
  15. Offline


    Hey whenever I click on the diamond block with the clock nothing happens.. Any ideas as to why?
  16. The plugin didn't load? Check your server console, you should see something like this:
    2011-09-23 01:25:26 [INFO] [CreativeGates v1.3.0] === ENABLE START ===
    2011-09-23 01:25:26 [INFO] [CreativeGates v1.3.0] Will use this plugin for permissions: PermissionsEx v1.14
    2011-09-23 01:25:26 [INFO] [CreativeGates v1.3.0] Downloading library gson.jar
    2011-09-23 01:25:40 [INFO] [CreativeGates v1.3.0] Creating default: plugins\CreativeGates\conf.json
    2011-09-23 01:25:40 [INFO] [CreativeGates v1.3.0] === ENABLE DONE (Took 14491ms) ===
  17. Offline


    This is fun... When I installed the new Bukkit, i get an error that the gates arent valid... When i try to reactivate i get "There is no valid frame for this gate"

    Of course there isn't a valid frame... not like I've been using this plugin for months with the same gates or anything...
  18. Offline


    Same problem here... Just upgraded to 1317
  19. can u update please its not working for me :( [creeper]
  20. Offline


    Regardless of what I do, it always tells me "There is no valid frame for this gate".
  21. Offline


    Agreed since the latest update I am also getting the same message. "there is no valid frame for this gate", So i went back to the last build but all of my gates need to be reset. :(
  22. Offline


    Just to report 1.1.4 doesn't work with 1317.
    Josephdennis what version did you use to get it working? 1.3.0?
  23. Offline


    I'm running 1.3.1. And I fixed it, by going back a build in Bukkit itself. But I'm not happy with that answer, of course. Also, just throwing an idea out there, how about adding a config option to change the material that the gate has in the middle, to perhaps a portal block or air?
  24. Offline


    Version 1.3.1 of creative gates and i am not sure what my version is of craftbukkit. If you know how to check i will tell you.
  25. ...so, you have no good news for me today...
  26. Offline


    Any idea if this great plugin will be updated for the new bukkit, 1317? I updated because I was getting tile entity errors but now this and worldmanager broke. The way my host is set up, I cannot go back in versions :(
  27. What must I do to make my multiworld compactable whit this (look at signature for link)
  28. Offline


    the pluggin is still not updated... for those who are checking
  29. Offline

    Olof Larsson

    New version is out now :)
  30. Hey, is there any possible way to use this in Single player? Or do you *have* to have craftbukkit and a server to run it?
  31. Unfortunately, it's still busted for me.

    Bukkit 1318
    CG 1.3.2

    When I try to create a gate (I used glowstone in a 5x5 square) and hit the keystone with the watch, it returns "There is no valid frame for the gate".

    I tried removing the old config files/directory and letting the plugin make a new one with no change.

    It's also not making a conf.txt

    EDIT: Never mind, it's working now. I may have had a conflict before and just didn't realise it. Sorry for any confusion. :)

Share This Page