TOWNY and Iconomy Error

Discussion in 'Bukkit Help' started by Desolationri, Nov 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline



    x64 bit computer
    windows vista
    Towny v0.77.1.0
    iconomy 6.0.7b
    bukkit 1337
    no permissions plugins added in
    register v1.5
    questioner v0.4
    server owner for 3 days :rolleyes:

    For a while now I've been have trouble with Towny and its getting really annoying. So first, i experienced players not being able to build or destroy in wild with the settings enabling the to be able to but they still couldn't. I fixed this by removing all my plugins and adding them in stages. I left some out but anyways that problem was fixed.

    Now to the point of this post. While trying to use the command
    /town new town
    town - replaced with some names.
    i get a message saying "internal error occurred while trying to perform this command"

    In the cmd prompt, it says

    Show Spoiler
    17:24:37 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'town
    ' in plugin Towny v0.77.1.0
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.

    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:108)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.IncompatibleClassChangeError: Expected static method
    at com.palmergames.bukkit.towny.object.TownyEconomyObject.getEconomyAcco
    at com.palmergames.bukkit.towny.object.TownyEconomyObject.getHoldingBala
    at com.palmergames.bukkit.towny.object.TownyEconomyObject.canPayFromHold
    at com.palmergames.bukkit.towny.object.TownyEconomyObject._pay(TownyEcon
    at com.palmergames.bukkit.towny.command.TownCommand.newTown(TownCommand.
    at com.palmergames.bukkit.towny.command.TownCommand.parseTownCommand(Tow
    at com.palmergames.bukkit.towny.command.TownCommand.onCommand(TownComman
    at org.bukkit.command.PluginCommand.execute(
    ... 12 more

    i have no idea why this error is occurring. I have had an error saying I didn't have enough money to make a town in the past but that was converted to this.

    now here are both the configs for both my Iconomy and Towny if needed.



    i have no idea what can be going wrong. i have tried so many things. I have tried changing to BOSEconomy and Iconomy 5. Any suggestions?


    bump :l

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 21, 2016
  2. Offline


    have you edited any of the config files?
  3. Offline


    same problem here, we use the essentials economy plugin so we had to install register.
    Without register installed i get a message i can't afford .......
    when i install register its an internal error occured
    i only get this when i use /town new name
  4. Offline


    redownload the plugins
    it works
  5. Offline


    You most likely have a plugin (or two) that doesn't support register.jar. Remove everything except your permissions plugin, your eco plugin, towny.jar and register.jar. Add plugins one at a time until you know which ones conflict with register.jar. Then see if the plugins need updating/contact the author and ask him/her to support register 1.5
  6. Offline


    Dude thanks i love you! I'm trying to do an rpg kind of server so i have heroes in the plugins. Heroes is what was causing the error! thanks i fixed it now and i can buy a new town and it will actually cost money!
Thread Status:
Not open for further replies.

Share This Page