[TOOL/ADMIN] Bukkit Server GUI v1.1.4544 - A (.NET) GUI for the Bukkit Server

Discussion in 'Bukkit Tools' started by Kanshunin, Jul 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    So, next release 1.1.4372 is available. I have fixed a lot of things, and added some features.

    Please test it and tell me what you think, and report to me if you got an error. As always, i will do my best to get rid of it :)
  2. Offline


    Due to a bug within the process priority, ive released a new version with some more extras.. the priority can now be choosed manually too.
  3. Offline


    this is a great GUI, simple and easy to use but not easy to setup. how would i set this up to work with a lan server?

    for example the pc im on now is my Development and gaming rig. i have another pc thats on that controls ALL server related activitities. How do i use this GUI to control the server from my game & dev rig?
  4. Offline


    The GUI is not administering the bukkit remotely, so you need to have the gui running on the same system where your bukkit is held. BUT, you can use the webinterface of the gui to administer the tool from your control pc.
    TopGear93 likes this.
  5. Offline


    hi, i really like this gui. i used it for an long time now. recently i found out that you can remotely access your gui. enabled the option, have my bukkit running on port 3000, works, port forwarded 25565 too so i put the remote control on 25565. works on my computer, using google chrome, tried it in school, google chrome, i tried it via teamviewer with my frend, internet explorer, wont work. do you know what can be the problem? internet explorer?

    EDIT: tried it on my computer with internet explorer, wont work. what is my problem?
  6. Offline


    Hi, seems like a really good program , but i'm having trouble . I keep getting this message:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    ************** Exception Text **************
    System.IO.FileNotFoundException: Could not load file or assembly 'ICSharpCode.SharpZipLib, Version=, Culture=neutral, PublicKeyToken=1b03e6acf1164f73' or one of its dependencies. The system cannot find the file specified.
    File name: 'ICSharpCode.SharpZipLib, Version=, Culture=neutral, PublicKeyToken=1b03e6acf1164f73'
      at .(Boolean )
      at  .(Object , EventArgs )
      at System.Windows.Forms.Form.OnLoad(EventArgs e)
      at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
      at System.Windows.Forms.Control.CreateControl()
      at System.Windows.Forms.Control.WmShowWindow(Message& m)
      at System.Windows.Forms.Control.WndProc(Message& m)
      at System.Windows.Forms.Form.WndProc(Message& m)
      at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    ************** Loaded Assemblies **************
        Assembly Version:
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
        Assembly Version: 1.1.4375.616
        Win32 Version: 1.1.4375.616
        CodeBase: file:///C:/Users/Opifex/Desktop/MineCraft/Rebirth/BukkitServerGUI_64.exe
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
        Assembly Version: 1.1.4375.616
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
        Assembly Version:
        Win32 Version: 4.0.30319.1 built by: RTMRel
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    For example:
        <system.windows.forms jitDebugging="true" />
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
  7. Offline


    the system cant find that file. try to redownload everything, i think it will work
  8. Offline


    Thanks that after this long term of "not updating the gui" some people still using it :).

    Of what kind is the problem?. Does the IE wont display the GUI correctly, or does it actually cant connect to the server? (Consider the wan/lan ip when connecting.. dont use your own wan ip on your local lan.)

    On the first issue i can work to make it browser compatible, but
    if you experiencing the second issue, it should work with every browser/tool where you can specify ip/port.

    rity177 : copyyou is right. The original rar package should have the "ICSharpCode.SharpZipLib" included in the root directory.
  9. Offline


    thanks for replying!!!
    (i think IE = internet explorer???)

    its IE that cant connect to the server, but google chrome can.
    google chrome can on my computer, internet explorer cant.
    google chrome can on another computer(and another network) but cant on IE(this is another computer than the previous.)
    so, its IE i think.
    and also, what does wan and lan ip mean? i suppose you mean my whatismyip.org ip? i tried it with both localhost:25565 and copysserver.zapto.org:255654 and myip:25565 on both google chrome and IE. again, google chrome works on them all, IE never.
  10. Offline


    yes, with IE i mean (internet explorer)

    If its an IE connection problem, then i cant help you very much within changing my code. :).

    But maybe i can help you to track the error.

    Does both pcs have some firewall issues?
    Does the security settings in the IE maybe block other ports than standard http/https ? (80,8080,443);

    Can you connect to other sites within the IE ? .. if yes, then try to set the GUI webinterface to port 80, and connect with IE then. If this works, then the IE itself or a firewall is blocking other ports expect standard web ports in conjunction to IE.

    IE works for me. Also on higher ports.. im using 33680 with no problems in IE/Firefox.
  11. Offline


    i tried very shortly now, will test out more tommorow. looks like port 80 is already taken i think. also, when i use localhost it searches localhost on google... thats kinda fail...
  12. Offline


    Are you using Skype? .. skype often catches the port 80 :) win7 also have a service running on port 80 depending on configuration.

    take 21 or 443 instead, IE yould be able to handle ftp or ssl as well.

    if your localhost doesnt work, then maybe you need to check your hosts file, or just use
  13. Offline


    yes im using skype indeed. so i use 443? ill look into it.
  14. Offline


    Hi Kanshunin,

    I just found out of thie bukkit GUI while searching the bukkit foruns.
    I wonder why you dont have this in plugins area since there is not a tools area.

    I installed this at school on the shitiest computer I can reach at the momment. Its a pentium 4 running at 3.6Ghz and 2Gb of memory.

    I didnt saw any CPU usage from the GUI. The main aplication is pretty awesome and will make life a lot easier.

    The reason Im replying is for a feature request which I think it will be very very easy to implement. On back-up I notice that it doesnt back-up the plugins folder and doesnt seem to give that option.

    Since nowadays a lot of info is stored in the plugins folder (plugins like AdminCmd and some economy plugins).

    So if you could add that option would be awesome. And if you can define a diferent interval for the plugin folder back-up would be perfect.

    Thanks a lot for the tool so far, too bad people dont know more about it.
  15. Offline


    copyyou you have pm :)

    Thank you for using my GUI :) .

    I will consider this plugin feature. I havent done much recently due to less response and feature requests.. and actually, because of my RL job. .. why cant somebody just send some million dollars :)

    Dont hesitate to advertise my tool *g*
  16. Offline

    Kyle Stilkey

    Hey, nice GUI, I like it, I hope to see an update on the Internet browser, like a way to let you know the PW/Username is entered in wrong.

    Other then that, no real complaints from me, I think I shall donate on my next Pay Day for your great work :)
  17. Offline



    Currently im working on the backup changes Ralm suggested and some fixes within the log window.. But the webiterface will also have new features in the new version.

    BTW. im still waiting for someone who make a new webinterface for me.. someone with better graphic and js/css skills than me ..
  18. Offline

    Kyle Stilkey

    Anyway you could direct message me, I don't know if you've blocked it or what but I would like to send you some stuff if your cool with it :)
  19. Offline


    Sure :) you have PM.
  20. Offline


    This GUI is still great! Just one bug in this version. The player's name in chat is not shown. Basically leaves me guessing as to who is saying what.

    Edit: seems like the chat-only log is broken too. :(
  21. Offline


    I really like the GUI and its FREE web interace :)

    But the web interface needs an overhaul/redesign, so I started working on a better web interace
    Here's a screenshot of my current (Phase I: Design) work.


    Edit: Design should be finished

    No I should be finished, creating a better version of the web UI.
    [​IMG] [​IMG]

    How to install: Replace index.html in BukkitServerGUI/webserver with the download index.html
    <Edit by Moderator: Redacted mediafire url>

    I'm currently improving the Web Interface (working on v.2.0)

    Here you can download v2.0 alpha 1 (Note: Not finished, but already useable)
    <Edit by Moderator: Redacted mediafire url>

    * Added menus to keep everything simple
    * Added a player manager (wraps around the console commands)
    * Plugin manager
    * Better design
    * Backup manager

    [​IMG] [​IMG] [​IMG]

    Attached Files:

    Last edited by a moderator: Nov 13, 2016
  22. Offline


    Works on mc v.1.2.3?
  23. Offline


    Yes. It's running very nice on our root server (now with the newest beta build) :)

    If you want to use my web interface, you have to replace the index.html in the webserver folder with the downloaded one.
  24. Offline


    Alpha 2 of Bukkit Server WebGUI v.2.0

    * Implemented design of Configuration, Update, Info
    * --> Future functions: Monitor CPU, RAM, World Size, Edit server.properties online (With a nice User Interface), Online backup manager
    * Added shortcut buttons to some important functions (--> Console screen)
    * Bugfixes/Designfixes

    [​IMG] [​IMG] [​IMG] [​IMG]


    ---> <Edit by Moderator: Redacted mediafire url>

    How to install?

    Replace webserver/index.html with the downloaded one. Nothing more.
    Last edited by a moderator: Nov 13, 2016
  25. Offline


    I've got problem:( Me and my friends are playing with Hamachi, Creative mode. And when I'm trying to start server it does not load any plugin. We are real newbie and don't know what to do. Can anybody help us?

    2012-03-06 14:32:45  [SEVERE] Could not load 'plugins\BSGUIPlugin.jar' in folder 'plugins'
    2012-03-06 14:32:45  org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: org/bukkit/event/player/PlayerListener
    2012-03-06 14:32:45  at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:148)
    2012-03-06 14:32:45  at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:287)
    2012-03-06 14:32:45  at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:211)
    2012-03-06 14:32:45  at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:207)
    2012-03-06 14:32:45
    2012-03-06 14:32:45
    2012-03-06 14:32:45  at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:156)
    2012-03-06 14:32:45  at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:425)
    2012-03-06 14:32:45  at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    2012-03-06 14:32:45  Caused by: java.lang.NoClassDefFoundError: org/bukkit/event/player/PlayerListener
    2012-03-06 14:32:45  at java.lang.ClassLoader.defineClass1(Native Method)
    2012-03-06 14:32:45  at java.lang.ClassLoader.defineClassCond(Unknown Source)
    2012-03-06 14:32:45  at java.lang.ClassLoader.defineClass(Unknown Source)
    2012-03-06 14:32:45  at java.security.SecureClassLoader.defineClass(Unknown Source)
    2012-03-06 14:32:45  at java.net.URLClassLoader.defineClass(Unknown Source)
    2012-03-06 14:32:45  at java.net.URLClassLoader.access$000(Unknown Source)
    2012-03-06 14:32:45  at java.net.URLClassLoader$1.run(Unknown Source)
    2012-03-06 14:32:45  at java.security.AccessController.doPrivileged(Native Method)
    2012-03-06 14:32:45  at java.net.URLClassLoader.findClass(Unknown Source)
    2012-03-06 14:32:46  at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    2012-03-06 14:32:46  at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    2012-03-06 14:32:46  at java.lang.ClassLoader.loadClass(Unknown Source)
    2012-03-06 14:32:46  at java.lang.ClassLoader.loadClass(Unknown Source)
    2012-03-06 14:32:46
    2012-03-06 14:32:46  at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    2012-03-06 14:32:46  at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    2012-03-06 14:32:46  at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    2012-03-06 14:32:46  at java.lang.reflect.Constructor.newInstance(Unknown Source)
    2012-03-06 14:32:46  at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:144)
    2012-03-06 14:32:46  ... 8 more
    2012-03-06 14:32:46  Caused by: java.lang.ClassNotFoundException: org.bukkit.event.player.PlayerListener
    2012-03-06 14:32:46  at java.net.URLClassLoader$1.run(Unknown Source)
    2012-03-06 14:32:46  at java.security.AccessController.doPrivileged(Native Method)
    2012-03-06 14:32:46  at java.net.URLClassLoader.findClass(Unknown Source)
    2012-03-06 14:32:46  at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    2012-03-06 14:32:47  at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    2012-03-06 14:32:47  at java.lang.ClassLoader.loadClass(Unknown Source)
    2012-03-06 14:32:47  at java.lang.ClassLoader.loadClass(Unknown Source)
  26. Offline


    The plugin needs an update. Just remove it, you dont need the plugin.
  27. Offline


    Redesign of alpha 2 (Not stealing the design of bukkit.org, anymore)

    <Edit by Moderator: Redacted mediafire url>

    [​IMG] [​IMG]

    What do you think about the redesign?
    Last edited by a moderator: Nov 13, 2016
  28. Offline


    Can anybody help me? When I'm trying to start server it stops after
    starting process...
    177 recipes
    27 achievements
    and you can wait but nothing happens! GUI is clear, computer was prepared to be server (only .NET, Java, Opera). What's wrong with it?
  29. Offline


    There are two possibilities:

    1. The version is defect
    2.They changed a part of the code that starting doesnt work anymore within the gui.

    Use version R5 instead, this version is working.

    Im investigating in R6 changes.
  30. Offline


    You mean that this is a common problem? And there is no chance to use gui with MC1.2.3?
Thread Status:
Not open for further replies.

Share This Page