Too high CPU Usage

Discussion in 'Bukkit Help' started by theone_123, Dec 2, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    theone_123

    Hey Guys!

    I'm having some problems with my Craftbukkit 1.4.5 R0.2 server. I think the CPU-usage is to high for the java process of craftbukkit.

    My server specs are:
    Intel Core i7-2600
    16 GB DDR3 RAM
    100 Mbit internet speed
    OS: Ubuntu 12.04 Server

    I used top to determine the cpu usage and noticed that it was over 100% for a short time. Now its around 50% with only 5 players on. I also run an tekkit server. I dedicated 3GB of rams to bukkit. The strange thing is that even if the CPU-time of the process is over 100% the cpu is idle for about 85%..

    Plugins installed: BKCommonLib, permissionex, Worldedit, LWC, worldguard, nolagg, essentials, dynmap (lowres)

    Thanks in advance!
     
  2. Offline

    BMX_ATVMAN14

    Try to get rid of NoLagg and see how that does
     
  3. Offline

    theone_123

    It was the same before nolagg. What i dont understand is Why top shows me that my cpu is 85% idle or even more. But the java process uses oder 100% cpu time.
     
  4. Offline

    BMX_ATVMAN14

    How many servers do you have running on this machine? I'm running 1 server on mine and I only get about 12% usage average
     
  5. Offline

    theone_123

    I only run one craftbukkit server and one tekkit server. And always only one world!

    Edit: I forgot to mention that i run the server in a ramdisk!
     
  6. Offline

    BMX_ATVMAN14

    Hm... Maybe update Java? Nolagg uses 100% of my CPU when I use /nolagg fix , So I'm sure there is other commands that do that as well,
     
  7. Offline

    theone_123

    I already run the latest version of sun java 64 bits!
     
  8. Is there any plugin that puts your server using more ram instead cpu? I've 32gb ram server and 4 core 2.7ghz, but i've noticed that the server never passes de 4gb ram, but cpu is almost 70% always
     
  9. Offline

    BMX_ATVMAN14

    Well I'm lost, sorry
     
  10. Offline

    theone_123

  11. Offline

    Symbiosis

    Close any unnecessary programs you have running. Also, try making your graphics (clouds, render distance, fog, you get the point...) set to a lower level or turned off: |Clouds: Off| |Render Distance: Either Tiny, Short, or Normal is recommended| |Fog: Off|
     
  12. Offline

    theone_123

    It's a server side problem not client side. My Server should be capable of handling 5 players on one world totally lag free. So there has to be a problem somewhere.
     
Thread Status:
Not open for further replies.

Share This Page