Teleport/World loading related crashes

Discussion in 'Bukkit Help' started by Derek Peterson, Feb 8, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Derek Peterson

    Hey all,

    In the last few days, I introduced portals to my bukkit plugin. This means the server is constantly teleporting players here and there. I also added a portal to a nether world when multiworld support was released.

    My server has since been crashing quite a bit, with absolutely nothing being printed out. I'm running java with with this flag:
    But nothing is ever printed out to that file, either.

    I've isolated the crashes to being caused when a player has a weird issue teleporting. Sometimes the chunks fail to load or something, and the user just falls. (Longer than is expected while the chunks load) It seems to be this that makes the server crash unexpectedly.

    I have been able to replicate this, but not anywhere near every time by using a command that just runs player.teleportTo(location).

    Does anybody have any ideas of how I can get more information out of this crash? I would report this as a bug in Bukkit, but I don't think this information is very useful without a stacktrace or something...

    Thanks in advance,


    1. What OS are you using: Ubuntu 10.10 Server (kernel x64
    2. What architecture is the OS you are running (x64 or x86)? x64
    3. What version and architecture is your java install?
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9) (6b20-1.9-0ubuntu1)
    OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)
    4. Are you running any wrappers? Nope.
    5. What build of CraftBukkit are you running? 287

    6. What command are you using to run your CraftBukkit server?
    java -server -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -XX:ErrorFile=/home/peacecraft/javaerror.log -Xmx1536M -Xms512M -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
    (I know people are going to jump all over those GC flags, but I've been using them since Bukkit was announced with no troubles, and I get this crash with or without them.
    7. What plugins are you running?
    8. What error are you getting (post your server.log file if possible)?
    No errors, the server just stops.

    9. What have you tried already?
    Tried to isolate the problem, it seems to be related to teleportation.
Thread Status:
Not open for further replies.

Share This Page