Specific chunks keep resetting?

Discussion in 'Bukkit Help' started by xemnes, Mar 22, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Recently there has a been a strip of land over our world where the land has decided to regenerate into flatland, at first i was like ugh i have to terraform that now. i have recently started doing so but for some reason, every time i do anything within these junks and move away and go back into the chunks. Everything i just done disappears, it seems to keep resetting those chunks -.- i have run Minecraft region fixer which fixed over 200 chunks so i assumed that was solved... nope, still the same issue. I have these huge holes in that land that will forever be there and i dont understand why its doing it!
    has anyone else had this issue? or knows ho to fix it?​
    update: i have gone over these chunks in mcedit and deleted then placed land within these chunks, loading the server back up and going back to them makes no difference, i dont understand what is causing these chunks to regenerate to flatland.... these chunks are right in the path of a build and without the ability to edit them, the project is not going to continue! regenerating the entire map is not an option due to the fact the world is covered in many peoples builds due to the world being the main world. the world is an ongoing project to create a coherent lore based world.

    edit: it turns out if the save-all comamnd is used (my server does this command every 5 minutes) whilst the chunks that i edited are unloaded causes the reset.

    you can see the affected chunks across the world just above spawn, the big holes:

    heres some screenshots:

    after i move away and type /save-all


    1. What OS are you using (Brand and version - Ex. Windows XP SP3 or Windows 7 x64)?
    Debian Linux 6.0

    2. What architecture is the OS you are running (x64 or x86)?

    3. What version and architecture is your java install? (Type: java -version in command prompt.)
    java version "1.7.0_11"
    Java(TM) SE Runtime Environment (build 1.7.0_11-b21)
    Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)

    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc?
    5. What build of CraftBukkit are you running? (do NOT say latest. Say the build number.)
    The build number is displayed in the top of the server.log.
    craftbukkit 1.4.7 r1.0

    6. Pastebin.com/Pastie.org your server.log, server.properties and bukkit.yml files.
    bukkit.yml > http://pastebin.com/j6hAKeCn
    server.properties > http://pastebin.com/13dFnrvL

    Now that you've given us all the basics, now we get into the more advanced stuff. Note, if you haven't answered 1-5 yet, answering 6-10 will be almost pointless.

    7. What command are you using to run your CraftBukkit server?
    java -jar Xms 8G -Xmx 8G craftbukkit.jar

    8. What plugins are you running?
    SimpleAFK, CommandSigns, PlugMan, VoxelSniper, TabToTheMax, Buycraft, PluginManager, ToolBelt, WorldModes, Vault, Multiverse-Core, RemoteToolkitPlugin, dynmap, GroupAnnouncer, VoxelUpdate, PetitionPlugin2, Colors, StopDaWarts, SparkTrail, TeleportSuite, SaplingGarden, bSpace, SpaceBukkit, ProtocolLib, Votifier, ForcedGrammar, TabAPI, LagMeter, Citizens, WorldEdit, FlatlandsBuilder, CreativeFireworks, StandardBooks, PermissionsEx, Stargate, LogBlock, NoEnderpearl, TheCleaner, ConsoleSay, InfinitePlots, QuantumConnectors, EasyVanish, NewCB, TeleParticles, FallingBlocks, CommandHelper, AlmostFlatLands, MinecartMania, CommandPermissions, FC_Suite_Shared, EntityAdmin, Modifyworld, MyWarp, VoxelPort, ManySmallTweaks, Giant Trees, WorldBorder, ShowCaseStandalone, Multiverse-Portals, StargateCommand, VoxelModPackPlugin, CommandBook, PlotMe, MCBans, VotifierScripts, Denizen, ChatManager, WorldGuard, FC_Announcer, HomeSpawnPlus, CraftBook, WeatherMan, BaseBukkitPlugin

    9. What error are you getting (remember to post your server.log file (from the start to finish of your server) - pastebin.com or pastie.org please)?
    there are no errors

    10. What have you tried already?
    regionfixer. i dont know what else to do. regionfixer reported and fixed errors but its still happening
  2. Offline


    Looks like a world corruption.
  3. Offline


    that doesnt help me... as i have said, i have run regionfixer and it would have cleared up corrupt world chunks.
  4. Offline


    Is that the only world it happens with? If so, try shutting off the server, temporarily renaming that world's directory, then starting the server and allowing it to generate a new world. See if the issue occurs again with the fresh world.
  5. Offline


    just tried it, the issue doesnt occur, this issue happened after we transfered servers, looking at the region files i noticed there are some missing, so i assumed it didnt transfer properly meaning some files didnt get transfered but that doesnt explain why they refuse to be edited at all...
  6. Offline


    I don't know enough about the mechanics of world saving, region files, or world generation to be able to explain that, but now that you know it's an issue with the world, you could try restoring from a known-good backup, if you've got one.
  7. Offline


    i dont lol, the backups were lost during the transfer. ive looked past this the holes for quite some time when i one day decided i wanted to fix them. as previously mentioned i felt they were just lost chunks as they are regenerating so i thought its easier to just terraform over them. recently i noticed my mcr files before the anvil format were still there so i copied those and converted them to the mca format and set that up as a worldedit snapshot, i can select the areas ans //restore and it restores them back to how they were. but as soon as i move away and use /save-all or restart the server, they just regenerate =S

    i have looked all over to figure out this issue and i have not found any solution, this map means a lot to the server and i cant just regenerate a new one and just copy the important stuff over as the world is huge (10k blocks from the center to the edge) tons of buildings are scattered all over. its a project to create a world with detail and make it coherent with backstories. not just some random creative world where people can build what they like anywhere. i have asked a lot of people on my server what they thought about regenerating a new world, the simple answer is... most dont like the thought of it.

    only fix i would think of is a tool that creates a new map and transfers all the block data into the new map leaving everything else behind. but i doubt theres a tool for that. =S

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  8. Offline


    As they said its a corrupt map and delete the map and restart. If your players ask what happened just say it was corrupt.
  9. Offline


    And as I have said. I can't do that. I have already asked my players and they dislike the idea. It would destroy the project. It's specific chunks on a specific strip of the map. Not the entire map. I'd rather find a fix than go through the hassle of ruining a perfectly good map with about 2 years of work on it and risk losing my valuable playerbase
  10. Offline


    Then mcedit it :D
  11. Offline


    mcedit what? the entire map? (10kx10k blocks of land?) if you mean each building, worldedit is better but its not just buildings, its entire land due to custom terraformed terrain.
  12. Offline


    I don't think you understand. Those things don't fix up the chunks that are corrupted. They just stop the corruption. The corruption could always happen again if you don't fix the problem at the source. But there is one thing you can try. Select the area that the chunk is all messed up in and do //regen with worldedit. That may work, but it will reset the land back to its original state.
  13. Offline


    That could work or it could fuck up his whole server. I've done it before :D
  14. Offline


    well the problem is that those chunks are already regenerating back to their original state, i dont think //regen does anything more than just place blocks and the biome data according to the world seed, it doesnt exactly modify region data
  15. Offline


    Well //regen regenerates it to when the map was first generated.
  16. Offline


    with a map dating back to beta 1.7 that information doesnt exist //regen regenerates to the worlds seed. this is besides the point though, this pretty much does what //restore does as to get back my old land i restore using a world backup as //regen doesnt work with old maps anymore.
  17. Offline


    //restore will get rid of most of your work. So that would be a waste.
  18. Offline


    so will //regen, i dont think you quite understand the situation =S the map was created in bet 1.7, the generation of the world has changed since then. the seed of the map is completely different to what it used to be back when i first created the map. the map has huge holes above spawn stretching from one end of the map to the other in a strip. the land will generate when going into these areas and the land does not look the same as the land that is left unaffected. placing blocks, //regen (which is pointless as it does nothing because the land is already regenerated) using //restore, terraforming, deleting the area using //set 0 then moving away, type /save-all or restart the server, go back to those chunks and any changes i made listed above will be gone as the map seems to keep regenerating the land within those holes after a map save

    if needed, if you still dont quite understand the situation, i can literally show you on my server what happens as its easily replicable
  19. Offline


    What you dont get is your map is probally too big. And you keep having these errors. And you think that //regen will not work and it will. Now if this is solved please make this post solved.
  20. Offline


    ok i used //regen, it doesnt work as i said it wouldnt. //regen only handles block data and biome data based on the seed. it doesnt modify chunk data. however maybe mcedit can
  21. Offline


    I hate to bump an old thread, but I just ran into the same situation on a relatively new map but still quite a few hours of work on it. I originally decided to use this odd strip of land for a road and it kept regenerating. More odd is the fact that the strip goes through a Taiga, registers as a Taiga, but looks like a Plains, which is why it caught my eye for a nice place to put a road.

    Since I searched Google and this thread came up at the top, and after a couple hours of research only to figure out that no one has yet to find a workable solution for an in-service server, I decided to reply to this thread with a decent solution in case someone types the same question I did.

    Now I am familiar with corrupted chunks, but I never made the connection to corrupted regions. You see, that "Plains-looking" strip of land through the Taiga is actually a strip of chunks that played musical chairs with other chunks in the same region. Kind of like mixing up a puzzle. After running the process to repair the regions found here: https://forums.bukkit.org/threads/how-to-fix-your-world-errors-corrupt-chunks.54254/ I still had the same reversion problem as described in the OP. You can repair the region, but it will keep trying to re-arrange the chunk order thus clearing any post-generation blocks built by the user.

    Ok, so now what? Well, the solution is so simple, but it is tedious, so you will have to perform this during a maintenance window where you can shut down your server for a couple hours without your users complaining. Before doing anything, backup your world, :rolleyes:.

    1) Shut down the server.
    2) Copy your region files into your Dev environment. (You do have a Dev environment right? :confused: , and it runs with at least 16 gigs of allocated memory right? :D You ARE going to need this later on. ;) ) Make sure you have the most recent version of the release you are running. If you are running 1.6.4 and it was a few builds before the last 1.6.4 build, use the last 1.6.4 build in your Dev environment.
    3) Copy/rename the world in the root folder to world_old.
    4) Go to the world folder and delete the data files so when you start it up, it will regenerate the entire world from scratch.
    5) Start up the Dev server and let it generate the world.
    6) Teleport to the world_old location of the region and select->//schem save all your precious buildings. (If it's a town or something, just save the entire cuboid, (this is where you will need gobs of RAM on your Dev server and the client you are running to paste it later.)
    7) Paste the schematics into the region on the new world.
    8) Shut down the server and copy the fixed world region into the world_old folder.
    9) Rename the world folder to world_wk and rename the world_old to world.
    10) You should now be good to go with this 'new' world, so go ahead and upload it

    The only issue is that you will likely find more regions with this problem, I haven't yet, but I am prepared to deal with it early on and hopefully won't have much work to do to salvage builds if I can catch the regions before they are too developed.

    Happy copy/pasting!
  22. Offline


    my server has over 7000 region files , and a lot of(may be over hundred,and i dont know where is,players use this bug to mining diamond ) chunks has this problem,, so i cant use this way to fix my server map.
  23. [Edit] Previous Post Erased Because My Previous Method Of Fixing It Failed

    So my first Suggestion Didn't work either...

    Under closer inspection the problem persisted. Although I did notice something while marking the chunks as "Warning,Broken" in Factions to make it so people knew. What I noticed was two numbers,
    (conquered 1 chunk world 3,4) after you claim the chunk. What was this? I wondered before looking at other chunks. It was marking locations. Chunk locations. I had seen these numbers before and had a suspicion, so I made a backup of my world and opened some files to look at my the place I thought I had seen them before. FOR ME (Desktop/BukkitServer/world/region) here is where i looked at all the numbers and files (It goes into the hundreds for me) I found where the broken chunks were supposed to be and discovered where* they were in the folder. So I'm going to look through and see what the issue is with those files and then try a few things and report back soon!

    [Edit] So It seems my prior assumption was incorrect. I have been doing some digging and it turns out Region IS marking chunks, and it IS using the same numbers, But Region measures in 32x32 chunks rather than by 1x1 chunks as presumed. So my idea of generating another world, stealing the chunk file and pasting the old one over it in the new file wont work.
    (Fir more info on Regions check here http://minecraft.gamepedia.com/Region_file_format )
    As I am unable to personally get the .mca files to open in a readable format, It makes me wonder if there is any actual way to get in and find the problem.
    Last edited: Feb 22, 2015
Thread Status:
Not open for further replies.

Share This Page