[Solved] Please help: operators have all permissions and non-ops have none

Discussion in 'Bukkit Help' started by subkid, Nov 5, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    subkid

    I am using the latest Bukkit RB, along with PEX, WorldGuard, Essentials, and Spout. When a player that is not an op logs on to the server, with or without PEX enabled, they cannot do anything at all except build. No commands except /pex and /plugins seem to work. However, when someone is an op, regardless of their permissions, they have access to all commands (I banned myself as a guest while testing this). This is confusing, as PEX's config.yml says "allowOps: false"

    OS: XP SP3
    Bukkit: 1337
    Java: 1.6.0_27

    Please?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  2. Offline

    subkid

    Not completely solved as to why non-ops could do nothing with PEX disabled, but I had PEX misconfigured, giving everyone no permissions when it was enabled. Funny thing though, AllowOps was off.

    Whatever. Fixed.
     
Thread Status:
Not open for further replies.

Share This Page