[SEVERE] java.net.SocketException: Socket closed

Discussion in 'Bukkit Help' started by brad00, Jan 29, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    1. What OS are you using (Brand and version - Ex. Windows XP SP3)?
    Windows 7 Pro SP1
    2. What architecture is the OS you are running (x64 or x86)?
    3. What version and architecture is your java install?
    4. Are you running any wrappers? McMyAdmin, mcadmin, Hamachi, etc?

    5. What build of CraftBukkit are you running?
    git-Bukkit-1.1-R2-b18 40jnks
    6. What command are you using to run your CraftBukkit server?
    7. What plugins are you running?
    8. What error are you getting (post your server.log file)?
    9. What have you tried already?
    Re-installing Java. (Problem persists.)

    Starting new bukkit server from scratch. (Problem persists.)

    Changing Router Settings. (The settings are rrelevant due to next troubleshooting method.)(Problem persists.)

    Plugging directly into the modem. (Problem persists.)

    Installing Bukkit on orher operating systems and machines: Ubuntu 10.10 x86, Windows 7 Home Premium x64 (Problem persists.)

    Running with java 6 update 30 instead of java 7 (Problem persists.)

    Removing all plugins and running the server. (Problem persists.)

    Playing on LAN. (Problem persists.)

    Switching to 1185 (1.81) - The issue becomes nonexistent, but this is hardly a fix.
    10. Run the vanilla Minecraft server (no Craftbukkit). Does the error/problem still occur?
    11. Remove all your plugins and try with just CraftBukkit. Does the error/problem still occur?

    Other Details:
    If information I have listed above is not enough to solve this error or to come to an conclusion as to why it is happening; please let me know. As I listed under question 9, even users on LAN still receive the end of stream error. Switching back to craftbukkit 1185 seems to fix the issue but, I would rather not run an out of date server. I know it is not related to my machine or router; as I have tried without both. I work in a tech support so I would like to think that my troubleshooting skills are not awful; there must be something I am missing here or maybe even just doing plain wrong. Also, when looking at minecraft's players list whomever joins second and so on shows a low ping on the first players connection list. While all other players on their connections list show the a perfect ping. (Note it only does this on bukkit servers.)Not sure if that has anything to do with the endofStream errors but it may be relevant.

    The following screens are examples of above. (This is online play but LAN has the same results)
    Player One's Screen: http://i.imgur.com/j823f.png
    Player Two's Screen: http://i.imgur.com/oSU9B.jpg

    System Specs:
    CPU: Phenom II x 4 3.4 GHZ
    RAM: 4GB
    Connection Speed:
    Download - 15. 35 Mb/s
    Upload - 3.18 Mb/s

    Amount of Players - 2 to 4

    Just updated to 1.1-R3, still receiving endOfStream errors.
    I have been troubleshooting this for weeks and reverting back to 1.81 seems to be the only fix that I can find.

    Any ideas?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 23, 2016
  2. Offline


    Guess no one knows? (Last Bump)
  3. Offline


    I get this error also sometimes but it never crashes my server it just "occurs". If it is not affecting anything i would leave it be.
  4. Offline


    I get that error too, it gives the error and kicks the person but the server doesn't crash, just kicks people. I need some help on this too, anyone that could help will put a smile on my face! Thanks
  5. Offline


    It doesn't "crash" the server, it causes players to lose connection to the server. This occurs through online play and through LAN. The occurrence is completely random it can take five minutes for it to occur or it could take five hours.

    After, looking through the forums I am starting to think this is a bug. Most if not all of the topics go unanswered or have no solution to the problem. I would look through the code and try to fix the error myself but when it comes down to big-O (Optimization) my programming skills are pretty bad. I'm a tech not a programmer.
  6. Offline


  7. Offline


    Thanks for the reply but, I have tried all the possible solutions listed in that thread. ;)
    Seems this error goes quite far back for some people.
  8. Offline


    Ye, I've seen it quite a lot. Doesn't seem to have a fix for it..
  9. Offline


    try setting up your .bat start file a little differently, I had a similar error before i changed the .bat file to this...

    use java 6 btw.
  10. Offline


    Mukrakiish likes this.
  11. Offline


  12. Offline


    i get the same thing, here is what i got today

    174 recipes
    27 achievements
    19:05:14 [INFO] Starting minecraft server version 1.1
    19:05:14 [INFO] Loading properties
    19:05:14 [INFO] Starting Minecraft server on xxx.xxx.x.xxx:25565
    19:05:15 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    19:05:15 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    19:05:15 [WARNING] To change this, set "online-mode" to "true" in the server.properties file.
    19:05:15 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R3-b18
    46jnks (MC: 1.1) (Implementing API version 1.1-R3)
    19:05:15 [INFO] Preparing level "NewWorld"
    19:05:15 [INFO] Default game type: 0
    19:05:16 [INFO] Preparing start region for level 0 (Seed: -2272206290904489676)
    19:05:16 [INFO] Preparing start region for level 1 (Seed: 9156462256522725959)
    19:05:17 [INFO] Preparing spawn area: 48%
    19:05:17 [INFO] Preparing start region for level 2 (Seed: 9156462256522725959)
    19:05:17 [INFO] [WolvesOnMeds] Loading WolvesOnMeds v1.4.
    19:05:17 [INFO] WolvesOnMeds v1.4 enabled.
    19:05:17 [INFO] [Lockette] Loading Lockette v1.4.9 beta.
    19:05:17 [INFO] [Lockette] Version 1.4.9 beta is being enabled! Yay! (Core version 1.3)
    19:05:17 [INFO] [Lockette] Detected craftbukkit build [1846] ok.
    19:05:17 [INFO] [Lockette] Using ops file for admin permissions.
    19:05:17 [INFO] [Lockette] Ready to protect your containers.
    19:05:17 [INFO] [WorldEdit] Loading WorldEdit v5.1.1.
    19:05:17 [INFO] WorldEdit 5.1.1 enabled.
    19:05:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    19:05:17 [INFO] WEPIF: Using the Bukkit Permissions API.
    19:05:18 [INFO] [iZone] Loading iZone v7.1.
    19:05:18 [INFO] [iZone v7.1] NewWorld.pvp = false
    19:05:18 [INFO] [iZone v7.1] NewWorld_nether.pvp = false
    19:05:18 [INFO] [iZone v7.1] NewWorld_the_end.pvp = false
    19:05:18 [INFO] [iZone v7.1] Enabled!
    19:05:18 [INFO] [iZone v7.1] Loaded 7 zones
    19:05:18 [INFO] [MobHealth] Loading MobHealth v3.1.
    19:05:18 [INFO] [MobHealth] Version 3.1 starting.
    19:05:18 [INFO] [MobHealth] Permissions Disabled.
    19:05:18 [INFO] [MobHealth] Spout Enabled.
    19:05:18 [INFO] [MobHealth] Player Notifications Enabled.
    19:05:18 [INFO] [MobHealth] Monster Notifications Enabled.
    19:05:18 [INFO] [MobHealth] Animals Notifications Enabled.
    19:05:18 [INFO] [MobHealth] Chat Features Enabled.
    19:05:18 [INFO] [MobHealth] Online.
    19:05:18 [INFO] Server permissions file permissions.yml is empty, ignoring it
    19:05:18 [INFO] Done (2.298s)! For help, type "help" or "?"
    21:15:38 [INFO] WilPlayer [XXXXXXXXXXXXXXXX] logged in with entity id 38
    21:15:47 [INFO] Connection reset
    21:15:47 [INFO] WilPlayer lost connection: disconnect.quitting
    21:15:47 [SEVERE] at java.net.SocketOutputStream.socketWrite(Unknown Source)
    21:15:47 [SEVERE] at java.net.SocketOutputStream.write(Unknown Source)
    21:15:47 [SEVERE] at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    21:15:47 [SEVERE] at java.io.BufferedOutputStream.flush(Unknown Source)
    21:15:47 [SEVERE] at java.io.DataOutputStream.flush(Unknown Source)
    21:15:47 [SEVERE] at net.minecraft.server.NetworkWriterThread.run(SourceFile:103)
    21:51:43 [INFO] CONSOLE: Forcing save..
    21:51:43 [INFO] CONSOLE: Save complete.
    21:51:45 [INFO] CONSOLE: Stopping the server..
    21:51:45 [INFO] Stopping server
    21:51:45 [INFO] [WolvesOnMeds] Unloading WolvesOnMeds v1.4.
    21:51:45 [INFO] WolvesOnMeds v1.4 disabled.
    21:51:45 [INFO] [Lockette] Unloading Lockette v1.4.9 beta.
    21:51:45 [INFO] Lockette is being disabled... ;.;
    21:51:45 [INFO] [Lockette] Closing all automatic doors.
    21:51:45 [INFO] [WorldEdit] Unloading WorldEdit v5.1.1.
    21:51:45 [INFO] [iZone] Unloading iZone v7.1.
    21:51:45 [INFO] [iZone v7.1] Disabled!
    21:51:45 [INFO] [MobHealth] Unloading MobHealth v3.1.
    21:51:45 [INFO] [MobHealth] --- END OF LINE ---
    21:51:45 [INFO] Saving chunks
    21:51:45 [INFO] Stopping server
    >Press any key to continue . . .

    I run Windows 7, 64bit.
    WilPlayer runs a Windows 7, 64bit

    This is my Run.bat

    Echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-1.1-R3.jar

    Any ideas?
  13. Offline



    "WilPlayer lost connection: disconnect.quitting"

    WilPlayer left the game manually. That socket error is quite normal in Bukkit, and it will not affect your server in any major way.
  14. Offline


    funny.. it does.. he was sitting next to me when it kicked him...
    i see people say it doesnt do anything.. we had 4 people playing all players except me (i was playing on the server were kicked and not all at the same time.
  15. Offline


    I hate to say it, but I doubt we will receive a fix anytime soon.
    What is ignored cannot be fixed. Maybe a newer build will fix it eventually. :)
  16. Offline


    hope so, its not as bad after i put 1.1 R4 but still occurs and everyone gets kicked..
    but yesterday it happened once in a 3 hour game session with 5 people playing all off site.. so that is better then it was.. every 5 mins
Thread Status:
Not open for further replies.

Share This Page