Server suddenly stopped working.

Discussion in 'Bukkit Help' started by DrWombat, Mar 4, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Yesterday I noticed my newly downloaded CraftBukkit had started turning up an error when it was started, but it seemed to run fine. Today I tried to log in and the everything has gone to hell. Huge holes in the map, chunks not being generated, big lag, that kind of thing. I rebooted my vps (centos 64bit) and tried again but it was still the same so I generated a new world and logged into that. Only there wasn't a world for me to log into, just blue sky and plummeting. After about a minute or so I was disconnected and told 'recv failed'.

    I'm at a loss as to what's happened. Any insights?

    If it's any help, here's a grab of my console.
    Thanks guys.
    --- merged: Mar 4, 2011 11:26 AM ---
    Well I've got my world back... using build 493 seems to have worked. Still getting the IO exception on startup though.
  2. Offline


    What version of Java are you using?
  3. Offline


    Hi TnT... According to my VPS I'm using

    Java version "1.6.0_17"
    OpenJDK Runtime Environment (IcedTea6 1.7.5) (rhel-1.16.b17.e15-x86_64)
    OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
  4. Offline


    What's confusing me is that error is happening before the CraftBukkit server starts up - and saying "cannot run program 'sh'" then continuing onto your regular CraftBukkit startup.

    It looks like the error is occurring before CraftBukkit comes into play which makes me think its your Java. Can you try to either update it, or install Sun Java and give that a try?
  5. Offline


    I've started with a completely fresh install, with build 493 of craftbukkit. I've downloaded java with;

    yum install java-1.6.0-openjdk
    So I'm guessing that should be the current version? I've also tried;

    yum update java
    and it stays there's nothing new

    I have to confess, aside from doing that, I wouldn't know how to install Sun Java on to my vps. I'm something of a n00b when it comes to *nix.

    On a completely clean install, with build 493, I'm still getting the same error and the same .sh trying to run. The error doesn't show up in the server log either.

    /EDIT - If I run minecraft_server.jar I don't get the error.
  6. Offline


    Can you give me the output of the "alias" command please? In your terminal, type: alias - post the output here.
  7. Offline


    Here you are, I've no idea what any of it means ;)

    alias l.='ls -d .* --color=tty'
    alias ll='ls -l --color=tty'
    alias ls='ls --color=tty'
    alias vi='vim'
    alias which='alias | /usr/bin/which --tty-only --read-alias --show-dot --show-tilde'
  8. Offline


    I was looking to see if there was something aliased in your Java command, but there isn't.

    I am going to guess at this point it is your Java version. My suggestion is to try Sun Java and see if that helps.
  9. Offline


    I'll give that a go... is it as simple as doing the following, or is there a bit more to it?
    yum erase java
    yum install sun java
  10. Offline


    Mine is like that but you cant join tho i need help because all my friends play on it... is it due to the portfoward?
    please help me :( Mine suddenly stopped working one night when i opened it i really neeeeeeeeeeeeeeeeeeeeeeeed help! I wish i could copy and paste ! it....
Thread Status:
Not open for further replies.

Share This Page