Server not loading on VPS (linux)

Discussion in 'Bukkit Help' started by Dragoboss, Jun 6, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I'm trying to set up a server on a VPS (linux) for someone.
    I've transferred the server files, and try to start it with the, using putty.
    Now, it takes me to the "screen" I used in the sh file but it doesn't completely load. It doesn't go any further than the "This server is running #version#"

    Like this:
    (sometimes it does a little more, like: )

    I've been trying many things to fix it, but it just doesn't load...
    The port is open, the directory is -including it's subdirectories- chmodded to 777 (I'm going to change that as soon as it works). But it just doesn't load...

    Any idea's?

    Extra info on my system:

    Linux (hidden this, it's the host of the VPS, not relevant to the problem.) 2.6.32-11-pve #1 SMP Wed Apr 11 07:17:05 CEST 2012 i686 i686 i386 GNU/Linux
    java version "1.6.0_22"
    OpenJDK Runtime Environment (IcedTea6 1.10.6) (rhel-
    OpenJDK Client VM (build 20.0-b11, mixed mode)

    Tried running with different commands. Current:
    "screen java -Xincgc -Xmx2G -jar craftbukkit.jar"

    No plugins, no errors, same problem on vanilla. (except for Bukkit's own "echo's"...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  2. Offline


    I have same problem help me. I tried Java 6 and Java 7, nothing works!
    Dragoboss Where you have your vps? Did you tried to run for example Counter-Strike server? CS gaves me error "segmentation fault". Maybe our VPS are broken somehow.
  3. Offline


    kubaku4 I haven't tried any other servers but minecraft ones on THIS vps.
    I've had other vps' myself, which worked perfectly. But this one I don't 'own', like I said, I'm setting it up for somebody else. So I'm not gonna try other servers, other unneeded files.

    The owner's got the VPS from a Dutch host, but I don't find it neccesary to post it's host on this Forum, sorry...
  4. Offline


    Okay, my VPS is not dutch. I had another VPS too, and there minecraft was working FINE.
  5. Offline


    Everything that's Dutch works fine. Period.
    Nathan C and Dragoboss like this.
  6. Offline


    True, but let's keep this ON-topic, alright?

    Anyone else has idea's?...
  7. Offline


    I've tried 32 bit OS i thought it will work but it still doesn't ;<
  8. Offline


    Let me take a wild guess and say this is a VolumeDrive VPS?
  9. Offline


    Nope, not really, has that anything to do with it? It should EVEN work on a volumedrive VPS, but anyways, no it isn't. (Is Volumedrive Dutch?) But again, any freakin' reason why that should matter? :O
  10. Offline


    Oh, I didn't realize that it was dutch. 8 months ago, I tried Volumedrive once to see how horrible they were, and encountered an error quite like yours. I can't remember my method for fixing it though...
  11. Offline


    And you don't have any idea what is causing it?
    I mean, could it be the port? The ram, the whole system? Wrong java version? (I use openJDK, so not Oracle's JDK).
    What could possibly be the cause of this problem? :O
  12. Offline


    try to install the latest version of craftbukkit

    Also open up your property file with text edit and set online more to true

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  13. Offline


    I've got the latest Recommend Build.
    That shouldn't be a problem, but I get practically the same when I put it to online, it just doesn't load terrains, doesn't load plugins. It just gets stuck after (the lines) I showed (in the pastebin files).
  14. Offline


    I am installing VMWare Workstation right now to try it on my computer, if it will work something is with our VPS.
  15. Offline


    So No-one can actually fix this? -.-
  16. Offline


    Okay. I have installed Java 7 openJDK and everything works fine on my virtual machine, but i still can not run in on VPS.
    @EDIT Installed SAME OS on VPS, same OpenJDK and nothing does after java -jar craftbukkit.jar command ;/
  17. Offline

    Nathan C

    Oh, but it 100% does matter.....

    The VPS host may be overselling to hell and be very slow and that could be why it is not loading all the way..
  18. Offline


    So the problem is caused by the VPS, and possible it's software or perms...

    I'll tell the owner he should mail the host, and then hope they can fix the problem.
    Thanks Nathan C
  19. Offline


    <Edit by Moderator: Redacted wklej url> Little more now. But after 5seconds... [SCREEN IS TERMINATING] ;/
    Last edited by a moderator: Apr 27, 2020
  20. Offline


  21. Offline


    Dragoboss I wrote message to my VPS host. They did something in 5 minutes, and server works FINE NOW! I asked their, what they did. If they will answer, i'll post it here.


    dziękuje za wiadomość. Informuję, że w przypadku minecrafta wymagana jest widoczność 2 rdzeni w systemie."
    So, minecraft server needs to see 2 CPU Cores to RUN!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 26, 2016
  22. Offline


    OK, then the one I'm setting this up for, is screwed, his hosts asks more money for the cores, ofcourse, like almost every host does. Thx for the answere kubaku4 It's the first helpfull answer in this topic...
  23. Offline


    I didn't paid for this. They just made second core seeable.
  24. Offline


    Don't use incgc (slow stuff...); also use Sun's Java, not OpenJDK, it might work better.
Thread Status:
Not open for further replies.

Share This Page