Server Lagging Out - "Read Timed Out"?

Discussion in 'Bukkit Help' started by Hunt800, May 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Basic Description:
    Recently, every now and then the server will just (randomly) begin to lag out. Everyone gets disconnected and unless I restart the server, they're unable to join back for a good 15 minutes or so. The issue always seems to occur right before, or directly after the console prints a "Read timed out" error and the error always appears a few more times before they're able to log back in. I run nothing else from the server other than a MineCraft server, and the only things that had changed right before this issue began was the addition of a few lightweight plugins. (bugfixes, like NoSlime (we use slimeballs as an alternate currency) and DontKickMe (we've been getting the "Moved to fast" thingy too))

    "uname -a && java -version":
    Linux MCServ 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:24:50 UTC 2010 i686 GNU/Linux
    java version "1.6.0_20"
    OpenJDK Runtime Environment (IcedTea6 1.9.2) (6b20-1.9.2-0ubuntu2)
    OpenJDK Server VM (build 19.0-b09, mixed mode)

    Running RemoteToolkit (link)

    Craftbukkit Info:
    Build: 789
    Command to Start Server: Default packaged with RemoteToolkit (unsure how the server itself is actually launched, but here's what I use (probably useless but...): java -Xmx40M -Xms40M -XX:MaxPermSize=50M -jar Minecraft_RKit.jar ${USER}:${PASS}
    Plugins: Lottery Citizens HeroChat BlockHead GravelClay obuShutTheHellUp FalseBookIC HeroBounty Landmarks WorldGuard LogBlock creaturebox MagicSpells Seasons Unknown Command FishPeople FalseBookCart WolfSpawn iZone CraftBukkitUpToDate Cookbook mcMMO Permissions Stargate Essentials MultiVerse MagicCarpet FalseBookBlock SignColours CommandHelper ThunderTower MobRider iConomy mcbans nSpleef DynamicMarket FenceStack HeroicDeath FalseBookExtra CommandSigns PortalStick WorldEdit RemoteToolkitPlugin MonsterHunt Dontkickme LWC Login Queue NoCheat BlastControl Yeditor NoSlimes War Jackpot dynmap Factions FakeMessage
    Server.log: Linky (from starting the server to when the error occurred)

    What I've Tried:
    1. Removed all plugins (1 by 1) that I'd added close to when the error began to appear
    2. Updated everything (plugins and CraftBukkit)
    3. Checked the RAM (when I use "gc" from the server console, I'm told that the server has about 750MB free still)
    4. Fixed corrupted plugin configs
    5. Running server without any plugins whatsoever
    6. Running the server without the remotetoolkit wrapper
  2. Offline


    Update: I've run it without ANY plugins whatsoever and the error still occurs.
    (will edit when I run without wrapper)

    EDIT: Ran without Wrapper: Nothing
  3. Offline


    Same issue man :( Except my whole desktop enviroment on my win08r2 server locks up.
  4. Offline


    try taking out your portal stick plugin, your wolfspawn plugin, and also something is up with ur mysql, fix that and noceheats config files needs to be edited.
    Also what is ur download and upload speed?
    try using the mc server gui in the bukkit tools section

    i think it has something to do with your internet, java, or ram
    try updating java or unistalling and reinstalling
  5. Offline


    Did you not read the actual post? I've tried with absolutely NO plugins (therefore it has nothing to do with plugins or mysql). I've also tried checking the RAM and there is definitely enough (About a gig of free RAM when it freezes up).

    I'll try updating Java though...
  6. Offline


    sorry, but did YOU not read MY post? i also asked for download and upload speed?
    also how much players are usually on when this happens? or does it happen when ur by urself or no one is on
    try keeping your server up by itself without anyone joining and tell me the ressults
  7. Offline


    Oh sorry. Here:

    Also, I never even log on anymore, just because I can't. However, when the error happens (it doesn't ONLY occur when I log in) there are usually between 3 and 10 people online (however, the server doesn't get 10+ people anymore because of the issue).

    I have an idea though, and I'll check it next.
  8. Offline


    I had the very same problem as this. I couldnt figure it out either but it was somthing to do with the map. I reset the map and it stopped. I have a feeling it might have been a problem with automated cactus farms or redstone constructions that people had although i cant be sure. It could aslo be that one of my admins used worldedit on a region way too big and created a massive sphere and lagged the server until it crashed. after starting up the sphere was still there. perhaps that could have corrupt the map in some way. i just dont no.
  9. Offline


    I also have the same problem.
    Hm I did the same...but it did not stop ;( So I dont think, that it has something to do with the map itself.
    But I cant give you information about the up- and download-speed and java as well because my server is hosted as normal Gameserver (no standalone root) by a german hosting-company.
  10. Offline


    I have the same problem. I had it before so I created a new Main Directory and re-downloaded plugins and CB Build and it stopped... then it came back :p
  11. Offline


    I found a fix for this. Whisper me.
  12. Offline


    for the second time, why not just post it here
  13. Offline


    ... Yeah, by not posting it here, it makes you seem like your fix is downloading a malicious virus...
  14. Offline


    same error! on ubuntu server 10.10 java7 and 24 gb of ram, so its not possible that could be hardware!
  15. Offline


    Not sure how I did it exactly, but I fixed it. I got a new router and completely reconfigured the internet setup. I guess that means it was an internet issue after all.
Thread Status:
Not open for further replies.

Share This Page