Server Crashing - No Real Reason I can See

Discussion in 'Bukkit Help' started by syonxwf, Apr 5, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Sorry for the delay, installing programs on my work pc so I had to reboot.

    I do get some errors after the server has already crashed:

    2012-04-12 21:29:15 [INFO] Connection reset
    2012-04-12 22:30:08 [INFO] Read timed out
    2012-04-12 23:13:44 [INFO] Connection reset
    2012-04-12 23:28:07 [SEVERE] Bad packet id 71
    2012-04-12 23:28:07 [SEVERE] at net.minecraft.server.Packet.a(
    2012-04-12 23:28:07 [SEVERE] at net.minecraft.server.NetworkManager.h(
    2012-04-12 23:28:07 [SEVERE] at net.minecraft.server.NetworkManager.c(
    2012-04-12 23:28:07 [SEVERE] at
    2012-04-13 02:22:31 [SEVERE] Bad packet id 71
    2012-04-13 02:22:31 [SEVERE] at net.minecraft.server.Packet.a(
    2012-04-13 02:22:31 [SEVERE] at net.minecraft.server.NetworkManager.h(
    2012-04-13 02:22:31 [SEVERE] at net.minecraft.server.NetworkManager.c(
    2012-04-13 02:22:31 [SEVERE] at
    2012-04-13 02:43:56 [INFO] Read timed out
    2012-04-13 03:51:56 [SEVERE] Bad packet id 71
    2012-04-13 03:51:56 [SEVERE] at net.minecraft.server.Packet.a(
    2012-04-13 03:51:56 [SEVERE] at net.minecraft.server.NetworkManager.h(
    2012-04-13 03:51:56 [SEVERE] at net.minecraft.server.NetworkManager.c(
    2012-04-13 03:51:56 [SEVERE] at
    2012-04-13 04:50:57 [INFO] Read timed out

    As well as some logblock consumer errors, but I've been getting those since 1.2 started, and this crashing thing has started just recently in the last couple weeks.

    I am working on fixing the consumer error now regardless, because I want to have it taken care of as well.
  2. Offline


    Those look like Vanilla errors so you are best contacting Jeb_ on twitter. You could try creating an issue in bukkit's JIRA instance with a description of the issue and make sure you include the errors you get. Make sure to include your full bukkit version string + plugin list if you create an issue on JIRA.
  3. Offline


    Did you rule out essentials conflicting with other plugin ?
  4. Offline


    I have not ruled out essentials.

    I might try installing commandbook to see if that makes a difference.

    My server did just crash again, so VanishNoPacket is not the culprit.

    02:15 PM [SEVERE] Bad packet id 71
    02:15 PM [SEVERE] at net.minecraft.server.Packet.a(
    02:15 PM [SEVERE] at net.minecraft.server.NetworkManager.h(
    02:15 PM [SEVERE] at net.minecraft.server.NetworkManager.c(
    02:15 PM [SEVERE] at
    I usually don't get that right when the server crashes, this time I did.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  5. Offline


    Have you tried disabling all your plugins one-by-one?
  6. Offline


    I've been trying to do 50% at a time rather than 1 at a time because of the amount of time it will take to do it 1 by 1.
    The server can be up for 2-12 hours before crashing, so it is going to take a while to do 1 by 1 but that's where I'm headed next.

    2 test servers at a time, disabling 1 by 1 lol
  7. Offline


    Any luck ?
  8. Offline


  9. Offline


    mine does this too and it says warning every 2 seconds and I think that it is Icomomy as it was taken off for copyright
    by the american government as i have lots of ram on mine
  10. Offline


    No luck at all. I'm starting to give up hope.

    I've lost all but a handful of my regulars at this point, I am pretty irritated and have all but given up.
  11. Offline


    I'm having the same issue you are. Of the plugins that both you, I, and the other two people have that might be causing the crash, only WorldEdit, WorldGuard, and Vault are left. I'd be losing people too, except I've only ever had a handful of regulars.
  12. Offline


    Everything was good for me for some time, but if the server reached 20 players it would crash, now the server on start lasts like 10~30 minutes and crashes.
  13. Offline


    I get these messages when server reaches like 15-20 people: It only happens sometimes but its quite often.
    Not crashed in awhile, just getting lag. (my plugins listed above) - been having these lag messages for bout week.

    >15:41:38 [WARNING] Your server appears to be running slowly. Server tick took 14.75 seconds longer than expected.
  14. Offline


    Removed wg, still have the problem,removed essentials/essentials spawn, still have the problem..
  15. I have similar Problems, Thanks to this post I upped my allocated memory from 265 to 2gb, but I have a similar crash. Link to the full server.log and plugin list I have managed to at least rule factions out as the cause. Any help is appreciated. I suspected essentials at first, but now I am unsure, And I can't remove it, as 98% of my players commands are based on it. I rely on essentials.
  16. Offline


    Hey i fixed my problem. There were 2 problems in my server.

    1.It was the fault of the vps provider (you should contact your own), they said that my host is in a bugged pc, which takes to much memory.After transffering to another one, the lag was gone.
    2.Jobs, was glitched, after someone joined job digger, and broke few blocks the server crashed.Maybe theres the same problem with your jobs plugin.
  17. Offline


    I don't have jobs installed, I also don't use a hosting service, I home host on my own server at home :/
  18. Offline


    I recently had a similar issue, the issue was that ram kept dropping lower and lower at each GC run, about 100mb each time, once it hit bottom the server would either crash or end up spamming "read timed out" and not letting users connect, but usually accept console input though.

    I did update WE, WG and Commandbook ( to the absolute latest working version at the same time though but I also kept messing with my java args and seemed to end up with something that worked for my system atleast and my issue.

    I have no idea if this is for any help or use at all... but I'll share it anyway.

    -server -XX:MaxPermSize=128m -XX:ParallelGCThreads=2 -XX:+AggressiveHeap
    (also 5gb ram but added another way)
  19. Hi guys, i have the same problem, but i believe i have a error when it happened the first time, i am not sure about it, but it could help if it indeed has something to do with the crash, here is the error i got from my server.log file:
    2012-04-21 22:29:46 [SEVERE] null Input/output error
        at Method)
        at jline.Terminal.readCharacter(
        at jline.UnixTerminal.readVirtualKey(
        at jline.ConsoleReader.readVirtualKey(
        at jline.ConsoleReader.readBinding(
        at jline.ConsoleReader.readLine(
    I hope this helps solving the problem:)
    greetz blackwolf12333
  20. Offline


    Keep this thread alive please! The issue is still not fixed and it broke my server :(
    I had a nice little community (10 players on at least) now its 0 players at least :/
    If anyone has any ideas?
    I have a lot of plugins but disabled most of them to check, didn't fix it, here is my list:
    WorldEdit, iConomy, BukkitCompat, PermissionsBukkit, BKCommonLib, Vault, LWC, WorldGuard, Essentials, EssentialsProtect, AuthMe, DynamicEconomy, EssentialsSpawn, mChatLite, SimpleSpleef, Factions
    Maybe it is Vault? that isn't ruled out yet.
  21. Try starting your server without jline, look at the wiki on how to do that.
  22. Offline


    jline? I will google it :)
    i dont use a start.bat btw, just mcmyadmin

    How could JLine fix that?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  23. I read somewhere that might have been the problem, otherwise, try starting your server without EssentialsSpawn and Essentials, especially the tp commands are bad, at least, that was it on my server:p A conflict with another plugin that denied the tp because the chunk wasn't loaded yet.
    greetz blackwolf12333
  24. Offline


    it can happen when noone is online so i dont think it has to do anything with tp, also i think its a conflict bec a serv with only essentials goes fine.
    thanks for the help

    nope crashed again any other ideas?

    Sorry but bump, still didnt find the problem.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  25. Offline


    i give my server 2 1/2 gb and it still says is system overloaded
    please help

    now 3

    Echo OFF
    SET BINDIR=%~dp0
    CD /D "%BINDIR%"
    java -Xmx3072M -Xms3072M -jar craftbukkit.jar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  26. Maybe your up and download speed isn't good enough, that's important too.
    greetz blackwolf12333
  27. Offline


    i fixed it by deleteing everything and redownloading it
  28. Offline


  29. Offline


  30. Offline


    Do not tag the admins/moderators like you just did. This is a plugin issue - the best way to figure out which one is to remove all plugins and add them back in until you find one giving errors.
    Darky1126 likes this.
Thread Status:
Not open for further replies.

Share This Page