Server crashes with new Bukkit

Discussion in 'Bukkit Help' started by imaxorz, Jul 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Here is the error I get when the server crashes.

    Show Spoiler

    2011-07-01 18:41:11 [SEVERE] java.lang.NullPointerException
    2011-07-01 18:41:11 [SEVERE] at net.minecraft.server.BlockFurnace.a(SourceFile:117)
    2011-07-01 18:41:11 [SEVERE] at net.minecraft.server.TileEntityFurnace.g_(
    2011-07-01 18:41:11 [SEVERE] at net.minecraft.server.World.cleanUp(
    2011-07-01 18:41:11 [SEVERE] at net.minecraft.server.MinecraftServer.h(
    2011-07-01 18:41:11 [SEVERE] at
    2011-07-01 18:41:11 [SEVERE] at
    2011-07-01 18:41:11 [SEVERE] Unexpected exception
    at net.minecraft.server.BlockFurnace.a(SourceFile:117)
    at net.minecraft.server.TileEntityFurnace.g_(
    at net.minecraft.server.World.cleanUp(
    at net.minecraft.server.MinecraftServer.h(
    at at

    General System information
    What operating system are you running the server on?
    Cent OS
    Is it a 64 bit or 32 bit version of the OS?
    What version of Java are you running (java -version to find out)?
    How much RAM do you have on the system?
    What are the specs of the server’s CPU?
    i7 2600
    What network card does the server have?
    Not sure
    What network card drivers is the server using?
    Not sure
    What firewall or other security software is running on the server?
    Not sure
    Is your server directly connected to your router or on a network?
    It's a hosted/dedicated server, so I assume they use some kind of router.
    What is the network connection to your server? (1,5,10, 100 mbit .. etc?)
    Are you hosting on a VPS / Cloud or dedicated hardware?
    Dedicated Hardware

    Minecraft Server Information
    What version of CraftBukkit are you running (output of /version in-game - please provide the full version string)?
    This server is running Craftbukkit version git-Bukkit-0.0.0-901-g9277096-b953jinks (MC: 1.7.2)
    What plugins (and their versions) is your server running?
    How much RAM do you allocate to the server process?
    What is the launch line you use to start the server?
    java -server -Xmx7000M -Xms7000M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:parallelGCThreads=8 -XX:+AggressiveOpts -jar craftbukkit.jar nogui
    Do you experience high CPU load or paging during the time of the EoS?
    How many users are actively using your server when you experience the errors?
    Irrevelant on how many users are on. Happens when we have 2, and when we have 30.
    What are your users doing around the time the error occurs?
    Seems to happen absolutely at random.
    How large is your map?
    Main world is 3500 block radius. (700MB)
    Other maps are all 1000block radius.
    Are there large redstone circuits or minecart tracks on your map?
    Are you seeing any “Cannot keep up” errors around the time of the EoS? (Or just post ~10 lines from the log around the event?)
    Do you still have these problems if you run your CraftBukkit server without plugins?
    Did not try, as the crashes happens at random.
    Do you still have these problems if you run a Minecraft server without CraftBukkit?
    Same as above.
  2. Offline


    I got exactly the same error twice since switching to craftbukkit 1.7.1 (github de8569e563d26a6a736a)!
    Plugins used: iConomy, iConomyChestShop, Permissions, Stackable, DefaultCommands, Dynmap
    Therefore, these are the plugins we have in common: Dynmap, iConomy, iConomyChestShop, Permissions
    Haven't tried vanilla yet, because the crashes were randomly scattered over time.
    Map size and system specs about the same.

    Couldn't find the error... Is the file in net.minecraft missing or something like that?
  3. Yeah, I'm getting this same error too. Same plugins as rasco. Any ideas anyone?
  4. Offline


    Same here.. running nix and noticed that java is now using 200% cpu usage on my quad core xeon.. It runs for less than a day before becoming totally unresponsive.
Thread Status:
Not open for further replies.

Share This Page