Solved Server can't even start - Anyone help please?

Discussion in 'Bukkit Help' started by Shaner_X, Jul 6, 2016.

Thread Status:
Not open for further replies.
  1. Offline



    Today I woke up and discovered that my server had crashed during the night. This is very unusual, as I have a fair amount of RAM and, although I have quite a high plugin count, I did not install any new plugins since middle June, so I do not know what could have caused this. Restarting it will not work: it crashes again and again, without loading up all the files. Does anyone know what may be causing the issue and how I could possibly solve it? Thank you so much!

    Here you may find the crash report:
  2. I dont know a lot about bukkit, but my server crashes when using thread.wait(millesecond)
  3. @Webb It will, Thread.sleep freezes the main thread.
  4. Offline


    Does anyone know what may be causing my issue?
  5. Offline


    Can you post a version of a readable server log next time it happens?
  6. Offline


    What exactly do you mean by "readable", @lordjohnaitest ?
    This happens all the time, as I cannot even start the server.
  7. Offline


    @Shaner_X he was talking about the latest server log wich can be found in the map logs

    if u dont know what i mean, i put a Red dot at the map u need to send a LOG from

    a log not just the .zip but the txt file thats in the .zip!
  8. Offline


  9. Offline


    Anything that blocks the main thread weather that is a loop taking too long, a wait statement, a sleep statement or any operation taking too much time off the main thread is going to cause such issues.

    @Shaner_X From the last error i can deduce that there was an error with JSON from the server.
    So lets debug the issue, try copying the following files OUT of the server folder:
    Make sure not to delete those! just take them out the server folder and store them somewhere else temporarily.
    Restart the server. These files will be re-created. If the error does not occur it means that it is one of these files that is corrupt that is causing the problem. If that is the case, start placing them back in one by one and restarting every time till the error re-occurs when it does it means you found the file responsible and thats when we will have to re-format the file.

    If the solution above does not solve the problem, try removing the plugin that loads right before the error occurs (not sure what plugin that is, i mean this:
  10. Offline


    @mine-care , that solved my problem! Thank you very much!
Thread Status:
Not open for further replies.

Share This Page