Inactive [SEC] Ore To Client Obfuscation v1.9.1.1 - Anti X-Ray (xray) [1.2.5-R4]

Discussion in 'Inactive/Unsupported Plugins' started by TyrOvC, Jul 12, 2011.

  1. Offline


    solarox5, DaveDee, kahlilnc and 27 others like this.
  2. Offline


    To use the Spout compatible version, you have to be running Spout.
  3. Offline


    yeah I'm running it, disregard that error, i accidentally update the Spout to the latest build.. Now I'm back to the Latest Stable Build and it works.. except for this when people who doesn't have Spout

    2011-08-05 00:20:05 [SEVERE] java.lang.NullPointerException
    2011-08-05 00:20:05 [SEVERE]     at com.rawcritics.TyrOvC.OreObfuscationPlugin.Spout.OreObfuscateChunkPacketListener.checkPacket(
    2011-08-05 00:20:05 [SEVERE]     at org.getspout.spoutapi.packet.listener.Listeners.canSendUncompressedPacket(
    2011-08-05 00:20:05 [SEVERE]     at org.getspout.spout.MapChunkThread.handle(
    2011-08-05 00:20:05 [SEVERE]     at
    2011-08-05 00:20:05 [SEVERE]     at Source)
    2011-08-05 00:20:09 [SEVERE] java.lang.NullPointerException
    2011-08-05 00:20:09 [SEVERE]     at com.rawcritics.TyrOvC.OreObfuscationPlugin.Spout.OreObfuscateChunkPacketListener.checkPacket(
    2011-08-05 00:20:09 [SEVERE]     at org.getspout.spoutapi.packet.listener.Listeners.canSendUncompressedPacket(
    2011-08-05 00:20:09 [SEVERE]     at org.getspout.spout.MapChunkThread.handle(
    2011-08-05 00:20:09 [SEVERE]     at
    2011-08-05 00:20:09 [SEVERE]     at Source)
  4. Offline


    This error also spammed me yesterday and caused the server to lag until I was forced to remove rawcritics"(
  5. Offline


    2011-08-05 00:50:43 [SEVERE] java.lang.[NullPointerException]
    2011-08-05 00:50:43 [SEVERE] at com.rawcritics.TyrOvC.OreObfuscationPlugin.Spout.OreObfuscateChunkPacketListener.checkPacket(
    2011-08-05 00:50:43 [SEVERE] at org.getspout.spoutapi.packet.listener.Listeners.canSendUncompressedPacket(
    2011-08-05 00:50:43 [SEVERE] at org.getspout.spout.MapChunkThread.handle(
    2011-08-05 00:50:43 [SEVERE] at
    2011-08-05 00:50:43 [SEVERE] at Source)
    another bug.. It just popping out..

    another bug again..

    when planting some sapling, and it grows, it will be invisible, and when u try to go to where the tree grows, you will hurt urself, when u reconnect, you'll see the trees..
  6. Offline


    Yeah had to remove spout again to be able to use rawcrtitcs
  7. Offline


    this also occur in rawcritics-spout..
  8. Offline


    i'm using a clean craftbukkit and removed the non-spout plugin, and I was getting those errors :(
  9. looks like there are some "buggy-chunks" alongside this null-pointer error. In this chunks nothing gets updated unless the block you build/destroy by yourself. stopping and then starting the server will fix this error... for a while...
    and yes im sure i have a clean craftbukkit and no leftovers from the normal version. normal version has worked fine. spout version wont...
  10. Offline


    yes I also reported that.
  11. Offline


    There are some errors (that have already been reported) so I just had to take this off my server for now. With spout being new I need to know what is giving my errors.
  12. looks like the error occurs when someone sees another one building! building alone and this error won't occur. with another player in sight (loaded chunk): he is building -> error; you are building and he sees you (has loaded chunk) -> error.
    havent tested if non-updating chunks still getting "generated" if this error dont occur. but it looks as if they're related to it.
    Im running a bunch of other plugins, so maybe one of them is causing it indirect. (no other plugin appears in error message, just spout and this one). Testing all will cause a headache, because i need another player to test if the null-pointer error still appears. Noone likes to connect- test - disconnect - wait - connect and so on...

    Installed Plugins (open)
    Appleseed [0.6.2]
    AutoKick [0.4]
    BananaChunk [4.6]
    BigBrother [1.10.1-SNAPSHOT]
    Cenotaph [1.6.2]
    ClayGen [1.4]
    creaturebox [0.7.6]
    CustomCrafting [0.6]
    DeathTpPlus [1.86]
    FalseBookBlock [0.86alpha]
    FalseBookCore [0.86alpha]
    FalseBookExtra [0.86alpha]
    Help [0.3.1]
    HeroChat [4.11.0]
    HigherExplosives [2.0]
    HomeSpawnPlus [0.7]
    iConomy [5.01]
    IgnoreLogger [1.0]
    LatencyTester [0.2]
    LongGrass [3.3]
    MegaCatch [0.8]
    MultiInv [2.3.0]
    MultiVerse [1.7.2]
    NarrowtuxLib [0.5.1]
    NoRegen [1.1]
    OtherBlocks [1.82]
    Permissions [3.1.6]
    PluginControl [1.0]
    PlugMan [1.3]
    PrivateWarp [1.4.9]
    RawcriticsOreObfuscationPluginSpout []
    RealShop [0.66]
    Showcase [0.7.2]
    Spout [1.0.1]
    Stackable [0.5.1]
    Towny [0.73.1]
    WorldEdit [4.6]
    WorldGuard [5.2.2]
    CommandHelper [3.1.2]
    dynmap [0.19.2]
    LWC [3.3]
    BaseBukkitPlugin [1.4]
    General [3.5.1]
  13. Offline


    Anyone know if this actually works?

    Been using Anti-xray 0.6.3, which only blocks people using texture packs but not the xray mods -_-
  14. Offline


    It causes some bugs with water :
  15. Offline


    16:55:52 [SEVERE] java.lang.NullPointerException
    16:55:52 [SEVERE] at org.getspout.spoutapi.packet.listener.Listeners.canSendUncompressedPacket(
    16:55:52 [SEVERE] at
    16:55:52 [SEVERE] at

    Been getting these errors since switching to the Spout Version
    Its a Fresh craftbukkit 1000 file, and the new Spout jar
  16. Offline


    Works perfectly for me.

  17. Offline


    With spout?
  18. Offline


    I tested here the latest version with the latest stable version of spout and it wouldnt let Spout Launcher users even connect to the server, it gave a bad login, however sometimes the login worked but after 30 seconds you would get auto kicked from the server without any error message which also happened to clean minecraft client users also when you mined something in those 30 seconds you wouldnt be able to see the edits. After you rejoined when u got kicked you saw the edits you have done, but u get kicked over and over again

    BukkitContrib 0.1.7 and this ore to client obfuscation worked flawless

    I guess imma just wait out until spout and this plugin is working together like it did with bukkitcontrib :)
  19. Offline


    No, I'm using the normal version.
  20. Offline


    Spout version still needs more work then I guess. Doesn't help that Spout it self has some bugs right now.
  21. Offline


    Works really well. I'd advise using Mode1. Even though 3 is really funny, I was having some issues with the faux iron/diamond showing up on visible blocks.
  22. Offline


    had to disable it for now since spout version has that error and the other conflicts with spout which other plugins use :( hope you get out a fix soon!
  23. Offline


    help :) & 35
  24. Offline


    The version up right now was made with Spout 1.0.1. I'm going to use the latest version that's out this weekend and try to work out issues then. Sorry!
    Ratchet likes this.
  25. Offline


  26. Offline


    The plugin was working fine without the use of Spout - virtually no performance loss either on mode 2.
    I'll stick with it for as long as I can
    GmK likes this.
  27. Offline


    The non-Spout version actually takes precedence over the Spout version because Spout is not going to be used anytime in the near future on my server. Don't worry about it being left behind ;)
  28. Offline


    Thank you!

    Totally offtopic, but I am SO annoyed at Spout, it suddenly installed itself on a server restart and all hell broke lose, so I support anyone that isnt going the Spout way currently!
  29. Offline


    Spout GooD :)
  30. Offline


    There is a bug when I'm using this. When players mine, it only updates the blocks for the person DOING the mining. If someone is watching them mine, then they see the fake iron/diamond.
    Information: Using spout version and cb1000 (mode 4)
  31. Currently the Spout version isn't working right (null-pointer exceptions, non-updating chunks). If you CAN live without Spout i recommend the normal version with modified CraftBukkit. If other plugins depend on Spout you can do nothing but wait for a fix, because the modified server wont work with spout at all (No chunks are loaded at login and you get kicked after a while). BukkitContrib worked a lot better then Spout...
    GmK likes this.

Share This Page