[SEC/MECH/FUN] PreciousStones - Block Area Proteciton System [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by phaed, Jan 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    So at the moment there are a few bugs:
    1. The region isn't auto-deleted when users break the ps. There should be a flag where not even the ps owner will be able to break it.
    2. Users can go into fields and destroy the ps even if they do not own the ps.
    3. Users can place their ps field stone inside a protected field and claim it as theirs.
    4. It overrides WorldGuard if placed at the border of a WG region.
  3. Offline


    I got a problem that each time i reset the server, many ps fields reset into nothing. im running 6.22
  4. Offline


    Change log
    Version 6.3

    • Fixed bug in that caused ppl to be able to place in others fields and other weird peculiarities of the sort
    • Fixed outline visualization missing one leg
    • Added "preciousstones.bypass.cuboid" permission to be able to design any size cuboid without restriction
    • Now recognizes WorldGuard regions
    • Explosion visual when launching
  5. Offline


    how do i down grade to 5.9 ?
  6. Offline


    Don't downgrade. Upgrade to 6.3.
    EarlyLegend and Grimo like this.
  7. Offline


    Still have problem where users can destroy a field ps that isn't theirs.
  8. Offline


    6.3? You sure? Check the version and restart the server.
  9. Offline


    Still problems...ForceFields are sometimes not symetrical(doesnt have shape and distance that they has to) and can be in conflict with other fields-not all of them ,but only two rows of field,or only one..other guy just can put his pstone few cubes near my field and owerlapp a few rows of my field..
    I´m sure i have 6.3.It´s better then 6.2.2 but there are still bugs..Thx for fixing:)
    Example: I have VIP ForceField,radius in config 15,so the field has to be 31x31,but it is 29x32 and non-symetrical around psstone.
  10. Offline


    I've searched and looked around a bit for how to deal with PreciousStones in creative mode. There are certain things that PS does via left-clicking (e.g. cuboid editing) that creative mode simply destroys the block when left-clicked.

    Is there a solution to this? Am I just brain dead and missing something obvious?
  11. Offline


    yes, I have 6.3, still getting issues.
  12. Offline


    I got some problem with the grief revert block, I can place it, and it will work just fine. But after a while its like it forgets that its protecting an area, and it no longer work.

    So, it work when placed, but if I leave it, disconnect or something, it won't work again.
  13. Offline


    can you please up date it so a non op can place one of these blocks without it actually working for example
    a non op placed a gold block it just wouldnt have greif protection because i want non ops to be able to use all blocks
  14. Offline


    Yea cube editing doesn't work in creative mode for that very reason.
  15. Offline


    And scoping. Oh well.
  16. Offline


    You could always change your gamemode to survival (0) while you place a pstone then back to creative mode afterwards - assuming you are an OP that is...
  17. Offline


    On my server, after a restart/reload, the existing fields don't seem to load. We had this problem with 6.2.2 originally. I updated to 6.3 and we still have the problem.

    After fiddling around with it for a while on my own, placing fields and using /reload, it seems it is only aware of the last field I created after a /reload. (Just tried it with a full restart, and the same thing seems to happen)

    I'm going to investigate the same thing with a clean install with no other plugins now.

    UPDATE: Same thing seems to happen even with a fresh install with no other plugins. I must have done something to displease the mining gremlins :[
  18. Offline


    That bug must have escaped me, will upload a patch soon.
  19. Offline


    So with all of the redstone bugs why not just make a list to answer everyones questions.

    Known Bugs:
    • Redstone fields still exist after being destroyed.
    • Fields suddenly started to overlap causing multiple people to have access to areas they shouldn't have.
    • Everyone can break a ps stone even if its not theirs. Fields are still there after they are deleted. You should make it so when you break a redstoneore ps, you get the full redstone ore back instead of the dust.
    If anyone has any other please let me know so that I can add it to the list.
    This will help felipe know what to start at easily.

    I will add screenshots of all of the other bugs shortly.
  20. Offline


    I want to make a stone, that when placed will protect chests - but i don't want all of my stones to protect chests(furnances, etc)

    If that's not already possible and i am missing something(explain), can you make this possible?
  21. Offline


    When creating a cuboid field, I can visualise it but my players can't. Is there a permission node to allow that?
  22. Offline


    Nope, only the person creating the field can see it. The blocks exist only on his client. They are never really changed on the server. That's why its called a visualization.
  23. Offline


    That's cool. He claimed he couldn't see it. I'll blame derp.

    Second question: I have a bouncer field (as per default config) and when someone enters it they get returned to spawn. Is this the expected behaviour? I'd rather they were just moved back to where they came from...
  24. Offline


    That looks an awful lot like the Zombe path tracker. Can PS even make lines like that?
  25. Offline


    Running into a similar issue. Blocks set-up just fine, work great.
    Steps to Replicate:
    a) Proximity
    b) grifer revert
    c) city protection
    All blocks worked fine.
    did a /save-all on server
    Restarted Server
    Only C remains, A,B are no longer precious stones, the blocks are still there.
    -- bonus round---
    Broke down the blocks A, B. Replaced them in same identical spot. They work again AND (A) reported past log events + (B) was able to rollback griefing.
    Only C remains, A,B again do not work.
    Broke A,B,C - ONLY placed B this time.
    B no longer works.

    Seems like some sort of memory->database caching issue. I hope this helps track it down REALLY want this plugin to work, i honestly just want self serve anti griefing. :(

    Started DB from scratch, same problem. Using essentials.
    Update 1:

    Could a server-client ore obfuscator plugin cause this? (Anti Xray)
    Update 2:
    Nope, removed obfuscater - replicated the results above, this time with 4 city Protect blocks, only the last block was saved after a reload.
  26. Offline


    Keep in mind I reported a bug already where if you try to place a block down in an identical spot there's a database conflict because the first field hasn't been swept out of the database yet. You end up placing the identical block down and then the old field gets deleted from the database, meaning when you restart it won't be there since it exists only in memory.

    Refer to this post for the details on this particular problem: http://forums.bukkit.org/threads/se...oteciton-system-1185.1034/page-50#post-702378

    The same could be true for your first example. The plugin may write SQL entries in bursts to prevent excessive i/o access lag, if you restarted the server before the 15 or so seconds that it seems to take for database entries to be written then that would have caused that behavior.
  27. Offline


    Thnx, i'll look into that :)

    Retried with blocks in different locations same issue.
    Also did this on a brand new server, nothing but precious stones installed, out of the box config etc. (no essentials loaded) Same results. (not using MySQL database, just the SQL lite one).

    This would make sense except that the final block should not be written as well.
    On a blank db, new server I just placed 4 PS's in a row. All worked. Waited a minute, verified the db file was written to, /reload, only the final block was working, the first 3 no longer were registered as precious stones. (Blocks showed up fine on the server of course)

    Any ideas? Seems like an easily replicable bug...
  28. Offline


    I couldn't replicate it with SQL, but I did notice with an earlier version (6.2) that I was getting async warnings about PreciousStones while using the /reload command.

    Which four pstones are you placing? I've tried placing multiple combinations and veried that they are written to the database. All survive on /reload.
  29. Offline


    Aight, did the most vanilla install of bukkit possible ;) Latest recommended build 1185, precious stones 6.3, default config file, absolutely nothing else changed. New world seed generated, PS database had not yet been created. Using SQLlite file system.
    Identical results, only the last block is saved. Server loaded up fine, no errors whatsoever.

    Sounds like the only difference between your environment is SQL vs SQLLite. I'll give that a go next and see if i can narrow it down. Very excited about this plugin, hoping this testing helps the developer a fair bit :)

    Tried it with Town Protect(Diamond_block), and Griefer Rollback (Gold_block) seperatly. Doesn't matter which stones i use, all the same result :(

    MySQL installing right now.. stay tuned.
  30. Offline


    When I use /ps visualize I can break the glass blocks and even stand on top of them. Interacting with the blocks in any way via right-click causes them to disappear. This isn't just happening client-side either, other connected players can see you running around in the air.

    The glass blocks are now stuck as "visualize" mode won't turn off. Using "/ps visualize" in this state tells me that I have insufficient permissions (this is as on op and administrator privs) or it is an invalid command.

    Reconnecting makes the visualization disappear and the 4 pstones I placed are no longer in the database (they were city protection blocks arranged in a 2x2 patter). The weird thing is that the blocks somehow got deleted from the database with no /reload or server restart.

    Tried to reproduce the problem by standing on top of the four City Protection blocks and using /ps visualize. It caused the server to hang and I had to do a forced restart. Restarted the server, confirmed the four fields, tried visualize again and the server hung a second time forcing another restart.
  31. Offline


    Alright! Found the source of the problem - the mysqlLite portion is what's messed up. Works PERFECTLY with a MYSQL server connection. Hopefully they can fix asap :)

    Noticed this too, it's not a big problem for Op's however non ops will get booted for "flying" when the client walks on the glass blocks.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 18, 2016
Thread Status:
Not open for further replies.

Share This Page