[SEC/FUN/INFO] Towny v0.68 Fuzze Edition [818]

Discussion in 'Inactive/Unsupported Plugins' started by FuzzeWuzze, Apr 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Version: v0.68

    Moderator Edit: Please direct your attention here for an updated version. This thread is now closed due to people spamming random things about how its not working.

    So this has been asked for many times so i decided to finally make this thread.
    This is related to Shade's brilliant Plugin Towny

    Since Shade has been MIA for a while now, and we dont know if hes coming back i've been trying to keep Towny afloat as best i can in hopes he does come back as i dont really have the RL schedule to much of anything other than maintain it to be usable.

    I hope in June once i have more free time if Shade still isnt back :'( to actually do a formal Github Fork and continue the project. So until then, dont bother asking for new features, as time allows the only thing i'll try to do is fix large glaring bugs that effect the mod. This is a very large plugin and Shade has spent a lot of time on it, so even when/if i do fork it will take some time to get fully up to speed on everything. For now i just have a basic understanding of how everything is interacting and enough debug skills to track down most bugs ;)

    How it works/Features
    -See Original Towny Page for Instructions on how to setup and Permissions.

    Read this page to learn what everything in the config does!

    When reporting bugs, please use /townyadmin set debugmode on. Then perform the action and post or send me the log from your server. This will assist me in being able to fix the issue 10 faster, just simply saying "People can do X in my town when they shouldnt be able too" doesnt really help me at all and is impossible to replicate.
    • Permission cache errors
      • You didnt install Permissions properly, it creates a RENAMEME.yml file or something of the like when first started. This must be renamed to match your world name(for most people world.yml). Also you CANNOT have spaces in your world name. Test World is not an acceptable folder name, TestWorld is. Both towny and permissions dont like the Permissions YML file to have spaces.
    • /town top money causes exception
      • Your iConomy database is likely setup to still use sqlite. Ensure that your iConomy config file is setup to use database Type: H2SQL. A lot of people had issues with the sqlite to H2 conversion, if you still experience this error with it set properly your db may be corrupt. Back up your iConomy db and configs, then delete them all and allow iConomy to recreate them and see if it still happens. If it doesnt, your going to have to manually regrant people cash somehow as your iConomy database was corrupt.
    • towny.admin: User is able to use /townyadmin, as well as the ability to build/destroy anywhere. User can also able to make towns or nations when set to admin only.
    • towny.town.new :User is able to create a town (only is use when TOWN_CREATION_ADMIN_ONLY is on)
    • towny.town.claim : User is able to expand his town with /town claim
    • towny.nation.new :User is able to create a nation (only is use when NATION_CREATION_ADMIN_ONLY is on)
    • towny.wild.*: User is able to build/destroy in wild regardless if the config says no.
    • towny.wild.build
    • towny.wild.destroy
    • towny.wild.switch
    • towny.wild.item_use
    • towny.wild.block.[block id] : User is able to edit [block id] in the wild.
    • towny.spawntp :Use /town spawn when allow_town_spawn=false
    • towny.publicspawntp : Use "/town spawn [town]" (teleport to other towns) when allow_town_spawn_travel=false.

    All versions .64 and after will require iConomy 5.0 and higher. When making this initial transition it is HEAVILY advised that you back up your h2 and MySQL database's. I tested as well as i could with various functionality within Towny and it seemed to be working as expected. Also note that a ton of plugins that use iConomy are still broken, so unless they ALL work i wouldnt suggest updating. You've been warned. Dont cry if something bad happens and you dont have a backup of your iConomy database ...
      • Essentials 2.2
      • Permissions 2.7.4(DO NOT USE 3.X!)
      • iConomy 5.01
    • (JAR ONLY) Latest Build(.68) HERE
    • V.61

    • Fix /towny top money from crashing towny
    • Investigate potential issues with build/destroy permissions.

    • /town spawn will not charge players
    • DO NOT GIVE PLAYERS TOWNY.WILD.* permissions. Give players permissions by editing your config file by editing these. If players have wild permissions they can do funny business to get permission to build in other peoples towns.
    • Some people are reporting a lot of [SEVERE] warnings related to Player_Item and Player_Move, i believe these are being triggered by other mods. If you are having this issue please list your other plugins.

    Version .68
    • Compiled for CB818 (Minecraft 1.6.6)
    • Disabled town renaming (finally)
    • Do not use Permissions 3.0.x with Towny yet, there are still some MAJOR issues with the rework they are doing and a ton of people are nerd raging on their thread. I couldnt even get it to create my config or default files they were always blank, and i guess a ton of other people are having the same issues. Still didnt work when following instructions on how to make the file yourself. Because 2.7.4 works perfectly fine with CB818 im not in a rush to upgrade until they figure out their issues. Sorry if this causes plugin conflicts if some require Permissions 3.x but i doubt it will as not many mods are moving to it in its badly broken state. Because Towny is so heavily dependent on a lot of Permissions nodes being read properly i decided to stick with 2.7.4 for now. Ill work on a 3.x permissions build as soon as i feel its functioning properly.
    Version .66
    • Compiled for CB766
    • Players no longer need to /town set spawn, when a player does /town spawn they automatically go back to their town. Need to figure out how to re-implement the essentials teleport timer cooldown they changed their API
    Version .64
    Version .63
    • Really fixed /town spawn!
    Version .62
    • First Official Release by Fuzze!
    • Fixed /town spawn INVESTIGATING
    • Fixed /towny map
    • Verified all permissions are working properly. I ran it on my test server and tested resident build/destroy/switch and outsider build/destroy/switch by using /town set perm and turning them on and off and trying them out. ALL the permissions acted as they should. This should put to rest a lot of bugs people are having with people building. This doesnt mean Towny is using the default_town_build=false config lines properly for new towns, thats next. It does mean if your mayor sets the options manually it works.
    Version .061R6
    • Disabled /towny top money for towns/nations until able to fix bug related to null iConomy accounts, I have a feeling its related to iConomy databases that were SQLite and transitioned to H2 like my own. It *should* work fine for Residents, so far i havent seen null resident returns.
    Version 0.61R5

    • Updated to work with CB670
  2. Any need to quote the OP twice?
  3. Offline


    2011-06-22 13:55:40 [INFO] [Towny] Loading Error: Could not read world data 'Akkadia'.
    2011-06-22 13:55:40 [INFO] [Towny] Loading Error: Exception while reading resident file xXWildRiotXx
    2011-06-22 13:55:40 [SEVERE] ca.xshade.bukkit.towny.NotRegisteredException: Gondolin is not 2011-06-22 13:55:40 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    2011-06-22 13:55:40 [INFO] [Towny] Loading Error: Exception while reading world file Akkadia
    2011-06-22 13:55:40 [SEVERE] ca.xshade.bukkit.towny.NotRegisteredException: Gallifrey is not registered.

    I have towns and residents not being recognized, the data is there but for some reason unable to read it. This is the missing towns and plots that seems to be common with recent updates. I restore backup info, but it doesn't really help if it can't read it though. I have read threads describing my problem but really saw no solution. Ideas???
  4. Offline


    It isn't a thing that's started recently. Make sure you check new townmembers/newtowns are good before you start your server after a crash.
  5. Offline


  6. Offline


    Whenever I go to use certain commands it says "(Command) not registered" or something of the like. What is causing this and is there anything I can do to resolve this?
  7. Offline


    How are you restoring your backups? Rename your data folder to 'DataBroken' then unzip a good backup, paste the data folder into plugins/towny/

    If it was working fine before you should have good backups to work with. You can always look at all the files, search for the towns/residents you see in the log, and fix them manually if your backups are not good.
  8. Offline


    I think Permissions 3.1.5b is pretty stable, and #860 is widely supported. Any chance of updating to support these two?
  9. Offline


    As much as I love this plugin, I am forced to stop using it as tows/ nations get nulled all the time, and players complaining about it.
  10. Offline


    the issue is not the backups, rather the inability to access them via bukkit, 860. I am aware that it is 818 recommended. So I guess the issue can be easily resolved, either revert back to a less stable bukkit build with known issues or; find another land management plugin. Sadly there is really nothing close to towny from my findings. I hope that it is updated one day, but it is becoming apparent that is not in the near future. Soon 1.7 will be out and the next bukkit and the problems begin anew. Sigh....

    These problems started for me around the beginning of 1.6 or so. I lost one town, then a week would go by then another. This was with bukkits that were recommended, I have since updated to 860 which is above 818 and the problems have grown worse. Please update TOWNY!!!!!!

    I have been trying to resolve the whole missing towns and residents. I have reinstalled players and the files will delete out or alter them to remove belonging to a town. I even manually change the files to add the the town and check residents assigned and then restart. BOOM, "you don't belong to a town". I recheck files and the assigned towns are missing from the files. It has happened repeatedly, and I am at a loss as to what I can do?

    2011-06-22 23:15:35 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    2011-06-22 23:15:35 [INFO] [Towny] Loading Error: Exception while reading resident file Darthevan7
    2011-06-22 23:15:35 [SEVERE] ca.xshade.bukkit.towny.NotRegisteredException: Gondolin is not registered.
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.object.TownyUniverse.getTown(TownyUniverse.java:531)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyFlatFileSource.loadResident(TownyFlatFileSource.java:244)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyDataSource.loadResidents(TownyDataSource.java:134)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyDataSource.loadAll(TownyDataSource.java:75)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.object.TownyUniverse.loadDatabase(TownyUniverse.java:579)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.Towny.onEnable(Towny.java:92)
    2011-06-22 23:15:35 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:125)
    2011-06-22 23:15:35 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:799)
    2011-06-22 23:15:35 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:253)
    2011-06-22 23:15:35 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:140)
    2011-06-22 23:15:35 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:118)
    2011-06-22 23:15:35 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    2011-06-22 23:15:35 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    2011-06-22 23:15:35 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    2011-06-22 23:15:35 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    2011-06-22 23:15:35 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-06-22 23:15:35 [INFO] [Towny] Loading Error: Could not read resident data 'Darthevan7'.
    2011-06-22 23:15:35 [INFO] [Towny] Loading Error: Exception while reading resident file JAW420
    2011-06-22 23:15:35 [SEVERE] ca.xshade.bukkit.towny.NotRegisteredException: Gallifrey is not registered.
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.object.TownyUniverse.getTown(TownyUniverse.java:531)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyFlatFileSource.loadResident(TownyFlatFileSource.java:244)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyDataSource.loadResidents(TownyDataSource.java:134)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.db.TownyDataSource.loadAll(TownyDataSource.java:75)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.object.TownyUniverse.loadDatabase(TownyUniverse.java:579)
    2011-06-22 23:15:35 [SEVERE] at ca.xshade.bukkit.towny.Towny.onEnable(Towny.java:92)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  11. Offline


    Have you been doing the edits while the server is fully stopped? It will revert if you use /reload.
  12. Offline


    Love towny. Curious if anyone has any news on updates coming soon? I know the dev was going to be inactive for a while but just curious.

    Also are their any other plugins that do what towny does? Just wondering if this is the only one =)
  13. Offline


    yes, fully stopped. The files change after the restart. I have one profile which has worked out of 8. The other ones simply change, even the manually altered ones. I guess the next step is to completely reinstall towny and go from there. I am not convinced that this will remedy my situation, but I love towny and want to solve this problem.
  14. Offline


    I've got an issue and not sure where to begin looking to fix it. About 3 weeks ago I was told that someone's town no longer existed, when he just put a few thousand in the bank to pay for the taxes. I thought it was a fluke and reimbursed him.
    Today, when I got on, I was told another town did the same thing. I did /t cliffside and it came up with both Mayor ad Board as NULL, but the bank has little over 4k in it.

    Just been told he cannot make a town since he already belongs to one, when he uses /t, it says cliffside ruin.
  15. Offline

    =BiG= kaotic

    oh oh im sorry for posting the topic again, it was an accident, how bout instead of being nasty you help
  16. I'd love to start using this, but it seems a bit buggy at the moment. My main issue is the commands look like they would conflict with essentials. /r and /t predominantly.
  17. Offline


    I've been using Towny with no issues on CB902. Not sure why everyone else is having problems but a fresh install of towny would most likely fix your issues as it doesn't appear to be a conflict between Towny and CB.

    You can change those shortcut commands in the config (i.e. disabling /r and /t from doing anything)
    LlmDl likes this.
  18. Offline


    Is Towny going to get updated for #860 ?
  19. Offline


    Fuzze, it's about time to update to Permissions 3.1.5b and RB 928. Both have been confirmed stable.
    Pim1234 likes this.
  20. Offline


    You need to add everything back in-game, editing the data (town, nation) files won't work. I tried to add protections in towns through the flat file database, but it resetted to its original state as soon as I started the server.
    Using the commands /town set perm [resident/ally/outsider] [build/destroy] [on/off] worked for me.
    You can find other commands at this page: http://towny.xshade.ca/commands/master-list
  21. Offline


    Finally.... a version that works! :0 thanks!
  22. Offline


    I might install this if I better understood what it was.
    Is it like that one SSP mod that creates towns?
    Or is it "Claim this as town, claim this as country" type of deal?
  23. Offline


    Reading is a very useful skill. :p
  24. Offline


    Working fine on #928.
  25. Offline


    Yeah, and I did go to the site aforementioned and STILL do not fully understand what it does.
  26. Offline


    Sorry folks, been super busy and honestly im not sure how much time im going to be able to devote to Towny advancement. Got tons of new responsibilities at work, and the three classes im taking during summer are much more brutal than anticipated....

    Im hoping someone else wants to take over at some point to add new features...
  27. Offline


  28. Offline


    Oh for the love of Minecraft, please update the plugin to work with Permissions 3.x before you leave! I understand life happens and I can appreciate that and also appreciate what you've done so far. But please just update to work with Permissions 3.x so we can use this while we wait for a new developer to take on the project. It's driving me nuts that right now anybody can do anything in our towns, regardless of set permissions.
    Pim1234 likes this.
  29. Offline


    euhm... whenever i try to claim more land for my town i get the message about not enough town blocks although i raised the maximum amount a lot (from default to a lot of 9's) but i still get the message and i cannot claim more land for my town.
  30. Offline


    umm am i the only one without money? and the /money command doesn't work
  31. Offline


Thread Status:
Not open for further replies.

Share This Page